Open main menu

Gramps β

Fr:Manuel wiki pour Gramps 5.1 - Navigation

Revision as of 18:54, 31 January 2021 by Arverne73 (talk | contribs) (Mise à jour)
Précédent Index Suivant



Tant qu'une base de données est ouverte, Gramps reste centré sur une personne désignée comme la personne active. Vous pouvez modifier ou voir les données de cette personne et de sa famille proche. La navigation dans la base de données consiste en fait à changer de personne active. Cette section décrit tous les moyens pour parcourir la base de données en utilisant l'interface utilisateur riche et pratique de Gramps. Toutes les méthodes produisent finalement le même résultat mais le choix du meilleur outil à utiliser dépend de ce que vous faites.

Contents

Utilisation de la catégorie Individus

La méthode la plus intuitive pour sélectionner l'individu actif est d'utiliser la catégorie Individus. Quand vous êtes dans ces vues, simplement sélectionnez le nom de la personne désirée depuis la liste en cliquant dessus. Cet individu devient alors actif. La barre de statut est mise à jour en tenant compte de ce changement de personne active.

Voir aussi :

Modifier ou ajouter des individus

Utilisation de la catégorie Relations

Quand vous êtes dans la catégorie Relations, vous pouvez facilement naviguer d'une personne à une autre dans la famille affichée comme suit :

Cliquer sur le nom souligné de la personne qui vous intéresse et cet individu devient le nouvel individu actif de la catégorie Relations.

Le nom de la personne active n'est pas souligné.

En plus de tout cela, Gramps propose de nombreux raccourcis-claviers pour la navigation. Lisez la documentation de référence de ces commandes dans raccourcis clavier.

Utilisation de la catégorie Familles

Quand vous êtes dans la catégorie famille, vous pouvez aisément naviguer parmi les familles. La configuration de l'affichage permet de choisir les colonnes à afficher. Il est ensuite facile de classer ces familles selon le nom du père, de la mère, le type d'union… en cliquant sur l'en-tête de la colonne correspondante.

Utilisation de la catégorie Graphiques

Gramps s'appuie beaucoup sur des écrans affichant des listes de relations. Cela suppose des liens entre vos enregistrements dans votre arbre généalogique. La catégorie Graphiques procure une alternative plus visuelle pour afficher ces relations. La position, la couleur, l'aspect des boites ainsi que les lignes qui les relient et les flèches peuvent mettre en évidence des liens complexes entre les individus. Les boites peuvent être simplement colorées, ou des arcs, des rubans ou d'autres formes.

La catégorie Graphiques permet également de vous déplacer à travers votre arbre familial. Le bénéfice de cette méthode étant que vous pouvez voir plus qu'une génération dans votre arbre. Par ailleurs, vous pouvez sauter directement d'un petit-fils à son grand-père sans passer par les générations intermédiaires.

Notez qu'après avoir changé de personne active dans les vues Graphiques, l'affichage est mis à jour en fonction de la nouvelle personne active. Dans les vues Graphiques, vous pouvez facilement naviguer entre les personnes affichées comme suit :

Pour définir une personne affichée comme étant la personne active, faire un clic-gauche sur la boîte correspondante. Un clic-droit sur une boite affiche un menu contextuel qui vous permet d'accéder à la modification de la personne de la boite mais aussi d'accéder aux conjoints, enfants, ou parents de chaque individu.

La navigation dans les graphiques dépend du type : vous pouvez soit tirer le graphique pour le déplacer vers la section qui vous intéresse, voit vous disposez de flèches qui vous permettent de vous déplacer dans les générations.

Par exemple, dans le graphique «arbre généalogique», pour naviguer vers un enfant de la personne active en cours (la racine à gauche de l'arbre), cliquez sur la flèche vers la gauche située à gauche de sa boîte. Si cette personne a plusieurs enfants, le bouton se développe en un menu déroulant proposant le choix entre les enfants. Pour déplacer le graphique d'une génération en arrière, cliquez sur le bouton correspondant à droite de l'arbre. Le bouton du haut fera suivre la lignée paternelle alors que le bouton du bas fera suivre la lignée maternelle.

 
Avantages du menu contextuel

Un accès direct aux conjoints et frères ou soeurs. Des listes complètes de tous les acteurs de toutes les catégories, pas seulement les individus préférés.


Un clic droit sur ces boutons de navigation offre aussi un menu contextuel d'actions.

Il existe aussi d'autres fonctionnalités comme l'affichage «à la volée» d'information sur une relation en passant la souris sur un trait de relation ou l'ouverture d'une fenêtre de modification en double-cliquant sur un trait de relation pour une famille ou sur une boite pour un individu.

Certaines vues de cette catégorie sont décrite au chapitre Catégories.

Les vues disponibles dans cette catégories peuvent être étendues par des extensions disponibles dans le gestionnaire d'extensions, avec le type «vue Gramps». Certaines extensions tiers ont finis par être intégrées à l'application principale. Pour les autres, la documentation est très aléatoire.

Utilisation des Gramplets

 
Fig. 8.1 Relatives gramplet into People View

Quelques Gramplets fournissent un support des liens uri/url (souvent la couleur par défaut des liens internet). Sur les Barres latérale et inférieure vous pouvez activer des gramplets comme :

pour avoir la possibilité de naviguer avec les proches, les descendants et les ascendants de la personne active dans les vues.

En cliquant sur un lien vous allez changer la personne active.



Choisir le de Cujus, la souche

Un seul individu peut être sélectionné comme souche, de Cujus. C'est l'affaire d'un seul clic dans n'importe quelle vue.

Pour choisir le de Cujus, sélectionnez d'abord, par le moyen de votre choix, la personne voulue comme personne active. Faites Édition->Définir comme la souche. À partir de ce moment, vous pouvez retourner à cette personne simplement en cliquant sur l'icône Souche dans la barre d'outils. Vous pouvez également choisir Aller à->Souche dans le menu ou choisir l'élément Souche dans n'importe quel menu contextuel accessible par un clic droit de la souris.

Utilisation de l'historique

Gramps dispose aussi d'un ensemble puissant d'outils reposant sur l'historique de navigation. Ces outils ressemblent à ceux des navigateur sur le Web. Ceci comprend les éléments Précédent et Suivant disponibles dans le menu Aller à les menus contextuels et les boutons de la barre d'outils. Il y a aussi la liste des sélections récentes accessible par le menu Aller à qui vous permet d'aller directement vers n'importe quelle personne sélectionnée récemment. Enfin, cliquer avec le bouton droit de la souris sur les boutons < Précédent et Suivant > de la barre d'outils active un menu déroulant avec les personnes correspondantes dans l'historique. Sélectionnez l'une d'elles et vous irez directement vers elle.

Signets

 
Fig. 8.2 Organiser vos signets

Similaire à l'action de définir la souche, vous pouvez marquer d'autres individus dans la base de données pour une navigation simplifiée. Pour marquer un individu, tout d'abord allez sur cet individu, puis choisissez Signets -> Ajouter un signet. Pour aller vers cette personne n'importe quand, choisissez Signets -> nom de l'individu.

Vous pouvez gérer vos signets en choisissant Signets ->Gérer les signets .... Ceci lance la fenêtre de Gestion des signets avec la liste des signets et les contrôle pour la modifier.

Utilisez les boutons Haut et Bas pour changer la séquence de la liste. Utilisez le bouton Enlever pour supprimer le signet. L'Aide vous conduit vers cette page, et vous pouvez fermer la fenêtre Édition des signets avec le bouton Fermer.

Les individus marqués peuvent être sélectionnés dans la catégorie individus, comme expliqué plus haut, mais également depuis les catégorie relations, familles et lignées.

Sur les mêmes bases vous pouvez également marquer : les événements, sources, citations, lieux, media, dépôts, et notes.

Trouver les enregistrements

 
Fig. 8.3 Rechercher une donnée

Pour trouver un enregistrement dans la base de données, tout d'abord choisissez la vue désirée pour votre enregistrement : individus, sources, lieux, media, dépôts, notes. Puis commencez par saisir le nom ou le titre que vous recherchez. Vous pouvez également utiliser Ctrl+F pour ouvrir le mode recherche, mais commencer par saisir avec le clavier doit être suffisant.

Les premières lettres que vous tapez sont recherchées.

 
Trouver les individus

Pour des recherches d'individus plus complexes vous pouvez utiliser les filtres.


Activez le contrôle de filtre par Affichage -> Barre latérale, sélectionnez le filtre désiré, et cliquez sur Appliquer. Voir les filtres pour plus de détails.

Utiliser le presse-papiers

 
Fig. 8.4 Presse-papiers

Cet outil fournit une note temporaire pour stocker des enregistrements de la base de données et une réutilisation plus facile. En résumé, il s'agit de la fonction glisser-déposer étendue aux objets et autres types d'enregistrements présents dans Gramps.

 
Le presse-papiers est optimisé avec la technique du glisser-déposer

Pour utiliser le presse-papiers, soit choisissez Édition -> Presse-papiers soit cliquez sur le bouton Presse-papiers de la barre d'outils.


On peut stocker des adresses, des attributs (personnel et famille), des événements (personnel et famille), des noms, les objets media, des références, des citations, des URLs, et naturellement l'information textuelle des notes et des commentaires. Pour stocker, glisser simplement le texte dans la boîte de dialogue. Pour réutiliser l'information, glisser-la à l'endroit correspondant, par exemple onglet d'adresse, onglet d'attribut, etc...

 
Astuce

Quelques objets montrent l'icône de lien du côté gauche. Ceci indique que déposer un tel choix produira une référence à un objet existant, pour ne pas copier l'objet lui-même. Par exemple, le fichier medium ne sera pas reproduit. Au lieu de cela, la référence sera faite à un objet existant, qui aura comme conséquence l'entrée locale.


 
Astuce

Le stockage est persistant au cours d'une session de Gramps. La fermeture de la fenêtre du presse papier ne perdra pas les informations stockées à l'intérieur de celui-ci. Par contre, le presse-papier sera réinitialisé lors de la fermeture de Gramps .

Le raccourci clavier est Ctrl+B. Pour une application comme Gramps, le presse-papiers est important.

Juste un exemple : vous trouvez l'acte de naissance d'un individu. Ce dernier mentionne également les témoins. Et cet acte est une source avec ses informations. La meilleure solution étant d'ouvrir le presse-papiers et de glisser la source. Puis d'utiliser la fonction glisser-déposer chaque fois que vous en avez besoin.

Vous finalisez les informations dans l'Éditeur d'individu. Glissez ces informations dans le presse-papiers. Vous ajoutez deux individus comme témoins (si ils ne sont pas déjà présents dans la base de données). Un simple glisser-déposer depuis l'information sur la naissance dans l'événement du témoin. Vous changez le rôle en témoin de la naissance. Vous pouvez reproduire ce schéma pour d'autres témoins.

Ceci vous évite de longues saisies et erreurs possibles.

Gestionnaire de fenêtres

 
Fig. 8.5 Gestionnaire de fenêtres

Le menu Fenêtres -> fournit un accès rapide aux fenêtres ouvertes.


Précédent Index Suivant
  Notice spéciale pour le droit à la copie: Toutes les éditions de cette page ont besoin des deux différentes licences pour la réutilisation:

Ces licences permettent au projet Gramps de maximiser l'utilisation du manuel wiki en tant que contenu libre pour les prochaines versions de Gramps. Si vous êtes en désaccord avec cette double licence, alors n'éditez pas cette page. Vous pouvez ajouter un lien pour cette page, ce dernier sera sous licence GFDL via le lien externe (utilisant la syntaxe: [http://www.gramps-project.org/...]), et non via les liens internes.
Utilisez également les conventions typographiques.