Difference between revisions of "Fr:Manuel wiki pour Gramps 5.1 - Navigation"

From Gramps
Jump to: navigation, search
m (image)
(Mise à jour selon original menu signets)
Line 261: Line 261:
 
{{-}}
 
{{-}}
  
==={{man menu|Bookmarks}}===
+
==={{man menu|Signets}}===
  
[[File:Menubar-BookmarksOverview-50.png|thumb|right|450px|Fig. {{#var:chapter}}.{{#vardefineecho:figure|{{#expr:{{#var:figure}}+1}}}} Menubar - Bookmarks Overview]]
+
[[File:Fr_menu_signets_Ubuntu_Groovy.png|thumb|right|400px|Fig. {{#var:chapter}}.{{#vardefineecho:figure|{{#expr:{{#var:figure}}+1}}}} Menu Signets]]
  
*{{man menu|Add Bookmark}} - Create a bookmark from the currently selected item eg: Person, Family etc..
+
*{{man menu|Ajouter un signet}} - Crée un signet pour l'item actuellement sélectionné, c-à-d : Individu, Famille, etc.
*{{man menu|Organize Bookmarks...}} - Opens the [[Gramps_5.1_Wiki_Manual_-_Navigation#Bookmarks|Organize Bookmarks]] window.
+
*{{man menu|Édition des signets…}} - Ouvre la fenêtre Édition des signets.
 
<hr>
 
<hr>
* Dynamic section where the bookmarks appear
+
* Section dynamique où les signets s'affichent.
 
{{-}}
 
{{-}}
  

Revision as of 14:22, 2 February 2021

Précédent Index Suivant



Tant qu'une base de données est ouverte, Gramps reste centré sur une personne désignée comme la personne active. Vous pouvez modifier ou voir les données de cette personne et de sa famille proche. La navigation dans la base de données consiste en fait à changer de personne active. Cette section décrit tous les moyens pour parcourir la base de données en utilisant l'interface utilisateur riche et pratique de Gramps. Toutes les méthodes produisent finalement le même résultat mais le choix du meilleur outil à utiliser dépend de ce que vous faites.

Utilisation de la catégorie Individus

La méthode la plus intuitive pour sélectionner l'individu actif est d'utiliser la catégorie Individus. Quand vous êtes dans ces vues, simplement sélectionnez le nom de la personne désirée depuis la liste en cliquant dessus. Cet individu devient alors actif. La barre de statut est mise à jour en tenant compte de ce changement de personne active.

Voir aussi :

Modifier ou ajouter des individus

Utilisation de la catégorie Relations

Quand vous êtes dans la catégorie Relations, vous pouvez facilement naviguer d'une personne à une autre dans la famille affichée comme suit :

Cliquer sur le nom souligné de la personne qui vous intéresse et cet individu devient le nouvel individu actif de la catégorie Relations.

Le nom de la personne active n'est pas souligné.

En plus de tout cela, Gramps propose de nombreux raccourcis-claviers pour la navigation. Lisez la documentation de référence de ces commandes dans raccourcis clavier.

Utilisation de la catégorie Familles

Quand vous êtes dans la catégorie famille, vous pouvez aisément naviguer parmi les familles. La configuration de l'affichage permet de choisir les colonnes à afficher. Il est ensuite facile de classer ces familles selon le nom du père, de la mère, le type d'union… en cliquant sur l'en-tête de la colonne correspondante.

Utilisation de la catégorie Graphiques

File:Arbre fil du temps Ubuntu Groovy.png
Arbre au fil du temps issu d'une extension - avec menu contextuel

Gramps s'appuie beaucoup sur des écrans affichant des listes de relations. Cela suppose des liens entre vos enregistrements dans votre arbre généalogique. La catégorie Graphiques procure une alternative plus visuelle pour afficher ces relations. La position, la couleur, l'aspect des boites ainsi que les lignes qui les relient et les flèches peuvent mettre en évidence des liens complexes entre les individus. Les boites peuvent être simplement colorées, ou des arcs, des rubans ou d'autres formes.

La catégorie Graphiques permet également de vous déplacer à travers votre arbre familial. Le bénéfice de cette méthode étant que vous pouvez voir plus qu'une génération dans votre arbre. Par ailleurs, vous pouvez sauter directement d'un petit-fils à son grand-père sans passer par les générations intermédiaires.

Notez qu'après avoir changé de personne active dans les vues Graphiques, l'affichage est mis à jour en fonction de la nouvelle personne active. Dans les vues Graphiques, vous pouvez facilement naviguer entre les personnes affichées comme suit :

Pour définir une personne affichée comme étant la personne active, faire un clic-gauche sur la boîte correspondante. Un clic-droit sur une boite affiche un menu contextuel qui vous permet d'accéder à la modification de la personne de la boite mais aussi d'accéder aux conjoints, enfants, ou parents de chaque individu.

La navigation dans les graphiques dépend du type : vous pouvez soit tirer le graphique pour le déplacer vers la section qui vous intéresse, voit vous disposez de flèches qui vous permettent de vous déplacer dans les générations.

Par exemple, dans le graphique «arbre généalogique», pour naviguer vers un enfant de la personne active en cours (la racine à gauche de l'arbre), cliquez sur la flèche vers la gauche située à gauche de sa boîte. Si cette personne a plusieurs enfants, le bouton se développe en un menu déroulant proposant le choix entre les enfants. Pour déplacer le graphique d'une génération en arrière, cliquez sur le bouton correspondant à droite de l'arbre. Le bouton du haut fera suivre la lignée paternelle alors que le bouton du bas fera suivre la lignée maternelle.

Tango-Dialog-information.png
Avantages du menu contextuel

Un accès direct aux conjoints et frères ou soeurs. Des listes complètes de tous les acteurs de toutes les catégories, pas seulement les individus préférés.


Un clic droit sur ces boutons de navigation offre aussi un menu contextuel d'actions.

Il existe aussi d'autres fonctionnalités comme l'affichage «à la volée» d'information sur une relation en passant la souris sur un trait de relation ou l'ouverture d'une fenêtre de modification en double-cliquant sur un trait de relation pour une famille ou sur une boite pour un individu.

Certaines vues de cette catégorie sont décrite au chapitre Catégories.

Les vues disponibles dans cette catégories peuvent être étendues par des extensions disponibles dans le gestionnaire d'extensions, avec le type «vue Gramps». Certaines extensions tiers ont finis par être «encastrées» (intégrées) à l'application principale. Pour les autres, la documentation est très aléatoire.

Utilisation des Gramplets

Fig. 8.1 Relatives gramplet into People View

Dans la barre latérale et la barre inférieure, vous pouvez ajouter des Gramplets pour accroitre vos options de navigation au delà d'une seule génération. Par exemple :

Ces exemples vous offrent la possibilité à partir de la personne active, de naviguer dans les relations familiales… vers des parents proches, les ascendants, les descendants. D'autres Gramplets à venir devrait vous permettre de naviguer parmi les différents lieux géographiques, voire des corrélations ADN et d'autres interconnexions à imaginer.

Les Gramplets faits de texte proposent des hyperliens pour naviguer tandis que les Gramplets graphiques utilisent plutôt les menus contextuels.



Choisir le de Cujus, la souche

Un seul individu peut être sélectionné comme souche, de Cujus dans l'arbre généalogique. Une fois défini, aller à cet individu est l'affaire d'un seul clic dans n'importe quelle vue.

Pour choisir le «de Cujus», sélectionnez d'abord, par le moyen de votre choix, la personne voulue comme personne active. Faites Édition->Définir comme la souche. À partir de ce moment, vous pouvez retourner à cette personne simplement en cliquant sur l'icône Souche dans la barre d'outils. Vous pouvez également choisir Aller à->Souche dans le menu ou choisir l'élément Souche dans n'importe quel menu contextuel accessible par un clic droit de la souris, ou utiliser le raccourci clavier Alt+Début.

Définir la personne active

La personne active est l'individu sur lequel seront centré les actions, rapports, modifications.

Dans la vue des Individus, la personne active est surlignée. Dans la vue Relations, la personne active est affichée en haut de la fenêtre, dans une section séparée. Tous les autres individus affichés en dessous ont une relation proche avec la personne active (conjoints, frères et sœurs, enfants, parents).

Navigation par hyperlien

Habituellement, un clic sur le lien que constitue le nom d'une personne va faire que cette personne devienne la personne active.

Fig. 8.2 Vue Relations

Tous les noms de personnes dans la vue Individus ou Relations sont des hyperliens. Dans la vue Individus, la sélection d'une nouvelle personne active correspond simplement au nouvel individu surligné. Mais tous les Gramplets se mettent à jour selon cette nouvelle personne active et les vue Relations, Graphiques et Géographie seront aussi mises recentrées sur cette nouvelle personne active.

Sélectionner un nouveau nom (lien) dans la vue Relations a un effet plus visible : la représentation des données familiales est ré-arrangée selon cette nouvelle personne active ; les détails de la personne active sont affichés dans le haut de la fenêtre tandis que les autres individus ayant une relation avec la nouvelle personne active sont affichés en dessous.



Navigation par menu contextuel

Néanmoins, un double-clic sur les noms de personnes dans les onglets Références et Notes (barre inférieure et dans certains Gramplets) vont seulement ouvrir la fenêtre de modification de cet individu sans qu'il devienne la nouvelle personne active. Ceci facilite la modification des informations d'une personne autour de la personne active sans perturber la navigation en changeant la personne ayant le focus.

Fig. 8.3 Menu contextuel de la modification d'une personne

Dans ce contexte, si vous voulez réellement faire de cette nouvelle personne la personne active, il suffit, dans la fenêtre de modification de cette personne, de faire un clic-doit sur son nom pour afficher un menu contextuel et sélectionner «Faire personne active» (Make active person).


Utilisation de l'historique

Fig. 8.4 Exemple d'outil de navigation dans l'historique

Gramps dispose aussi d'un ensemble puissant d'outils reposant sur l'historique de navigation. Ces outils ressemblent à ceux des navigateur sur le Web. Ceci comprend les éléments Précédent et Suivant disponibles dans le menu Aller à les menus contextuels et les boutons de la barre d'outils. Il y a aussi la liste des sélections récentes accessible par le menu Aller à qui vous permet d'aller directement vers n'importe quelle personne sélectionnée récemment. Enfin, cliquer avec le bouton droit de la souris sur les boutons < Précédent et Suivant > de la barre d'outils active un menu déroulant avec les personnes correspondantes dans l'historique. Sélectionnez l'une d'elles et vous irez directement vers elle.

Navigation par signets

Gramps Go-Home48x48 win.png

Le bouton Aller à l'individu par défaut de la barre d'outils est un lien particulier. Il permet de faire de lapersonne souche (De Cujus) la personne active. Ceci est très fréquemment utile si bien qu'il est lié à un raccourci clavier Alt+Début.

Fig. 8.5 Organiser vos signets

Similaire à l'action de définir la souche, vous pouvez marquer d'autres individus dans la base de données pour une navigation simplifiée. Pour marquer un individu, tout d'abord allez sur cet individu, puis choisissez Signets -> Ajouter un signet. Pour aller vers cette personne n'importe quand, choisissez Signets -> nom de l'individu. Les autres catégories ont leur propre liste de signets.

Vous pouvez gérer vos signets en choisissant Signets ->Édition des signets ... ou par le raccourci clavier Maj+CTRL+D. Ceci lance la fenêtre de Édition des signets avec la liste des signets et les contrôles pour modifier la liste.

Utilisez les boutons Haut et Bas pour changer la séquence de la liste. Utilisez le bouton Enlever pour supprimer le signet. L'Aide vous conduit vers cette page, et vous pouvez fermer la fenêtre Édition des signets avec le bouton Fermer.

Les individus marqués peuvent être sélectionnés dans la catégorie individus, comme expliqué plus haut, mais sont partagés avec les catégories Relations, Graphiques.

Sur les mêmes bases vous pouvez également créer des signets dans les catégories Familles, Événements, Sources, Citations, Media, Dépôts, et Notes.

Les notes comme raccourcis de navigation

Il y a différentes listes de signets pour chaque catégorie. Mais ce ne sont que de simples listes. Les longues listes de signets deviennent rapidement lourdes.

Des liens permanents peuvent être créés dans les notes. L'éditeur de liens accessible dans la fenêtre de création des notes permet d'organiser vos liens vers différents types d'enregistrements dans Gramps selon votre méthode de travail.

Fig. 8.6 Éditeur de lien des notes

Pour créer un lien dans une note, vous devez d'abord surligner le texte de la note qui servira de lien puis cliquer sur le bouton Lien. Dans l'éditeur de lien, choisissez le type de lien dans la liste. Ensuite, sur la même ligne, vous avez le choix entre créer un nouvel objet pour ce lien avec le bouton Nouveau et rechercher un enregistrement existant par le bouton STOCK_INDEX (used for share).

Une fois le lien défini dans la note, il peut être utilisé comme un signet. Naviguer vers l'enregistrement lié en cliquant sur le lien tout en maintenant la touche Ctrl enfoncée. Une note peut servir d'index et pointer vers d'autres notes avec des listes de liens.

Un exemple de notes avec des liens pourrait concerner une inhumation avec des liens vers les individus présents, les lieux voire des évènements. Ceci permet de naviguer vers des individus qui ont des liens indirects voire une absence de liens (porteurs, personnes présentes, officiants…).

Une autre note pourrait être la transcription de la bibliographie publiée par un autre généalogiste. Au fur et à mesure que vous faites l'asquisition de ces sources, vous pouvez les lier dans votre note pour naviguer plus facilement vers elles.


Trouver les enregistrements

Fig. 8.7 Rechercher une donnée

Pour trouver un enregistrement dans la base de données, tout d'abord choisissez la vue désirée pour votre enregistrement : individus, sources, lieux, media, dépôts, notes. Puis commencez par saisir le nom ou le titre que vous recherchez. Vous pouvez également utiliser Ctrl+F pour ouvrir le mode recherche, mais commencer par saisir avec le clavier doit être suffisant.

Les premières lettres que vous tapez sont recherchées.

Tango-Dialog-information.png
Trouver les individus

Pour des recherches d'individus plus complexes vous pouvez utiliser les filtres en affichant la barre latérale.


Activez le contrôle de filtre par Affichage -> Barre latérale, sélectionnez le filtre désiré, et cliquez sur Appliquer. Voir les filtres pour plus de détails.

Tango-Dialog-information.png
Champ recherche

Un champ recherche apparaît au-dessus de la liste des individus si vous n'affichez pas la barre latérale comme dans l'image ci-dessus.


Utiliser le presse-papiers

Fig. 8.8 Presse-papiers

Cet outil fournit une note temporaire pour stocker des enregistrements de la base de données et une réutilisation plus facile. En résumé, il s'agit de la fonction glisser-déposer étendue aux objets et autres types d'enregistrements présents dans Gramps (c'est donc une fonction bien plus évoluée que le simple presse-papier du système d'exploitation permettant de faire copier-coller).


Pour une application comme Gramps, le presse-papiers est très pratique.Pour faire appel au presse-papiers, utilisez soit le menu {{{1}}} ou cliquez dans la barre d'outils sur le bouton Clipboard ou le raccourci clavier Ctrl+B.

Tango-Dialog-information.png
Le presse-papiers est optimisé avec la technique du glisser-déposer

Pour utiliser le presse-papiers, soit choisissez Édition -> Presse-papiers soit cliquez sur le bouton Presse-papiers de la barre d'outils.


On peut stocker des adresses, des attributs (personnel et famille), des événements (personnel et famille), des noms, les objets media, des références, des citations, des URLs, et naturellement l'information textuelle des notes et des commentaires. Pour stocker, glisser simplement le texte dans la boîte de dialogue. Pour réutiliser l'information, glisser-la à l'endroit correspondant, par exemple onglet d'adresse, onglet d'attribut, etc...

Tango-Dialog-information.png
Astuce

Quelques objets montrent l'icône de lien du côté gauche. Ceci indique que déposer un tel choix produira une référence à un objet existant, pour ne pas copier l'objet lui-même. Par exemple, le fichier medium ne sera pas reproduit. Au lieu de cela, la référence sera faite à un objet existant, qui aura comme conséquence l'entrée locale.


Gnome-important.png
Attention !

Le stockage est persistant au cours d'une session de Gramps. La fermeture de la fenêtre du presse-papiers ne perdra pas les informations stockées à l'intérieur de celui-ci. Par contre, le presse-papiers sera réinitialisé lors de la fermeture de Gramps.

Si vous voulez vraiment enregistrer ce presse-papiers pour une future session, il existe une extension-tierce Collections Clipboard Gramplet qui le permet.

Juste un exemple : vous trouvez l'acte de naissance d'un individu. Ce dernier mentionne également les témoins. Et cet acte est une source avec ses informations. La meilleure solution étant d'ouvrir le presse-papiers et de glisser la source. Puis d'utiliser la fonction glisser-déposer chaque fois que vous en avez besoin.

Vous finalisez les informations dans l'Éditeur d'individu. Glissez ces informations dans le presse-papiers. Vous ajoutez deux individus comme témoins (si ils ne sont pas déjà présents dans la base de données). Un simple glisser-déposer depuis l'information sur la naissance dans l'événement du témoin. Vous changez le rôle en témoin de la naissance. Vous pouvez reproduire ce schéma pour d'autres témoins.

Ceci vous évite de longues saisies et erreurs possibles.

Menus principaux

La barre des menus affiche les menus de Gramps. Le contenu des menus peut varier suivant la catégorie sélectionnée. Les menus disponibles sont plus réduits s'il n'y a pas d'arbre généalogique ouvert.


Arbres familiaux

Fig. 8.9 Menu "Arbres familiaux"
  • Gestion des arbres familiaux… - ouvre la fenêtre de gestion des arbres familiaux
  • Fichiers récemment ouverts - un accès rapide aux arbres récemment utilisés
  • Fermer - enregistre et ferme la généalogie en cours

  • Importer… - Ajouter les données d'autres formats.
    Faire une sauvegarde avant une importation ! Il y a des Préférences d'importation permettant de marquer les données importés avec une étiquette (Tag) et/ou la Source. Ces options peuvent beaucoup ralentir le processus d'importation mais sont utiles pour ensuite pour faire le tri de vos données.
  • Exporter… - Exportation des données : cela vous permet de partager n'importe quelle partie de votre arbre familial Gramps avec d'autres chercheurs ainsi que le transfert de vos données vers un autre ordinateur.

  • {{man menu|[[Fr:Manuel_wiki_pour_Gramps_5.1_-_Réglages#Exporter_l'écran|Exporter l'affichage…]}} - Ce menu n'apparait que dans certaines vues si les données affichées peuvent être exportées. Gramps va exporter les données à l'écran au format de tableur CSV ou Open Document selon votre choix.


  • Abandonner mes modifications et quitter… -
  • Quitter… -


Ajouter

Fig. 8.10 Menu AJouter



Édition

Fig. 8.11 Menu Édition pour la Catégorie Individu
  • Annuler -
  • Rétablir -
  • Historique d'annulation… - Ouvre la fenêtre Historique d'annulation

Des options de menu supplémentaires s'affichent ici selon la vue de Catégorie sélectionnée.


  • Presse-papiers - Le presse-papiers offre un calepin temporaire pour enregistrer des données et les réutiliser facilement durant la session en cours.

  • Préférences... - Affiche la fenêtre des Préférences. Elle vous permet d'ajuster les principaux réglages de Gramps.
  • Des options supplémentaires s'affiche ici selon la vue de Catégorie sélectionnée.


Affichage

Fig. 8.12 Menu Affichage pour la catégorie Relations
  • Configuration… - Vous permet de configurer la vue actuelle. Propose des options pour cacher, afficher ou réorganiser des éléments.
  • Navigateur… - Le navigateur est la barre latérale qui contient les icônes de navigation parmi les Catégories. Quand elle est sélectionnée (par défaut), cette barre latérale s'affiche à gauche de la vue active. La délectionner cache le navigateur. Si toutes les icônes de catégorie ne peuvent pas entrer dans l'espace vertical disponible, un ascenceur caché va apparaître à la partie droite de la barre latérale et se révèle au passage de la souris.
    Le texte des étiquettes liés aux icônes peuvent être cachés via une option dans l'onglet des préférences d'affichage. Le mode d'affichage des catégories peut être choisi dans la liste déroulante au pied de la barre latérale du navigateur.
  • Barre d'outils - Affiche (ou cache) un conteneur d'icônes d'actions (fréquemment utilisées) au dessus de la fenêtre principale de la Catégorie. La sélection d'icônes varie pour s'adapter à la Catégorie affichée.
    Des extensions tierces peuvent être installées pour ajouter des préférences avec un onglet qui propose une option pour afficher le texte des étiquettes pour chaque bouton de la barre d'outils.
  • Barre latérale - Affiche (ou cache) un conteneur d'écran partagé pour des Gramplets à la droite de la fenêtre principale de la Catégorie en cours.
  • Barre inférieure - Affiche (ou cache) un conteneur d'écran partagé pour des Gramplets au pied de la fenêtre principale, juste au dessus de la barre d'état.
  • Plein écran - Agrandit l'affichage pour utiliser tout l'espace d'écran disponible tout en désactivant les contrôles pour déplacer ou modifier la taille de la fenêtre. La désélection restore la taille précédente de la fenêtre et réactive la possibilité de déplacer et modifier la taille de la fenêtre.

  • Selon la vue active, d'autres items de menu peuvent s'afficher ici et modifier l'organisation des donnéees pour la vue active.


Aller à

Fig. 8.13 Menubar - Go Overview
  • Précédent - pour la vue actuelle, vous ramène à la sélection précédente de votre historique de navigation
  • Suivant - pour la vue actuelle, vous emmène à la sélection suivante de votre historique de navigation


  • Une liste dynamique des 10 enregistrements les plus récents sélectionnés (Individus, Familles, etc). La liste est dépendante de la vue de Catégorie affichée.
Gnome-important.png
Bug connu patch pour Gramps version 5.1.1 (résolu en Version 5.1.2)

Résoud la perturbation de la sélection du menu 'Aller à' secondaire à une mise à niveau récente du gestionnaire d'interface utilisateur
Rapport de bug : 11341 du 24 Sept 2019

Tango-Dialog-information.png
Vous pouvez utiliser l'extension tierce RestoreHist

Elle permet de conserver une partie du menu "Aller à" quand vous relancez Gramps. Si vous l'installez, vous pouvez manuellement supprimer l'état enregistré en cherchant puis en supprimant le fichier /gramps51/plugins/RestoreHist/hist_save.ini dans votre répertoire utilisateur (dans le répertoire ~.gramps ou le répertoire %Appdata% sous Windows).



Signets

Fig. 8.14 Menu Signets
  • Ajouter un signet - Crée un signet pour l'item actuellement sélectionné, c-à-d : Individu, Famille, etc.
  • Édition des signets… - Ouvre la fenêtre Édition des signets.

  • Section dynamique où les signets s'affichent.


Reports

Fig. 8.15 Menubar - Reports Overview
  • Books... - The Books Report allows you to create a custom genealogy book containing a collection of Gramps textual and graphical reports in a single document (i.e. a Book)


Tools

Fig. 8.16 "Tool >..." Menubar - Tools Overview


Windows

Fig. 8.17 Menubar - "Windows" - overview example
  • Windows - This menu provides quick access to opened windows you are working on.


Help

Fig. 8.18 Menubar - "Help" - overview example
  • User Manual - Direct link to the online Gramps User manual you are viewing right now. Yes, you need an internet connection to consult the Gramps User Manual.
  • FAQ - A link to the Frequently Asked Questions about Gramps.
  • Key Bindings - A link to the Keybindings reference for Gramps. Also known as Keyboard shortcuts.
  • Tip of the Day - Displays the "Tip of the day" dialog.
  • Plugin Manager - From this menu you can manage the built in plugins as well as any Third-Party Addons you may have installed.
  • Gramps Home Page - This item opens your web browser and connects to the Gramps project web site.
  • Gramps Mailing List - This item opens your web browser to the Gramps mailing list page. On this page, you can browse the mailing list archives and join the gramps-users mailing list so you can share your experiences with other Gramps user's.
  • Report a Bug - Choose this item to file a bug report in the Gramps bug tracking system. (This requires you to have a registered account on the Gramps bug reporting system) (Remember, Gramps is a living project. We want to know about any problems you encounter so we can work to solve them for you and everyone elses benefit.)
  • Extra Reports/Tools - A link to Installing Third-Party Addons in Gramps.
  • About - This item displays a dialog with general information about the Gramps version you are running.