De:Gramps 5.1 Wiki Handbuch - Werkzeuge

From Gramps
Revision as of 11:53, 30 December 2021 by Leonhaeuser (talk | contribs) (Werkzeuge)
Jump to: navigation, search
Zurück Index Nächste


Abb. 14.1 "Werkzeuge >..." Menüleiste - Werkzeuge Übersicht

Dieses Kapitel beschreibt die verschiedenen Werkzeuge, die in Gramps verfügbar sind.

Gramps Werkzeuge ermöglichen dir verschiedene Arten der Analyse deiner Genealogiedaten durchzuführen. Typischerweise erzeugen Werkzeuge keine Ausgaben in der Form von Ausdrucken oder Dateien. Stattdessen erzeugen sie Bildschirmausgaben die dem Forscher sofort zur Verfügung stehen. Allerdings kannst du, wenn es dienlich ist, die Ergebnisse eines laufenden Werkzeugs in einer Datei speichern.

Contents

Werkzeuge

Abb. 14.2 Werkzeugleistensymbol für "Öffnet den Werkzeugdialog"

Auf die Werkzeuge kann über das Menü Werkzeuge ->Werkzeugabschnitt ->Jeweiliges Werkzeug zugegriffen werden.

Alternativ kannst du die komplette Liste der verfügbaren Werkzeuge mit einer kurzen Beschreibung im Werkzeugauswahl Dialog, der über die Werkzeuge Schaltfläche in der Werkzeugleiste aufgerufen wird, durchsuchen.

Gramps-notes.png
Zusätzliche Werkzeuge

Gramps ermöglicht es dir, noch mehr Werkzeuge zu installieren. Dieses System wird über die Zusatzmodulverwaltung gesteuert. Die Zusatzmodulverwaltung kann zusätzliche Erweiterungen für dich holen.

Werkzeugauswahl Dialog

Abb. 14.3 Werkzeugauswahl Dialog - Beispiel zeigt " Finde mögliche doppelte Personen" Information

Im Dialog Werkzeugauswahl kannst du die vollständige Auswahl der verfügbaren Werkzeuge zusammen mit ihren kurzen Beschreibungen durchsuchen, wenn sie aufgerufen werden, indem du in einer der Kategorien auf das Symbol Werkzeugdialog öffnen in der Symbolleiste klickst und die Listen mit den Pfeilen erweiterst.

Analyse und Untersuchung

Dieser Abschnitt enthält Werkzeuge, die die Datenbank analysieren und untersuchen, sie aber nicht verändern. Die folgenden Analyse- und Untersuchungswerkzeuge stehen aktuell in Gramps zur Verfügung:

Einzelne Ereignisse vergleichen

Abb. 14.4 "Einzelne Ereignisse vergleichen" - "Filterauswahl für Ereignisvergleich" - Dialog

Dieses Werkzeug vergleicht quer über die gewählte Gruppe von Personen.

Du kannst dieses Werkzeug über das Menü Werkzeuge->Analyse und Untersuchung > Einzelne Ereignisse vergleichen... aufrufen, wodurch der Filterauswahl für den Ereignisvergleich Dialog geöffnet wird.

Die Personen für diesen Vergleich können aus zuvor erstellten benutzerdefinierten Filtern ausgewählt werden, indem du die Dropdown-Liste Filter: auswählst, die standardmäßig die Gesamte Datenbank enthält. Oder indem du die Schaltfläche Benutzerfiltereditor auswählst, um benutzerdefinierte Filter im Editor für Personenfilter zu erstellen. Um den Bericht auszuführen, wähle Anwenden und die Ergebnisse werden im Dialogfeld Ereignisvergleichs-Resultate angezeigt.


Im Dialogfeld Ereignisvergleichs-Resultate kannst du die Ergebnisse anzeigen oder als Ergebnistabelle als Tabellenkalkulation (ODS-Format) Speichern unter. Wähle Schließen, um den Bericht zu beenden.

Abb. 14.5 "Einzelne Ereignisse vergleichen" - "Ereignisvergleichs-Resultate" - Dialog - erweitertes Beispiel


Stammbaumverarbeitung

Dieser Abschnitt enthält Werkzeuge die deine Daten ändern können. Die Werkzeuge aus diesem Abschnitt werden Hauptsächlich dazu verwendet Fehler in den Daten zu finden und zu beheben. Die folgenden Stammbaumverarbeitungswerkzeuge stehen aktuell in Gramps zur Verfügung:

Gramps-notes.png
Hinweis

Die Änderungen werden außer bei den automatischen Fehlerkorrekturen durch das Datenbank überprüfen und reparieren Werkzeug erst nach deinem ausdrücklichen Einverständnis durchgeführt.

Datenbankeigner Informationen bearbeiten

Abb. 14.6 "Datenbankeignereditor" - Dialog - zeigt Kontextmenü

Dieses Werkzeug ändert alle vorhandenen Forscherinformationen.

Klicken von Werkzeuge-->Stammbaumverarbeiung-->Datenbankeigner Informationen bearbeiten öffnet das Editor Datenbankeigner Fenster, in das du die benötigten Informationen eingeben kannst.

  • Name:
  • Straße:
  • Lokalität:
  • Stadt:
  • Bundesland/Kreis:
  • Land:
  • PLZ/Postleitzahl:
  • Telefon:
  • E-Mail:

Diese Informationen sind stammbaumspezifisch und werden beim Export deiner Daten in das GEDCOM-Format verwendet.

Über das Kontextmenü (Rechtsklick) stehen zwei Auswahlmöglichkeiten zur Verfügung:

  • Kopiere aus DB in die Einstellungen -
  • Kopiere von den Einstellungen in die DB -


Ereignisbeschreibung extrahieren

Gramps-notes.png
Hinweis

Das Namensformat im Beschreibungsfeld des Ereignisses hängt vom definierten Namensformat in Bearbeiten->Einstellungen->Anzeige->Namensformat ab

Abb. 14.7 Ereignisbeschreibung extrahieren - Änderungen durchgeführt - Fenster - Beispielergebnis

Extrahiert Ereignisbeschreibungen aus Ereignisdaten nach folgendem Schema:

{Ereignistyp} von {Familienname}, {Vorname}

Wenn eine Ereignisbeschreibung fehlt, füllt dieses Werkzeug das Feld nach oben genanntem Schema.

Du erreichst dieses Werkzeug über das Menü Werkzeuge->Stammbaumverarbeitung->Ereignisbeschreibung extrahieren...

Der Verlauf zurücksetzen Warnung Dialog wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Sobald du Mit dem Werkzeug fortfahren gewählt hast, scannt und modifiziert dieses Werkzeug deinen Stammbaum und zeigt dir das Ergebnisfenster Änderungen vorgenommen an, das die Gesamtzahl der hinzugefügten Ereignisbeschreibungen auflistet.

Informationen aus Namen extrahieren

Dieses Werkzeug durchsucht die gesamte Datenbank und versucht Titel und Spitznamen die in dem Vornamenfeld einer Person enthalten sein können zu extrahieren. Wenn irgendeine Information extrahiert werden konnte, werden die Kandidaten für eine Korrektur in einer Tabelle dargestellt. Du kannst dann entscheiden welche wie vorgeschlagen korrigiert werden und welche nicht.

Du kannst auf dieses Werkzeug über das Menü Werkzeuge->Stammbaumverarbeitung->Informationen aus Namen extrahieren.... zugreifen.

Der Verlauf zurücksetzen Warnung Dialog wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Abb. 14.8 "Standard Präfix und Verbinder einstellen" - Dialog für das Werkzeug "Informationen aus Namen extrahieren"

Der Standard Präfix und Verbinder einstellen Dialog wird gezeigt und du kannst jede Option wie benötigt ändern:

  • Präfix für die Suche: de, van, von, di, le, du, dela, della, des, vande, ten, da, af, den, das, dello, del, en, ein, elet, les, lo, los, un, um, una, uno, der, ter, te, die (Vorgabe)
  • Verbinder, die Nachnamen aufteilen: e, y (Vorgabe)
  • Verbinder, die Nachnamen nicht aufteilen: de, van (Vorgabe)

Wenn du fertig bist, wähle OK um das Werkzeug zu starten.

Abb. 14.9 "Auszug von Name und Titel Werkzeug" - Ergebnisdialogfenster für das Werkzeug "Informationen aus Namen extrahieren"

Anschließend wird das Auszug von Namen und Titeln Ergebnisdialogfenster angezeigt.

Extrahiere Ortsdaten aus Ortstitel

Gnome-important.png
Dieses Werkzeug wurde in Zusatzmodule von Drittanbietern verschoben!

Als die Ortshierarchie zum ersten Mal zu Gramps hinzugefügt wurde, benötigte jeder Anwender ein Werkzeug zum Extrahiere Ortsdaten aus Ortstitel. Da nun eine Hierarchie von Orten etabliert ist, wird das Werkzeug nur noch selten benötigt. Die Installation ist also optional.

Finde mögliche doppelte Personen

Abb. 14.10 Finde mögliche doppelte Personen - Dialog - Vorgabe

Das Werkzeug Finde mögliche doppelte Personen durchsucht die gesamte Baumdatenbank nach Einträgen, die möglicherweise dieselbe Person repräsentieren.

Du erreichst dieses Werkzeug über das Menü Werkzeug -> Stammbaumverarbeitung Stammbaumverarbeitung-> Finde mögliche doppelte Personen....

Das Dialogfeld Finde mögliche doppelte Personen wird angezeigt und du kannst die folgenden Optionen anpassen:

  • Vergleichsschwellwert : wähle zwischen Niedrig(Standard) Mittel und Hoch aus dem Aufklappmenü.
Gramps-notes.png
Wie wird die Qualität der Übereinstimmung gemessen?

Dies berechnet die Chancen (oder 'Quoten') der Übereinstimmung auf einer Qualitätsskala, die als niedrig, mittel und hoch bezeichnet wird. Für jede entsprechende Information wird die Qualität der Übereinstimmung als geringfügig erhöht angesehen. Je enger die einzelnen Daten korrelieren, desto größer ist der Anstieg. Wenn die Wahrscheinlichkeit größer als der ausgewählte Übereinstimmungsschwellenwert ist, wird eine Übereinstimmung gemeldet. Die Schwellenwerte sind Niedrig = 0,25, Mittel = 1,0 und Hoch = 2,0. Wenn also der Filterschwellenwert auf Hoch eingestellt ist, werden weniger Übereinstimmungen erwartet.

Optionen

  • Verwendung von Soundex Code für mögliche übereinstimmende Personen. (Kontrollkästchen standardmäßig aktiviert)


Die folgenden Schaltflächen sind vorhanden: Hilfe bringt dich auf diese Seite, Abbrechen zum Beenden der Verarbeitung und OK zum Start der Verarbeitung der Daten. Klicke auf die OK Schaltfläche um das Werkzeug zu starten und die Daten werden in zwei Durchgängen verarbeitet.

  • Durchgang 1: vorläufige Listen erstellen
  • Durchgang 2: mögliche Übereinstimmungen berechnen.

Es wird ein Fortschrittsbalken angezeigt und abhängig von der Geschwindigkeit deines Rechners und der Anzahl der Personen in deiner Datenbank kann dies eine Weile dauern.


Abb. 14.11 "Mögliche Zusammenführungen" Ergebnisdialogfenster für "Finde mögliche doppelte Personen" - Dialog - Beispiel

Zum Schluss wird ein Mögliche Zusammenführungen Fenster angezeigt. Dieses Fenster enthält eine Liste mit drei Spalten:

  • Bewertung : dies gibt dir eine Vorstellung von der Ähnlichkeit der beiden Personen. Je höher die Bewertung desto größer ist die Wahrscheinlichkeit, das diese Personen identisch sind.
  • Erste Person
  • Zweite Person

Wenn du eine Zeile auswählst, kannst du die Details mit der Vergleichen Schaltfläche überprüfen oder du kannst die gewählte Zeile doppelklicken.

Das Fenster besitzt drei Schaltflächen: Hilfe bringt dich auf diese Seite, Schließen um das Fenster zuschließen, was dich zurück zu dem Mögliche doppelte Personen finden Fenster bringt und eine Vergleichen Schaltfläche die ein Personen vergleichen Fenster öffnet, welches in Personen zusammenfassen im Detail beschrieben wurde. Hier kannst du mit den Optionsschaltflächen eine der Personen wählen und eventuell die Zusammenfassen und schließen Schaltfläche verwenden um die Daten zusammenzufassen wenn du herausgefunden hast, das diese Personen identisch sind.

Wenn du auf die Schaltfläche Abbrechen klickst, gelangst du zurück zum Ergebnislistenfenster Mögliche Zusammenführungen.

Großschreibung von Nachnamen korrigieren

Dieses Werkzeug durchsucht die gesamte Datenbank und versucht die Großschreibung von Familiennamen zu korrigieren.

Das Ziel ist es, eine übliche Groß/Kleinschreibung zu erreichen: erste Buchstabe groß und die restlichen Buchstaben des Familiennamens klein. Wenn Abweichungen von dieser Regel festgestellt werden, werden die Kandidaten für die Korrektur in der Tabelle angezeigt.

Du kannst dann entscheiden, welche wie vorgeschlagen korrigiert werden sollen und welche nicht.

Du erreichst dieses Werkzeug über das Menü Werkzeuge->Stammbaumverarbeitung->Großschreibung von Nachnamen korrigieren....

Der Verlauf zurücksetzen Warnung Dialog wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.


Abb. 14.12 "Capitalization changes" - Dialog - Ergebnis Beispiel für "Großschreibung von Nachnamen korrigieren" Werkzeug

Wenn es Änderungen in der Großschreibung von Namen gab, wird das Änderungen der Großschreibung Fenster geöffnet. Das Fenster zeigt eine Liste der Familiennamen, die Gramps in die (laut Gramps) korrekte Großschreibung umwandeln kann (bitte überprüfe, ob es für dich richtig ist.). In der Ergebnisliste der Groß-/Kleinschreibungsänderungen stehen die folgenden Spalten zur Verfügung:

  • Auswählen - Aktiviere oder deaktiviere diese "nach Namen", wenn du die Empfehlung nicht akzeptierst (Kontrollkästchen standardmäßig aktiviert)

Ursprünglicher Name - Der Name wie aktuell aufgezeichnet. Änderungen der Großschreibung - Der Name mit Änderung, falls angewendet.

Wähle die Namen, die du ändern möchtest dann klicke auf die Änderungen akzeptieren und schließen Schaltfläche. Oder verwende die Abbrechen Schaltfläche um die Änderungen zu verwerfen.

Du kannst auch das "Großschreibung von Vornamen korrigieren" Werkzeugzusatzmodul installieren es arbeitet nahezu identisch wie dieses Werkzeug aber für "Vornamen".

Fundstellen zusammenfassen

Tango-Dialog-information.png
Das Fundstellen zusammenfassen Werkzeug

funktioniert durch die Kombination von Notizen, Medienobjekten und Datenelementen passender Fundstellen.


Du erreichst dieses Werkzeug über das Menü Werkzeuge > Stammbaumverarbeitung > Fundstellen zusammenfassen...

Der Verlauf zurücksetzen Warnung Dialog wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.


Abb. 14.13 "Fundstellen zusammenfassen" - Dialog - Voreinstellung

Dann wird der Dialog Fundstellen zusammenfassen (Titel des Dialogs zeigt: Notizen, Medienobjekte und Datenelemente passender Zitate werden kombiniert.) angezeigt

Folgende Optionen stehen zur Verfügung:

  • Vergleichsschwellwert Aufklappliste:
    • Liefert Seite/Band, Datum und Vertrauensgrad
    • Datum ignorieren (Vorgabe)
    • Vertrauensgrad ignorieren
    • Datum und Vertrauensgrad ignorieren
  • Optionen
    • Nicht zusammenfassen, wenn die Fundstelle Notizen enthält (Kontrollkästchen standardmäßig deaktiviert)


Abb. 14.14 "Anzahl erfolgter Zusammenfassungen" Ergebnisdialog für "Fundstellen zusammenfassen" - Dialog - Werkzeug - Beispiel

Wähle OK, um das Werkzeug auszuführen, und nach Abschluss wird die Gesamtsumme mit dem Ergebnisdialogfeld Anzahl erfolgter Zusammenfassungen zurückgemeldet.
Siehe auch die Option Fundstellen zusammenfassen, die in der Listenansicht der Fundstellenkategorie verfügbar ist

Ereignisarten umbenennen

Dieses Werkzeug benennt alle Ereignisse einer Art in eine andere Art um.

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Stammbaumverarbeitung -> Ereignisarten umbenennen....

Der Verlauf zurücksetzen Warnung Dialog wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.


Abb. 14.15 "Ereignisarten ändern" - Dialog - Beispiel für "Ereignisarten umbenennen" Werkzeug

Der Ereignisarten ändern Dialog wird angezeigt.

  • Ursprüngliche Ereignisart: schreibe in das Textfeld oder verwende das Aufklappmenü, um eine originale Ereignisart zu wählen.
  • Neue Ereignisart: Schreibe in das Textfeld (du kannst hier eine völlig neue Art erstellen) oder verwende das Aufklappmenü, um eine neue Art zu wählen.

Das Beispiel zeigt eine Umbenennung des Ereignisses Geburt in ein Ereignis Taufe.

Gramps-notes.png
Benutzerdefinierten Arten

Während die benutzerdefinierten Arten nicht in der Dropdown-Liste angezeigt werden, kannst du überschreiben oder in eines der Auswahlfelder einfügen und von einer in eine andere konvertieren.



Abb. 14.16 "Arten ändern" - Ergebnisdialog - Beispiel für "Ereignisarten umbenennen" Werkzeug

Verwende abschließend Abbrechen, um das Werkzeug zu beenden, oder wähle OK, um das Werkzeug auszuführen, und sobald es abgeschlossen ist, werden die gesamten geänderten Ereignisse mit dem Ergebnisdialogfeld Arten ändern zurückgemeldet.

Gnome-important.png
Ereignisarten umbenennen

Wenn es einmal abgeschlossen ist, kann es nicht mit der üblichen Rückgängig Funktion rückgängig gemacht werden.

See also:

Ordne Gramps-IDs neu

Dieses Werkzeug kann verwendet werden, um deine Gramps-IDs neu zu ordnen. Es stehen mehrere Optionen zur Verfügung.

Gnome-important.png
Benutzerdefinierte IDs

Wenn du deine IDs angepasst hast, können alle diese durch dieses Werkzeug ersetzt werden. Sei also vorsichtig, bevor du dieses Werkzeug verwendest!

Abb. 14.17 Ordne Gramps-IDs neu

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Stammbaumverarbeitung -> Ordne Gramps-IDs neu....

Die Spalte 'Objekt' listet die Art der ID auf. Unmittelbar links neben dieser Spalte befinden sich Kontrollkästchen, die das Aktivieren von Änderungen an einzelnen Objekttarten ermöglichen. Wenn aktiviert, kann die Art neu geordnet werden. Die Bezeichnung 'Objekt' ist eigentlich eine Schaltfläche, mit der du alle Kontrollkästchen auf einmal umschalten kannst.

Die Spalte 'Aktuell' zeigt ein Beispiel für die aktuelle ID. Die Spalte 'Anzahl' zeigt die Anzahl der Objekte.

In der Spalte 'Format' kann das ID-Format für jede Objektart geändert werden. Beachte, dass das Format aus einem Präfix, dem '%04d' und einem Suffix besteht. Es MUSS mindestens ein Präfix oder ein Suffix vorhanden sein, beides ist erlaubt. Es wird empfohlen, diese relativ kurz zu halten. '%04d' definiert die Länge des numerischen Teils der ID, die '4' kann geändert werden, alles von '3' (zulässige Zahlen von 000-999) bis '9' (000000000-999999999) ist erlaubt. Die hier vorgenommenen Änderungen sind die gleichen wie im Menü Bearbeiten->Einstellungen... und wähle dann die Registerkarte ID-Formate. Das Bezeichnung 'Format' ist eigentlich eine Schaltfläche, mit der alle Formate auf den zuletzt verwendeten Wert zurückgesetzt werden können.

Die Spalte 'Ändern' enthält Kontrollkästchen für jede Objektart. Wenn dies aktiviert ist, werden die IDs für dieses Objekt durch neue IDs des Stils 'Format' ersetzt, es sei denn, 'Schutz' ist ebenfalls aktiviert. Wenn nicht aktiviert, werden die ID-Formate NICHT aktualisiert, aber das Nummernfeld innerhalb des Formats wird neu nummeriert. Die Beschriftung 'Ändern' ist eigentlich eine Schaltfläche, mit der alle Kontrollkästchen gleichzeitig umgeschaltet werden können.

Das Feld 'Start' zeigt die Startnummer an, die während der Neunummerierungsoperation verwendet wurde. Die Beschriftung 'Start' ist eigentlich eine Schaltfläche, mit der zwischen Start bei 0 und Start nach der letzten aktuellen Nummer umgeschaltet werden kann.

Das Feld 'Schritt' zeigt das Intervall zwischen den Zahlen während der Neunummerierung an, '1' ist eine einfache Erhöhung, '2' wird um 2 erhöht usw. Die Beschriftung 'Schritt' ist eigentlich eine Schaltfläche, die verwendet werden kann, um zwischen '1', '2', '5' und '10' umzuschalten.

Die Spalte 'Schutz' enthält Kontrollkästchen für jede Objektart. Wenn dies und 'Änderung' markiert sind, werden die ID-Formate für dieses Objekt beibehalten und das Nummernfeld innerhalb des Formats wird neu nummeriert. Die Beschriftung 'Schutz' ist eigentlich eine Schaltfläche, mit der alle Kontrollkästchen gleichzeitig umgeschaltet werden können.

Der Verlauf zurücksetzen Warnung Dialog wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.

Wenn du auf 'OK' klickst, zeigt das Werkzeug einen Fortschrittsbalken an.

In verschiedenen Phasen werden die folgenden IDs neu geordnet: Personen-IDs neu anordnen, Familien-IDs neu anordnen, Ereignis-IDs neu anordnen, Medienobjekt-IDs neu anordnen, Quellen-IDs neu anordnen, Fundstellen-IDs neu anordnen, Orts-IDs neu anordnen, Aufbewahrungsorte-IDs neu anordnen und schließlich Notiz-IDs neu anordnen.

In einem nächsten Schritt werden ungenutzte IDs gesucht und zugewiesen.

Während dieses Vorgangs überprüft das Werkzeug jede ID, um zu sehen, ob sie 'angepasst' aussieht, ob sie nicht wie das vorherige ID-Format oder das Standard-ID-Format aussieht. Dies kann der Fall sein, wenn der Benutzer beim Bearbeiten einen eigenen Text in das ID-Feld des Objekts eingegeben hat. Es kann auch auftreten, wenn das Drittanbieter GetGOV Zusatzmodul oder GeoName Zusatzmodul verwendet wurde, da dieses Werkzeug die GOV-ID im ID-Feld speichert. Wenn eine 'benutzerdefinierte' ID gefunden wird, wird der Benutzer gefragt, ob er die ID wirklich ersetzen möchte. Der Dialog ermöglicht es dem Benutzer auch, dieselbe Antwort für andere gefundene benutzerdefinierte IDs zu verwenden.

Sortiert Ereignisse

Ereignisse im Ereignisreiter vom Personen und Familieneditor erscheinen in keiner bestimmten Reihenfolge außer in der Reihenfolge in der sie hinzugefügt wurden. Der Grund warum die Ereignisse nicht auf eine bestimmte Art wie zum Beispiel nach Datum sortiert werden, ist das ein Ereignis eingeordnet werden kann auch wenn kein genaues Datum oder Reihenfolge bekannt sind. Der Import oder das Zusammenfassen von Daten aus einer externen Quelle kann auch zu zusätzlich hinzugefügten Ereignissen, die außerhalb der Reihenfolge bestehender Ereignisse einer Person oder Familie liegen führen.

Ereignisse können manuell via Drag & Drop oder durch Verwendung der neu-ordnen Schaltflächen im Ereignisse Reiter neu angeordnet werden. So oder so kann ein Ereignis in der Ereignisliste hoch oder runter bewegt werden und Gramps merkt sich die neue Anordnung, wenn die Änderungen gespeichert werden. Die neue Reihenfolge wird überall dort verwendet, wo Ereignisse in Gramps angezeigt werden zum Beispiel in einem Bericht.

Die Reihenfolge von allen Ereignissen in einem Reiter kann auch durch klicken auf den Spaltentitel geändert werden. Zum Beispiel klicken auf den 'Datum' Spaltentitel sortiert alle Ereignisse nach Datum. Jedoch ist diese Art der Sortierung nicht von Dauer beim Schließen des Fensters werden diese Änderungen rückgängig gemacht.

Die Drag & Drop Methode zum Sortieren von Ereignissen ist gut wenn eine kleine Anzahl sortiert wird aber für große Mengen ungeeignet. Das Ereignisse sortieren Werkzeug wurde speziell für diesen Zweck entwickelt, alle Ereignisse in der Datenbank neu sortieren oder nur jene die mit über einen Filter ausgewählten Personen zusammenhängen.

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Stammbaumverarbeitung -> Sortiert Ereignisse....

Der Verlauf zurücksetzen Warnung Dialog wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.


Abb. 14.18 "Sortiert Ereignisse" - Dialog - zeigt "Werkzeugoptionen" Registerkarte für "Sortiert Ereignisse" Werkzeug

Die erste Option im Ereignisse sortieren Fenster wird verwendet um die Auswahl der Personen, deren Ereignisse sortiert werden, festzulegen. Die erste Möglichkeit in der Liste ist, alle Personen der Datenbank zu sortieren. Alternative Möglichkeiten sind die Sortierung auf Vorfahren oder Nachkommen einer bestimmten Person oder eine Reihe von Personen aus einem vom Anwender erstellten Filter anzuwenden. Nach der Wahl, wen die Sortierung betreffen soll, ist der nächste Schritt festzulegen, wie die Ereignisse sortiert werden sollen. Die erste Möglichkeit ist, sie nach dem Datum zu sortieren,. Das ist wohl die wahrscheinlichste Auswahl, es können aber auch andere Ereigniseigenschaften ausgewählt werden. Die letzten Auswahlen betreffen die Sortierreihenfolge (aufsteigen oder absteigend) und ob die zur Person gehörenden Familienereignisse auch sortiert werden sollen.


Gnome-important.png
Ereignisse sortieren

Sobald dies abgeschlossen ist, kann dies nicht mehr mit der regulären Funktion Rückgängig rückgängig gemacht werden.

Stammbaumreparatur

Datenbank prüfen und reparieren

Gnome-important.png
Warnung

Das Werkzeug Datenbank prüfen und reparieren führt automatische Korrekturen durch. Sobald diese abgeschlossen sind, kann dies nicht mehr mit der regulären Funktion Rückgängig rückgängig gemacht werden.

Dieses Werkzeug überprüft die Datenbank auf Integritätsprobleme und behebt sie wenn es ihm möglich ist. Im Besonderen sucht es nach:

  • Kaputten Familienverknüpfungen. Dies sind die Fälle in denen ein Personendatensatz auf eine Familie verweist, der Familiendatensatz aber nicht auf die Person verweist und umgekehrt.
  • Fehlende Medienobjekte. Das fehlende Medienobjekt ist das Objekt dessen Datei in der Datenbank verknüpft ist aber nicht existiert. Dies kann passieren wenn eine Datei versehentlich gelöscht, umbenannt oder an einen anderen Ort verschoben wird.
  • Leere Familien. Dies sind die Familieneinträge die keine Verknüpfungen zu Personen als ihre Angehörige besitzt.
  • Elternbeziehung. Dies überprüft alle Familien um sicherzustellen, das Vater und Mutter nicht verwechselt wurden. Der Test überprüft auch ob die Eltern ein unterschiedliches Geschlecht haben. Wenn sie das gleiche Geschlecht haben, wird die Beziehung in "Partner" umbenannt.

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Stammbaumreparatur ->Datenbank prüfen und reparieren....

Der Verlauf zurücksetzen Warnung Dialog wird gezeigt und du kannst entweder Stopp oder Mit dem Werkzeug fortfahren wählen.

Gnome-important.png
Verlaufinformationen

Das Ausführen dieses Werkzeugs löscht die Verlaufinformationen für diese Sitzung. Im einzelnen bedeutet dies, das du keine Änderungen dieses Werkzeug oder vorher getätigte Änderungen rückgängig machen kannst. Es wird empfohlen hier zu stoppen und deine Datenbank zu sichern; so das du die Änderungen dieses Werkzeugs rückgängig machen kannst.


Abb. 14.19 "Ergebnisse der Integritätsprüfung" - Beispiel Ergebnisdialog - für das "Datenbank prüfen und reparieren" Werkzeug

Alle gefundenen Probleme werden automatisch behoben und das Dialogfeld Ergebnisse der Integritätsprüfung wird mit einer Zusammenfassung der durchgeführten Aktionen angezeigt.
Andernfalls sehen Sie den Keine Fehler gefunden Dialog mit der Meldung Die interne Prüfungen der Datenbank wurden erfolgreich durchgeführt.

Geschlechtsstatistik neu erstellen

Abb. 14.20 "Geschlechtsstatistik neu erstellen" - Ergebnisdialog für "Geschlechtsstatistik neu erstellen" Werkzeug

Erstellt Geschlechterstatistiken für das Erraten des Namensgeschlechts neu...

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Stammbaumreparatur ->Geschlechtsstatistik neu erstellen....

Sobald dies abgeschlossen ist, wird der Geschlechtsstatistik neu erstellen Ergebnisdialog angezeigt.

Interne Referenzen neu erstellen

Abb. 14.21 "Interne Referenzen neu erstellen" - Ergebnisdialog für "Interne Referenzen neu erstellen" Werkzeug

Dieses Werkzeug erstellt Referenzkartentabellen neu. Dies steuert die Liste der Referenzen-Elemente in Editoren.

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Stammbaumreparatur -> Interne Referenzen neu erstellen....

Sobald dies abgeschlossen ist, wird der Interne Referenzen neu erstellt Ergebnisdialog angezeigt.

Siehe auch


Neuaufbau sekundäre Indexe

Abb. 14.22 "Neuaufbau sekundäre Indexe" - Ergebnisdialog für "Neuaufbau sekundäre Indexe" Werkzeug

Dieses Werkzeug erstellt Sekundärindizes neu.

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Stammbaumreparatur -> Neuaufbau sekundäre Indexe....

Nach Abschluss wird der Ergebnisdialog Sekundäre Indizes neu erstellt angezeigt.

Das Neuaufbau sekundäre Indexe... rekonstruiert die sekundären Tabellen in der Baum-DB. Diese Tabellen enthalten Dinge wie Geschlechtsstatistiken (Vorname versus Geschlecht), um das Geschlecht von Namen bei der Eingabe erraten zu können, Nachnamen (für eine schnellere Suche nach möglichen Nachnamen und damit die Personenbaumansicht funktioniert), die verschiedenen IDs für Objekte (zum erleichtern der Suche nach ID), Platzieren von Beilagentabellen, damit die Ortsbaumansicht funktioniert, und einige andere.

Theoretisch werden diese Tabellen ständig aktualisiert, wenn sich etwas ändert. Ein Neuaufbau der Referenzkarten und Sekundärindizes sollte daher nicht erforderlich sein. Aber besonders zu Beginn der Gramps-Geschichte haben Fehler manchmal die korrekte Ausführung von Updates beeinträchtigt. Die Werkzeuge bleiben also verfügbar... ‘nur für alle Fälle’.

Siehe auch


Unbenutzte Objekte entfernen

Dieses Werkzeug durchsucht deine Datenbank nach nicht verwendeten Informationen und ermöglicht dir diese anschließend zu bearbeiten, zu verknüpfen oder zu entfernen.

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Stammbaumreparatur ->Unbenutzte Objekte entfernen....


Abb. 14.23 "Unused Objects" - Beispiel Ergebnisdialog für "Unbenutzte Objekte entfernen" Werkzeug

Der Unbenutzte Objekte Dialog wird angezeigt.

Du kannst im oberen Abschnitt des Dialogfelds Unbenutzte Objekte aus der Suchoption auswählen, die du verwenden möchtest:

  • Suche nach Ereignissen (Kontrollkästchen standardmäßig aktiviert)
  • Suche nach Quellen (Kontrollkästchen standardmäßig aktiviert)
  • Suche nach Fundstellen (Kontrollkästchen standardmäßig aktiviert)
  • Suche nach Orten (Kontrollkästchen standardmäßig aktiviert)
  • Suche nach Medien (Kontrollkästchen standardmäßig aktiviert)
  • Suche nach Aufbewahrunsorten (Kontrollkästchen standardmäßig aktiviert)
  • Suche nach Notizen (Kontrollkästchen standardmäßig aktiviert)

Wähle die Schaltfläche Suchen, um den Bericht auszuführen. Sobald abgeschlossen, werden die Ergebnisse wenn vorhanden im unteren Abschnitt des Dialogfelds Unbenutzte Objekte mit den folgenden angezeigten Spalten angezeigt:

  • Markieren Wähle die Zeile aus, wenn du das Objekt löschen möchtest (standardmäßig deaktiviert)
  • - Symbol für den Objekttyp.
  • ID - Gramps interner Name für das Objekt.
  • Name - des Objekts.

Um das Objekt zu untersuchen, musst du auf die Zeile doppelklicken und es wird der entsprechende Editor für das Objekt angezeigt, in dem du es bei Bedarf bearbeiten kannst.

Markieren die Objekte, die du löschen möchtest, entweder über die einzelnen Kontrollkästchen oder über die zugehörigen Schaltflächen:

  • alles markieren
  • Markierung komplett aufheben
  • Markierungen invertieren

Nachdem du deine Löschentscheidungen getroffen hast, wähle die Schaltfläche Löschen, um die Objekte zu löschen.

Wenn du fertig bist, kannst du das Werkzeug mit der Schaltfläche Schließen beenden.

Werkzeuge

Dieser Abschnitt enthält Werkzeuge, mit denen du einen einfachen Vorgang an einem Teil der Daten ausführen kannst. Die Ergebnisse können in deiner Datenbank gespeichert werden, ändern jedoch nicht deine vorhandenen Daten. Die folgenden Dienstprogramme sind derzeit in Gramps verfügbar:


Eingabedaten bereinigen

Abb. 14.24 Eingabedaten bereinigen

Werkzeug zum Unterdrücken von führenden und nachgestellten Leerzeichen. Das Werkzeug sucht nach Ortsnamen mit führenden oder/und nachgestellten Leerzeichen. Es sucht auch im Vor- und Nachnamen.

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Werkzeuge -> Eingabedaten bereinigen...

Siehe auch:

Finde Datenbankschleife

Abb. 14.25 Finde Datenbankschleife

Mit dem Dienstprogramm Finde Datenbankschleife kannst du überprüfen, ob die Datenbank Vorfahrenschleifen enthält.

Wähle dies über das Menü Werkzeuge -> Werkzeuge -> Finde Datenbankschleife... Du erhältst ein Finde Datenbankschleife Fenster. Das Fenster hat fünf Registerkarten; Gramps-ID,Elter, Gramps-ID, Kind, Familie-ID.

  1. Die erste Gramps_ID ist eine Referenz auf das Elter.
  2. Elter (Vorfahr auf dem Bild) ist die Person, nach der wir eine Schleife suchen.
  3. Die zweite Gramps-ID ist ein Verweis auf das Kind.
  4. Kind (Nachfahre) ist der Ursprung der Schleife.
  5. Familie-ID ist ein Verweis auf die zugehörige Familie


Abb. 14.26 Finden einer mögliche Schleife in einem komplexen Beispiel

Im folgenden komplexen Beispiel haben wir mehrere Ahnenschleifen:

Wenn wir uns die zweite Zeile ansehen, haben wir :

  1. Erste Gramps-ID : I0002
  2. Elter ist : Vater, Kind2
  3. Zweite Gramps-ID : I0001
  4. Kind ist : Vater, Vater
  5. Familie-ID ist : F0000

Um zu verstehen was passiert :

  1. Wir beginnen bei [I0002] Vater, Kind2.
  2. Weiter geht es mit seinem Sohn [I0003] Vater, Kind3.
  3. Weiter geht es mit seinem Sohn: [I0000] Kind, Kind.
  4. Weiter geht es mit seinem Sohn: [I0001] Vater, Vater.
  5. Weiter geht es mit seinem Sohn: [I0002] Vater, Kind2 ==> HIER haben wir eine Ahnenschleife.


Um mehr über Ahnenschleifen zu erfahren, siehe:

Medienverwaltung

Abb. 14.27 Einleitung - Seite für "Gramps Medienverwaltung" - Werkzeug-Assistent

Die Gramps Medienverwaltung ist eine Gruppe von vier separaten Werkzeugen, auf die über einen assistentenähnlichen Dialog zugegriffen werden kann, auf den du über das Menü Werkzeuge -> Werkzeuge -> Medienverwaltung... zugreifen kannst die erste Dialogseite zeigt Einführung mit den folgenden Informationen zu den Fähigkeiten des Werkzeugs.

Gramps-notes.png
Einleitung

Dieses Werkzeug ermöglicht Stapelverarbeitun für Medienobjekte, die in Gramps gespeichert sind. Ein wichtiger Unterschied muss zwischen einem Gramps-Medienobjekt und seiner Datei gemacht werden.

Das Gramps-Medienobjekt ist eine Sammlung von Daten über die Medienobjektdatei: ihr Dateiname und/oder Pfad, ihre Beschreibung, ihre ID, Anmerkungen, Quellenverweise usw. Diese Daten enthalten nicht die Datei selbst.

Die Dateien mit Bild, Ton, Video usw. liegen separat auf deiner Festplatte. Diese Dateien werden nicht von Gramps verwaltet und sind nicht in der Gramps-Datenbank enthalten. Die Gramps-Datenbank speichert nur die Pfad- und Dateinamen.

Mit diesem Werkzeug kannst du nur die Datensätze in deiner Gramps-Datenbank ändern. Wenn du die Dateien verschieben oder umbenennen möchtest, musst du dies selbst tun, außerhalb von Gramps. Anschließend kannst du die Pfade mit diesem Werkzeug anpassen, damit die Medienobjekte die richtigen Dateispeicherorte speichern.


Auf der Seite Einleitung, wenn du die Schaltfläche weiter auswählst (oder die Tastenkombination Alt+N verwendest), wird die Auswahl Seite Fenster.

Abb. 14.28 Auswahl - Seite für "Medienverwaltung" - Werkzeugassistent - Standard

Wähle im Auswahl Seite Fenster aus einer der vier Optionen die Aktionen aus, die du ausführen möchtest, und wähle dann die Schaltfläche Weiter:


Ersetze die Zeichenfolge in dem Pfad

Abb. 14.29 Ersetze Zeichenfolge Einstellungen - Seite für "Medienverwaltung" - Werkzeugassistent - Standard

Dieses Werkzeug ermöglicht das Ersetzen einer angegebenen Teilzeichenfolge im Pfad von Medienobjekten durch eine andere Teilzeichenfolge. Dies kann nützlich sein, wenn du deine Mediendateien von einem Verzeichnis in ein anderes verschiebst.

Wenn du dieses Optionsfeld auswählst, wird ein Ersetze Zeichenfolgen Einstellungen-Fenster geöffnet, in dem du eine beliebige Zeichenfolge in das Textfeld Ersetze und das Textfeld Durch eingeben kannst . Du kannst jederzeit auf die Schaltfläche Abbrechen oder auf die Schaltfläche Zurück klicken. Wenn du auf die Schaltfläche Weiter klickst, wird das Fenster Endgültige Bestätigung angezeigt.


Ändere Pfade von relativ zu absolut

Abb. 14.30 'Ändere Pfade von relativ zu absolut':"Endgültige Bestätigung" Seite für "Medienverwaltung" - Werkzeugassistent - Beispiel

Dieses Werkzeug ermöglicht die Konvertierung relativer Medienpfade in absolute. Dies geschieht, indem das Basisverzeichnis für relative Medienpfade: vorangestellt wird, wie in der Registerkarte Bearbeiten > Einstellungen > Allgemeines angegeben, oder wenn dies nicht festgelegt ist, stellt es das vorgegebene Benutzerverzeichnis voran.



Ändere Pfade von absolut zu relativ

Abb. 14.31 'Ändere Pfade von absolut zu relativ':"Endgültige Bestätigung" Seite für "Medienverwaltung" - Werkzeugassistent - Beispiel

Dieses Werkzeug ermöglicht die Konvertierung absoluter Medienpfade in einen relativen Pfad. Der relative Pfad ist relativ zum angegebenen Basispfad in der Einstellung Basispverzeichnis für relative Medienpfade: der Registerkarte Bearbeiten > Einstellungen > Allgemeines oder Wenn dies nicht festgelegt ist, wird das Verzeichnis des Benutzers verwendet. Ein relativer Pfad ermöglicht es, den Dateispeicherort an einen Basispfad zu binden, der sich deinen Anforderungen anpassen kann.


Bilder, die nicht in der Datenbank enthalten sind, hinzufügen

Abb. 14.32 'Bilder, die nicht in der Datenbank enthalten sind, hinzufügen':"Endgültige Bestätigung" Seite für "Medienverwaltung" - Werkzeugassistent - Beispiel

Verzeichnisse auf Bilder überprüfen, die nicht in der Datenbank enthalten sind. Dieses Werkzeug fügt Bilder in Verzeichnissen hinzu, auf die von vorhandenen Bildern in der Datenbank verwiesen wird. Du musst ein Medienelement aus jedem Unterverzeichnis manuell importieren. Medienverwaltung schließt Unterverzeichnisse nicht automatisch ein. Alle im Werkzeug angezeigten Verzeichnispfade werden durchsucht.

Nicht verwandt

Abb. 14.33. "Nicht verwandt mit '...'" - Dialog - zeigt Ergebnisse für "Nicht verwandt" Werkzeug

Dieses Werkzeug listet Personen auf, die nicht mit der ausgewählten aktiven Person verbunden sind. Verbindungen können verknüpft in einer Kette von Referenzen oder in Verknüpfungen, die mit dem Verknüpfungseditor in Notizen erstellten wurden enthalten sein.

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Werkzeuge -> Nicht verwandt....

Es öffnet sich ein Nicht verwandt mit '...' Fenster, welches eine Liste aller NICHT mit der gewählten Person verwandten Personen enthält.

Diese Liste enthält:

  • Name
  • ID
  • Eltern
  • Markierungen

In der Spalte Name kannst du die Schaltflächen rechter Pfeil und Pfeil nach unten verwenden, um die gruppierte Name-Liste zu reduzieren oder zu erweitern. Wenn du auf eine Person doppelklickst, wird das Dialogfeld Person bearbeiten oder Familie bearbeiten angezeigt.

Wenn du eine Person wählst, kannst du das Marke Feld verwenden: Es gibt 3 Möglichkeiten: leer (du kannst reinschreiben was du willst), Zu erledigen, Nicht verwandt. Mit der Anwenden Schaltfläche kannst du die gewählte Marke der Person zuordnen. Diese Marke wird dann in der rechten Spalte angezeigt.

Verwandtschaftsrechner

Abb. 14.34 "Verwandtschaft zu'...' " - Dialog - zeigt Ergebnisse für "Verwandtschaftsrechner" Werkzeug

Du erreichst dieses Werkzeug über das Menü Werkzeuge -> Werkzeuge-> Verwandtschaftsrechner....

Wenn du das Beziehungsrechner-Werkzeug auswählst, wird eine Liste geöffnet, die nach allen Personen gefiltert ist, die mit der Aktive Person verbunden sind, aber nicht unbedingt verwandt sind. Um die Beziehung zu einer anderen Person zu berechnen, schließe das Fenster, aktiviere diese Person und wählen Das Werkzeug erneut aus dem Menü aus.

Wähle die Person aus der gefilterten Liste aus, um zu melden, ob eine Beziehung besteht. Die genaue Beziehung wird im unteren Feld neben den gemeinsamen Vorfahren dieser gemeldeten Beziehung angezeigt. Es werden nur Blutsverwandtschaften angezeigt (außer Mann-Frau-Beziehungen). Hinweis "Schwiegereltern"-Beziehungen werden nicht angezeigt.

Die gefilterte Liste wird gruppiert und alphabetisch nach Nachnamen sortiert. (Unabhängig davon, ob die Menüeinstellung Ansicht der Kategorie Person auf Gruppiert gesetzt wurde.) Die Listenspalten können nicht umsortiert werden.

Der Grad der Trennung (Generationsabstand), der erkannt wird, wird durch den Wert Max. Generationen für Beziehungen in der Registerkarte Allgemein unter dem Bearbeiten -> Einstellungen... Menü. (Bei der Vorgabe von 15 Generationen wird eine 12. Urgroßelternbeziehung gemeldet, nicht jedoch deren Eltern. Die aktive Person wird als eine der Generationen gezählt.)

Im Wesentlichen sind zwei Personen direkt blutsverwandt, wenn sie einen gemeinsamen Vorfahren haben. Eine dieser Personen kann tatsächlich ein Vorfahre der anderen sein – beispielsweise ein Urgroßelternteil. Auch bei Tanten und Onkeln kannst du die Verwandtschaft durch die Suche nach dem gemeinsamen Vorfahren berechnen. In diesem Fall werden der Vater oder die Mutter der Tante oder des Onkels Großeltern des Neffen oder der Nichte.

Die grundlegendste Blutsverwandtschaft durch gemeinsame Vorfahren ist die der Geschwister (Brüder und Schwestern), die nur eine Generation unter dem gemeinsamen Vorfahren stehen. Eine weitere besondere Beziehung ist die eines dieser Geschwister zu den Nachkommen der anderen Geschwister. Wenn die aktive Person ein Enkel des gemeinsamen Vorfahren ist, wäre das Geschwister eine Tante oder ein Onkel. Abgesehen von dieser Generation von Nachkommen gibt es zwei gleichwertige Arten, die Beziehung zu beschreiben. Die Tochter von Urgroßeltern kann entweder Großtante oder Großtante genannt werden. (Der Beziehungsrechner verwendet die 'große' Variante.) Diese Person ist eine Urgroßtante der zweiten Urenkel, die vier Generationen vom gemeinsamen Vorfahren entfernt sind. (Sie kann auch eine zweite Großtante genannt werden.) Die umgekehrte Beziehung einer Tante oder eines Onkels ist ein Neffe oder eine Nichte.

Cousins (auch Cousins ersten Grades) sind zwei Generationen nach dem gemeinsamen Vorfahren durch verschiedene Geschwister. Cousins zweiten Grades sind also drei Generationen vom gemeinsamen Vorfahren entfernt - und so weiter.

Danach gilt jeder als "Cousin", aber um anzuzeigen, dass sie nicht zur gleichen Generation gehören, verwenden wir das Wort "entfernt", um die Anzahl der Generationen anzugeben, die sich zwischen den beiden unterscheiden. Zum Beispiel ist der Cousin "ersten" meines Vaters auch mein Cousin "ersten" aber "einmal entfernt" (ein Generationenunterschied zwischen uns). Der Cousin ersten Grades meines Vaters ist der "zweimal entfernte Cousin ersten Grades" meines eigenen Kindes - zwei Generationen unterschiedlich.

Wenn mehrere Blutsverwandte aufgrund eines Zusammenbruchs des Stammbaums bestehen, werden alle gemeldet.

Eine Volltextliste aller Blutsverwandten und ihrer Ehepartner kann in der Verwandtschaftsliste eingesehen werden.

Siehe auch:

  • Die Beziehung zur Hauptperson Anzeigeeinstellungen Optionen für die Statusleiste
  • Beziehung zur Hauptperson Schnellansicht.
  • Das Gramplet Tiefe Verbindungen: Wenn dieses Zusatzmodul von Drittanbietern installiert ist, listet es die dazwischenliegenden Generationen durch die Geschwister eines gemeinsamen Vorfahren auf. (Aber es listet nicht den gemeinsamen Vorfahren auf oder wenn beide Personen durch denselben Ehepartner verbunden sind.) Das Gramplet beschreibt auch die indirekten Beziehungen.


Die Daten überprüfen

Abb. 14.35 "Die Daten überprüfen..." - "Die Daten überprüfen" Werkzeug Dialog - "Allgemeines" Registerkarte - Vorgaben

Dieses Werkzeug ermöglicht dir die Überprüfung der Datenbank auf der Grundlage einer Reihe von dir festgelegter Kriterien.

Zum Beispiel, du willst sicherstellen, das keiner in deiner Datenbank im Alter von 98 Kinder bekam. Nach gesundem Menschenverstand würde ein solcher Datensatz auf einen Fehler hinweisen. Jedoch ist dies kein Konsistenzfehler in der Datenbank. Außerdem könnte jemand im alter von 98 ein Kind bekommen haben (das ist wirklich passiert). Das überprüfen Werkzeug zeigt alles, was deine Kriterien verletzt, so das du überprüfen kannst, ob der Datensatz fehlerhaft ist oder nicht. Du triffst die endgültige Entscheidung.

Über das Menü Werkzeuge->Werkzeuge->Die Daten überprüfen... erhältst du das Daten überprüfen Fenster. Das Fenster enthält vier Reiter; Allgemeines, Frauen, Männer und Familien. Diese Reiter enthalten eine Liste von Kriterien und Eingabefelder in denen du die Werte für die Kriterien ändern kannst. In den Listen unten stehen einige brauchbare Werte.

Die Daten überprüfen Registerkarten

Wähle auf den folgenden Registerkarten die Kriterien aus, mit denen du das Werkzeug ausführen möchtest. Wenn du mit den Kriterien einverstanden st, klicke auf die Schaltfläche Ausführen (oder drücke Alt+R und du erhälst ein Ergebnisse der Datenüberprüfung Fenster.

Abhängig von deinen Kriterien und deinen Daten wird eine Liste angezeigt. Nachfolgend sind einige Möglichkeiten der Feststellungen aufgeführt. Aber es gibt andere.

  • Einzeln stehende Personen (Personen ohne Elternteil oder Ehepartner oder Kind oder Geschwister)
  • alter/toter Vater
  • Heirat nach dem Tod/vor der Geburt
  • Große Zeitspanne für alle Kinder
  • frühe/späte Heirat
  • junge/ungeborene Mutter
  • Ehemann und Ehefrau mit dem gleichen Nachnamen
  • gleichgeschlechtliche Ehe/weiblicher Ehemann
  • ...
Allgemeines
  • Maximales Alter: 90
  • Minimales Alter bei Heirat: 17
  • Maximales Alter bei Heirat: 50
  • Maximale Anzahl von (Ehe-)Partnern pro Person: 3
  • Maximale Anzahl aufeinander folgender Jahre der Witwenschaft, vor der nächsten Hochzeit: 30
  • Maximales Alter für eine unverheiratete Person: 99

Es gibt zwei Kontrollkästchen:

  • Fehlende oder ungenaue Daten schätzen (Kontrollkästchen standardmäßig deaktiviert) : bewirkt, dass das Werkzeug ein Taufdatum akzeptiert, wenn ein Geburtsdatum nicht bekannt ist, und ein Bestattungsdatum akzeptiert, wenn ein Sterbedatum nicht bekannt ist. Es bewirkt auch, dass das Werkzeug "ungenaue" Daten akzeptiert (d. h. jedes "legale" Gramps-Datum, das nicht vollständig spezifiziert ist (mit einem expliziten Tag, Monat und Jahr)).
  • Ungültige Daten erkennen : überprüft, ob die Daten ungültig sind. (Kontrollkästchen standardmäßig aktiviert)
Frauen
  • Mindestalter bei der Geburt eines Kindes: 17
  • Maximales Alterbei der Geburt eines Kindes: 48
  • Maximale Anzahl von Kindern: 12
Männer
  • Minimales Alter bei der Zeugung eines Kindes: 18
  • Maximales Alter bei der Zeugung eines Kindes: 65
  • Maximale Anzahl an Kindern: 15
Familien
  • Maximale Altersunterschied in einer Partnerschaft: 30
  • Maximale Abstand zwischen zwei Kindern: 8
  • Maximaler Zeitraum für die Geburt aller Kinder: 25


Ergebnisse der Datenüberprüfung Fenster

Abb. 14.36 Datenüberprüfung Ergebnisfenster.

Nachdem du das Werkzeug ausgeführt hast, wird das Fenster Ergebnisse der Datenüberprüfung angezeigt.

Am unteren Rand des Fensters stehen vier Schaltflächen zur Verfügung, um die Auswahl zu erleichtern. Dies sind alles markieren, Msarkierung komplett aufheben, Markierung invertieren und als versteckt markiert.

Durch Doppelklicken auf eine Zeile hast du die Möglichkeit, die Daten anzuzeigen und/oder zu bearbeiten.

Mit der Schaltfläche Schließen (oder der Tastenkombination Alt+C) schließt du das Fenster Ergebnisse.

Beispiele

Zwei Beispiele für die Verwendung von Echtdaten mit diesem Werkzeug:

Die Warnung zeigt 'weiblicher Ehemann': Beim Überprüfen der Daten fand ich eine Familie mit dem Vater: Anna Roelants. Glücklicherweise las ich in der Beschreibung: Die Hochzeit von Adam Roelants und Cornelia Crabbe. Es war also klar ein Tippfehler: Anna anstatt Adam. Ohne dieses Werkzeug wäre dies schwer zu finden.
Die Warnung zeigt 'späte Heirat': Überprüfung der Daten: männliche Person °1738 weibliche Person °1756 : Heirat X 1804 [Gregorian Calender|Gregorianischer Kalender] : Alles scheint OK. zu sein: Sie heirateten im alter von 66 und 48 Jahren! Die Warnung wurde gezeigt, weil die Allgemeinen Kriterien auf 60 gesetzt waren.
Tango-Dialog-information.png
Unterschied zwischen Die Daten überprüfen Werkzeug und dem Datenbank prüfen und reparieren Werkzeug

Das Datenbank prüfen und reparieren Werkzeug erkennt Inkonsistenzen in der Datenbankstruktur. Das Werkzeug Die Daten überprüfen erkennt jedoch die Datensätze, die deinen bestimmten Kriterien nicht entsprechen.


Fehlersuche

Gnome-important.png
Warning do not use the Debug tools on your working Family Tree

Always create a new empty Family Tree or a copy of your exiting Family Tree for testing.
The tools available in this advanced menu are used for testing only.

Abb. 14.37 "Tools >Debug>..." Menubar - Tools - Debug menu Overview

When the python -O optimise flag is not turned on, an additional Debug entry appears in the Tools menu.

See Command Line: Python options

Check Localized Date Displayer and Parser

Abb. 14.38 "Start date test?" dialog - for "Check Localized Date Displayer and Parser" - Tool

This test tool will create many people showing all different date variants as birth. The death date is created by parsing the result of the date displayer for the birth date. This way you can ensure that dates printed can be parsed back in correctly.


Geschlechtsstatistik verwerfen

Abb. 14.39 "Gender Statistics tool" dialog results example - for "Dump Gender Statistics" - Tool

Will dump the statistics for the gender guessing from the first name.

Generate Testcases for Persons and Families

Abb. 14.40 "Generate testcases" dialog - for "Generate Testcases for Persons and Families" - Tool - default

The testcase generator will generate some persons and families that have broken links in the database or data that is in conflict to a relation.

The Undo history warning dialog will be shown and you can either Stop or Proceed with the tool.


Populate Sources and Citations

Abb. 14.41 "Populate sources and citations tool" dialog - default

This tool generates sources and citations for each source in order to populate the database for testing with significant numbers of sources and citations.


Zurück Index Nächste
Gnome-important.png Spezielle Copyright Notiz: Alle Änderungen auf dieser Seite müssen unter zwei copyright Lizenzen stehen:

Diese Lizenzen ermöglichen es dem Gramps-Projekt die bestmögliche Verwendung dieses Handbuchs als freien Inhalt in zukünftigen Gramps Versionen. Wenn du mit dieser dual Lizenzierung nicht einverstanden bist, bearbeite diese Seite nicht. Du darfst zu anderen Seiten des Wiki die nur unter die GFDL Lizenz fallen nur über externe Links (verwende die Syntax: [http://www.gramps-project.org/...]), nicht über interne Links verlinken.
Außerdem verwende nur die Bekannten Drucktechnische Konventionen