De:Gramps 5.1 Wiki Handbuch - Stammbäume Verwalten

From Gramps
Revision as of 22:04, 11 February 2021 by Leonhaeuser (talk | contribs) (Endgültige Bestätigungn)
Jump to: navigation, search
Zurück Index Nächste


Eine detaillierte Beschreibung des täglichen Gebrauchs von Gramps. In diesem Kapitel geben wir einen detaillierten Überblick darüber, wie du deine Stammbäume verwalten und deine Daten mit anderen Ahnenforschern teilen kannst.

Contents

Neuen Stammbaum beginnen

Abb. 5.1 Menubar - "Family Trees" - overview example

Um einen neuen Stammbaum zu beginnen wähle Stammbäume ->Stammbäume verwalten oder wähle die ChartsStammbäume verwalten Schaltfläche aus der Werkzeugleiste oder verwende die Tastenkombination Strg+O.. Dies öffnet das Stammbaumverwaltung Fenster.

Wähle die Neu Schaltfläche und Gramps fügt einen neuen Stammbaumeintrag zur Liste der Stammbäume hinzu. Um seinen Namen vom Standard Stammbaum 1 zu ändern, wähle den Namen und drücke die Umbenenne Schaltfläche gib einen neuen Namen ein.

To open the new, empty Family Tree select the Family Tree and either double click or press the Load Family Tree button to load.

Abb. 5.2 Manage databases - icon on toolbar (Same as using menu Family Trees ->Manage Family Trees...)


Abb. 5.3 Connect to a recent database - icon drop down on toolbar menu Family Trees ->Open Recent...


Stammbaummanagerfenster

Abb. 5.4 "Family Trees" manager window

Clicking the Family Tree Manager button brings up the Family Trees manager windows this allows you to work with and manage your Family Trees.

The Family Tree Manager window allows the you to create a new Family tree, rename an existing Family tree, delete a Family tree, or load a Family tree or check information) about the Family tree. All the names of your Family trees appear in the list. If a Family tree is open, an icon will appear next to the name in the status column. The Database Type as well an indication of the date and time your family tree was Last accessed' is shown.

  • New creates a new Family tree.
  • Info shows information about the selected Family tree.
  • Delete the selected Family tree, this will show a warning with a final confirmation for you to select.
  • Rename the selected existing Family tree.
  • Close the selected existing Family tree.
  • Convert the selected family tree. This option only available for legacy BSDDB databases. See: Converting a BSDDB Family Tree to SQlite
  • Repair the selected existing Family tree, only available if Gramps detects an issue.
  • Archive option is only present if GNU Revision Control System (RCS) is installed.
  • Extract used with the Archive button and the option is only present if GNU Revision Control System (RCS) is installed.
  • Help - from this section.
  • Close Window - dismisses the Family Tree manager windows
  • Load Family Tree the selected existing Family tree.


Einen Stammbaum öffnen

Um einen Stammbaum zu öffnen wähle entweder Stammbäume ->Stammbäume verwalten oder klicke die Stammbäume Schaltfläche in der Werkzeugleiste. Die Stammbaumverwaltung öffnet sich und du siehst eine Liste aller Gramps bekannten Stammbäume. Ein Symbol wird in der Status Spalte (sieht aus wie ein geöffneter Ordner) neben jedem aktuell geöffneten Stammbaum angezeigt. Wähle den Baum den du öffnen willst und öffne ihn durch klicken der Stammbaum laden Schaltfläche. Alternativ kannst du den gewünschten Baum auch doppelt klicken.

Um einen zuletzt geöffneten Stammbaum zu öffnen, wähle entweder Stammbäume ->Zuletzt geöffnet oder den abwärts Pfeil neben der Stammbäume Schaltfläche und wähle den Stammbaum aus der Liste.

Nur lesen Modus

Gnome-important.png
Nur lesen Modus

Wenn du keine "Schreibrechte" für den gewählten Stammbaum hast, wird er im nur lesen Modus geöffnet. In diesem Modus können die Daten angesehen werden, es sind aber keine Änderungen an dem Stammbaum möglich. Als Indikator für diesen Modus wird der Titel des Hauptfensters um den Text (Nur lesen) erweitert.

The Tools menu will not be available.

Änderungen im Stammbaum speichern

Gramps speichert ihre Daten direkt nachdem du sie eingegeben hast. Dies bedeutet zum Beispiel, das jedes mal wenn du Ok klickst während du Gramps verwendest werden deine Daten unverzüglich übernommen und gespeichert. Es gibt kein spezielles "speichern" Kommando.

Du kannst deine Änderungen durch aufrufen von Bearbeiten ->Rückgängig rückgängig machen. Wenn du dieses Kommando wiederholt aufrufst, werden deine letzten Änderungen Stück für Stück rückgängig gemacht. Um mehrere Kommandos am Stück rückgängig zu machen, kannst du den Bearbeitungschronik Dialog verwenden, verfügbar über das Bearbeiten->Bearbeitungschronik Menü.

Wenn du deinen Stammbaum in den Zustand beim Öffnen zurücksetzen willst, wähle Stammbäumen ->Änderungen verwerfen und beenden. (Dies ist wie Beenden ohne speichern in anderen Programmen.)

Wenn du eine Kopie deines Stammbaums unter einem anderen Namen speichern willst, musst du ihn exportieren und dann in einen neuen Stammbaum importieren. Die Verwendung des Gramps XML Datenbank Format wird hierfür empfohlen.

Eine GEDCOM oder XML Datei öffnen

Gramps erlaubt dir verschiedene Daten, die nicht im GRAMPS eigenen Format gespeichert wurden, von der Kommandozeile aus zu öffnen, siehe Kommandozeilenreferenz. Dies beinhaltet XML und GEDCOM Dateien. Du solltest dir aber bewusst sein, dass wenn die XML oder GEDCOM Datei relativ groß ist, du Leistungsprobleme bekommst und im Falle eines Absturzes deine Daten beschädigt werden können. Daher ist es normalerweise besser, einen neuen Gramps Stammbaum (Datenbank) zu erstellen und deine XML/GEDCOM Daten in diesen zu importieren.

Gramps-notes.png
Dateien öffnen

XML und GEDCOM Dateien erfordern es alle Daten im Speicher zu halten und enthalten keine Indizes. Das Gramps eigene Format ist eine Datenbank, die die Daten nur liest, wenn sie benötigt werden. Also kann bei einem großen Stammbaum schneller und effizienter auf die Daten zugegriffen werden, wenn XML oder GEDCOM nicht verwendet werden.

Gnome-important.png
GEDCOM Bearbeiten

Bitte beachte, dass Daten aus einer GEDCOM-Datei sowohl beim Import in Gramps als auch beim Export zurück nach GEDCOM verloren gehen können. Nur öffnen und betrachten der Datei ändert sie nicht. Wenn allerdings Änderungen durchgeführt wurden und bis zum beenden noch bestehen, speichert Gramps die Daten mit möglichem Datenverlust.

Einen Stammbaum löschen

Wählen den Stammbaum, den du löschen willst und klicke die Löschen Schaltfläche.

Dies löscht den Stammbaum komplett ohne die Möglichkeit die Daten zurück zu holen. Überlege eine Sicherung deiner Daten durch Export in das Gramps XML-Format zu erstellen und diese Datei zu sichern.

Einen Stammbaum umbenennen

Du kannst einen Stammbaum (oder ein Archiv von ihm) durch wählen des gewünschten Baums und klicken auf Umbenennen umbenennen. Du kannst auch auf den Namen in der Liste von Stammbäumen klicken.

In beiden Fällen gib einfach den neuen Namen ein damit er gültig wird.

Gramps-notes.png
Family Tree name Limitations

There are some characters that are not allowed within a Family Tree name. They will be automatically replaced with the underscore character "_".

The comma, double quote and vertical bar characters and these: "\:/<>][.+*?"

Einen Stammbaum sichern

Der sicherste Weg deinen Stammbaum zu sichern, ist der Export ohne Einschränkungen und Filter im Gramps XML Format (oder als Gramps Paket, um Elemente aus der Galerie mit zu sichern) und die resultierende Datei an einem sicheren Ort zu kopieren, bevorzugt in einem anderen Gebäude.

Sicherungsdialog

Abb. 5.5 Eine Sicherung erstellen

Wähle einfach das Stammbäume->Sicherung erstellen... Menü.

The Gramps XML Backup window will appear.

You can enter the Path: where the backup should be stored manually or using the path selector button to bring up the Select backup directory dialog.

You can enter a File: name manually or use the automatically generated file name.

Du kannst auswählen, ob du die Medien Einbeziehen(Vorgabe) oder Ausschließen willst.

Gramps-notes.png
Beachte

Dass dies nur ein gewöhnlicher XML-Export ist, nur dass keine Daten ausgefiltert sind. Du kannst ihn wie jede exportierte Datei importieren.


  • You can use the Archive feature (see next section) to store snapshots of your Family Tree. These snapshots can be used as simple backups, very useful if you want to try something that you might later want to undo. However this method should not be used for standard backups, as it will not survive a hard disk crash or most of the other disasters that can befall a computer.
  • For advanced users: each database is stored in its own subdirectory under ~/.gramps. Although a manual backup can be made by backing up this directory, it is not recommended. It is strongly recommended that you please use a Gramps XML backup instead.

Siehe auuch:

Einen Stammbaum archivieren

Tango-Dialog-information.png
Beachte

Die Archive Option ist nur verfügbar wenn GNU Revision Control System (RCS) vorhanden ist so das Gramps es verwenden kann. Normalerweise musst du es unabhängig von Gramps installieren.

Du kannst mit der in Gramps verwendeten GNU Revision Control System oder RCS wenn dieses installiert ist einfach Stammbäume archivieren oder mit einem Zeitstempel versehen. Um dies zu ermöglichen, muss das Programm auf deinem Computer installiert sein.

Um ein Archiv zu erstellen:

Fig. 5.6 Ein Beispiel zum Stammbaum archivieren
  1. lade den Stammbaum.
  2. klicke in der Werkzeugleiste auf die ChartsStammbäume Schaltfläche (sie hat das Gramps-Logo und zeigt Stammbäume verwalten, wenn man über sie fährt).
  3. klicke auf den Stammbaum, den du gerade geladen hast: die Archiv Schaltfläche sollte erscheinen.
  4. klicke auf Archiv und du wirst nach einer "Revisionskommentar - Versionsbeschreibung" für dein Archiv gefragt.

Nach dem Archivieren zeigt die Liste der Stammbäume links neben dem originalen Stammbaum ein nach rechts zeigendes Dreieck.

  • Klicke auf das Dreieck um, den Archivnamen zu zeigen. (Klicke erneut zum zuklappen der Archivliste).

Archive können gelöscht, umbenannt und entpackt werden.


Ein Stammbaumarchiv entpacken

Abb. 5.7 (Manage)"Family Trees" dialog - Archive selected ready to "Extract" - example

To retrieve a version of a previously archived family tree in the "Family Tree" manager highlight the archive you want to restore, and select the Extract button.


Abb. 5.8 (Manage)"Family Trees" dialog - Archived version extracted and selected - example

The archive will then be restored into a new Family Tree and be listed in the family tree manager.

The Family Tree name is based on the original name and the archive name eg: <name of original tree>:<name of archive>.(see also Archiving a Family Tree)

This can be a useful way of preserving an archive, because archives disappear if the originating tree is deleted; and 'they are not incorporated into a Gramps XML export of the family tree.

Einen Stammbaum entsperren

Fig. 5.9 Family Trees (Manager) - Dialog - Showing Locked "Sample" Family Tree

Gramps is a single-user database application and identifies Tree database files as busy with a 22x22-gramps-lock.png'lock' when in use. As Gramps opens a tree, it drops a lock file (which lists the username and domain) in the tree's subfolder in the grampsdb folder of the User Directory. Gramps refuses to let you (or anyone else) open that Tree at the same time. A second instance of Gramps will be able to open another family tree, but any tree that is already open will appear with the lock icon in the Status column of the Manage Family Trees dialog. Closing the tree in the first copy of Gramps deletes the lock file and will make the tree available to be opened in the second instance.

If you could open the same Family Tree in two instances of Gramps at once, it is likely your data would be damaged as the two overwrite each other's work.

Siehe auch:

Gnome-important.png
Be careful Breaking Locks!

Only do this if you are sure no other copy of Gramps is using the selected Family Tree.

Die Sperre für die Datenbank "Stammbaumname" aufheben? Dialog

Fig. 5.10Error parsing arguments - dialog - Database is locked example

In the unlikely event that Gramps crashes, the family tree will be left in a locked state (indicated by a 22x22-gramps-lock.pnglock icon in the Status column next to the Family Tree name)

To unlock the Family Tree during startup

  • If the Family Tree Preferences have been set to open a tree automatically on startup, then you will see the Error parsing arguments dialog which remarks that the Database is locked. Click on the Close button then choose Manage Family trees... from the Family Trees menu.
  • Otherwise, the Family Tree Manager will appear automatically as Gramps starts.


Fig. 5.11 Break the lock on the "Sample" database? - Dialog - example

Choose the locked family tree and then click the Load Family Tree button. The Break the lock on the '[Family Tree name]' database? dialog will be shown.

Click the Break lock button and the Family Trees (Manager) window should show that the lock icon has gone.

Choose the previously locked family tree and then click the Load Family Tree button to continue your work.

Einen beschädigten Stammbaum reparieren

Abb. 5.12 Family Trees (Manager) - Dialog - Showing Red Error Status Icon for "Sample" Family Tree

Wenn dein Stammbaum in irgendeiner Weise beschädigt wurde, zeigt die Gramps-Stammbaumverwaltung ein rotes Fehlersymbol in der Status Spalte.

Um Gramps mitzuteilen, das es versuchen soll, den Schaden zu reparieren, wähle den Baum und klicke auf die Reparieren Schaltfläche.

Gramps wird versuchen den Stammbaum aus den Sicherungsdateien, die automatisch beim Beenden erstellt werden, wieder herzustellen.

Siehe auch:


Konvertieren eines BSDDB-Stammbaums in SQLite

Tango-Dialog-information.png
From Gramps 5.1.x the default database is SQLite.

Before following the conversion advice in this section, take the time to backup your family trees


Abb. 5.13 Convert the 'Family Tree Name' database? dialog with Family Trees (Manager) - Dialog shown in background

If you have an older legacy BSDDB format Database Type shown for any of your family tree's in the Family Trees (Manager) - Dialog, then selecting a family tree in the Family Trees (Manager) - Dialog will show the Convert button as available.

It is highly recommended that before doing the following you back up the family trees to be converted.

When ready select the Convert button and the Convert the 'Family Tree Name' database? dialog will be shown with the message Do you wish to convert this family tree into a SQLite database? you can select Cancel to stop or Convert to start the process, once completed the Family Trees (Manager) - Dialog will show a new entry for the converted copy of your Family tree but with the Database Type of SQLite, you should then open and backup the converted family tree.

You may then rename the original BSDDB family tree with the word OLD or you can Delete it to avoid confusion, then you can rename the new SQLite database.



Daten importieren

Gramps-notes.png
Importieren im Vergleich zum Öffnen

Bitte beachte, eine Datenbank importieren ist etwas anderes als sie zu öffnen. Wenn du importierst, bringst du Daten von einer Datenbank in einen Gramps-Stammbaum. Wenn du eine Datei öffnest, bearbeitest du die original Datei.

Importieren ermöglicht dir Daten aus anderen Genealogieprogrammen in einem Gramps-Stammbaum zu verwenden. Zur Zeit kann Gramps Daten in folgenden Formaten importieren:

  • Gramps XML (.gramps file extension) Gramps native data exchange format in uncompressed text and gzip compressed
  • Gramps XML Package (.gpkg file extension) Gramps .tar.gz archive compressed backup format
  • GRAMPS V2.x database (.grdb file extension)
  • CSV Spreadsheet - comma separated values (.csv file extension)
  • GEDCOM (.ged file extension) de facto standard file format for data interchange between genealogy programs
  • GeneWeb (.gw file extension) - GeneWeb is genealogy software with a web interface.
  • Pro-Gen (.def file extension) - Pro-Gen has been very popular in the Netherlands and North-West Germany. It is often used by people who started collecting and storing data as early as 1989. This was a DOS based program which has been patched to work with Win 10.
  • vCard (.vcf file extension) - Virtual Contact File is a file format standard for electronic business cards.
  • JSON Import (.json file extension) - JavaScript Object Notation is a lightweight data-interchange format.
  • SQLite Import (.sql file extension) - SQLite database format

Import Stammbaumdialog

Gramps-notes.png
Note that data can only be imported into a prepared Family Tree (database)

So, if migrating from another program, it is necessary to first create a new empty Family Tree before importing the unauthenticated data into it. Once the data is imported, clean up any corruptions or incompatibilities.
If the intent is use the import for merging outside data into an existing Gramps Tree, it is less complex to import data from a pre-cleaned and validated Tree already in Gramps format.
Importing is a risky task, always make a backup of your Tree before importing.

Abb. 5.14 Import Family Tree - dialog example

First create a new and empty Family Tree. Dann wähle Stammbäumen ->Importoder die Tastenkombination Strg+I. Either the Undo history warning dialog will open if you attempt to import into an existing Family Tree (Achtung du kannst nur Daten in einen bestehenden Stammbaum importieren. Wenn du also deine gesamten Daten von einem anderen Programm oder einer älteren Version von Gramps übernehmen willst, erst einen neuen leeren Stammbaum erstellen und dann die Daten in diesen importieren.) oder der Datenbankimport Dialog wird geöffnet, fragt nach der Datei die du importieren willst.

Fig. 5.15 Import warning dialog

As you attempt to import into a Family Tree that is not empty, the Undo history warning dialog will open. This reminds you make a backup before importing. Create a new Family Tree instead, unless you are knowingly attempting to merge data.

Gramps uses a GTK File Chooser for selecting the data file to be exported. The basic options for navigating to a file are familiar and obvious.

The default display option for the filepath is to show each folder level as clickable breadcrumb navigation. The path can be typed in an editable text box by pressing the CTRL+L keybinding.

The file type extension will normally allow the Automatically detected option to expect a particular pattern of data to be converted to the native database format. You can override this by choosing a different Select file type: options. The list of files may be filtered by changing from the All files option.

When planning to use the import repeatedly (for ongoing updates or including genealogy research), you can customize the dialog by adding buttons for bookmarked folder paths. Right-click on a folder name and choose Add to bookmarks from the pop-up menu.

Gnome-important.png
Datenverlust bei einigen Formaten

Es ist wichtig zu wissen, das es keine direkte eins zu eins Beziehung zwischen all den Fähigkeiten von Gramps und denen von GEDCOM, GeneWeb oder Pro-Gen existiert. Daher können beim Import aus diesen Formaten Daten verloren gehen. Details welche Daten beim Import aus GEDCOM verloren gehen können siehe weiter unten.

Gramps-notes.png
Von anderen Programmen erzeugte Ereignisse neu ordnen

Einige Programme von denen du Daten importiert hast, sortieren die Ereignisse eventuell nicht so wie du es erwartest. Gramps bietet dir Hilfe beim neu Ornen der Ereignisse nach deinen Vorstellungen. Siehe Ereignisse sortieren Werkzeug.

GRAMPS V2.x Datenbankimport

GRAMPS V2.x Datenbank (.grdb): Vor Version 3.0 war dies das Format in dem Gramps die Daten gespeichert hat, eine speziell angepasste Berkeley Datenbank (BSDDB) mit einer angepassten Datentabellenstruktur. Dieses Format war System und Architektur gebunden. Es war schnell und effizient, aber nicht sehr übertragbar auf Computer mit einer anderen Architektur (z.B. i386 nach Alpha).

Der Import im GRAMPS v2.x Datenbankformat wird nur von Gramps Version 3.0.x unterstützt. Der Import von V2.x in Gramps V3.0.x geschieht ohne Datenverlust.

Gnome-important.png
Der Import aus dem GRAMPS V2.x Format wird von Gramps 5.1 nicht unterstützt.

Wenn du eine alte V2.x Datenbank besitzt, musst du sie in Gramps V3.0.x importieren und von dort in Gramps XML (oder Gramps XML-Paket) exportieren und dies dann in Gramps 5.1 importieren.

Umziehen einer Gramps 2.2-Datenbank nach Gramps 3.x.

To move your Gramps data from version 2.x to version 5.1.x you must import the v2.x database into an earlier Gramps v3.0.x program and then either save the database and import it into Gramps 5.1.x, or export the database in XML format from the earlier Gramps version and import it into Gramps 5.1.x.

Please refer to the User Manual for earlier versions of Gramps for instructions on the import of v2.x databases into Gramps v3.x.


Gramps XML und XML Paket Import

Die Gramps XML und Gramps XML Paket sind die eigenen Gramps-Formate. Es besteht kein Risiko von Datenverlust beim importieren von oder exportieren in diese Formate.

  • Gramps XML (.gramps): Die Gramps XML Datei ist das Standarddatenaustausch und Sicherungsformat von Gramps und war auch das Arbeitsformat für ältere (vor 2.x) Gramps Versionen. Anders als das grdb-Format ist es architekturunabhängig und kann von Menschen gelesen werden. Die Datenbank kann auch Verweise auf nicht lokale (externe) Medienobjekte enthalten, daher ist nicht garantiert, das diese Datei voll übertragbar ist (für volle Übertragbarkeit inklusive Medienobjekten, sollte das Gramps XML Paket Format (.gpkg) verwendet werden). Die Gramps XML Datei wird durch Export (Menü Stammbäume ->Export...) der Daten in dieses Format erstellt.
  • Gramps XMLPaket (.gpkg): Das Gramps XML Paket ist eine komprimiertes Archiv welches die Gramps XML Datei und alle Medienobjekte (Bilder, Klangdateien usw.) enthält, auf die der Stammbaum verweist. Weil es alle Medienobjekte enthält, ist dieses Format komplett übertragbar. Das Gramps XMLPaket wird durch den Export (Stammbäume ->Export...) der Daten in dieses Format erstellt.

Wenn du Informationen von einer anderen Gramps Datenbank oder Gramps XML Datei importierst, wird dir der Fortschritt im Fortschrittsbalken im Gramps Hauptfenster angezeigt. Wenn der Import abgeschlossen ist, zeigt ein Statusfenster die Anzahl der importierten Objekte. Wenn die importierten Daten ursprünglich von dem Stammbaum stammen, in den du sie importierst, bekommst du Vorschläge, was zusammengefasst werden könnte; das Zusammenfassen wird nicht automatisch für dich erledigt. Wenn du genealogische Grunddaten automatisch zusammengefasst haben möchtest, denke über CSV Tabellen Export/Import nach.

Gramps CSV Import

  • Das Gramps CSV Tabellenformat erlaubt dir den Im- und Export einer Teilmenge deiner Gramps-Daten in einem einfachen Tabellenformat. Siehe CSV Import und Export für mehr Informationen.

GEDCOM Import

First create a new empty Family Tree. Then select the menu Family Trees ->Import or the keybinding CTRL+I then use the Import Family Tree dialog to select the GEDCOM file you want to import, depending on the the type of GEDCOM you may then see the GEDCOM Encoding dialog.

When you import information from GEDCOM, Gramps main window will show you a progress bar. When the GEDCOM import finishes, the Import Statistics window and the GEDCOM import report: windows show any results or warnings.


GEDCOM-Codierungsdialog

Fig. 5.16 GEDCOM Encoding - dialog

The GEDCOM Encoding dialog will be shown when the GEDCOM file you are importing has identified itself as using the ANSEL encoding format. Sometimes, this is in error. If after the GEDCOM is imported you notice that your data contains unusual characters, undo the import, and override the character set by selecting a different encoding from the available list.

Encoding:

  • default
  • ANSEL
  • ANSI (iso-8859-1)
  • ASCII
  • UTF8


Import Statistik Dialog

Abb. 5.17 Import Statistikken - Dialog

Zeigt Details der Importstatistik an.

GEDCOM Import Bericht Dialog

Abb. 5.18 GEDCOM-Importbericht - Beispielergebnisse.

The GEDCOM import report details most of the GEDCOM lines that were either ignored or could not be understood. These are most likely because they are not part of the GEDCOM 5.5.1 standard. (See GEDCOM Extensions.) The contents of the GEDCOM line (or lines where there are continuation lines) are also shown. In some cases, the lines may not be exactly what is contained in the input GEDCOM file, because the line is reconstructed following some processing.

Den Bericht lesen
Abb. 5.19 GEDCOM import note indicating omitted data attached to "Source>Note"(data from "GEDitCOM" - "GEDCOM 5.5 Torture Test Files"

Gramps uses a more advanced 'data model' than GEDCOM, therefore some data in GEDCOM cannot be imported into Gramps. (See Gramps and GEDCOM.) The main exceptions are:

  • Some GEDCOM attribute structures are treated as Gramps Attributes and therefore many of the GEDCOM Primitive Elements cannot be stored.
  • The DATA elements of a SOURCE_RECORD (indicating the events recorded and responsible agency) are ignored.
  • Any source citations on notes are ignored.
  • Many GEDCOM Primitive Elements do not have exactly corresponding data elements in Gramps, and they are therefore stored as Attributes with appropriate names, normally the GEDCOM tag. This applies particularly to the header, submitter and submission GEDCOM records and particular fields like REFN, RFN, RIN and AFN.

Where data is listed as 'ignored', its omission is reported in the feedback at the end of import, and it is included in a Note attached to a relevant object with a custom type of GEDCOM import. See, for example, the Source object in the example screenshot.

Where data is listed as 'silently ignored', it is not reported and not included in a note. At present this may be regarded as something that has been missed by Gramps and should be raised as an issue.

GEDCOM-Importbeschränkungen

This section describes any GEDCOM data that cannot be directly represented in Gramps, and how it is handled. For additional information on the limits of GEDCOM imports (and exports), please read the section on Gramps and GEDCOM.


Kopf(HEAD), Sender(SUBM) und Einsendung(SUBN)

Gramps hat keine direkte Entsprechung für diese Daten, daher müssen diese Informationen in anderen Objekten gespeichert werden. Abhängig von den Allgemeinen Einstellungen wird ein 'Standardquelle' Objekt erstellt. Wenn diese erstellt wird, werden die meisten Daten in der Quelle oder im Aufbewahrungsort der Quelle zugeordnet gespeichert.

Kopf
   KOPF:=
        n HEAD                                          {1:1}
          +1 SOUR <APPROVED_SYSTEM_ID>                  {1:1}  (Datenelement der 'Standardquelle')
            +2 VERS <VERSION_NUMMER>                    {0:1}  (Datenelement der 'Standardquelle')
            +2 NAME <NAME_DES PRODUKT>                  {0:1}  (Datenelement der 'Standardquelle')
            +2 CORP <NAME_OF_BUSINESS>                  {0:1}  (Aufbewahrungsort der 'Standardquelle')
              +3 <<ADRESSEN_STRUKTUR>>                  {0:1}  (Aufbewahrungsort der 'Standardquelle')
            +2 DATA <NAME_OF_SOURCE_DATA>               {0:1}  (Datenelement der 'Standardquelle')
              +3 DATE <VERÖFFENTLICHUNGSDATUM>          {0:1}  (Datenelement der 'Standardquelle')
              +3 COPR <COPYRIGHT_SOURCE_DATA>           {0:1}  (Datenelement der 'Standardquelle')
          +1 DEST <RECEIVING_SYSTEM_NAME>               {0:1*} (Datenelement der 'Standardquelle')
          +1 DATE <ÜBERTRAGUNGSDATUM>                   {0:1}  (Datenelement der 'Standardquelle')
            +2 TIME <ZEIT_WERT>                         {0:1}  (Datenelement der 'Standardquelle')
          +1 SUBM @<XREF:SUBM>@                         {1:1}  (Datenelement der 'Standardquelle')

(Wird auch verwendet, um den Übermittlerdatensatz zu bestimmen)

                                                               (dies sollte als Datenbankeignerinformation gespeichert werden)
          +1 SUBN @<XREF:SUBN>@                         {0:1}  (ignoriert)
          +1 FILE <DATEINAME>                           {0:1}  (Datenelement der 'Standardquelle')
          +1 COPR <COPYRIGHT_GEDCOM_DATEI>              {0:1}  (als Veröffentlichungsinformation der 'Standardquelle' gespeichert)
          +1 GEDC                                       {1:1}
            +2 VERS <VERSION_NUMMER>                    {1:1}  (Datenelement der 'Standardquelle')
            +2 FORM <GEDCOM_FORM>                       {1:1}  (Datenelement der 'Standardquelle')
          +1 CHAR <ZEICHENSATZ>                         {1:1}  (Datenelement der 'Standardquelle')
            +2 VERS <VERSION_NUMMER>                    {0:1}  (Datenelement der 'Standardquelle')
          +1 LANG <SPRACHE_VON_TEXT>                    {0:1}  (Datenelement der 'Standardquelle')
          +1 PLAC                                       {0:1}
            +2 FORM <ORTEHIERARCHIE>                    {1:1}  (siehe unten)
          +1 NOTE <GEDCOM_CONTENT_DESCRIPTION>          {0:1}  (Notiz der 'Standardquelle')
            +2 [CONT|CONC] <GEDCOM_CONTENT_DESCRIPTION> {0:M}
            
   * Anmerkung: Einsendungen zu the Family History Department for Ancestral
     File submission oder für clearing temple ordinances muss ein Ziel (DEST) aus 
     DESTination of ANSTFILE oder TempleReady verwenden.

Das PLAC Formular wird intern gespeichert und verwendet die Interpretation von Orten zu steuern (in Übereinstimmung mit den GEDCOM Spezifikation).

Sender

Der SUBMISSION_Datensatz (es sollte nur einen geben, dies wird aber nicht überprüft) wird als Daten Element der 'Standardquelle' gespeichert.

    SUBMISSION_RECORD:=
        n @<XREF:SUBN>@ SUBN                            {1:1]
          +1 SUBM @<XREF:SUBM>@                         {0:1}
          +1 FAMF <NAME_OF_FAMILY_FILE>                 {0:1}
          +1 TEMP <TEMPLE_CODE>                         {0:1}
          +1 ANCE <GENERATIONS_OF_ANCESTORS>            {0:1}
          +1 DESC <GENERATIONS_OF_DESCENDANTS>          {0:1}
          +1 ORDI <ORDINANCE_PROCESS_FLAG>              {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
Einreicher

SUBMITTER_Datensätze (Es können mehr als einer vorkommen) werden als Aufbewahrungsort Datensätze verknüpft mit der 'Standardquelle' gespeichert. Ausnahmen sind unten FETT dargestellt. Der Übermittlerdatensatz entspricht dem SBM Datensatz im KOPF und wird verwendet den Datenbankeigner zu setzen siehe dort.

   SUBMITTER_RECORD:=
        n @<XREF:SUBM>@   SUBM                          {1:1}
          +1 NAME <SUBMITTER_NAME>                      {1:1}
          +1 <<ADRESSEN_STRUKTUR>>                      {0:1}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
          +1 LANG <LANGUAGE_PREFERENCE>                 {0:3}
          +1 RFN <SUBMITTER_REGISTERED_RFN>             {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • Multimedia Link wird ignoriert
  • LANG wird ignoriert
  • RFN und RIN werden ignoriert
Person_Datensatz

Der INDI_Datensatz wird in Gramps als Person Datensatz gespeichert. Ausnahmen sind unten FETT dargestellt.

   PERSON_DATENSATZ: =
        n @<XREF:INDI>@  INDI                           {1:1}
          +1 RESN <RESTRICTION_NOTICE>                  {0:1}
          +1 <<PERSÖNLICHER_NAME_STRUKTUR>>             {0:M}
          +1 SEX <SEX_Wert>                             {0:1}
          +1 <<PERSÖNLICHE_EREIGNIS_STRUKTUR>>          {0:M}
          +1 <<PERSÖNLICHE_ATTRIBUTE_STRUKTUR>>         {0:M}
          +1 <<LDS_INDIVIDUAL_ORDINANCE>>               {0:M}
          +1 <<KIND_ZU_FAMILIE_LINK>>                   {0:M}
          +1 <<PARTNER_ZU_FAMILIE_LINK>>                {0:M}
          +1 SUBM @<XREF:SUBM>@                         {0:M}
          +1 <<ASSOCIATION_STRUCTURE>>                  {0:M}
          +1 ALIA @<XREF:INDI>@                         {0:M}
          +1 ANCI @<XREF:SUBM>@                         {0:M}
          +1 DESI @<XREF:SUBM>@                         {0:M}
          +1 <<SOURCE_CITATION>>                        {0:M}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 RFN <PERMANENT_RECORD_FILE_NUMMER>         {0:1}
          +1 AFN <ANCESTRAL_FILE_NUMMER>                {0:1}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYP>                 {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
   
  • Link zum Übermittler, Vorfahren und Nachkommen Interesse Anzeige werden stillschweigend ignoriert.
  • Die Alias Kennzeichnung ("Eine Kennzeichnung um verschiedene Beschreibungsdatensätze einer Person, die die selbe Person sein könnten, zu verknüpfen") wird als Verknüpfung mit dem Namen 'Alias' gespeichert.
  • Die REFN und REFN:TYPE werden als Attribute der Person gespeichert. Wenn es aber mehr als eine REFN gibt ist nicht klar welcher TYP zu welcher REFN gehört.

Die Behandlung der PERSÖNLICHE_ATTRIBUTE_STRUKTUR ist komplizierter. Die folgenden Tags:

  • EDUC (schulische Leistungen),
  • NMR (Anzahl der Heiraten),
  • OCCU (Beruf),
  • PROP (Besitz),
  • RELI (Religion),
  • RESI und
  • TITL (Adelstitel)

werden als Gramps Ereignis behandelt und die zugehörigen Informationen werden in der Ereignisstruktur gespeichert. Die Details, die dem Haupttag folgen (dargestellt in den Klammern in der obigen Liste), werden als die Beschreibung des Ereignis gespeichert. Der <EREIGNIS_DESKRIPTOR> der dem Typtag folgt, überschreibt die Beschreibung wenn der <EREIGNIS_DESKRIPTOR> nicht der Attributname ist.

Die folgenden Tags:

  • CAST (Kastenname),
  • DSCR (körperliche Beschreibung),
  • INDO (National ID Nummer),
  • NATI (Nationalität oder Stammeszugehörigkeit),
  • NCHI (Anzahl der Kinder) und
  • SSN (Sozialversicherungsnummer)

werden in Gramps als Attribut behandelt und die meisten Felder mit Ausnahme den Details die dem Haupttag folgen (in der Liste oben in Klammern dargestellt) der Quellenverweise und Notizstrukturen werden ignoriert wie unten in FETT angedeutet.

   PERSON_ATTRIBUTE_STRUKTUR: =
        n  CAST <CASTE_NAME>                            {1:1}
          +1 <<EREIGNIS_DETAIL>>                        {0:1}
             usw.
   
   EREIGNIS_DETAIL: =
        n  TYPE <EREIGNIS_DESKRIPTOR>                   {0:1}
        n  DATE <DATUMSWERT>                            {0:1}
        n  <<ORTSSTRUKTUR>>                             {0:1}
        n  <<ADRESSE_STRUKTUR>>                         {0:1}
        n  AGE <ALTER_AM_EREIGNIS>                      {0:1}
        n  AGNC <RESPONSIBLE_AGENCY>                    {0:1}
        n  CAUS <URSACHE_DES_EREIGNIS>                  {0:1}
        n  <<SOURCE_CITATION>>                          {0:M}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
        n  <<MULTIMEDIA_LINK>>                          {0:M}
        n  <<NOTIZ_STRUKTUR>>                           {0:M}
        
        
  • Person Attribute Struktur, Art, Datum, Ortsstruktur, Adresse Struktur, Alter, Agentur, Ursache und Multimedia Link werden alle ignoriert.
FAM_Datensatz

Der FAM Datensatz wird als Gramps Familie Datensatz gespeichert.

   FAM_Datensatz:=
        n @<XREF:FAM>@   FAM                            {1:1}
          +1 <<FAMILIEN_EREIGNIS_STRUKTUR>>             {0:M}
          +1 HUSB @<XREF:INDI>@                         {0:1}
          +1 WIFE @<XREF:INDI>@                         {0:1}
          +1 CHIL @<XREF:INDI>@                         {0:M}
          +1 NCHI <ANZAHL_DER_KINDER>                   {0:1}
          +1 SUBM @<XREF:SUBM>@                         {0:M}
          +1 <<LDS_SPOUSE_SEALING>>                     {0:M}
          +1 <<SOURCE_CITATION>>                        {0:M}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYPE>                {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • Die Verknüpfung zum Übermittler (SUBM) wird stillschweigend ignoriert.
  • Die REFN und REFN:TYPE werden als Attribut der Familie gespeichert. Wenn es aber mehr als eine REFN gibt ist nicht klar welcher TYP zu welcher REFN gehört.
Quellen_Datensatz

Der SOUR_Datensatz wird in Gramps als Quelle Datensatz gespeichert. Ausnahmen sind unten FETT dargestellt.

   QUELLE_DATENSATZ:=
        n @<XREF:SOUR>@ SOUR                            {1:1}
          +1 DATA                                       {0:1}
            +2 EVEN <EVENTS_RECORDED>                   {0:M}
              +3 DATE <DATE_PERIOD>                     {0:1}
              +3 PLAC <SOURCE_JURISDICTION_PLACE>       {0:1}
            +2 AGNC <RESPONSIBLE_AGENCY>                {0:1}
            +2 <<NOTE_STRUKTUR>>                        {0:M}
          +1 AUTH <SOURCE_ORIGINATOR>                   {0:1}
            +2 [CONT|CONC] <SOURCE_ORIGINATOR>          {0:M}
          +1 TITL <SOURCE_DESCRIPTIVE_TITLE>            {0:1}
            +2 [CONT|CONC] <SOURCE_DESCRIPTIVE_TITLE>   {0:M}
          +1 ABBR <SOURCE_FILED_BY_ENTRY>               {0:1}
          +1 PUBL <SOURCE_PUBLICATION_FACTS>            {0:1}
            +2 [CONT|CONC] <SOURCE_PUBLICATION_FACTS>   {0:M}
          +1 TEXT <TEXT_AUS_QUELLE>                     {0:1}
            +2 [CONT|CONC] <TEXT_AUS_QUELLE>            {0:M}
          +1 <<SOURCE_REPOSITORY_CITATION>>             {0:1}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYPE>                {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • DATA und seine untergeordneten Datensätze werden ignoriert
Aufbewahrungsort Datensatz

Der REPO_Datensatz wird als Gramps Aufbewahrungsort Datensatz gespeichert. Ausnahmen sind unten FETT dargestellt.

   AUFBEWAHRUNGSORT_Datensatz: =
        n @<XREF:REPO>@ REPO                            {1:1}
          +1 NAME <NAME_DES_AUFBEWAHRUNGSORT>           {0:1}
          +1 <<ADRESSE_STRUKTUR>>                       {0:1}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYP>                 {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • REFN, REFN:TYPE und RIN werden ignoriert
Multimedia Datensatz

Der MULTIMEDIA_Datensatz wird in Gramps als Medien Datensatz gespeichert.Ausnahmen sind unten FETT dargestellt.

   MULTIMEDIA_DATENSATZ:=
        n @<XREF:OBJE>@ OBJE                            {1:1}
          +1 FORM <MULTIMEDIA_FORMAT>                   {1:1}
          +1 TITL <Beschreibender_TITEL>                {0:1}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 <<SOURCE_CITATION>>                        {0:M}
          +1 BLOB                                       {1:1}
            +2 CONT <ENCODED_MULTIMEDIA_LINE>           {1:M}
          +1 OBJE @<XREF:OBJE>@     /* chain to continued object */  {0:1}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYPE>                {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
  • Es wird ein 'File' Tag erwartet das auf die Datei hinweist, die das Multimediaobjekt enthält. Diese Verwendung wurde aus GEDCOM 5.5.1 übernommen, aber die Möglichkeiten in GEDCOM 5.5.1 mehr als eine <Multimedia_Datei_REFN> und die zur FILE GEDCOM_Zeile untergeordneten FORM, TYPE und TITLE zu haben wird nicht unterstützt (ein späteres FILE kann ein früheres überschreiben - es gibt keine Fehlerprüfung).
  • BLOB wird ignoriert
  • REFN, REFN:TYPE und RIN werden ignoriert
Notiz Datensatz

Der NOTE_Datensatz wird als Gramps Notiz Datensatz gespeichert. Ausnahmen sind unten FETT dargestellt.

   NOTIZ_DATENSATZ:=
        n @<XREF:NOTE>@ NOTE <SUBMITTER_TEXT>           {1:1}
          +1 [ CONC | CONT] <SUBMITTER_TEXT>            {0:M}
          +1 <<QUELLEN_ZITAT>>                          {0:M}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYPE>                {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • Quellen Zitat wird ignoriert
  • REFN, REFN:TYPE und RIN werden ignoriert

Daten exportieren

Gramps-notes.png
Exportieren bedeutet eine Kopie zu speichern

Wenn du exportierst, speicherst du eine Kopie deiner aktuell geöffneten Datenbank. Exportieren erstellt eine zweite Datei mit der Kopie deiner Daten. Beachte das die Datenbank, die in Gramps geöffnet bleibt, NICHT die Datei ist, die bei deinem Export gespeichert wurde. Zusätzliche Änderungen an deiner geöffneten Datenbank ändern nicht die Kopie, die durch den Export erstellt wurde.

Um Daten zu exportieren wähle Stammbaum ->Export oder die Tastenkombination Strg+E oder Command ⌘+E auf Apple Mac's. Dies öffnet den {{man label|[[De:Gramps 5.1 Wiki Handbuch - Stammbäume Verwalten#Exportassistentdialog|Exportassistentendialog}}.

Das Exportieren erlaubt dir jeden Teil deiner Gramps Datenbank mit anderen Forschern zu teilen, genauso wie das überspielen deiner Daten auf einen anderen Computer.

Gramps kann Daten in den folgenden Formaten exportieren:


Exportassistentdialog

Abb. 5.20 Export Assistant: Saving your data - wizard start page

Die Exportassistent Seiten führen dich durch die Datei- und Formartauswahl und formatspezifische Exportoptionen. Nach einer abschließenden Bestätigungsseite, wird der Export basierend auf deinen Angaben durchgeführt. Du kannst zu jeder Zeit die Zurück Schaltfläche klicken und deine Auswahl ändern und vorwärts klicken um den Export zu wiederholen.


Deine Daten speichern

General information about exporting from Gramps.

Select the Next button to continue.


Ausgabeformat wählen

Abb. 5.21 Export Assistant - Choose the output format - wizard dialog

Select the file format to export your data to:

Then select the Next button to continue.

Exportoptionen

Fig. 5.22 Export Assistant - Export Options - wizard dialog (showing defaults for "Comma Separated Values Spreadsheet(CSV)") with highlight Bottom section for File format specific options

After you have adjusted your options in the two sections.

Select the Next button to continue.

Filter und vertraulich

Gramps ermöglicht es dir Daten in gebräuchlichen Formaten zu exportieren.

Es bietet Optionen, die es ermöglichen, deinen Export genau fest zu legen.

Filter ermöglichen es dir einen begrenzten Umfang deiner Daten, basierend auf deinen gewählten Kriterien, zu exportieren.

Vertraulichkeitsfilter:

[✓] Als privat markierte Datensätze ignorieren Dieses aktivieren, um zu verhindern, das als privat markierte Datensätze im Export enthalten sind.

Lebendfilter:

These option restrict data and help limit the information exported for living people. This means that all information concerning their birth, death, addresses, significant events, etc., will be omitted in the exported file. For example, you can choose to substitute the word Living for the first name (see your settings); you can exclude notes; and you can exclude sources for living people.

Sometimes, it is not always obvious from the data if someone is actually alive. Gramps uses an advanced algorithm to try to determine if a person could still be alive. Remember, Gramps is making its best guess, and it may not always be able to guess correctly all the time. Please double check your data.


Select from the following options:

  • Include all selected people (default)
  • Replace given names of living people
  • Replace complete name of living people
  • Do not include living people
Personenfilter:

Select from the following options:

  • Include all selected people (default)
  • Descendants of [Active Person]
  • Descendant Families of [Active Person]
  • Ancestors of [Active Person]
  • People with common ancestor with [Active Person]
  • Create a custom filter by selecting the Edit icon to show the Define filter dialog.
Notizfilter:

Select from the following options:

  • Include all selected notes (default)
  • Create a custom filter by selecting the Edit icon to show the Define filter dialog.
Referenzfilter:

Select from the following options:

  • Include all selected records (default)
  • Do not include records not linked to a selected person
Dateiformatspezifische Exportoptionen

Depending on the file format chosen, you may find a number of file format specific export options to choose from listed underneath the "Filters and privacy" section.

See the relevant section for each of file formats listed that have specific export options:

Gramps-notes.png

Please update or expand this section.


Wähle Speicherdatei

Abb. 5.23 Export Assistant - Select save file - wizard dialog - example

Enter a export file Name: Untitled_1.<file format extension>(default) and choose the folder location to save the export file to (normally your Documents folder.

Then select the Next button to continue.

If you don't have permission to save the file to that location you will see the Could not create <file location and export file name> warning dialog and then the Export Assistants Saving failed wizard dialog, select the Close button and start the export again this time choosing a suitable folder.

Endgültige Bestätigung

Abb. 5.24 Export Assistant - Final confirmation - wizard dialog - example

The Export Assistants Final confirmation wizard dialog allows you to check the summarized details (Format/Name/Folder) of the export file to be created.

At this point you can press Back to revisit your options or Cancel to abort.

Or select the Apply button to continue.

Zusammenfassung

Abb. 5.25 Export Assistant - Summary - wizard dialog - example

The Export Assistants Summary wizard dialog shows the Filename: and confirms that you export data has been saved successfully.

Select the Close button to exit the Export Assistant.

CSV-Export (Tabelle mit durch Kommas getrennten Werten)

Abb. 5.26 Export Assistant - Export Options - wizard dialog (showing defaults for "Comma Separated Values Spreadsheet(CSV)") with highlight Bottom section for File format specific options

Comma Separated Values Spreadsheet(CSV): Allows exporting (and importing) a subset of your Gramps data in a simple spreadsheet format.

See CSV Import and Export for additional information and examples.

Comma Separated Values Spreadsheet(CSV) has the following file format specific export options:

  • Include people -
  • Include marriages -
  • Include children -
  • Include places -
  • Translate headers -


Siehe auch Ansicht exportieren.

GEDCOM Export

Gramps-notes.png
Gramps supports the GEDCOM 5.5.1 version last updated 15 November 2019.

Gramps allows you to export a database into the common legacy GEDCOM format.

GEDCOM export has no file format specific export options but you can change the following:

  • In the General Gramps settings section of the General tab in preferences you can also choose to Add default source on GEDCOM import and also Add tag on import both can significantly slow down the importing of your data.
Gramps-notes.png
If you have installed the third party addon GEDCOM Extensions(.GED2)

it will have its own specific file format specific export options.

For more information on the GEDCOM format see: :

See Gramps and GEDCOM for details of data which is not exported when exporting to GEDCOM (Use Gramps XML for a full family tree export/backup).

GeneWeb Export

GeneWeb Export nach GeneWeb speichert deine Daten in einem gängigen Webgenealogieformat.

Um mehr Informationen zu GeneWeb und sein Format zu erhalten, besuche

GenWeb has no file format specific export options

Gramps XML (family tree) export

Gnome-important.png
Vertraulichkeits Filter

Es ist wichtig deine Vertraulichkeitsoptionen im Exportassistenten zu überprüfen. Aktiviere keine Vertraulichkeitsoptionen für Gramps-XML Sicherungen.

Fig. 5.27 Export Assistant - Export Options - wizard (showing defaults for "Gramps XML (family tree)") with highlight Bottom section for File format specific options

Gramps XML (family tree) Export (.gramps): Dies Format ist das Standardformat für Datenaustausch und Sicherungen (siehe das verwandte .gpkg Format weiter unten für volle Portabilität inklusive Medienobjekten). Der Export im Gramps XML Format erzeugt eine portable Datenbank. Da XML ein textbasiertes von Menschen lesbares Format ist, kannst du es auch verwenden, um einen Blick auf deine Daten zu werfen. Gramps garantiert dir, das du XML Ausgaben älterer Gramps Versionen in neueren Gramps Versionen öffnen kannst (allerdings nicht andersherum!).


Wenn eine Mediendatei während des Exports nicht gefunden wird, siehst du den selben Fehlende Medien Dialog wie beim GEDCOM Export.

Gramps XML (family tree) has the following file format specific export options:

  • Use Compression -


Was ist nicht enthalten:

The Gramps Package backup only contains your family tree and (when the 'include media' backup option is selected) your media.

The following settings in Gramps are not transferred:

Tango-Dialog-information.png
Custom Filter migration

Keep your collection of custom filters through a minor updates to patch Gramps (e.g., from version 5.1.0 to 5.1.2) by manually copying your custom_filter.xml from Gramps User Directory to the corresponding directory in new gramps_version_number.

Even minor upgrades with feature changes (e.g., from a 5.0.x to a 5.1.x version) may include XML format changes since the recent innovation of addon rules are causing rapid evolution in Filters. So porting filters in this manner requires verification that the XML definitions haven't changed. Also, Addon rules may have to be installed in the new upgrade before copied custom filters will work safely.


You can keep your custom settings by manually copying each of the *.xml files from the Gramps User Directory to the corresponding directory in the new gramps_version_number directory. Be aware that (due to changes in different versions of Gramps) the settings may no longer work. So be diligent that you test.


Gramps XML Package (family tree and media) export

Gnome-important.png
Privacy Filters

It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for Gramps XML backups.


Gramps XML Package (family tree and media) Export (.gpkg): Der Export in das Gramps-Paketformat erstellt eine komprimierte Datei, welche die Gramps XML Datei und Kopien aller zugehörigen Mediendateien enthält. Dies ist sinnvoll wenn du deine Daten auf einen anderen Computer kopieren oder mit jemanden teilen willst.

Wenn eine Mediendatei während des Exports nicht gefunden wird, siehst du den selben Fehlende Medien Dialog wie beim GEDCOM Export.

Gramps XML Package (family tree and media) has no file format specific export options

Was ist nicht enthalten:

The Gramps Package backup only contains your family tree and (when the 'include media' backup option is selected) your media.

The following settings in Gramps are not transferred:

Tango-Dialog-information.png
Custom Filter migration

Keep your collection of custom filters through a minor updates to patch Gramps (e.g., from version 5.1.0 to 5.1.2) by manually copying your custom_filter.xml from Gramps User Directory to the corresponding directory in new gramps_version_number.

Even minor upgrades with feature changes (e.g., from a 5.0.x to a 5.1.x version) may include XML format changes since the recent innovation of addon rules are causing rapid evolution in Filters. So porting filters in this manner requires verification that the XML definitions haven't changed. Also, Addon rules may have to be installed in the new upgrade before copied custom filters will work safely.


You can keep your custom settings by manually copying each of the *.xml files from the Gramps User Directory to the corresponding directory in the new gramps_version_number directory. Be aware that (due to changes in different versions of Gramps) the settings may no longer work. So be diligent that you test.


Web Family Tree Export

Web Family Tree export creates a text file that can be used by the Web Family Tree program.

To find out more about Web Family Tree and its format, visit

Web Family Tree has no file format specific export options

vCalendar Export

vCalendar Export speichert die Informationen in einem Format welches in vielen Terminplanungs und Adressverwaltungsprogrammen verwendet wird, manchmal als PIM (Persönlicher Informationsmanager)bezeichnet.

Für mehr Informationen über das Format siehe:

vCalendar has no file format specific export options

vCard Export

vCard Export speichert die Informationen in einem Format welches in vielen Terminplanungs und Adressverwaltungsprogrammen verwendet wird, manchmal als PIM (Persönlicher Informationsmanager)bezeichnet.

Für mehr Informationen über das Format siehe:

vCard has no file format specific export options

Zurück Index Nächste
Gnome-important.png Spezielle Copyright Notiz: Alle Änderungen auf dieser Seite müssen unter zwei copyright Lizenzen stehen:

Diese Lizenzen ermöglichen es dem Gramps-Projekt die bestmögliche Verwendung dieses Handbuchs als freien Inhalt in zukünftigen Gramps Versionen. Wenn du mit dieser dual Lizenzierung nicht einverstanden bist, bearbeite diese Seite nicht. Du darfst zu anderen Seiten des Wiki die nur unter die GFDL Lizenz fallen nur über externe Links (verwende die Syntax: [http://www.gramps-project.org/...]), nicht über interne Links verlinken.
Außerdem verwende nur die Bekannten Drucktechnische Konventionen