De:Gramps 5.1 Wiki Handbuch - Stammbäume Verwalten

From Gramps
Revision as of 20:53, 7 February 2021 by Leonhaeuser (talk | contribs)
Jump to: navigation, search
Zurück Index Nächste


Eine detaillierte Beschreibung des täglichen Gebrauchs von Gramps. In diesem Kapitel geben wir einen detaillierten Überblick darüber, wie du deine Stammbäume verwalten und deine Daten mit anderen Ahnenforschern teilen kannst.

Neuen Stammbaum beginnen

Abb. 5.1 Menubar - "Family Trees" - overview example

Um einen neuen Stammbaum zu beginnen wähle Stammbäume ->Stammbäume verwalten oder wähle die ChartsStammbäume verwalten Schaltfläche aus der Werkzeugleiste oder verwende die Tastenkombination Strg+O.. Dies öffnet das Stammbaumverwaltung Fenster.

Wähle die Neu Schaltfläche und Gramps fügt einen neuen Stammbaumeintrag zur Liste der Stammbäume hinzu. Um seinen Namen vom Standard Stammbaum 1 zu ändern, wähle den Namen und drücke die Umbenenne Schaltfläche gib einen neuen Namen ein.

To open the new, empty Family Tree select the Family Tree and either double click or press the Load Family Tree button to load.

Abb. 5.2 Manage databases - icon on toolbar (Same as using menu Family Trees ->Manage Family Trees...)


Abb. 5.3 Connect to a recent database - icon drop down on toolbar menu Family Trees ->Open Recent...


Stammbaummanagerfenster

Abb. 5.4 "Family Trees" manager window

Clicking the Family Tree Manager button brings up the Family Trees manager windows this allows you to work with and manage your Family Trees.

The Family Tree Manager window allows the you to create a new Family tree, rename an existing Family tree, delete a Family tree, or load a Family tree or check information) about the Family tree. All the names of your Family trees appear in the list. If a Family tree is open, an icon will appear next to the name in the status column. The Database Type as well an indication of the date and time your family tree was Last accessed' is shown.

  • New creates a new Family tree.
  • Info shows information about the selected Family tree.
  • Delete the selected Family tree, this will show a warning with a final confirmation for you to select.
  • Rename the selected existing Family tree.
  • Close the selected existing Family tree.
  • Convert the selected family tree. This option only available for legacy BSDDB databases. See: Converting a BSDDB Family Tree to SQlite
  • Repair the selected existing Family tree, only available if Gramps detects an issue.
  • Archive option is only present if GNU Revision Control System (RCS) is installed.
  • Extract used with the Archive button and the option is only present if GNU Revision Control System (RCS) is installed.
  • Help - from this section.
  • Close Window - dismisses the Family Tree manager windows
  • Load Family Tree the selected existing Family tree.


Einen Stammbaum öffnen

Um einen Stammbaum zu öffnen wähle entweder Stammbäume ->Stammbäume verwalten oder klicke die Stammbäume Schaltfläche in der Werkzeugleiste. Die Stammbaumverwaltung öffnet sich und du siehst eine Liste aller Gramps bekannten Stammbäume. Ein Symbol wird in der Status Spalte (sieht aus wie ein geöffneter Ordner) neben jedem aktuell geöffneten Stammbaum angezeigt. Wähle den Baum den du öffnen willst und öffne ihn durch klicken der Stammbaum laden Schaltfläche. Alternativ kannst du den gewünschten Baum auch doppelt klicken.

Um einen zuletzt geöffneten Stammbaum zu öffnen, wähle entweder Stammbäume ->Zuletzt geöffnet oder den abwärts Pfeil neben der Stammbäume Schaltfläche und wähle den Stammbaum aus der Liste.

Nur lesen Modus

Gnome-important.png
Nur lesen Modus

Wenn du keine "Schreibrechte" für den gewählten Stammbaum hast, wird er im nur lesen Modus geöffnet. In diesem Modus können die Daten angesehen werden, es sind aber keine Änderungen an dem Stammbaum möglich. Als Indikator für diesen Modus wird der Titel des Hauptfensters um den Text (Nur lesen) erweitert.

The Tools menu will not be available.

Änderungen im Stammbaum speichern

Gramps speichert ihre Daten direkt nachdem du sie eingegeben hast. Dies bedeutet zum Beispiel, das jedes mal wenn du Ok klickst während du Gramps verwendest werden deine Daten unverzüglich übernommen und gespeichert. Es gibt kein spezielles "speichern" Kommando.

Du kannst deine Änderungen durch aufrufen von Bearbeiten ->Rückgängig rückgängig machen. Wenn du dieses Kommando wiederholt aufrufst, werden deine letzten Änderungen Stück für Stück rückgängig gemacht. Um mehrere Kommandos am Stück rückgängig zu machen, kannst du den Bearbeitungschronik Dialog verwenden, verfügbar über das Bearbeiten->Bearbeitungschronik Menü.

Wenn du deinen Stammbaum in den Zustand beim Öffnen zurücksetzen willst, wähle Stammbäumen ->Änderungen verwerfen und beenden. (Dies ist wie Beenden ohne speichern in anderen Programmen.)

Wenn du eine Kopie deines Stammbaums unter einem anderen Namen speichern willst, musst du ihn exportieren und dann in einen neuen Stammbaum importieren. Die Verwendung des Gramps XML Datenbank Format wird hierfür empfohlen.

Eine GEDCOM oder XML Datei öffnen

Gramps erlaubt dir verschiedene Daten, die nicht im GRAMPS eigenen Format gespeichert wurden, von der Kommandozeile aus zu öffnen, siehe Kommandozeilenreferenz. Dies beinhaltet XML und GEDCOM Dateien. Du solltest dir aber bewusst sein, dass wenn die XML oder GEDCOM Datei relativ groß ist, du Leistungsprobleme bekommst und im Falle eines Absturzes deine Daten beschädigt werden können. Daher ist es normalerweise besser, einen neuen Gramps Stammbaum (Datenbank) zu erstellen und deine XML/GEDCOM Daten in diesen zu importieren.

Gramps-notes.png
Dateien öffnen

XML und GEDCOM Dateien erfordern es alle Daten im Speicher zu halten und enthalten keine Indizes. Das Gramps eigene Format ist eine Datenbank, die die Daten nur liest, wenn sie benötigt werden. Also kann bei einem großen Stammbaum schneller und effizienter auf die Daten zugegriffen werden, wenn XML oder GEDCOM nicht verwendet werden.

Gnome-important.png
GEDCOM Bearbeiten

Bitte beachte, dass Daten aus einer GEDCOM-Datei sowohl beim Import in Gramps als auch beim Export zurück nach GEDCOM verloren gehen können. Nur öffnen und betrachten der Datei ändert sie nicht. Wenn allerdings Änderungen durchgeführt wurden und bis zum beenden noch bestehen, speichert Gramps die Daten mit möglichem Datenverlust.

Einen Stammbaum löschen

Wählen den Stammbaum, den du löschen willst und klicke die Löschen Schaltfläche.

Dies löscht den Stammbaum komplett ohne die Möglichkeit die Daten zurück zu holen. Überlege eine Sicherung deiner Daten durch Export in das Gramps XML-Format zu erstellen und diese Datei zu sichern.

Einen Stammbaum umbenennen

Du kannst einen Stammbaum (oder ein Archiv von ihm) durch wählen des gewünschten Baums und klicken auf Umbenennen umbenennen. Du kannst auch auf den Namen in der Liste von Stammbäumen klicken.

In beiden Fällen gib einfach den neuen Namen ein damit er gültig wird.

Gramps-notes.png
Family Tree name Limitations

There are some characters that are not allowed within a Family Tree name. They will be automatically replaced with the underscore character "_".

The comma, double quote and vertical bar characters and these: "\:/<>][.+*?"

Einen Stammbaum sichern

Der sicherste Weg deinen Stammbaum zu sichern, ist der Export ohne Einschränkungen und Filter im Gramps XML Format (oder als Gramps Paket, um Elemente aus der Galerie mit zu sichern) und die resultierende Datei an einem sicheren Ort zu kopieren, bevorzugt in einem anderen Gebäude.

Sicherungsdialog

Abb. 5.5 Eine Sicherung erstellen

Wähle einfach das Stammbäume->Sicherung erstellen... Menü.

The Gramps XML Backup window will appear.

You can enter the Path: where the backup should be stored manually or using the path selector button to bring up the Select backup directory dialog.

You can enter a File: name manually or use the automatically generated file name.

Du kannst auswählen, ob du die Medien Einbeziehen(Vorgabe) oder Ausschließen willst.

Gramps-notes.png
Beachte

Dass dies nur ein gewöhnlicher XML-Export ist, nur dass keine Daten ausgefiltert sind. Du kannst ihn wie jede exportierte Datei importieren.


  • You can use the Archive feature (see next section) to store snapshots of your Family Tree. These snapshots can be used as simple backups, very useful if you want to try something that you might later want to undo. However this method should not be used for standard backups, as it will not survive a hard disk crash or most of the other disasters that can befall a computer.
  • For advanced users: each database is stored in its own subdirectory under ~/.gramps. Although a manual backup can be made by backing up this directory, it is not recommended. It is strongly recommended that you please use a Gramps XML backup instead.

Siehe auuch:

Einen Stammbaum archivieren

Tango-Dialog-information.png
Beachte

Die Archive Option ist nur verfügbar wenn GNU Revision Control System (RCS) vorhanden ist so das Gramps es verwenden kann. Normalerweise musst du es unabhängig von Gramps installieren.

Du kannst mit der in Gramps verwendeten GNU Revision Control System oder RCS wenn dieses installiert ist einfach Stammbäume archivieren oder mit einem Zeitstempel versehen. Um dies zu ermöglichen, muss das Programm auf deinem Computer installiert sein.

Um ein Archiv zu erstellen:

Fig. 5.6 Ein Beispiel zum Stammbaum archivieren
  1. lade den Stammbaum.
  2. klicke in der Werkzeugleiste auf die ChartsStammbäume Schaltfläche (sie hat das Gramps-Logo und zeigt Stammbäume verwalten, wenn man über sie fährt).
  3. klicke auf den Stammbaum, den du gerade geladen hast: die Archiv Schaltfläche sollte erscheinen.
  4. klicke auf Archiv und du wirst nach einer "Revisionskommentar - Versionsbeschreibung" für dein Archiv gefragt.

Nach dem Archivieren zeigt die Liste der Stammbäume links neben dem originalen Stammbaum ein nach rechts zeigendes Dreieck.

  • Klicke auf das Dreieck um, den Archivnamen zu zeigen. (Klicke erneut zum zuklappen der Archivliste).

Archive können gelöscht, umbenannt und entpackt werden.


Ein Stammbaumarchiv entpacken

Abb. 5.7 (Manage)"Family Trees" dialog - Archive selected ready to "Extract" - example

To retrieve a version of a previously archived family tree in the "Family Tree" manager highlight the archive you want to restore, and select the Extract button.


Abb. 5.8 (Manage)"Family Trees" dialog - Archived version extracted and selected - example

The archive will then be restored into a new Family Tree and be listed in the family tree manager.

The Family Tree name is based on the original name and the archive name eg: <name of original tree>:<name of archive>.(see also Archiving a Family Tree)

This can be a useful way of preserving an archive, because archives disappear if the originating tree is deleted; and 'they are not incorporated into a Gramps XML export of the family tree.

Einen Stammbaum entsperren

Fig. 5.9 Family Trees (Manager) - Dialog - Showing Locked "Sample" Family Tree

Gramps is a single-user database application and identifies Tree database files as busy with a 22x22-gramps-lock.png'lock' when in use. As Gramps opens a tree, it drops a lock file (which lists the username and domain) in the tree's subfolder in the grampsdb folder of the User Directory. Gramps refuses to let you (or anyone else) open that Tree at the same time. A second instance of Gramps will be able to open another family tree, but any tree that is already open will appear with the lock icon in the Status column of the Manage Family Trees dialog. Closing the tree in the first copy of Gramps deletes the lock file and will make the tree available to be opened in the second instance.

If you could open the same Family Tree in two instances of Gramps at once, it is likely your data would be damaged as the two overwrite each other's work.

See also:

Gnome-important.png
Be careful Breaking Locks!

Only do this if you are sure no other copy of Gramps is using the selected Family Tree.

Break the lock on the "Family Tree name" database? dialog

Fig. 5.10Error parsing arguments - dialog - Database is locked example

In the unlikely event that Gramps crashes, the family tree will be left in a locked state (indicated by a 22x22-gramps-lock.pnglock icon in the Status column next to the Family Tree name)

To unlock the Family Tree during startup

  • If the Family Tree Preferences have been set to open a tree automatically on startup, then you will see the Error parsing arguments dialog which remarks that the Database is locked. Click on the Close button then choose Manage Family trees... from the Family Trees menu.
  • Otherwise, the Family Tree Manager will appear automatically as Gramps starts.


Fig. 5.11 Break the lock on the "Sample" database? - Dialog - example

Choose the locked family tree and then click the Load Family Tree button. The Break the lock on the '[Family Tree name]' database? dialog will be shown.

Click the Break lock button and the Family Trees (Manager) window should show that the lock icon has gone.

Choose the previously locked family tree and then click the Load Family Tree button to continue your work.

Einen beschädigten Stammbaum reparieren

Abb. 5.12 Family Trees (Manager) - Dialog - Showing Red Error Status Icon for "Sample" Family Tree

Wenn dein Stammbaum in irgendeiner Weise beschädigt wurde, zeigt die Gramps-Stammbaumverwaltung ein rotes Fehlersymbol in der Status Spalte.

Um Gramps mitzuteilen, das es versuchen soll, den Schaden zu reparieren, wähle den Baum und klicke auf die Reparieren Schaltfläche.

Gramps wird versuchen den Stammbaum aus den Sicherungsdateien, die automatisch beim Beenden erstellt werden, wieder herzustellen.

Siehe auch:


Converting a BSDDB Family Tree to SQLite

Tango-Dialog-information.png
From Gramps 5.1.x the default database is SQLite.

Before following the conversion advice in this section, take the time to backup your family trees


Fig. 5.13 Convert the 'Family Tree Name' database? dialog with Family Trees (Manager) - Dialog shown in background

If you have an older legacy BSDDB format Database Type shown for any of your family tree's in the Family Trees (Manager) - Dialog, then selecting a family tree in the Family Trees (Manager) - Dialog will show the Convert button as available.

It is highly recommended that before doing the following you back up the family trees to be converted.

When ready select the Convert button and the Convert the 'Family Tree Name' database? dialog will be shown with the message Do you wish to convert this family tree into a SQLite database? you can select Cancel to stop or Convert to start the process, once completed the Family Trees (Manager) - Dialog will show a new entry for the converted copy of your Family tree but with the Database Type of SQLite, you should then open and backup the converted family tree.

You may then rename the original BSDDB family tree with the word OLD or you can Delete it to avoid confusion, then you can rename the new SQLite database.



Daten importieren

Gramps-notes.png
Importieren im Vergleich zum Öffnen

Bitte beachte, eine Datenbank importieren ist etwas anderes als sie zu öffnen. Wenn du importierst, bringst du Daten von einer Datenbank in einen Gramps-Stammbaum. Wenn du eine Datei öffnest, bearbeitest du die original Datei.

Importieren ermöglicht dir Daten aus anderen Genealogieprogrammen in einem Gramps-Stammbaum zu verwenden. Zur Zeit kann Gramps Daten in folgenden Formaten importieren:

  • Gramps XML (.gramps file extension) Gramps native data exchange format in uncompressed text and gzip compressed
  • Gramps XML Package (.gpkg file extension) Gramps .tar.gz archive compressed backup format
  • GRAMPS V2.x database (.grdb file extension)
  • CSV Spreadsheet - comma separated values (.csv file extension)
  • GEDCOM (.ged file extension) de facto standard file format for data interchange between genealogy programs
  • GeneWeb (.gw file extension) - GeneWeb is genealogy software with a web interface.
  • Pro-Gen (.def file extension) - Pro-Gen has been very popular in the Netherlands and North-West Germany. It is often used by people who started collecting and storing data as early as 1989. This was a DOS based program which has been patched to work with Win 10.
  • vCard (.vcf file extension) - Virtual Contact File is a file format standard for electronic business cards.
  • JSON Import (.json file extension) - JavaScript Object Notation is a lightweight data-interchange format.
  • SQLite Import (.sql file extension) - SQLite database format

Import Stammbaumdialog

Gramps-notes.png
Note that data can only be imported into a prepared Family Tree (database)

So, if migrating from another program, it is necessary to first create a new empty Family Tree before importing the unauthenticated data into it. Once the data is imported, clean up any corruptions or incompatibilities.
If the intent is use the import for merging outside data into an existing Gramps Tree, it is less complex to import data from a pre-cleaned and validated Tree already in Gramps format.
Importing is a risky task, always make a backup of your Tree before importing.

Fig. 5.14 Import Family Tree - dialog example

Um Daten zu importieren, wähle Stammbäumen ->Importoder die Tastenkombination Strg+I. Either the Undo history warning dialog will open if you attempt to import into an existing Family Tree (Achtung du kannst nur Daten in einen bestehenden Stammbaum importieren. Wenn du also deine gesamten Daten von einem anderen Programm oder einer älteren Version von Gramps übernehmen willst, erst einen neuen leeren Stammbaum erstellen und dann die Daten in diesen importieren.) oder der Datenbankimport Dialog wird geöffnet, fragt nach der Datei die du importieren willst.

Gnome-important.png
Datenverlust bei einigen Formaten

Es ist wichtig zu wissen, das es keine direkte eins zu eins Beziehung zwischen all den Fähigkeiten von Gramps und denen von GEDCOM, GeneWeb oder Pro-Gen existiert. Daher können beim Import aus diesen Formaten Daten verloren gehen. Details welche Daten beim Import aus GEDCOM verloren gehen können siehe weiter unten.

Gramps-notes.png
Von anderen Programmen erzeugte Ereignisse neu ordnen

Einige Programme von denen du Daten importiert hast, sortieren die Ereignisse eventuell nicht so wie du es erwartest. Gramps bietet dir Hilfe beim neu Ornen der Ereignisse nach deinen Vorstellungen. Siehe Ereignisse sortieren Werkzeug.

GRAMPS V2.x Datenbankimport

GRAMPS V2.x Datenbank (.grdb): Vor Version 3.0 war dies das Format in dem Gramps die Daten gespeichert hat, eine speziell angepasste Berkeley Datenbank (BSDDB) mit einer angepassten Datentabellenstruktur. Dieses Format war System und Architektur gebunden. Es war schnell und effizient, aber nicht sehr übertragbar auf Computer mit einer anderen Architektur (z.B. i386 nach Alpha).

Der Import im GRAMPS v2.x Datenbankformat wird nur von Gramps Version 3.0.x unterstützt. Der Import von V2.x in Gramps V3.0.x geschieht ohne Datenverlust.

Gnome-important.png
Der Import aus dem GRAMPS V2.x Format wird von Gramps 5.1 nicht unterstützt.

Wenn du eine alte V2.x Datenbank besitzt, musst du sie in Gramps V3.0.x importieren und von dort in Gramps XML (oder Gramps XML-Paket) exportieren und dies dann in Gramps 5.1 importieren.

Gramps XML und XML Paket Import

Die Gramps XML und Gramps XML Paket sind die eigenen Gramps-Formate. Es besteht kein Risiko von Datenverlust beim importieren von oder exportieren in diese Formate.

  • Gramps XML (.gramps): Die Gramps XML Datei ist das Standarddatenaustausch und Sicherungsformat von Gramps und war auch das Arbeitsformat für ältere (vor 2.x) Gramps Versionen. Anders als das grdb-Format ist es architekturunabhängig und kann von Menschen gelesen werden. Die Datenbank kann auch Verweise auf nicht lokale (externe) Medienobjekte enthalten, daher ist nicht garantiert, das diese Datei voll übertragbar ist (für volle Übertragbarkeit inklusive Medienobjekten, sollte das Gramps XML Paket Format (.gpkg) verwendet werden). Die Gramps XML Datei wird durch Export (Menü Stammbäume ->Export...) der Daten in dieses Format erstellt.
  • Gramps XMLPaket (.gpkg): Das Gramps XML Paket ist eine komprimiertes Archiv welches die Gramps XML Datei und alle Medienobjekte (Bilder, Klangdateien usw.) enthält, auf die der Stammbaum verweist. Weil es alle Medienobjekte enthält, ist dieses Format komplett übertragbar. Das Gramps XMLPaket wird durch den Export (Stammbäume ->Export...) der Daten in dieses Format erstellt.

Wenn du Informationen von einer anderen Gramps Datenbank oder Gramps XML Datei importierst, wird dir der Fortschritt im Fortschrittsbalken im Gramps Hauptfenster angezeigt. Wenn der Import abgeschlossen ist, zeigt ein Statusfenster die Anzahl der importierten Objekte. Wenn die importierten Daten ursprünglich von dem Stammbaum stammen, in den du sie importierst, bekommst du Vorschläge, was zusammengefasst werden könnte; das Zusammenfassen wird nicht automatisch für dich erledigt. Wenn du genealogische Grunddaten automatisch zusammengefasst haben möchtest, denke über CSV Tabellen Export/Import nach.

Gramps CSV Import

  • Das Gramps CSV Tabellenformat erlaubt dir den Im- und Export einer Teilmenge deiner Gramps-Daten in einem einfachen Tabellenformat. Siehe CSV Import und Export für mehr Informationen.

GEDCOM Import

Abb. 5.15 Gedcom Import Bericht - Beispiel.

Wenn du Informationen von GEDCOM importierst, siehst du den Fortschrittsbalken im Gramps Hauptfenster. Wenn der GEDCOM Import abgeschlossen ist, zeigt das GEDCOM Importbericht: Fenster welche Daten nicht importiert wurden. Der GEDCOM Importbericht: detailliert die meisten Zeilen die entweder ignoriert oder nicht verstanden wurden (Most likely as they are not part of the GEDCOM 5.5 standard. See GEDCOM Erweiterungen englisch).. Der Inhalt der Zeilen (oder Zeilen wenn es Fortsetzungszeilen gibt) wird auch angezeigt. In einigen Fällen kann es sein, das die Zeilen nicht exakt denen in der Importdatei entsprechen, da die Zeile während des Verarbeitungsprozess unstrukturiert wird.

Gramps verwendet ein anderes 'Datenmodell' als GEDCOM daher können einige Daten aus GEDCOM nicht in Gramps importiert werden (siehe Gramps und GEDCOM englisch).

Die Hauptausnahmen sind:

  • Einige GDCOM Attribute Strukturen werden als Gramps Attribute behandelt und daher können viele der einfachen GEDCOM Elemente nicht gespeichert werden.
  • Die Datenelemente eines Quelldatensatz (anzeigen der aufgezeichneten Ereignisse und zuständige Filiale) werden ignoriert.
  • Jedes Quellenzitat bei Notizen wird ignoriert.
  • Viele einfache GEDCOM Elemente besitzen keine entsprechenden Datenelemente in Gramps und werden daher als Attribut oder Datum mit entsprechendem Namen normalerweise das GEDCOM Tag gespeichert. Dies trifft auch teilweise auf den Kopf, Übermittler und Übermittlung, GEDCOM Datensätze und einzelne Felder wie REFN, RFN, RIN und AFN zu.
Abb. 5.16 Importbericht:Beispiel einer Notiz die ausgelassene Daten zeigt

Wenn bei Daten festgelegt ist, das sie 'ignoriert' werden, wird ihr Wegfall in der Rückmeldung am Ende des Imports berichtet und sie werden als Notiz dem entsprechenden Objekt beigefügt.

Wenn Daten 'stillschweigend ignoriert' werden, werden sie (aktuell - dies sollte als Lücke angesehen werden) nicht berichtet und nicht als Notiz gespeichert.


Dieser Abschnitt beschreibt alle GEDCOM Daten die nicht direkt in Gramps dargestellt werden können und wie sie behandelt werden. Für zusätzliche Informationen über die Beschränkungen beim GEDCOM Im- und Export, lies bitte den Abschnitt in Gramps und GEDCOM (in englisch).

Kopf(HEAD), Sender(SUBM) und Einsendung(SUBN)

Gramps hat keine direkte Entsprechung für diese Daten, daher müssen diese Informationen in anderen Objekten gespeichert werden. Abhängig von den Allgemeinen Einstellungen wird ein 'Standardquelle' Objekt erstellt. Wenn diese erstellt wird, werden die meisten Daten in der Quelle oder im Aufbewahrungsort der Quelle zugeordnet gespeichert.

   KOPF:=
        n HEAD                                          {1:1}
          +1 SOUR <APPROVED_SYSTEM_ID>                  {1:1}  (Datenelement der 'Standardquelle')
            +2 VERS <VERSION_NUMMER>                    {0:1}  (Datenelement der 'Standardquelle')
            +2 NAME <NAME_DES PRODUKT>                  {0:1}  (Datenelement der 'Standardquelle')
            +2 CORP <NAME_OF_BUSINESS>                  {0:1}  (Aufbewahrungsort der 'Standardquelle')
              +3 <<ADRESSEN_STRUKTUR>>                  {0:1}  (Aufbewahrungsort der 'Standardquelle')
            +2 DATA <NAME_OF_SOURCE_DATA>               {0:1}  (Datenelement der 'Standardquelle')
              +3 DATE <VERÖFFENTLICHUNGSDATUM>          {0:1}  (Datenelement der 'Standardquelle')
              +3 COPR <COPYRIGHT_SOURCE_DATA>           {0:1}  (Datenelement der 'Standardquelle')
          +1 DEST <RECEIVING_SYSTEM_NAME>               {0:1*} (Datenelement der 'Standardquelle')
          +1 DATE <ÜBERTRAGUNGSDATUM>                   {0:1}  (Datenelement der 'Standardquelle')
            +2 TIME <ZEIT_WERT>                         {0:1}  (Datenelement der 'Standardquelle')
          +1 SUBM @<XREF:SUBM>@                         {1:1}  (Datenelement der 'Standardquelle')

(Wird auch verwendet, um den Übermittlerdatensatz zu bestimmen)

                                                               (dies sollte als Datenbankeignerinformation gespeichert werden)
          +1 SUBN @<XREF:SUBN>@                         {0:1}  (ignoriert)
          +1 FILE <DATEINAME>                           {0:1}  (Datenelement der 'Standardquelle')
          +1 COPR <COPYRIGHT_GEDCOM_DATEI>              {0:1}  (als Veröffentlichungsinformation der 'Standardquelle' gespeichert)
          +1 GEDC                                       {1:1}
            +2 VERS <VERSION_NUMMER>                    {1:1}  (Datenelement der 'Standardquelle')
            +2 FORM <GEDCOM_FORM>                       {1:1}  (Datenelement der 'Standardquelle')
          +1 CHAR <ZEICHENSATZ>                         {1:1}  (Datenelement der 'Standardquelle')
            +2 VERS <VERSION_NUMMER>                    {0:1}  (Datenelement der 'Standardquelle')
          +1 LANG <SPRACHE_VON_TEXT>                    {0:1}  (Datenelement der 'Standardquelle')
          +1 PLAC                                       {0:1}
            +2 FORM <ORTEHIERARCHIE>                    {1:1}  (siehe unten)
          +1 NOTE <GEDCOM_CONTENT_DESCRIPTION>          {0:1}  (Notiz der 'Standardquelle')
            +2 [CONT|CONC] <GEDCOM_CONTENT_DESCRIPTION> {0:M}
            
   * Anmerkung: Einsendungen zu the Family History Department for Ancestral
     File submission oder für clearing temple ordinances muss ein Ziel (DEST) aus 
     DESTination of ANSTFILE oder TempleReady verwenden.

Das PLAC Formular wird intern gespeichert und verwendet die Interpretation von Orten zu steuern (in Übereinstimmung mit den GEDCOM Spezifikation).

Der SUBN_Datensatz (es sollte nur einen geben, dies wird aber nicht überprüft) wird als Daten Element der 'Standardquelle' gespeichert.

    SUBMISSION_RECORD:=
        n @<XREF:SUBN>@ SUBN                            {1:1]
          +1 SUBM @<XREF:SUBM>@                         {0:1}
          +1 FAMF <NAME_OF_FAMILY_FILE>                 {0:1}
          +1 TEMP <TEMPLE_CODE>                         {0:1}
          +1 ANCE <GENERATIONS_OF_ANCESTORS>            {0:1}
          +1 DESC <GENERATIONS_OF_DESCENDANTS>          {0:1}
          +1 ORDI <ORDINANCE_PROCESS_FLAG>              {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}

SUBM_Datensätze (Es können mehr als einer vorkommen) werden als Aufbewahrungsort Datensätze verknüpft mit der 'Standardquelle' gespeichert. Ausnahmen sind unten FETT dargestellt. Der Übermittlerdatensatz entspricht dem SBM Datensatz im KOPF und wird verwendet den Datenbankeigner zu setzen siehe dort.

   SUBMITTER_RECORD:=
        n @<XREF:SUBM>@   SUBM                          {1:1}
          +1 NAME <SUBMITTER_NAME>                      {1:1}
          +1 <<ADRESSEN_STRUKTUR>>                      {0:1}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
          +1 LANG <LANGUAGE_PREFERENCE>                 {0:3}
          +1 RFN <SUBMITTER_REGISTERED_RFN>             {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • Multimedia Link wird ignoriert
  • LANG wird ignoriert
  • RFN und RIN werden ignoriert

Person_Datensatz

Der INDI_Datensatz wird in Gramps als Person Datensatz gespeichert. Ausnahmen sind unten FETT dargestellt.

   PERSON_DATENSATZ: =
        n @<XREF:INDI>@  INDI                           {1:1}
          +1 RESN <RESTRICTION_NOTICE>                  {0:1}
          +1 <<PERSÖNLICHER_NAME_STRUKTUR>>             {0:M}
          +1 SEX <SEX_Wert>                             {0:1}
          +1 <<PERSÖNLICHE_EREIGNIS_STRUKTUR>>          {0:M}
          +1 <<PERSÖNLICHE_ATTRIBUTE_STRUKTUR>>         {0:M}
          +1 <<LDS_INDIVIDUAL_ORDINANCE>>               {0:M}
          +1 <<KIND_ZU_FAMILIE_LINK>>                   {0:M}
          +1 <<PARTNER_ZU_FAMILIE_LINK>>                {0:M}
          +1 SUBM @<XREF:SUBM>@                         {0:M}
          +1 <<ASSOCIATION_STRUCTURE>>                  {0:M}
          +1 ALIA @<XREF:INDI>@                         {0:M}
          +1 ANCI @<XREF:SUBM>@                         {0:M}
          +1 DESI @<XREF:SUBM>@                         {0:M}
          +1 <<SOURCE_CITATION>>                        {0:M}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 RFN <PERMANENT_RECORD_FILE_NUMMER>         {0:1}
          +1 AFN <ANCESTRAL_FILE_NUMMER>                {0:1}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYP>                 {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
   
  • Link zum Übermittler, Vorfahren und Nachkommen Interesse Anzeige werden stillschweigend ignoriert.
  • Die Alias Kennzeichnung ("Eine Kennzeichnung um verschiedene Beschreibungsdatensätze einer Person, die die selbe Person sein könnten, zu verknüpfen") wird als Verknüpfung mit dem Namen 'Alias' gespeichert.
  • Die REFN und REFN:TYPE werden als Attribute der Person gespeichert. Wenn es aber mehr als eine REFN gibt ist nicht klar welcher TYP zu welcher REFN gehört.

Die Behandlung der PERSÖNLICHE_ATTRIBUTE_STRUKTUR ist komplizierter. Die folgenden Tags:

  • EDUC (schulische Leistungen),
  • NMR (Anzahl der Heiraten),
  • OCCU (Beruf),
  • PROP (Besitz),
  • RELI (Religion),
  • RESI und
  • TITL (Adelstitel)

werden als Gramps Ereignis behandelt und die zugehörigen Informationen werden in der Ereignisstruktur gespeichert. Die Details, die dem Haupttag folgen (dargestellt in den Klammern in der obigen Liste), werden als die Beschreibung des Ereignis gespeichert. Der <EREIGNIS_DESKRIPTOR> der dem Typtag folgt, überschreibt die Beschreibung wenn der <EREIGNIS_DESKRIPTOR> nicht der Attributname ist.

Die folgenden Tags:

  • CAST (Kastenname),
  • DSCR (körperliche Beschreibung),
  • INDO (National ID Nummer),
  • NATI (Nationalität oder Stammeszugehörigkeit),
  • NCHI (Anzahl der Kinder) und
  • SSN (Sozialversicherungsnummer)

werden in Gramps als Attribut behandelt und die meisten Felder mit Ausnahme den Details die dem Haupttag folgen (in der Liste oben in Klammern dargestellt) der Quellenverweise und Notizstrukturen werden ignoriert wie unten in FETT angedeutet.

   PERSON_ATTRIBUTE_STRUKTUR: =
        n  CAST <CASTE_NAME>                            {1:1}
          +1 <<EREIGNIS_DETAIL>>                        {0:1}
             usw.
   
   EREIGNIS_DETAIL: =
        n  TYPE <EREIGNIS_DESKRIPTOR>                   {0:1}
        n  DATE <DATUMSWERT>                            {0:1}
        n  <<ORTSSTRUKTUR>>                             {0:1}
        n  <<ADRESSE_STRUKTUR>>                         {0:1}
        n  AGE <ALTER_AM_EREIGNIS>                      {0:1}
        n  AGNC <RESPONSIBLE_AGENCY>                    {0:1}
        n  CAUS <URSACHE_DES_EREIGNIS>                  {0:1}
        n  <<SOURCE_CITATION>>                          {0:M}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
        n  <<MULTIMEDIA_LINK>>                          {0:M}
        n  <<NOTIZ_STRUKTUR>>                           {0:M}
        
        
  • Person Attribute Struktur, Art, Datum, Ortsstruktur, Adresse Struktur, Alter, Agentur, Ursache und Multimedia Link werden alle ignoriert.

FAM_Datensatz

Der FAM Datensatz wird als Gramps Familie Datensatz gespeichert.

   FAM_Datensatz:=
        n @<XREF:FAM>@   FAM                            {1:1}
          +1 <<FAMILIEN_EREIGNIS_STRUKTUR>>             {0:M}
          +1 HUSB @<XREF:INDI>@                         {0:1}
          +1 WIFE @<XREF:INDI>@                         {0:1}
          +1 CHIL @<XREF:INDI>@                         {0:M}
          +1 NCHI <ANZAHL_DER_KINDER>                   {0:1}
          +1 SUBM @<XREF:SUBM>@                         {0:M}
          +1 <<LDS_SPOUSE_SEALING>>                     {0:M}
          +1 <<SOURCE_CITATION>>                        {0:M}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYPE>                {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • Die Verknüpfung zum Übermittler (SUBM) wird stillschweigend ignoriert.
  • Die REFN und REFN:TYPE werden als Attribut der Familie gespeichert. Wenn es aber mehr als eine REFN gibt ist nicht klar welcher TYP zu welcher REFN gehört.

Quellen_Datensatz

Der SOUR_Datensatz wird in Gramps als Quelle Datensatz gespeichert. Ausnahmen sind unten FETT dargestellt.

   QUELLE_DATENSATZ:=
        n @<XREF:SOUR>@ SOUR                            {1:1}
          +1 DATA                                       {0:1}
            +2 EVEN <EVENTS_RECORDED>                   {0:M}
              +3 DATE <DATE_PERIOD>                     {0:1}
              +3 PLAC <SOURCE_JURISDICTION_PLACE>       {0:1}
            +2 AGNC <RESPONSIBLE_AGENCY>                {0:1}
            +2 <<NOTE_STRUKTUR>>                        {0:M}
          +1 AUTH <SOURCE_ORIGINATOR>                   {0:1}
            +2 [CONT|CONC] <SOURCE_ORIGINATOR>          {0:M}
          +1 TITL <SOURCE_DESCRIPTIVE_TITLE>            {0:1}
            +2 [CONT|CONC] <SOURCE_DESCRIPTIVE_TITLE>   {0:M}
          +1 ABBR <SOURCE_FILED_BY_ENTRY>               {0:1}
          +1 PUBL <SOURCE_PUBLICATION_FACTS>            {0:1}
            +2 [CONT|CONC] <SOURCE_PUBLICATION_FACTS>   {0:M}
          +1 TEXT <TEXT_AUS_QUELLE>                     {0:1}
            +2 [CONT|CONC] <TEXT_AUS_QUELLE>            {0:M}
          +1 <<SOURCE_REPOSITORY_CITATION>>             {0:1}
          +1 <<MULTIMEDIA_LINK>>                        {0:M}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYPE>                {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • DATA und seine untergeordneten Datensätze werden ignoriert

Aufbewahrungsort Datensatz

Der REPO_Datensatz wird als Gramps Aufbewahrungsort Datensatz gespeichert. Ausnahmen sind unten FETT dargestellt.

   AUFBEWAHRUNGSORT_Datensatz: =
        n @<XREF:REPO>@ REPO                            {1:1}
          +1 NAME <NAME_DES_AUFBEWAHRUNGSORT>           {0:1}
          +1 <<ADRESSE_STRUKTUR>>                       {0:1}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYP>                 {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • REFN, REFN:TYPE und RIN werden ignoriert

Multimedia Datensatz

Der MULTIMEDIA_Datensatz wird in Gramps als Medien Datensatz gespeichert.Ausnahmen sind unten FETT dargestellt.

   MULTIMEDIA_DATENSATZ:=
        n @<XREF:OBJE>@ OBJE                            {1:1}
          +1 FORM <MULTIMEDIA_FORMAT>                   {1:1}
          +1 TITL <Beschreibender_TITEL>                {0:1}
          +1 <<NOTIZ_STRUKTUR>>                         {0:M}
          +1 <<SOURCE_CITATION>>                        {0:M}
          +1 BLOB                                       {1:1}
            +2 CONT <ENCODED_MULTIMEDIA_LINE>           {1:M}
          +1 OBJE @<XREF:OBJE>@     /* chain to continued object */  {0:1}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYPE>                {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
  • Es wird ein 'File' Tag erwartet das auf die Datei hinweist, die das Multimediaobjekt enthält. Diese Verwendung wurde aus GEDCOM 5.5.1 übernommen, aber die Möglichkeiten in GEDCOM 5.5.1 mehr als eine <Multimedia_Datei_REFN> und die zur FILE GEDCOM_Zeile untergeordneten FORM, TYPE und TITLE zu haben wird nicht unterstützt (ein späteres FILE kann ein früheres überschreiben - es gibt keine Fehlerprüfung).
  • BLOB wird ignoriert
  • REFN, REFN:TYPE und RIN werden ignoriert

Notiz Datensatz

Der NOTE_Datensatz wird als Gramps Notiz Datensatz gespeichert. Ausnahmen sind unten FETT dargestellt.

   NOTIZ_DATENSATZ:=
        n @<XREF:NOTE>@ NOTE <SUBMITTER_TEXT>           {1:1}
          +1 [ CONC | CONT] <SUBMITTER_TEXT>            {0:M}
          +1 <<QUELLEN_ZITAT>>                          {0:M}
          +1 REFN <USER_REFERENZ_NUMMER>                {0:M}
            +2 TYPE <USER_REFERENZ_TYPE>                {0:1}
          +1 RIN <AUTOMATED_RECORD_ID>                  {0:1}
          +1 <<ÄNDERUNGSDATUM>>                         {0:1}
  • Quellen Zitat wird ignoriert
  • REFN, REFN:TYPE und RIN werden ignoriert

Daten exportieren

Gramps-notes.png
Exportieren bedeutet eine Kopie zu speichern

Wenn du exportierst, speicherst du eine Kopie deiner aktuell geöffneten Datenbank. Exportieren erstellt eine zweite Datei mit der Kopie deiner Daten. Beachte das die Datenbank, die in Gramps geöffnet bleibt, NICHT die Datei ist, die bei deinem Export gespeichert wurde. Zusätzliche Änderungen an deiner geöffneten Datenbank ändern nicht die Kopie, die durch den Export erstellt wurde.

Das Exportieren erlaubt dir jeden Teil deiner Gramps Datenbank mit anderen Forschern zu teilen, genauso wie das überspielen deiner Daten auf einen anderen Computer. Zur Zeit kann Gramps Daten in den folgenden Formaten exportieren: Gramps XML, GEDCOM, Gramps XML Paket, Web Family Tree, GeneWeb, und Gramps CSV Tabellenformat.

Um Daten zu exportieren wähle Stammbaum ->Export oder die Tastenkombination Strg+E. Dies öffnet den {{man label|[[De:Gramps 5.1 Wiki Handbuch - Stammbäume Verwalten#Exportassistentdialog|Exportassistentendialog}}.

Exportassistentdialog

Abb. 5.17 Export Assistent: Start Schirm

Die Exportassistent Seiten führen dich durch die Formartauswahl (siehe Abb. 5.14), Dateiauswahl und formatspezifische Exportoptionen. Nach einer abschließenden Bestätigungsseite, wird der Export basierend auf deinen Angaben durchgeführt. Du kannst zu jeder Zeit die Zurück Schaltfläche klicken und deine Auswahl ändern und vorwärts klicken um den Export zu wiederholen.


Abb. 5.18 Export Assistent: Wähle das Ausgabeformat Schirm


Filter und vertraulich

Abb. 5.19 Exportassistent: GEDCOM Export Optionen

Gramps ermöglicht es dir Daten in gebräuchlichen Formaten zu exportieren.

Es bietet Optionen, die es ermöglichen, deinen Export genau fest zu legen.

  • Personen und Notizfilter: Der Filter ermöglicht es dir einen begrenzten Umfang deiner Daten, basierend auf deinen gewählten Kriterien, zu exportieren.
  • Als privat markierte Datensätze ignorieren: Dieses aktivieren, um zu verhindern, das als privat markierte Datensätze im Export enthalten sind.
  • Daten von lebenden Personen beschränken: aktiviere dies, um die Informationen, die für lebende Personen exportiert werden zu limitieren. Dies bedeutet, das alle Informationen die ihre Geburt, Tot, Adresse, aussagekräftige Ereignisse usw. betreffen, nicht in der exportierten Datei enthalten sind. Wenn du diese Option wählst, bekommst du weitere Optionen um die Daten lebender Personen weiter einzuschränken. Z.B. kannst du den Vornamen durch das Wort Lebt ersetzen (siehe ihre Einstellungen); du kannst Notizen ausschließen; und du kannst Quellenangaben für lebende Personen ausschließen.
  • Keine unverknüpften Datensätze einschließen: Aktiviere dies um zu verhindern, das nicht verknüpfte Datensätze in der Exportdatei enthalten sind.

Manchmal ist es aus den Daten nicht ersichtlich ob jemand noch lebt. Gramps verwendet einen erweiterten Algorithmus um festzustellen ob eine Person noch am leben sein könnte. Bedenke: Gramps versucht sein bestes bei den Schätzungen und es kann sein das es nicht immer richtig liegt. Bitte überprüfe deine Daten.

Im Gramps Format exportieren

Gnome-important.png
Vertraulichkeits Filter

Es ist wichtig deine Vertraulichkeitsoptionen im Exportassistenten zu überprüfen. Aktiviere keine Vertraulichkeitsoptionen für Gramps-XML Sicherungen.

  • GRAMPS XML Datenbankexport (.gramps): Dies Format ist das Standardformat für Datenaustausch und Sicherungen (siehe das verwandte .gpkg Format weiter unten für volle Portabilität inklusive Medienobjekten). Der Export im Gramps XML Format erzeugt eine portable Datenbank. Da XML ein textbasiertes von Menschen lesbares Format ist, kannst du es auch verwenden, um einen Blick auf deine Daten zu werfen. Gramps garantiert dir, das du XML Ausgaben älterer Gramps Versionen in neueren Gramps Versionen öffnen kannst (allerdings nicht andersherum!).
  • Gramps Paket Export (.gpkg): Der Export in das Gramps-Paketformat erstellt eine komprimierte Datei, welche die Gramps XML Datei und Kopien aller zugehörigen Mediendateien enthält. Dies ist sinnvoll wenn du deine Daten auf einen anderen Computer kopieren oder mit jemanden teilen willst.
  • Export to CD: Exporting to CD will prepare your database and copies of all media object files for recording onto a CD. To actually burn the CD, you will need to go to the GNOME burn:/// location, which can be accessed by navigating through Nautilus: After exporting to CD, select Go ->CD Creator in the Nautilus menu. Your database directory will show up. To burn it to the CD, click the CD icon on the Nautilus toolbar, or select File ->Write to CD in the Nautilus menu.

Wenn eine Mediendatei während des Exports nicht gefunden wird, siehst du den selben Fehlende Medien Dialog wie beim GEDCOM Export.

Im GEDCOM Format exportieren

Abb. 5.20 Exportassistent: GEDCOM Export Optionen

Gramps ermöglicht es dir Daten im gebräuchlichen GEDCOM-Format zu exportieren. Für eine Angabe welche Daten nicht exportiert werden wenn du in GEDCOM exportierst (verwende Gramps XML für einen vollständigen Export) siehe Gramps und GEDCOM. Gramps bietet Optionen, die es ermöglichen, deinen Export fein einzustellen.

  • Personen und Notizfilter: Der Filter ermöglicht es dir einen begrenzten Umfang deiner Daten, basierend auf deinen gewählten Kriterien, zu exportieren.
  • Als privat markierte Datensätze ignorieren: Dieses aktivieren, um zu verhindern, das als privat markierte Datensätze im Export enthalten sind.
  • Daten von lebenden Personen beschränken: Aktiviere dies, um die Informationen, die für lebende Personen exportiert werden zu limitieren. Dies bedeutet, das alle Informationen die ihre Geburt, Tot, Adresse, aussagekräftige Ereignisse usw., nicht in der exportierten Datei enthalten sind. Wenn du diese Option wählst, bekommst du weitere Optionen um die Daten lebender Personen weiter einzuschränken. Z.B. kannst du den Vornamen durch das Wort Lebt ersetzen (siehe Einstellungen); du kannst Notizen ausschließen; und du kannst Quellenangaben für lebende Personen ausschließen.
  • Keine unverknüpften Datensätze einschließen: Markiere dies um zu verhindern, das nicht verknüpfte Datensätze in der Exportdatei enthalten sind.


In anderen Formaten exportieren

GeneWeb

  • GeneWeb: Der Export nach GeneWeb speichert deine Daten in einem gängigen Webgenealogieformat. Um mehr Informationen zu GeneWeb und sein Format zu erhalten, besuche GeneWeb .

Gramps CSV Tabellenformat

  • Gramps CSV Tabellenformat: Erlaubt den Export (und Import) einer Teilmenge deiner Gramps Daten in einem einfachen Tabellenformat. für mehr Informationen siehe CSV Import und Export. Siehe auch Ansicht exportieren.

Web Family Tree

  • Web Family Tree: Der Export nach Web Family Tree erstellt eine Textdatei, die von dem Web Family Tree Programm verwendet werden kann. Exportoptionen enthalten Filterauswahl und die Möglichkeit Daten von lebenden Personen und deren Familienverbindungen zu begrenzen.

vCard

vCard: Der Export nach vCard speichert die Informationen in einem Format welches in vielen Terminplanungs und Adressverwaltungsprogrammen verwendet wird, manchmal als PIM (Persönlicher Informationsmanager)bezeichnet. Für mehr Informationen über das Format siehe: https://de.wikipedia.org/wiki/VCard

vCalendar

vCalendar: Der Export nach vCalendar speichert die Informationen in einem Format welches in vielen Terminplanungs und Adressverwaltungsprogrammen verwendet wird, manchmal als PIM (Persönlicher Informationsmanager)bezeichnet. Für mehr Informationen über das Format siehe: https://en.wikipedia.org/wiki/ICalendar#vCalendar_1.0

2.2 Datenbanken nach Gramps 3.x transferieren

Gnome-important.png
Der Import aus dem Gramps V2.x Format wird von Gramps 5.1 nicht unterstützt.

Wenn du eine alte V2.x Datenbank besitzt, musst du sie in Gramps V3.0.x importieren und von dort in Gramps XML (oder Gramps XML-Paket) exportieren und dies dann in Gramps 5.1 importieren.

To move your Gramps data from version 2.x to version 5.1.x you must import the v2.x database into an earlier Gramps v3.0.x program and then either save the database and import it into Gramps 5.1.x, or export the database in XML format from the earlier Gramps version and import it into Gramps 5.1.x.

Bitte schau im Handbuch für ältere Gramps Versionen nach, wie du eine v2.x Datenbank in V 3.0.x importierst.

Zurück Index Nächste


Gnome-important.png Spezielle Copyright Notiz: Alle Änderungen auf dieser Seite müssen unter zwei copyright Lizenzen stehen:

Diese Lizenzen ermöglichen es dem Gramps-Projekt die bestmögliche Verwendung dieses Handbuchs als freien Inhalt in zukünftigen Gramps Versionen. Wenn du mit dieser dual Lizenzierung nicht einverstanden bist, bearbeite diese Seite nicht. Du darfst zu anderen Seiten des Wiki die nur unter die GFDL Lizenz fallen nur über externe Links (verwende die Syntax: [http://www.gramps-project.org/...]), nicht über interne Links verlinken.
Außerdem verwende nur die Bekannten Drucktechnische Konventionen