Changes

Jump to: navigation, search

Installation/pl

1,959 bytes removed, 01:02, 1 October 2021
no edit summary
Ostatnie wydanie to '''GRAMPS''' {{version}}. Ta wersja może nie być jeszcze dostępna do instalacji na twojej platformie, dlatego zobacz stronę [[Download/pl|Pobierania]] aby dowiedzieć się więcej na ten temat.
==Aktualizacja GRAMPSGramps==
Jeśli '''Aktualizujesz GRAMPS''' z poprzedniej wersji powinieneś/powinnaś wcześniej:
* '''ttf-freefont''': Użyteczne fonty w standardzie TrueType, które obsługują większość znaków ze standardu unicode. Dobrze działają zarówno przez wydrukach jak i generacji wykresów przez graphviz.
* '''[http://portland.freedesktop.org/wiki/ XdgUtils]''' jest zestawem narzędzi działających w linii poleceń, które pomagają aplikacji w różnych zadaniach integrujących z pulpitem. Około połowa z tych narzędzi zwykle jest wymagana podczas instalacji aplikacji okienkowej, a pozostałe ukierunkowane są na integrację ze środowiskiem pulpitu podczas pracy aplikacji. Jeśli nawet narzędzia te są ograniczone do podzestawu potrzebnego do instalacji, konfiguracji czy narzędzi zarządzających, Xdg-utils zapewnia łatwy sposób na zwiększenie możliwości programu i efektywności użytkowników przez integrację tych komponentów w środowisko pracy użytkownika końcowego.
* '''[http://tilloy.net/dev/pyexiv2/overview.html pyexiv2]''' is a module that allows Gramps to read and write metadata embedded in image files. It is used in the Metadata Viewer and Image Metadata gramplets.
Przydatne mogą być też inne narzędzia:
===Automatyczne pobieranie i instalacja GRAMPS===
Przed instalacją, sprawdź czy może jest dostępna aktualna wersja GRAMPS dla Twojej dystrybucji.
Aby sprawdzić aktualną wersję, zobacz na stronę [http://sourceforge.net/projectprojects/gramps/files/Stable/showfiles.php?group_id=25770&package_id=109309 GRAMPS stable on Sourceforge (stabilna wersja na SourceForge)] i zobacz na numer wersji najnowszego pakietu (jest na samej górze listy).
Aby sprawdzić (i zainstalować) najnowszą wersję GRAMPSa dla swojej wersji Linuxa, możesz użyć poniższej komendy:
====Ubuntu and derivatives====
Repozytoria pakietów dla '''Ubuntu''' oraz pochodne (Kubuntu, Mephis, LinuxMint, ...): są dostępne na [http://sourceforge.net/project/showfiles.php?group_id=25770 GRAMPS download page (strona pobierania GRAMPS)]. {|{{prettytable}}!Ubuntu (Version)! GRAMPS<br>Release!Download|-|<!-- Ubuntu (Version) -->(10.04)|<!-- GRAMPS<br>Release -->3.2.4|<!-- Download -->See [http://sourceforge.net/projects/gramps/files/Stable/3.2.4/gramps_3.2.4-1_ubuntu10.deb/download gramps_3.2.4-1_ubuntu10.deb]|-|<!-- Ubuntu (Version) -->Jaunty Jackalope (9.04) (Jurny Jarząbek)|<!-- GRAMPS<br>Release -->3.1.2|<!-- Download -->[http:OldFiles//sourceforge.net/project/downloading.php?group_id=25770&filename=gramps_3.1.2-1_Ubuntu904.deb gramps_3.1.2-1_Ubuntu904.deb] |-|<!-- Ubuntu (Version) -->Intrepid Ibex (8.10) (Intrygująca Iranka)|<!-- GRAMPS<br>Release -->3.1.2|<!-- Download -->[http://downloads.sourceforge.net/gramps/gramps_3.1.1-1_Ubuntu810.deb?modtime=1228530730&big_mirror=0 gramps_3.1.2-1_Ubuntu810.deb] |-|<!-- Ubuntu (Version) -->Hardy (8.04) (Hoża Hawajka)|<!-- GRAMPS<br>Release -->3.1.2|<!-- Download -->[http://transact.dl.sourceforge.net/sourceforge/gramps/gramps-3.1.2-1_Ubuntu804.deb gramps-3.1.2-1_Ubuntu804.deb]|-|<!-- Ubuntu (Version) -->Gutsy (7.10) (Grymaśny Gąsiorek)|<!-- GRAMPS<br>Release -->3.0.3|<!-- Download -->[http://sourceforge.net/project/showfiles.php?group_id=25770 gramps_3.0.3-1_ubuntu710.deb]|-|<!-- Ubuntu (Version) -->Feisty (7.04) (Frywolny Fulmar)|<!-- GRAMPS<br>Release -->2.2.10|<!-- Download -->Pobierz [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps_2.2.10-1_all.deb]<br>and [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps-help_2.2.10-1_all.deb], and install with your package manager.|-|<!-- Ubuntu (Version) -->Dapper, Edgy<br> oraz wcześniejsze wersje Ubuntu|<!-- GRAMPS<br>Release -->2.2.8|<!-- Download -->Pobierz [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps_2.2.8-1dapper1_all.deb]<br>and [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps-help_2.2.8-1dapper1_all.debOldFiles], i zainstaluj za pomocą swojego menadżera pakietówfor archives.|}
====Debian====
====Fedora====
'''Fedora''': Jeśli masz system Fedora Core, zobacz stronę [http://sourceforge.net/project/showfiles.php?group_id=25770 GRAMPS download page] i pobierz pakiety zawierające ''fc'' z numerem wersji Twojego systemu i kończące się na ''.rpm''. Alternatywa do instalacji ze źródeł jest [[fedora rpmFedora RPM|build a package]] z pliku rpm spec, albo instalacja wersji binarnej z gałęzi testowej fedora.
====Różne dystrybucje GNU/Linux====
==Instalacja ze źródła==
===Ogólne wymagania===
GRAMPS 3.1.x {{version}} wymaga python'a w wersji minimum 2.56, pygtk2 pygtk 2.12 16 albo wyższej oraz łączeń do bibliotek glade oraz librsvg2.
==== Wymagania pakietów pod Linuksem ====
|python
|python
|Wymagane (wersja 2.5 6 lub późniejsza)
|-
|pygtk2
|pygtk2
|Wymagane (wersja 2.12 16 lub późniejsza)
|-
|xdg-utils
|rcs
|Zalecane do pracy
|-
|python-gnome2-extras
|
|Zalecane do pracy (sprawdzanie pisowni)
|-
|python-enchant
|
|Zalecane do pracy (sprawdzanie pisowni)
|-
|librsvg2-common
|libglib2.0-dev
|
|Wymagane przy kompilacji
|-
|python-glade2
|
|Wymagane
|-
|
|gnome-common
|Wymagane przy kompilacji
|-
|intltool
|intltool
|Wymagane przy kompilacji
|-
|
|gnome-doc-utils
|Wymagane przy kompilacji
|-
===BSD===
Instalacja w BSD jest bardzo podobna do instalacji na Linuksie, poza kilkoma drobnymi niedogodnościami jak nazwami narzędzi używanych do kompilacji kodu. Zobacz [[BSD Platformsplatforms|BSD page]] po szczegóły.
===Mac OS X===
1,492
edits

Navigation menu