Changes

Jump to: navigation, search

Ru:Установка

739 bytes added, 20:33, 6 October 2009
no edit summary
[[Category:Ru:Documentation]][[Category:Developers/Installation]][[Category:Developers/Packaging]]
{{languages|Installation|Установка}}
==Live CDПоследняя выпущенная версия ==Если вам интересен Последняя версия выпущенная на данный момент - '''GRAMPS, но вы не хотите или не можете установить его прямо сейчас (чужой ПК, Windows, нет Интернета и т3. д1.), попробуйте наш [[Linux Genealogy CD]]2'''. Он запускается без Эта версия может быть еще недоступна для установки на жёсткий диск и содержит набор бесплатного открытого программного обеспечения для генеалогиивашу платформу. Потом вы сможете установить Пожалуйста, посетите страницу [http:[Download//ubuntu.com Ubuntu 8.04ru|Загрузки]] и GRAMPS с этого диска в любой моментдля получения дополнительной информации.
==Автоматическая закачка и установка Обновление GRAMPS==Прежде чем скачивать Если Вы хотите '''обновить GRAMPS ''' с этого сайт, проверьте доступность текущей предыдущей версии в репозатарии вашей системы. Чтобы узнать текущую версию, посетите [httpВы должны выполнить следующие действия://sourceforge.net/project/showfiles.php?group_id=25770&package_id=109309 страницу GRAMPS на Sourceforge] и посмотрите на версию верхнего пакета.
Чтобы проверить, что же доступно # '''Экспортировать''' ваше Семейное Дерево в вашей системеформате GRAMPS XML, воспользуйтесь одним из методовиспользую '''старую версию GRAMPS''', приведённых ниже.* Системы установленную на основе Debian вашем компьютере (Ubuntu и её варианты, Mepis, Suse…'''снимите галку "Не включать записи помеченные как личные"''' в параметрах помощнике экспорта): <code> apt-get install gramps</code># '''Удалить''' старую установленную версию GRAMPS* Gentoo (и Sabayon):<code># '''Установить''' новую версию GRAMPS, следуя инструкция приведенным ниже emerge gramps </code># '''Создать''' новое семейное дерево* Mandriva: <code> urpmi gramps</code>* Системы на основе Redhat (Fedora, CentOS…): <code> yum install gramps</code># '''Импотировать''' ваши сохранённые данные в формате GRAMPS XML
==Ручная закачка и установка Дополнительные программы, которые могут расширить возможности GRAMPS==GRAMPS does not rely on the following programs, however, having them will increase your productivity:
Если текущая версия не доступна в репозитарии вашей операционной системы* '''Spell checking''': Installing python-gnome2-extras and python-enchant provides the gtkspell module and the enchant module, вам придётся скачать её с этого сайтаwhich adds spell checking in the notes* '''Graphviz''', '''Inkscape''': Gramps can make nice Genealogical trees (relationship graphs). Некоторые добрые пользователи These are generated by the Graphviz package, which defines a code (dot), as well as programs to produce graphs (dotty, to be called from command line). This gives you as researcher most power over how your tree will look, but has a learning curve. Also, [https://gna.org/projects/kgraphviewer kgraphviewer] works fine with dot generated by GRAMPS собрали пакеты для различных систем. Если вам повезётAn alternative is to make a graphical report, вы найдёте свою систему в списке нижеconverting the tree to an svg file, which you then can open/edit/refine in eg Inkscape.* '''ttf-freefont''': Useful as a font that supports a large subset of the unicode and is a true type. This works well with both print and graphviz output.* '''[http://portland.freedesktop.org/wiki/ XdgUtils]''' is a set of command line tools that assist applications with a variety of desktop integration tasks. About half of the tools focus on tasks commonly required during the installation of a desktop application and the other half focuses on integration with the desktop environment while the application is running. Если её там нетEven if the desktop components of your application are limited to an installer, configuration or management tool, то свяжитесь с разработчиками через список рассылки и попросите советаXdg-utils provides you with an easy way to enhance the usage experience of your customers by improving the integration of these components in the user's environment.
* '''Ubuntu''' и производные (Kubuntu, Mephis…): пакеты Ubuntu доступны на [http://sourceforge.net/project/showfiles.php?group_id=25770 странице загрузок GRAMPS].** Jaunty Jackalope (9.04) : скачайте [http://sourceforge.net/project/downloading.php?group_id=25770&filename=gramps_3.1.2-1_Ubuntu904.deb gramps_3.1.2-1_Ubuntu904.deb] ** Intrepid (8.10) : скачайте [http://sourceforge.net/project/showfiles.php?group_id=25770&package_id=109309&release_id=645507 gramps_3.1.2-1_Ubuntu810.deb]** Hardy (8.04) : скачайте [http://sourceforge.net/project/showfiles.php?group_id=25770&package_id=109309&release_id=645507 gramps_3.1.1-1_Ubuntu804.deb]** Gutsy (7.10) : скачайте [https://sourceforge.net/project/showfiles.php?group_id=25770&package_id=109309&release_id=634561 gramps_3.0.3-1_Ubuntu710.deb]** Feisty (7.04) : скачайте [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps_2.2.10-1_all.deb] и [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps-help_2.2.10-1_all.deb] и установите их с помощье своего менеджера пакетов. Так же можно воспользоваться пакетом [http://packages.ubuntu.com/gutsy/admin/gdebi gdebi].** Dapper, Edgy и предыдущие: версия 2.2.10 пока не доступна, поэтому скачайте [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps_2.2.8-1dapper1_all.deb] и [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps-help_2.2.8-1dapper1_all.deb] и установите их с помощью своего менеджера пакетов.* '''SuSE''': Ричард Бос (''Richard Bos'') обеспечивает выпуск пакетов GRAMPS для репозитариев SuSE. Они доступны из его [http://software.opensuse.org/download/home:/rbos/ репозитария ''rbos'']. Так же посмотрите на форуме тему об [http://www.suseforums.net/index.php?s=22f80a050a1e3cffffd590db0813dea9&showtopic=28727&pid=152093&st=0&#entry152093 удовлетворении зависимостей GRAMPS на SuSE с использованием ''rbos'' и SMART] <small style="color:grey">(англ.)</small>.* '''Mandriva''': Над новыми версиями иногда проводят бэкпорт. Чтобы установить бэкпорт, вы должны активировать репозитарий ''backports'' (убедитесь, что вы понимаете инструкции, приведённые в [http://wiki.mandriva.com/en/Docs/Basic_tasks/Installing_and_removing_software#Advanced_use:_Backports_and_candidate_updates Mandriva wiki]) <small style="color:grey">(англ.)</small>. Если последней версии нет в репозитарии ''backports'', то проверьте репозитарий ''contrib''.* '''Fedora''': В случае Fedora Core найдите на [http://sourceforge.net/project/showfiles.php?group_id=25770 странице загрузок GRAMPS] пакет с буквами ''fc'' и номером вашей версии в названии, а так же оканщивающийся на ''.rpm''. Альтернативой установке из исходников является [[fedora rpm|сборка пакета]] из особого файла frm или установка бинарных файлов из тестового репозитария Fedora.* '''Debian''': Последняя версия должна находиться в нестабильном (''unstable'') репозитарии ([http://Other packages.debian.org/sid/gramps Sid Gramps]) и может быть установлена с помощью вашего менеджера пакетов. Тестовый (''testing'') репозитарий обновляется с задержкой в 10 дней, см. [httpmight also be useful://packages.debian.org/lenny/gramps Lenny Gramps].
* '''desktop-file-utils''': see list of programs to open a media file on right click on an image
{{man note| Обратите внимание |Различные дистриутиву GNU/== Linux используют различные стандартные способы загрузки ===== Автоматичская загрузка и установки пакетов ПОустановка GRAMPS ===Прежде чем скачивать GRAMPS с этого сайт, проверьте доступность последней версии в репозатарии вашей системы. ПрочтитеЧтобы узнать последнею версию, пожалуйта, инструкции по установке для своего дистрибутива, прежде чем приступить к загрузкепосмотрите в начало этой страницы или же посетите [http://sourceforge.net/project/showfiles.php?group_id=25770&package_id=109309 страницу GRAMPS на SourceForge] и посмотрите на версию нижнего пакета.}}
Во всех остальных случаях вам придётся [httpЧтобы проверить, что же доступно в вашей системе, воспользуйтесь одним из методов, приведённых ниже:{|{{prettytable}}!Операционная система Linux!Командная строка|-|<!--Linux Operating System-->Системы на основе Debian <br>(Ubuntu & варианты, Mepis,...)|<!--Command Line--><code>apt-get install gramps</code>|-|<!--Linux Operating System-->Gentoo (и Sabayon)|<!--Command Line--><code>emerge gramps </sourceforge.net/projectcode>|-|<!--Linux Operating System-->Mandriva|<!--Command Line--><code>urpmi gramps</showfiles.php?group_id=25770 скачать] пакет с искодниками code>|-|<!--Linux Operating System-->Системы на основе Redhat<br>(файлFedora, оканчивающийся на «CentOS..tar.gz») и установить GRAMPS вручную. Подробности можно найти в разделе об установке из исходников.|<!--Command Line--><code>yum install gramps</code>|-|<!--Linux Operating System-->OpenSUSE|<!--Command Line--><code>sudo zypper install gramps</code>|}
==Windows, BSD, Mac OS X, Solaris= Ручная загрузка и установка GRAMPS ===Для Windows существует экспериментальный [[Windows installer/ru|установщик]]. Если последняя версия этого установщика не соответствует последнеей версии GRAMPSдоступна в репозитарии вашей операционной системы, то Вы можете установить более старую версию, имеющуюся там, или же вам придётся подождать, пока не появится новая версияскачать её с этого сайта.{{man note| Для пользователей Windows |Больше информации об использовании некоторых дистрибутивов Linux пакет GRAMPS собран. Если вам повезёт, вы найдёте свою систему в Windows можно найти на странице [[GRAMPS_and_Windows|GRAMPS списке ниже. Если её там нет, то свяжитесь с разработчиками через список рассылки и Windows]]попросите совета.}}
Для Mac OS X, [http://finkproject.org Fink project] ==== Ubuntu и [http://macports.org MacPorts] имеют Gramps в виде пакетов установки. Fink в настоящее время имеет производные ====Пакеты для '''оченьUbuntu''' старую версию доступную и производных от неё (Kubuntu, Mephis, LinuxMint, ...): доступны на [http://pdb.finkprojectsourceforge.orgnet/pdbproject/packageshowfiles.php/gramps# package database?group_id=25770 странице загрузок GRAMPS]. Детальные инструкции по использованию этих версий и установки последних версий gramps на странице об [[Mac_OS_X|Установке из открытого кода на Mac OS X]]
Для BSD {|{{prettytable}}!Ubuntu (версия)!GRAMPS<br>релиз!Загрузить|-|<!-- Ubuntu (Version) -->Jaunty Jackalope (9.04)|<!-- GRAMPS<br>Release -->3.1.2|<!-- Download -->[http://sourceforge.net/project/downloading.php?group_id=25770&filename=gramps_3.1.2-1_Ubuntu904.deb gramps_3.1.2-1_Ubuntu904.deb] |-|<!-- Ubuntu (Version) -->Intrepid Ibex (8.10)|<!-- GRAMPS<br>Release -->3.1.2|<!-- Download -->[http://downloads.sourceforge.net/gramps/gramps_3.1.1-1_Ubuntu810.deb?modtime=1228530730&big_mirror=0 gramps_3.1.2-1_Ubuntu810.deb] |-|<!-- Ubuntu (Version) -->Hardy (8.04)|<!-- GRAMPS<br>Release -->3.1.2|<!-- Download -->[http://transact.dl.sourceforge.net/sourceforge/gramps/gramps-3.1.2-1_Ubuntu804.deb gramps-3.1.2-1_Ubuntu804.deb]|-|<!-- Ubuntu (Version) -->Gutsy (7.10)|<!-- GRAMPS<br>Release -->3.0.3|<!-- Download -->[http://sourceforge.net/project/showfiles.php?group_id=25770 gramps_3.0.3-1_ubuntu710.deb]|-|<!-- Ubuntu (Version) -->Feisty (7.04)|<!-- GRAMPS<br>Release -->2.2.10|<!-- Download -->Загрузите [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps_2.2.10-1_all.deb]<br>и Solaris ниже приведена инструкция по эксперементальной установке[http://sourceforge.net/project/showfiles.php?group_id=25770 gramps-help_2.2.10-1_all.deb], и установите с помощью вашего менеджера пакетов.|-|<!-- Ubuntu (Version) -->Dapper, Edgy<br> и более старые Ubuntu|<!-- GRAMPS<br>Release -->2.2.8|<!-- Download -->Загрузите [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps_2.2.8-1dapper1_all.deb]<br>и [http://sourceforge.net/project/showfiles.php?group_id=25770 gramps-help_2.2.8-1dapper1_all.deb], и установите с помощью вашего менеджера пакетов.|} ====Debian===='''Debian''': Последняя версия должна находиться в нестабильном (''unstable'') репозитарии ([http://packages.debian.org/sid/gramps Sid Gramps]) и может быть установлена с помощью вашего менеджера пакетов. Тестовый (''testing'') репозитарий ([http://packages.debian.org/testing/gramps Testing GRAMPS]) обновляется с задержкой в 10 дней. ====SuSE===='''SuSE''': Richard Bos has been providing the GRAMPS releases for OpenSUSE. The repository for OpenSUSE 11.1 is available from [http://download.opensuse.org/repositories/Education/openSUSE_11.1/]. Note that at the time of writing this repository is not the same as that in the repository list as "Education" and must be added as a URL. The repository for 11.0 is [http://download.opensuse.org/repositories/Education/openSUSE_11.0/] and 10. Для FreeBSD используется 3 is [http://portsmondownload.freebsdopensuse.org/portoverviewrepositories/Education/openSUSE_10.py3/]. For earlier versions of OpenSUSE (10.2) see the forum entry about [http://www.suseforums.net/index.php?categorys=22f80a050a1e3cffffd590db0813dea9&showtopic=28727&pid=152093&st=science0&portname#entry152093 satisfying GRAMPS dependencies for SuSE with the ''rbos'' and SMART]. Also, there is [[OpenSUSE_RPM|an other alternative using openSUSE BuildService]]. ====Mandriva===='''Mandriva''': Над новыми версиями иногда проводят бэкпорт. Чтобы установить бэкпорты, вы должны включить репозитарий ''backports'' (убедитесь, что вы понимаете инструкции, приведённые в [http://wiki.mandriva.com/en/Docs/Basic_tasks/Installing_and_removing_software#Advanced_use:_Backports_and_candidate_updates Mandriva wiki]<small style="color:grey">(англ.)</small>). Если последней версии нет в репозитарии ''backports'', то проверьте репозитарий ''contrib''. ====Fedora=gramps ==='''Fedora''': В случае Fedora Core смотрите на [http://sourceforge.net/project/showfiles.php?group_id=25770 странице загрузок GRAMPS] пакет с буквами ''fc'' и номером вашей версии в названии, и оканщивающийся на ''.rpm''. Альтернативой установке из исходных кодов является [[fedora rpm|сборка пакета]] из особого файла frm или установка бинарных файлов из тестового репозитария Fedora. ====Different GNU/Linux distributions====Different GNU/Linux distributions have other preferred ways to download and install packages for GRAMPS. Please read the installation instructions specific to your distribution before downloading. In all other cases, you must [http:/usr/portssourceforge.net/scienceproject/showfiles.php?group_id=25770 download] the source package (the file ending with '.tar.gz') and install GRAMPS manually. See the section about installing from source for details. ===GNOME и KDE===Вы можете использовать обе, но GRAMPS лучше работает с GNOME. В KDE есть незначительные проблемы с GTK не зависящие от GRAMPS. На [[KDE page|странице о KDE]] эта проблема изложена подробнее. В GNOME, есть некоторые проблемы с ATK/grampsGAIL не зависящие от GRAMPS. Посетите страницу [[Known issues|Известные проблемы]] порт, чтобы знать, что эти сложности могут быть.
==Gnome и KDE==
Вы можете использовать обе, но GRAMPS согласуется с GNOME лучше. В KDE есть незначительные проблемы с GTK не зависящие от GRAMPS. На [[KDE page|странице KDE]] эта проблема изложена подробнее.
Смотрите так же [http://portland.freedesktop.org/wiki/ XdgUtils].
===GRAMPS может использовать дополнительное программное обеспечение on handhelds===GRAMPS does not rely can run fine on some small-factor devices. Users have been successful in using GRAMPS on: * [[Gramps on the following programsEee|Asus Eee PC]]  == Генеалогический загрузочный диск ==Если вам интересен GRAMPS, но Вы не хотите или не можете установить его прямо сейчас (чужой ПК, howeverWindows, having them will increase your productivityнет интернета, работа, ноутбук и т.д.), попробуйте наш [[Linux Genealogy CD]]. Он запускается без установки на жёсткий диск и содержит набор бесплатного открытого программного обеспечения для генеалогии. Потом Вы сможете установить [http://ubuntu.com Ubuntu 8.04] и GRAMPS с этого диска в любой момент.
* '''Gnome-print''': It adds the ability to directly print== Windows, to previewFreeBSD, and to generate fully internationalized PS and PDF output. At this timeMac OS X, one needs to install gnome-python-desktop to obtain this package (it might be known under different names, eg on debian python-gnome2-desktop).Solaris ==* '''Spell checking''': Installing python-gnome2-extras provides the gtkspell module, which adds spell checking in the notes=== Windows ===* '''Graphviz''', '''Inkscape''': Gramps can make nice Genealogical trees (relationship graphs). These are generated by the Graphviz package, which defines a code (dot), as well as programs to produce graphs (dotty, to be called from command line). This gives you as researcher most power over how your tree will look, but has a learning curve. Also, Сторите страницу [[https:Download//gna.org/projects/kgraphviewer kgraphviewerru|Загрузки]] works fine with dot generated by GRAMPS. An alternative is to make a graphical reportдля того, converting the tree to an svg fileчтобы получить установщик для Windows, which you then can open/edit/refine in eg Inkscapeубедитесь что вы загрузили и установили [[Windows_installer#Installation|необходимые зависимости для Windows]].* '''ttf-freefont''': Useful as a font that supports a large subset of the unicode Дополнительную информацию для пользоавтелей Windows можно найти на странице [[GRAMPS and is a true type. This works well with both gnomeprint and graphviz output.* '''[http://portland.freedesktop.org/wiki/ XdgUtilsWindows|GRAMPS и Windows]]''' is a set of command line tools that assist applications with a variety of desktop integration tasks. About half of the tools focus on tasks commonly required during the installation of a desktop application and the other half focuses on integration with the desktop environment while the application is running. Even if the desktop components of your application are limited to an installer, configuration or management tool, Xdg-utils provides you with an easy way to enhance the usage experience of your customers by improving the integration of these components in the user's environment.
Other packages might === Mac OS X ===A new port of Gramps to Mac is available (July 2009). This is relatively untested and it is wise to back up data carefully before running it. It's available as a ready-built binary application for both Intel and PPC Macs. It's also available as a build environment and can be useful:built from scratch by any Mac with the Apple Xcode toolset.
* '''desktop-file-utils''': see list of programs to open a media file Mac for Gramps is described at [[Using Gramps on right click on an imageApple Mac]].
==Установка из исходных кодов=====General Requirements===Macports and Fink versions of Gramps have been used in the past.
GRAMPS 2.0 requires python 2.3 and the gnome-python === FreeBSD и Solaris ===Для FreeBSD and pygtk2 packages. The gnome-python module should be 2.6.0 or greaterSolaris приведена экпериментальная инструкция по установке. The pygtk package should be version 2* Для FreeBSD испоотльзуется порт: [http://portsmon.5freebsd.0 or greaterorg/portoverview.py?category=science&portname=gramps /usr/ports/science/gramps]
Also librsvg2-common is needed. This is a common error at the moment in some packages. Without this library, the icons are not shown.== Установка из исходных кодов =====General Requirements===
GRAMPS 3.1.x requires python 2.5 or greater, pygtk2 2.12 or greater, glade bindings and librsvg2
==== Linux Package Requirements ====
{| {{prettytablePrettytable}}
|-
!Debian /Ubuntu
|pygtk2
|pygtk2
|Required (needs 2.5.0 or greater)|-|gnome-python|gnome-python|Required (needs 2.6.0 12 or greater)
|-
|xdg-utils
|xdg-utils
|Required (for Gramps-3.1.x or greater)later
|-
|rcs
|rcs
|Suggested for running
|-
|python-gnome2-extra
|
|Suggested for running (spell check)
|-
|python-enchant
|
|Suggested for running (spell check)
|-
|librsvg2-common
|librsvg2
|Required for building
|-
|libglib2.0-dev
|
|Required for building
|-
|python-glade2
|
|Required
|-
|
|Required for building
|-
|intltool
|intltool
|Required for building
|}
====Obtaining the source====
There are two ways to get the source code: download a stable version source, or checkout the source from svn. Please, now is the time to read the [http://gramps.svn.sourceforge.net/viewvc/gramps/trunk/INSTALL?view=markup INSTALL] and [http://gramps.svn.sourceforge.net/viewvc/gramps/trunk/README?view=markup README] files accompanying the code. They come with the most recent information. Details on each download method: '''1. Download a Stable Version''' * The latest stable version of GRAMPS can be downloaded from the [http://sourceforge.net/projects/gramps GRAMPS SourceForge page]. As of this writing, this is Eg: gramps-3.1.12.tar.gz. Extract this file into a directory: <code>
tar xzvf gramps-zzz.tar.gz
</code> and then go into this directory:<code>
* If you are interested in testing out the very latest development versions of GRAMPS, they can be obtained from SVN, see [[Brief introduction to SVN]]. The SVN versions of GRAMPS are potentially very dangerous as they have not been extensively tested - especially the "trunk" version which contains features that may still be partly implemented. Be aware that they may be prone to crashing and cause extensive data loss. Please use with extreme caution - and only ever on a copy of your data!
Please'''2. Download from SVN''' You can get a branch version (similar as above) or the latest bleeding-edge version through SVN, now is the time to read the [httpsuch as://gramps.  svn.sourceforge.net/viewvc/gramps/trunk/INSTALL?view=markup INSTALL] and [httpco https://gramps.svn.sourceforge.net/viewvcsvnroot/gramps/trunk/README?view=markup README] files accompanying the code. They come with the most recent information.gramps
===Dealing with earlier versions=Upgrading GRAMPS====
If you have an older version of the GRAMPS source code installed you need to make a decision what you want to do with it before installing a later version. If you wish to keep the old version, make sure that you read the instructions in the INSTALL file regarding the use of the --prefix option to specify where the new version gets installed.
make uninstall</code>
as root '''from where you installed the old version from'''. Use your distribution's package manager to uninstall if your old version was installed as a package. '''Note that you should use your old GRAMPS version to export backup copies to GRAMPS XML before removing the old version.'''
===Installing from source code on Linux===
GRAMPS provides a script that can be used to prepare the code for building. This script automatically calls the standard configure script:<code>
./autogen.sh (as user)</code> as user
This script will report any missing dependencies. Install these (see also INSTALL file). Building from source code typically requires that the development versions of the required libraries be installed. You might consider setting a prefix path with autogen.sh, see the INSTALL file for instructions. Standard install is in /usr/local.
make install (as root) </code>
===Installing from source code on BSD=== Installing on BSD is as straightforward as on Linux, apart from some minor issues like tools having different names. See the [[BSD page]] for details.
===Installing on BSD is as straightforward as on Linux, apart from source code on Mac OS X===Version 3some minor issues like tools having different names.0.1 has been successfully installed via fink, see: See the [[Mac OS X fink localBSD Platforms|BSD page]]for details.
Some users have successfully installed GRAMPS on ===Mac OS X. See the [[Mac OS X]] page for details. Please, add to the wiki if you successfully installed GRAMPS on OS X.===
Для установки An overview of installing GRAMPS с помощью from source on the Mac ports перед установкой самого GRAMPS нужно установить пакет p5-xml-sax затем уже устанавливать саму программу после того как программа и все зависимости установяться не спешим запускать её вводим следующие командыsudo port install python_select доустанавливаем питон нужной нам версииsudo python_select python25 устанавливаем питон нужной нам версии по умолчаниюsudo launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plistsudo launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist добовляем демоны в автозагрузку необходимые для корректного запуска программыis given under [[Mac_OS_X|Installing from source code on Mac OS X]]
Запуск проги выполняем через sudo затем закрываем прогу выполняем sudo chmod -R 777 /Users/ЮЗЕР/.gramps/ и свободно уже запускаем программу из консоли от своего имени) ===Installing from source code on Windows===
Fortunately for users of Microsoft Windows, some users have made a [[Windows installer]]. So far there have not been any reports of serious differences between the official builds of GRAMPS and the Windows Installer, so the future looks promising, but please, use this at your own risk.
If the dependencies are in place, the development version can be tested by getting the source (see above), making a copy of the file const.py.in and rename it to const.py, then execute "python gramps.py" from within the src directory. Of course, this is a development version, so warnings apply even more to this case than when using the installer. ===Solaris===
===Installing from source code on Solaris=== Version 3.0.1 GRAMPS has been successfully installed from source on both Solaris 10 (SPARC) and OpenSolaris X86 (2008.05). Please see the [[Solaris Platforms|Solaris page]] for step-by-step details. ==GRAMPS on handhelds==GRAMPS can run fine on some small-factor devices. Users have been successful in using GRAMPS on: * [[Gramps on the Eee|Asus Eee PC]]
27
edits

Navigation menu