2021-12-04 - Sorry the Gramps wiki is currently being upgraded to a newer software version. Please check back after the 2021-12-08. We apologize for the inconvenience.

Fr:Manuel wiki pour Gramps 5.1 - Outils

From Gramps
Jump to: navigation, search
Précédent Index Suivant



Ce chapitre décrit les différents outils disponibles dans Gramps.

Introduction

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.1 Bouton "Ouvrir le dialogue d'outils"

Les outils de Gramps vous permettent d'exécuter divers types d'analyses de vos données généalogiques. Typiquement, les outils ne produisent pas de sortie sous la forme d'imprimés ou de fichiers. Au lieu de cela, ils produisent une sortie d'écran immédiatement disponible pour le chercheur. Cependant, quand cela est approprié, vous pouvez enregistrer le résultat de l'outil dans un fichier.

Les outils peuvent être consultés par le menu Outils -> Section Outils -> Outil Particulier. Vous pouvez aussi avoir accès à la liste complète des outils avec leur brève description en utilisant l'icône Ouvrir le dialogue d'outils de la barre d'outils.

Analyse et exploration

Ce groupe comprend les outils qui analysent et explorent la base de données sans la modifier. Les outils suivants sont actuellement disponibles dans Gramps :

Comparaison d'événements individuels

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.2 "Comparaison d'événements individuels" - "sélection du filtre"

Cet outil compare des événements parmi un ensemble d'individus.

Vous pouvez utiliser cet outil via le menu Outils->Analyses et exploration -> Comparaison d'événements individuels... qui va ouvrir le dialogue Sélection du filtre des évènements de comparaison.

Les individus à prendre en compte sont choisis par des filtres personnalisés préalablement définis en sélectionnant la liste déroulante Filtre avec par défaut Toute la base de données. Ou en sélectionnant le bouton Éditeur de filtre personnalisé, pour créer des filtres personnalisés dans l'éditeur Filtres des individus. Pour lancer cet outil sélectionnez Appliquer et les résultats seront affichés dans le dialogue Résultats de comparaison d'événements.

Depuis le dialogue Résultats de comparaison d'événements vous pouvez voir les résultats ou Enregistrer sous forme d'un tableur (format ODS). Sélectionnez Fermer pour quitter.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.3 "Comparaison d'événements individuels" - "Résultats des comparaisons d'événements individuels" - exemple étendu


Modification de l'arbre familial

Cette section décrit des outils qui peuvent modifier la base de données. Les outils décrits ici servent principalement à trouver et corriger les erreurs dans les données. Les outils suivants sont actuellement disponibles dans Gramps :

Error creating thumbnail: Unable to save thumbnail to destination
Note

Les modifications seront seulement effectuées avec votre consentement explicite, excepté pour les contrôles et les outils Réparation de la base de données.


Extraire les descriptions de l'événement

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.4 Extraire les descriptions de l'événement - Fenêtre de résultats

Cet outil essaye d'extraire les descriptions de l'événement depuis ses données, utilisant le modèle :

{type d'événement} de {Nom de famille}, {Prénom}

Si une description de l'événement est absente, alors l'outil utilisera ce modèle de description de l'événement.

Accédez à cet outils par le menu Outils->Modification de l'arbre familial->Extraire les descriptions de l'évènement…

L'Avertissement sur l'historique d'annulation va s'afficher et vous pouvez soit Annuler soit Poursuivre avec cet outil.

Un fois que vous avez cliqué sur Poursuivre avec cet outil, il va balayer et modifier l'arbre familial puis afficher une fenêtre Modifications réalisées indiquant le nombre total de descriptions d'évènements ajoutés.

Extraire l'information des noms

L'outil recherche dans toute la base de données et tente d'extraire les titres et surnoms qui peuvent être imbriqués dans le prénom d'un individu. Si une information peut être extraite, les propositions pour de correction seront présentées dans le tableau. Vous pouvez alors décider ceux que vous voulez corriger selon les propositions et ceux que nous ne voulez pas modifier.

Accédez à cet outils par le menu Outils->Modification de l'arbre familial->Extraire l'information des noms….

L'Avertissement sur l'historique d'annulation va s'afficher et vous pouvez soit Annuler soit Poursuivre avec cet outil.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.5 Extraire l'information des noms - Paramètres

Le dialogue Paramètres par défaut du préfixe et du connecteur s'affiche et vous pouvez modifier chacune des options :

  • A la recherche des préfixes : de, van, von, di, le, du, dela, della, des, vande, ten, da, af, den, das, dello, del, en, ein, elet, les, lo, los, un, um, una, uno, der, ter, te, die (par défaut)
  • Connecteurs de séparation des noms de famille : e, y (par défaut)
  • Connecteurs non séparant des noms de familles : de, van (par défaut)

Une fois terminé, cliquez Valider pour lancer l'outil.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.6 Extraire l'information des noms - Résultats

Une fois le rapport terminé, le dialogue des résultats Outil d'extraction du nom et du titre s'affiche. Pour chaque nom dans la liste, vous pouvez garder sélectionnée la ligne ou non. En cliquant sur le bouton Accepter et fermer, vous allez lancer les corrections pour les lignes sélectionnées.

Fusion des citations

Error creating thumbnail: Unable to save thumbnail to destination
L'outil Fusion des citations…

travaille en combinant les notes, media et données des citations en correspondance.


You can select this via menu Tools > Family Tree Processing > Merge Citations... .

L'Avertissement sur l'historique d'annulation va s'afficher et vous pouvez soit Annuler soit Poursuivre avec cet outil.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.7 Fusion des citations - paramètres

Ensuite, le dialogue Fusion des citations (Titre du dialogue : Les notes, objets media et données des deux citations seront combinés.) est affiché.

Les options suivantes sont disponibles :

  • Liste déroulante Seuil de correspondance :
    • Correspondance à page/volume, date et confiance
    • Ignorer la date (par défaut)
    • Ignorer le niveau de confiance
    • Ignorer la date et le niveau de confiance
  • Options
    • Ne pas fusionner si la citation a des notes (non coché par défaut)


Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.8 Fusion des citations - Résultat

Sélectionner Valider pour lancer l'outil ; une fois l'opération terminée, un rapport indique le Nombre de fusions effectuées.
Voir aussi les options de [Fusion de citations] disponibles dans la vue de la catégorie Citations.

Recherche des doublons

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.9 Recherche des doublons - paramètres

Cet outil parcourt la base de données et cherche les enregistrements qui pourraient décrire en réalité la même personne.

Vous pouvez accéder à cet outil via Outils -> Modification de l'arbre familial… -> Trouver des doublons….

Le dialogue Recherche des doublons s'affiche et vous pouvez modifier les options :

  • Le seuil de correspondance : choisir entre Élevé, Moyen, et Bas (par défaut) depuis le menu déroulant. (Note : la probabilité de correspondance est calculée en nombre à virgule flottante. Si la probabilité est supérieure au seuil, la correspondance est alors rapportée. Les seuils sont définis à Bas = 0,25, Moyen = 1 et Élevé = 2. Ainsi, avec le seuil haut, moins de correspondances sont attendues)

Options

  • Utiliser les codes SoundEx case à cocher permettant d'activer ou non l'utilisation des codes SoundEx pour rechercher les doublons d'individus. Cette option a un intérêt pour les noms à consonance anglaise. (coché par défaut)

Seulement trois boutons sont présents : l'Aide vous conduisant à cette page, Annuler pour arrêter le processus et le bouton Valider pour lancer l'outil.

Si vous cliquez sur le bouton Valider, les données suivront deux étapes.

  • Étape 1 : Construction d'une liste préliminaire
  • Étape 2 : Calcul des correspondances possibles.

Une barre de progression s'affichera et sa rapidité dépendra de votre processeur et de nombre d'individus dans votre base de données, ceci pouvant prendre un peu de temps.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.10 Recherche des doublons - résultats

Finalement une fenêtre Fusions potentielles sera présentée. Elle affiche une liste avec trois colonnes :

  • Évaluation : ceci vous donne une idée de la ressemblance entre les deux individus. Plus l'indice est élevé, plus la probabilité est grande que ce soit un doublon.
  • Le premier individu
  • Le second individu

Trois boutons sont présents : Aide vous conduisant à cette page, Fermer pour quitter et le bouton Comparer.

Si vous sélectionnez une ligne, vous pourrez vérifier les détails avec le bouton Comparer (ou cliquez deux fois sur la ligne). Une nouvelle fenêtre Fusion des individus s'affiche avec les détails de comparaison. si vous cliquez le bouton Valider les individus seront fusionnés. Voir pour les détails fusion des individus.

Renommer les types d'événement

Fig. 12.11 Changement de type

Cet outil renomme tous les événements d'un type vers un nouveau type.

Accédez à cette outil par le menu Outils -> Modification de l'arbre familial -> Renommer les types d'évènements…

Error creating thumbnail: Unable to save thumbnail to destination
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez pas annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

La fenêtre Echanger des types d'événement est affichée.

  • Type d'événement original : saisir dans le champ texte ou utilisez le menu déroulant et sélectionnez le type d'événement à renommer.
  • Nouveau type d'évènement : saisir dans le champ texte (vous pouvez créer un type d'événement nouveau) ou utilisez le menu déroulant et sélectionnez le type d'événement de remplacement.

L'exemple montre le changement de l'événement Baptême religieux vers l'événement Baptême.

Error creating thumbnail: Unable to save thumbnail to destination
Types personnalisés

Quand un type personnalisé n'apparait pas dans la liste déroulante, vous pouvez le saisir directement dans le champ ou coller un texte dans chacun des deux champs pour convertir le premier en deuxième.

Cliquez sur Valider pour poursuivre, Annuler pour abandonner. A la fin de cette tâche, l'outil affiche un dialogue de résultats indiquant le nombre d'évènements modifiés.

Error creating thumbnail: Unable to save thumbnail to destination
Renommer les évènements

Une fois terminée, cette opération ne peut pas être annulée par la fonction habituelle Annuler.

Voir aussi :



Réorganiser les identifiants Gramps

Cet outil réordonne les identifiants des objets de la base de données Gramps et peut aussi permettre d'en modifier le format. Plusieurs options sont disponibles.

Accédez à cette outil par le menu Outils -> Modification de l'arbre familial -> Réorganiser les identifiants Gramps…

L'Avertissement sur l'historique d'annulation va s'afficher et vous pouvez soit Annuler soit Poursuivre avec cet outil.

Error creating thumbnail: Unable to save thumbnail to destination
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez pas annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

Error creating thumbnail: Unable to save thumbnail to destination
Identifiants personnalisés

Si vous avez déjà personnalisé vos identifiants, cet outil va les remplacer. Attention avant d'utiliser cet outil !

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.12 Réorganiser les identifiants Gramps

La colonne 'Objet' liste les types d'identifiant. A la gauche de cette colonne, des cases à cocher permettent d'activer les changements pour chaque type d'objet. Quand elle est cochée, le type d'objet sera ré-ordonné. L'étiquette 'Objet' est en fait un bouton qui peut être utilisé pour inverser toutes les cases à cocher en une seule fois.

La colonne 'Actuel' affiche un exemple de l'identifiant en cours. La colonne 'Quantité' affiche le nombre d'objet de ce type.

La colonne 'Format' est utilisée pour modifier le format de l'identifiant pour chaque type d'objet. Notez que le format consiste en un préfixe, le '%04d' et un suffixe. Il DOIT y avoir au moins un préfixe ou un suffixe, les deux étant autorisés. Il est recommandé de garder des identifiants assez courts. Le '%04d' définit la longueur de la portion numérique de l'identifiant, le '4' peut être changé, de '3' (permettant des nombres de 000-999) à '9' (000000000-999999999) est autorisé. Les modifications faites ici sont les mêmes que dans le menu Édition --> Préférences… par l'onglet Formats ID. L'étiquette 'Format' est en fait un bouton qui réinitialise tous les formats à la dernière valeur utilisée.

La colonne 'Modifier' contient des cases à cocher pour chaque type d'objet. Si coché, l'identifiant de cet objet sera remplacé par le nouveau 'Format' à moins que la case 'Conserver' ne soit aussi cochée ; dans ce cas, l'identifiant est ré-ordonné en tenant compte du numéro de départ et de l'étape, définis dans les champs suivants. Si aucune case n'est cochée, le format de l'identifiant n'est PAS mis à jour mais l'identifiant est recalculé. L'étiquette 'Modifier' est en fait un bouton qui permet d'inverser toutes les cases à cocher en une fois.

Le champ 'Démarrer' indique le numéro de départ utilisé pour l'opération de renumérotation. L'étiquette 'Démarrer' est en fait un bouton qui permet de basculer entre démarrer à 0 et démarrer après le dernier numéro en cours.

Le champ 'Étape' indique l'intervalle entre les numéros pour la renumérotation. '1' est un incrément simple, '2' va incrémenter par 2, etc. L'étiquette 'Étape' est en fait un bouton qui permet de basculer entre '1', '2', '5' et '10'.

La colonne 'Conserver' contient des cases à cocher pour chaque type d'objet. Si cette case et celle de la colonne 'Modifier' sont cochées, le format d'identifiant pour cet objet sera conservé mais l'identifiant sera recalculé en tenant compte des 2 champs précédents. L'étiquette 'Conserver' est en fait un bouton qui permet d'inverser toutes les cases à cocher en une fois.

Si vous cliquer le bouton Valider le processus sera lancé et une fenêtre affichera une barre de progression.

Les identifiants sont ré-ordonnés en plusieurs étapes : les identifiants individuels, les identifiants familiaux, les identifiants événements, les identifiants objets media, les identifiants sources, les identifiants citations, les identifiants lieux, les identifiants dépôts et enfin les identifiants notes.

L'étape suivante consiste à rechercher les identifiants non-utilisés et les assigner.

Durant ce processus, l'outil examine chaque identifiant pour voir s'il correspond à la personnalisation, s'il ne correspond pas au format d'identifiant précédent ou au format par défaut. Ce peut être le cas si l'utilisateur a saisi son propre texte dans le champ de l'identifiant lors de la modification d'un objet. Ceci peut aussi arriver si les greffons tiers GetGOV ou GeoName ont été utilisés puisque cet outil enregistre l'identifiant GOV dans le champ de l'identifiant Gramps. Si un identifiant 'personnalisé' est trouvé, il va demander à l'utilisateur s'il veut réellement le remplacer. Le dialogue permet aussi à l'utilisateur d'avoir la même réponse pour les autres identifiants personnalisés qui seront retrouvés.

Réparer la casse des noms de famille

Cet outil recherche dans la base de données les noms de famille pour les normaliser. Le but est d'avoir la norme conventionnelle : première lettre en capital et des minuscules pour le reste du nom de famille. Si des déviations à cette règle sont détectées, les candidats pour la modification seront présentés dans un tableau. Vous pouvez alors décider de les modifier ou non.

Vous pouvez utiliser cet outil via Outils -> Modification de l'arbre familial -> Réparer la casse des noms de famille….

Error creating thumbnail: Unable to save thumbnail to destination
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez pas annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

Vous pouvez choisir le bouton Annuler ou Poursuivre avec cet outil.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.13 Correction de la casse

Si des changements sont possibles sur les lettres capitales vous verrez la fenêtre Changements de la casse. Elle affiche une liste des noms de famille pouvant être convertis par Gramps (vérifiez que ceci est correct pour vous). Dans la liste il y a trois colonnes :

  • Sélectionner : cochez ou non si vous acceptez ou non la recommandation de correction
  • Nom d'origine : le nom tel qu'il est actuellement enregistré.
  • Changement de la casse : le nom avec la modification si le changement est appliqué.

Sélectionnez les noms que vous souhaitez modifier, puis appuyez sur le bouton Accepter les modifications et fermer la fenêtre. Ou utilisez le bouton Annuler pour ne rien changer.

Vous pouvez aussi installer le greffon Réparer la casse des prénoms qui, une fois installé, fonctionne sur le même principe pour les prénoms.

Trier les événements

Les événements de l'onglet Événements dans les Éditeurs de l'individu ou de la Famille ne sont pas triés dans un ordre particulier autre que celui de la saisie. La raison pour ne pas forcer une quelconque règle de tri, particulièrement par date, étant de permettre pour chaque événement connu d'avoir lieu sans en connaître la date dans la chronologie. Importer ou fusionner une donnée depuis une source extérieure peut générer des événements extérieurs, pouvant être ajoutés, mais sans règle de tri, aux évènements existants pour les individus ou familles.

Les événements peuvent être ré-ordonnés manuellement par un glisser-déposer ou par l'utilisation des boutons réordonner dans l'onglet Événements, lesquels permettent à un événement d'être monté ou descendu dans la liste des événements et Gramps se souviendra de l'ordre dès lors que les changements seront sauvés. Le nouveau tri sera utilisé partout dans Gramps, tel que dans les rapports.

L'ordre des événements dans l'onglet peut également être modifié en cliquant sur l'en-tête/titre des colonnes. Ainsi, cliquer sur la colonne 'Date' triera les événements selon les dates. Néanmoins cette méthode de tri des événements est temporaire et les changements ne sont pas conservés quand vous quittez la fenêtre.

L'approche du glisser-déposer pour classer les événements est bonne pour changer l'ordre d'un petit nombre d'événements mais n'est pas très pratique pour un grand nombre de modifications dans la chronologie des événements. C'est pour ce type de modifications que l'outil Tri des événements peut être utilisé. Il a été conçu pour le tri de tous les événements de la base de données ou ceux associés à une sélection ciblée d'individus choisie à l'aide d'un filtre.

Vous pouvez utiliser cet outil via Outils -> Modification de l'arbre familial -> Trier les évènements….

Error creating thumbnail: Unable to save thumbnail to destination
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez pas annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.14 Tri des événements

La première option de l'outil Trier les événements est prévu pour définir l'étendue des individus sur lesquels l'outil va appliquer le tri. Le premier choix dans la liste étant d'appliquer les changements à tous les individus de la base de données. Les choix alternatifs étant d'appliquer les modifications aux ascendants et descendants de la personne choisie par le filtre ou un ensemble d'individus sélectionné par un filtre personnalisé. Après la désignation des individus à trier, l'étape suivante est de définir la règle du tri. La première option étant de trier par date. C'est probablement le choix le plus courant, mais d'autres attributs des événements peuvent également être choisis. Les dernières options sont pour le choix du tri, croissant ou décroissant, et d'appliquer ou non le tri sur les événements familiaux des individus sélectionnés.

Error creating thumbnail: Unable to save thumbnail to destination
Trier les évènements

Une fois terminée, cette opération ne peut pas être annulée par la fonction habituelle Annuler.


Éditer l'information sur le propriétaire de la base de données

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.15 Information sur le propriétaire

Cet outil permet de modifier toutes les informations existante sur le chercheur.

Cliquer sur Outils -> Modification de l'arbre familial -> Édition des données sur le propriétaire de la base..., ouvre la fenêtre de Éditeur du propriétaire de la base de données, dans laquelle vous pouvez saisir les informations.

  • Nom :
  • Rue :
  • Lieu-dit :
  • Ville :
  • Province/Comté :
  • Pays :
  • Code postal :
  • Téléphone :
  • Courriel :

Ces informations sont spécifique à cet arbre familial et seront utilisées lors d'une exportation au format GEDCOM.

Deux choix sont disponibles à partir du menu contextuel (clic droit) :

  • Copier depuis BD vers préférences
  • Copier depuis préférences vers BD


Réparation de l'arbre familial

Reconstruire les seconds indices

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.16 Seconds indices reconstruits

Cet outil reconstruit les seconds indices.

Vous pouvez utiliser cet outil via Outils -> Réparation de l'arbre familial -> Reconstruire les seconds indices…. Une fois terminé, un dialogue Seconds indices reconstruits est affiché.

Reconstruire les statistiques du prénom d'après le genre

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.17 Seconds indices reconstruits

Cet outil reconstruit les statistiques de genre d'après le genre probable du prénom.

Vous pouvez utiliser cet outil via Outils -> Réparation de l'arbre familial -> Reconstruire les statistiques du prénom d'après le genre….

Une fois terminé, un dialogue Statistiques du genre du prénom est affiché.

Reconstruire les tables de références

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.18 Seconds indices reconstruits

Ce outil reconstruit les tables de référence (item Références dans les fenêtres de saisie).

Vous pouvez utiliser cet outil via Outils -> Réparation de l'arbre familial -> Reconstruire les tables de références….

Une fois terminé, un dialogue Tables de références reconstruites est affiché.

Supprimer les objets non référencés

Cet outil parcourt votre base de données à la recherche d'éléments d'informations non connectés à quoi que ce soit d'autre, puis vous permettre de les modifier pour les rattacher à un autre élément ou les supprimer.

Vous pouvez utiliser cet outil via Outils -> Réparation de l'arbre familial -> Supprimer les objets non référencés….

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.19 Objets non référencés - Recherche

Le dialogue Objets non référencés est présenté.

Choisissez parmi les options de recherche dans la section supérieure de la boite de dialogue Objets non référencés :

  • Recherche des évènements (coché par défaut)
  • Recherche des sources (coché par défaut)
  • Recherche des citations (coché par défaut)
  • Recherche des lieux (coché par défaut)
  • Recherche des objets media (coché par défaut)
  • Recherche des dépôts (coché par défaut)
  • Recherche des notes (coché par défaut)

Selectionnez le bouton Rechercher pour lancer le rapport et une fois terminé, les résultats, s'il y en a, s'affiche dans la section inférieure de la fenêtre Objets non référencés avec les colonnes suivantes :

  • Marquer Sélectionne le rang si vous voulez supprimer l'objet (non coché par défaut)
  • - Une icône représentant le type d'objet.
  • ID - L'identifiant Gramps interne de l'objet.
  • Nom - de l'objet.

Pour examiner un objet, double-cliquez sur son rang va ouvrir la fenêtre de modification de l'objet appropriée pour la corriger si nécessaire.

Marquer les objets que vous voulez supprimer soit en utilisant les cases à cocher individuelles soit en utilisant les boutons :

  • Tout sélectionner
  • Tout désélectionner
  • Inverser les marques

Une fois vos choix de suppression faits, sélectionner le bouton Supprimer pour supprimer les objets.

When finished you may then use the Close button to exit the tool.


Vérifier et réparer la base de données

Error creating thumbnail: Unable to save thumbnail to destination
Attention

L'outil Vérifier et réparer la base de données exécute des corrections automatiques. Une fois terminées, elles ne peuvent pas être annulées par la fonction habituelle Annuler.

Cet outil vérifie la base de données en recherchant les problèmes d'intégrité et en corrigeant ceux qu'il peut corriger. Dans le détail, cet outil détecte les défauts suivants :

  • Liens familiaux rompus. Ceci arrive quand l'enregistrement d'un individu référence à une famille alors que l'enregistrement de la famille n'a pas de référence pour cet individu, et vice versa.
  • Media introuvables. Un medium introuvable est un objet multimedia dont le fichier est référencé dans la base de données mais absent. Ceci arrive quand le fichier est supprimé, renommé ou bien encore déplacé.
  • Familles vides. Ce sont les entrées de famille qui n'ont aucune référence à un individu en tant que membre.
  • Liens erronés entre parents. Ceci vérifie toutes les familles pour s'assurer que père et mère ne sont pas mélangés. Le sexe des parents doit aussi être différent. S'ils sont du même genre, alors leur relation est modifiée en "Partenaires".

Vous pouvez utiliser cet outil via Outils -> Réparation de l'arbre familial -> Vérifier et réparer la base de données….

Error creating thumbnail: Unable to save thumbnail to destination
L'historique de modifications

En poursuivant avec cet outil vous allez effacer l'historique de cette session. Vous ne pourrez pas annuler les changements effectués par cet outil ou revenir aux modifications antérieures. Si vous pensez avoir besoin de retourner à une action précédente, veuillez arrêter et sauvegarder votre base de donnée.

Vous pouvez choisir le bouton Annuler ou Poursuivre avec cet outil.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.20 Vérification de l'arbre - media non trouvé
Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.21 Résultats de la vérification de l'intégrité

Les anomalies retrouvées sont automatiquement corrigées mais une boite de dialogue peut s'afficher pour les media non retrouvés. Vous pouvez alors supprimer la référence ou indiquer le nouveau chemin si le medium a simplement été déplacé. Une case à cocher permet de répercuter la même modification pour les autres fichiers media non trouvé.

En fin de processus, une fenêtre de résultats s'affichera alors pour résumer les corrections s'il y en a eu.

Utilitaires

Cette section contient des outils vous permettant d'effectuer une opération simple sur une partie de données. Les résultats peuvent être sauvés dans votre base de données, mais ils ne modifieront pas vos données existantes. Les utilitaires suivants sont actuellement disponibles dans Gramps:

Calcul relationnel

Cet utilitaire affiche la liste de tous les individus connectés, mais pas forcément en relation avec la personne active. Pour calculer la relation avec un individu différent, fermer la fenêtre, faire de cet individu la personne active et relancer l'outil.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.22 "Relations avec '…' " - Boite de dialogue montrant les résultats de l'outil «Calcul relationnel»

Accéder à cet outils par le menu Outils->Utilitaires->Calcul relationnel….

Sélectionnez un individu dans la liste filtrée obtenue pour voir si une relation existe. La relation exacte sera affichée dans la partie inférieure de la fenêtre ainsi que l'ancêtre commun de cette relation. Seuls les liens du sang seront affichés (à l'exception des relations époux-épouse). Noter que les relations «par alliance» ne sont pas affichées.

La liste filtrée est affichée groupée et par ordre alphabétique des noms de famille (quelque soit les réglages de groupage dans la vue de la catégorie Individus). Les colonnes ne peuvent pas être triées.

Le degré de séparation (nombre de générations) qui sera pris en compte est réglé par le Nb. max. de générations à parcourir entre 2 générations de l'onglet Général du menu Édition -> Préférences…. (La valeur par défaut de 15 générations va rapporter des arrières grands-parents au 12e degré mais pas leurs parents. La personne active est compté comme une génération.)

Fondamentalement, deux individus sont liés directement par un lien du sang s'ils ont un ancêtre commun. Un de ces individus peut être l'ancêtre du second - comme un arrière grand-parent. Même dans le cas d'oncles et de tantes, vous pouvez toujours calculer la relation en recherchant l'ancêtre commun. Dans ce cas le père ou la mère de la tante ou de l'oncle sera un grand-parent du neveu ou de la nièce.

Le lien du sang le plus évident à travers les ancêtres est celui des frères et sœurs qui sont juste une génération en dessous de l'ancêtre commun. Une autre relation particulière est celle d'un individu de cette fratrie avec les descendants d'une autre individu de la fratrie. Si la personne active est le petit-fils ou la petite-fille de l'ancêtre commun, le frère ou la sœur d'un parent sera un oncle ou une tante. Au delà de cette génération de descendants, la fille des arrières grands-parents sera appelée grande tante. Cet individu est une arrière grande tante pour le second arrière petit-enfant qui est à quatre générations de l'ancêtre commun. La relation inverse d'une tante ou d'un oncle est un neveu ou une nièce.

Les cousins germains sont à deux générations de l'ancêtre commun par des fratries différentes. Les cousins issus-de-germains sont eux, à trois générations de l'ancêtre commun, et ainsi de suite.

Ensuite, tout le monde est dénommé «cousin» mais pour indiquer qu'ils ne sont pas de la même génération, on peut utiliser le terme «degré» pour indiquer la distance entre les générations.

S'il y a des liens de sang multiples, ils seront tous rapportés.

Une liste textuelle complète des liens du sang et les conjoints peut être vue avec le Rapport de parenté.

Gérer les Media

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.23 Outil «Gérer les media» - Introduction

Cet outil est un ensemble de quatre outils différents utilisables par un assistant avec des fenêtres de dialogue. Il est accessible par le menu Outils -> Utilitaires -> Gérer les media… qui va afficher un premier dialogue Introduction avec les informations suivantes sur les actions de l'outil.

Error creating thumbnail: Unable to save thumbnail to destination
Introduction

Cet outil permet un traitement par lots des objets media enregistrés dans Gramps. Une distinction importante doit être faite entre les objets media de Gramps et ses fichiers.

L'objet medium de Gramps est une collection de données sur les fichiers (media) : leur nom de fichier et/ou leur chemin, leur description, leur identifiant, notes, références de la source, etc. Ces données ne sont pas incluses dans le fichier lui-même.

Les fichiers image, audio, video, etc. existent séparément sur votre disque dur. Ces fichiers ne sont pas gérés par Gramps et ne sont pas inclus dans la base de données Gramps. La base de données Gramps ne conserve que le chemin et le nom du fichier.

Cet outil permet de modifier seulement les enregistrements dans votre base de données Gramps. Si vous voulez déplacer ou renommer les fichiers, vous devez le faire vous-même, hors du programme. Puis vous pourrez corriger les chemins en utilisant cet outil de sorte que les objets media dans Gramps enregistre le bon emplacement des fichiers.


De la page Introduction, sélectionnez le bouton Suivant (ou utilisez le raccourci clavier Alt+S) pour afficher la fenêtre de la page Sélection.

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.24 Outil «Gérer les media» - Sélection

A partir de cette page Sélection, sélectionner une des quatre actions que vous souhaitez faire puis sélectionnez le bouton Suivant :

  • Remplacer une partie du chemin (par défaut)
  • Convertir les chemins relatifs en chemins absolus
  • Convertir les chemins absolus en chemins relatifs
  • Ajouter les images non présentes à cette base de données


Remplacement une partie du chemin

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.25 Outil «Gérer les media» - Paramètres du remplacement de sous-chaîne

Cet outil permet le remplacement spécifique de sous-chaînes dans le chemin des objets media par une autre sous-chaîne. Ceci est utile quand vous déplacez les fichiers d'un répertoire vers un autre.

Tapez la chaîne de caractères correspondant à la partie de chemin à remplacer dans le champ Remplacer : et la chaîne correspondant au nouveau chemin dans le champ Par :. A n'importe quel moment, vous pouvez cliquer sur le bouton Annuler ou le bouton Précédent. Cliquez sur le bouton Suivant ouvre la fenêtre de Confirmation finale.

Convertir les chemins relatifs en chemins absolus

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.26 Outil «Gérer les media» - Convertir les chemins relatifs en absolus

Cet outil permet de convertir les chemins relatifs vers les media en chemins absolus. Il utilise pour cela le prédéfini Chemin de base pour les chemins relatifs des media : indiqué dans l'onglet Général du menu Édition -> Préférences… ou, s'il n'est pas renseigné, le répertoire racine de l'utilisateur.

Convertir les chemins absolus en chemins relatifs

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.27 Outil «Gérer les media» - Convertir les chemins absolus en relatifs

Cet outil permet de convertir les chemins absolus vers les fichiers media en chemins relatifs. Le chemin relatif est relatif vis-à-vis du chemin de la base défini dans l'onglet Général du menu Édition -> Préférences… ou, s'il n'est pas renseigné, le répertoire racine de l'utilisateur. Un chemin relatif permet de lier la localisation des fichiers au chemin de la base qui pourra être modifié selon vos besoins.

Ajouter les images non présentes à cette base de données

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.28 Outil «Gérer les media» - Ajouter les images

Vérifie les répertoires à la recherche d'images non incluses dans la base de données. Cet outil ajoute les images des répertoires référencés par les images déjà connues dans la base de données. Vous aurez à importer un item media pour chaque sous-répertoire manuellement. Le gestionnaire de media n'inclus pas les sous-répertoires automatiquement. Tous les chemins de répertoire affichés par l'outil seront explorés.

Nettoyage des données saisies

C'est un outil qui supprime les espaces en début ou en fin de nom. Il va rechercher les noms de lieux, les noms de famille et les prénoms avec des espaces inutile en début ou fin de nom.

Utilisez le menu Outils -> Utilitaires -> Nettoyage des données saisies….

Une fenêtre de résultats vous affiche les anomalies retrouvées pour les individus en partie supérieure et les lieux en partie inférieure.

Gramps prévient ce type d'anomalie en supprimant ces espaces inutiles lors de la saisie.

Non lié

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.29 Non lié

Ce rapport va trouver les individus non reliés à la personne active sélectionnée. Les connexions comprennent les liaisons par une chaîne de références ou les liens créés avec l'éditeur de liens dans les notes.

Vous pouvez l'utiliser via le menu Outils -> Utilitaires -> Non lié….

Vous obtenez une fenêtre Non lié à… dans laquelle une liste affichera tous les individus NON liés à la personne sélectionnée.

Cette liste vous fournit :

  • Nom
  • Identifiant
  • Parents
  • Marqueur

Dans la colonne des noms, le bouton et le bouton permettent de déployer ou de refermer la liste des Noms. Un double-clic sur un individu ouvrira le dialogue de modification individuel ou familial.

Si vous sélectionnez un individu vous pouvez utiliser le champ texte Marqueur dans la section inférieure de la fenêtre : vous pouvez saisir le texte que vous voulez ou choisir dans la liste déroulante une étiquette existante, c-à-d A Faire ou Non lié. Avec le bouton Appliquer vous marquez les individus sélectionnés. Ce marqueur sera alors affiché dans la colonne de droite.

Trouver une boucle dans la base de données

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.30 Exemple simple de boucle dans un arbre avec la fenêtre de recherche de boucle

Cet outil permet de recherche une boucle parmi les ancêtres dans votre arbre généalogique.

Cliquez sur Outils-->Utilitaires-->Trouver une boucle dans la base de données… pour lancer la vérification.

La fenêtre de résultats affiche un tableau avec cinq colonnes Identifiant Gramps,Parent, Identifiant Gramps, Enfant, Identifiant de la famille.

  1. Le premier Identifiant Gramps se réfère au parent.
  2. Parent est l'individu pour lequel nous recherchons la boucle.
  3. Le second Identifiant Gramps se réfère à l'enfant.
  4. L'enfant (le descendant) à l'origine de la boucle.
  5. Identifiant de la famille est la référence à la famille correspondante.


Pour plus d'informations sur les boucles, lire (en anglais) :

Vérifier les données

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.31 Vérification des données - Paramètres

Cet utilitaire permet de vérifier les données de la base selon des critères spécifiés par l'utilisateur.

Par exemple, vous voulez vous assurer qu'aucune personne dans votre base n'a des enfants à l'âge de 98 ans. Ceci serait le résultat d'une erreur de saisie de toute évidence, mais ne serait pas une erreur de structure de la base de données. A côté de cela, quelqu'un pourrait avoir un enfant à 98 ans même si c'est très improbable. L'outil de vérification affiche tout ce qui ne répond pas à vos critères pour que vous puissiez vérifier plus à fond les données.

Cliquez sur Outils-->Utilitaires-->Vérifier les données… pour ouvrir la fenêtre Vérification des données. Ce dialogue a cinq onglets, Général, Femmes, Hommes, Familles. Ces derniers affichent une liste de critères dont vous pouvez modifier les valeurs. Dans la liste ci-dessous, voici quelques valeurs réalistes.

Général

  • Âge maximal : 90
  • Âge minimal pour se marier : 17
  • Âge maximal pour se marier : 50
  • Nombre maximum de conjoints par une personne : 3
  • Nombre maximal d'années consécutives de veuvage avant le mariage suivant : 30
  • Âge maximal pour un(e) célibataire : 99


  • Estimer des dates manquantes ou inexactes permet à l'outil d'accepter une date de baptême si la date de naissance n'est pas connue et d'accepter la date d'inhumation si la date de décès n'est pas connue. Elle permet aussi à l'outil d'accepter les dates «inexactes» (c-à-d toute date Gramps «légitime» qui n'est pas une date complète - avec un jour, un mois et une année explicites).
  • Identifie les dates invalides : vérifie si les dates sont valides.

Femmes

  • Âge minimal pour porter un enfant : 17
  • Âge maximal pour porter un enfant : 48
  • Nombre maximal d'enfants : 12

Hommes

  • Âge minimal pour être père : 18
  • Âge maximal pour être père : 65
  • Nombre maximal d'enfants : 15

Familles

  • Différence d'âge maximale entre conjoints : 30
  • Nombre maximal d'années entre enfants : 8
  • Étendue maximale d'année du premier au dernier enfant : 25

Résultat de la vérification des données

Error creating thumbnail: Unable to save thumbnail to destination
Fig. 12.32 Vérification des données - Résultat

Si vous êtes d'accord avec les critères, cliquez sur le bouton Exécuter (ou le raccourci clavier Alt+R et vous obtiendrez une fenêtre Résultat de la vérification de vos données.

Selon vos critères et données une liste sera affichée. Plusieurs types de résultat sont listées ci-dessous. Mais il en existe d'autres.

  • Individus non reliés (sans parents ou conjoint ou enfants ou fratrie)
  • père à un âge avancé ou décédé
  • mariage après le décès ou avant la naissance
  • grand écart d'âge entre les enfants
  • mariage précoce ou tardif
  • mère jeune ou pas encore née
  • conjoint portant le même nom de famille
  • mariage entre individus du même sexe / mère de genre masculin

Au bas de la fenêtre, il y a quatre boutons pour faciliter la sélection : Tout sélectionner, Tout désélectionner, Inverser les marques, et Cacher les marqués.

Double-cliquer sur une ligne permet de voir et/ou d'éditer vos données.

Avec le bouton Fermer (ou le raccourci clavier Alt+F) vous fermez la fenêtre Résultat.

Exemple

Pour démontrer à quel point cet Utilitaire est maniable, voici deux exemples tirés de données existantes :

  • La mise en garde affichait « mère de genre masculin » : en vérifiant les données il y avait une famille ayant pour père : Anna Roelants. Heureusement dans la Description on pouvait lire : Le mariage de Adam Roelants et de Cornelia Crabbe. C'était une faute de frappe : Anna étant Adam. Sans cet Outil il aurait été difficile de mettre à jour cette erreur.
  • La mise en garde affichait « mariage tardif », en vérifiant les données : homme né en 1738, femme née en 1756, mariage en 1804 [Calendrier Grégorien], tout semblait valide, mais ils avaient 66 et 48 ans ! L'alerte s'affiche parce que dans les critères généraux la limite a été définie à 60 ans.


Error creating thumbnail: Unable to save thumbnail to destination
Différence entre l'outil Vérifier les données et l'outil de recherche d'erreurs dans la base décrit dans le chapitre Réparation de l'arbre

La vérification de la base détecte les incohérences dans la structure de la base de données. En revanche, l'outil de vérification des données, détecte les enregistrements qui ne correspondent pas à vos critères de recherche.


Précédent Index Suivant
Error creating thumbnail: Unable to save thumbnail to destination
Notice spéciale pour le droit à la copie: Toutes les éditions de cette page ont besoin des deux différentes licences pour la réutilisation:

Ces licences permettent au projet Gramps de maximiser l'utilisation du manuel wiki en tant que contenu libre pour les prochaines versions de Gramps. Si vous êtes en désaccord avec cette double licence, alors n'éditez pas cette page. Vous pouvez ajouter un lien pour cette page, ce dernier sera sous licence GFDL via le lien externe (utilisant la syntaxe: [http://www.gramps-project.org/...]), et non via les liens internes.
Utilisez également les conventions typographiques.