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Abstract
The Gramps Manual details all aspects of the Gramps software application.
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Gramps is a software package designed for genealogical research. Although similar to
other genealogical programs, Gramps offers some unique and powerful features which
we'll discuss below.
Gramps is an Open Source software package, which means you are free to make
copies and distribute it to anyone you like. It's developed and maintained by a worldwide team of volunteers whose goal is to make Gramps powerful, yet easy to use.

mation about people even if those people are not related to the primary family you happen to be researching. And they may include features that let you exchange data with
other programs and print different types of reports.
Gramps has all these capabilities and more. Notably, it allows you to integrate bits
and pieces of data as they arise from your research and to put them in one place -- your
computer. You can then use your computer to manipulate, correlate, and analyze your
data, rather than messing with reams of paper.

Typographical conventions

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions
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In this book, some words are marked with special typography:
• Applications
•
Commands you type at the command line
•
•
•
•
•
•
•

Next

Filenames
Replaceable text
Labels for buttons and other portions of the graphical interface
Menu selections look like this: Menu -> Submenu -> Menu Item
Buttons you can click
CTRL + D Key combinations you can press on your Keyboard.
Anything you type in

The manual also provides assorted bits of additional information in tips and notes as
follows:

Why use Gramps?
Most genealogy programs allow you to enter information about your ancestors and descendants. Typically, they can display family relationships through charts, graphs, or
reports. Some allow you to include pictures or other media. Most let you include infor-
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Example Tip

Previous

Tips and bits of extra information will look like this.

Index

Next

Example Note
Notes will look like this.
This page was last modified on 26 October 2011, at 21:37. This page has been accessed
1,622 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers

Finally, there are warnings, notifying you where you should be careful:

Example Warning
This is what a warning looks like. If there's a chance
you'll run into trouble, you will be warned beforehand.

2

From Gramps

Gramps 3.3 Wiki Manual - What's new?

Gramps 3.3 Wiki Manual - What's new?
From Gramps
Jump to: navigation, search

also corrupt the archive. An export as outlined in this
section is recommended.

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
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Before you upgrade, make sure your family tree data is secure. The best way to do this
is:
1. Start Gramps 3.2
2. Open your family tree
3. Export the family tree to the gramps xml format or the gramps xml package
format (which includes your photographs and other media files associated
with your family tree data). Export your tree via menu Family Trees->Export
Trees->Export,
making sure you export all data with no filters applied.
4. Close this family tree and repeat the above steps for any other family trees
you have
5. Keep the resulting file(s) in a safe place
For more information, please review Backing up a Family Tree.

Next

After properly safeguarding your data, proceed to install Gramps 3.3. Use your operating system's regular installation process to do this. It is also best to uninstall Gramps 3.2
before installing Gramps 3.3, or make sure you install Gramps 3.3 in a different location.
After you install Gramps 3.3, you can open your existing family trees and continue
working. In case of problems (e.g., after a complete system upgrade), use the backup
file(s) created above to recreate your family tree(s).

This section gives an overview of changes since Gramps version 3.2. These changes are
also detailed later in this manual. Users of Gramps version 3.2 are encouraged to review
this section to be sure to take advantage of these new features.

Before you upgrade

Warning

Warning

Once you open a family tree in a newer version of
Gramps or using a newer operating system, you generally should not try to open that database using an older
version again. As always, the gramps xml format is the
format to use for the interchange of your data in such

Creating an archive alone to safeguard your data might
not be appropriate before upgrading. In the unlikely
event that Gramps 3.3 corrupts your database, it could
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Locality

cases. There are tools to repair broken databases, but
they are for expert users, so avoid needing them by following the steps above before you upgrade your OS or
Gramps.

A Locality field has been added to Location between the Street and City fields.

Custom rules migration
For avoiding unwanted effects after major upgrades
(eg, from 3.2.x to 3.3.x), if need, we can manually copy
our custom_filter.xml from GRAMPS User Directory to
gramps_version_number.

Visible changes to the core
Names

New Selection Dialog in Export

• Formats
• New Editor
• New filter rules

When exporting your data, you now have a fine-grained control over the details of how
filters can be applied. You also can now check which records are selected (and which
ones are not) through this interface.

Custom rules migration

More tooltips

For avoiding unwanted effects after major upgrades
(eg, from 3.2.x to 3.3.x), if need, we can manually copy
our custom_filter.xml from GRAMPS User Directory to
gramps_version_number.

All fields on Editors have now tooltips.

Linking in Notes

GrampsBar

Notes now support links to other items in Gramps. For example, when writing a note,
you can put a link to a person, family, or marriage. When viewing these notes, you can
quickly click on the link and bring up the object.
Links are also converted to HTML links when, for example, running the Narrative
Web report.

A sidebar and bottombar are available on all views except for the Gramplet View. They
allow gramplets to be displayed alongside a view.
See Gramplets for more details.

Tags

Backup dialog

Tags replace Markers. Tagging is available for Person, Family, Media and Note objects.
Users can tag an object with multiple tags.

Simply select "Make
Make Backup...
Backup..." from the "Family
Family Trees
Trees" menu item.

Merging
All primary objects could now be merged.
See Merging Records for more details.
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You can either choose to include the media or not.
Note that this is just a regular XML export, except that no data is filtered out. You
can import these as usual with any exported file.
You can also define the pattern for the backup filename by setting the paths.quickbackup-filename in the ~/.gramps/gramps33/gramps.ini key file like the following:
[paths]
quick-backup-filename='%(filename)s_%(year)d-%(month)02d-%(day)02d.%(extension)s'
More: Pedigree View
• GeoView
More: GeoView

You can use any of the following keywords in the pattern: year, month, day, hour, minutes, seconds, filename, extension.

Automatic update for Addons

Plugins changes

Gramps now supports a method for automatically checking for updated Addons. You
can control what and how often it checks for new and updated addons.
These settings are controlled in Preferences.

Views

News

• Pedigree view

• "Image Metadata Gramplet" now works with pyexiv2-0.1.3 and above

Reports
•
•
•
•
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Performances

Book
Web stuff
Improvements on Place report
StringOption separated from GUI widget 4593
Records report and gramplet 3220

• Improvements (memory leaks) [2]
• time for XML import
• Speed up on gramplets (pedigree)

Localisation

Under the hood changes

•
•
•
•
•
•
•

Database
There were three changes to the database file structure:
1. Added a new field "locality" to the Place schema
2. Added surnames to the Name schema
• surnames is a list of surnames
• prefix and patronymic are moved to the surname
3. Replaced Markers with Tags
• marker removed from all
• tags added to Person, Media, Family, and Notes
• Transaction
• Merging
• New DB version; and XML DTD (1.4.0) [1]
• Improvements on Import/Export file formats (vcard, gedcom, xml)

New translations: Ukrainian, Portuguese from Portugal
Lang selector on Detailed textual reports
Holidays on Calendar reports
Improvements on some Date handlers
Better translation on some addons
cleanup (configure, makefiles)
Better support for win32/64 API

Further info
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.
See the 3.3.0 roadmap, the change log and Roadmap.
• Additional Name Fields [3][4]
• Tagging
• Place handling
• Database (XML /part of GEPS016/, transaction, merging /part of GEPS009/)
• Sidebar/bottombar [5]
• New Individual Editor [6][7]
• Geography
• Enhanced Pedigree View [8] and support 'config' on views into ancestry category
3710.
• Substitution Keys
• Draw reports: Ancestor3.3, Descendant3.3, Page_size3.3

Dependencies
• python 2.6 and later
•

Optional
• exif
• pyexiv2-0.1.3, pyexiv2-0.2.2, or pyexiv2-0.3.0
•
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• Exporter has added control of filters and proxies; also has method for seeing
intermediate results along the filtering process
• New simple backup option on menu
• New gramplets and performance improvements (Pedigree gramplet)
• Url style on Note object (internal uri)
• Automatic check for update (Addons)
• New filter rules
• Complete tooltips on editors and manual
• Use language selector on detailled reports, enhancement on place report,
translated holiday names, numbering system alternatives on descendant report
3635, better support for win32/mac packages, cleanup, need python 2.6 or later,
new translations (Ukrainian, Portuguese from Portugal), etc ...

Previous

Index

Next

This page was last modified on 29 October 2011, at 22:02. This page has been accessed
3,768 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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In this chapter, we'll begin with the basics. We'll show you how to start Gramps and
how to get help when you need it.

reports, do conversion, ..., without opening a window.
Command line use of Gramps can also help to fix problems, as extra information is printed in the terminal
window. To start Gramps like this, type in a terminal:

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions
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gramps
and then pressing ↵ Enter . For more information,
see the Command Line appendix.

Choosing a Family Tree
If Gramps is started without a family tree selected, the initial screen will have little
functionality. Most operations will not be available. To load a family tree (also referred
to as database), select in the menu Family Trees->Manage Family Trees to open the family tree manager, or click the Family Tree icon in the toolbar. Gramps keeps
track of your recently opened Family Trees, and these can be selected by clicking on the
arrow next to the Family Tree button and choosing from the drop down menu.
For more detailed information on the Family Tree manager and the Family Trees
menu, see the chapter dedicated to this: Manage Family Trees.

Next

Start Gramps

Tell me how to start right now!

If you installed Gramps via one of the installation packages, an entry for Gramps will
have been created in the Application menu. In Linux Gramps is normally installed in the
Office section.

We advise everyone to read/go over the manual to learn all the details of Gramps. Genealogy takes time, so learning the tools; is not wasted time.
However, if you really want the bare minimum to start, then read this How-To start
with Genealogy using Gramps.

Command line use
Like many applications that started on Linux, Gramps
allows command line operation, allowing you to create
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• Tip of the day
day: Displays the "Tip of the day" dialog.
• Plugin Manager
Manager: From this menu you can manage the plugins you may have added.
• Gramps Home Page
Page: This item opens your web browser and connects to the Gramps
project web site.
• Gramps Mailing Lists
Lists: This item opens your web browser to the Gramps mailing list
page. On this page, you can browse the mailing list archives and join the grampsusers mailing list so you can share your experiences with other Gramps user's.
• Report a Bug
Bug: Choose this item to file a bug report in the Gramps bug tracking
system. (Remember, Gramps is a living project. We want to know about any
problems you encounter so we can work to solve them for you and everyone elses
benefit.)
• Extra Reports/Tools
Reports/Tools: A link to the Installing Addons in Gramps.
• About
About: This item displays a dialog with general information about the Gramps
version you are running.

Previous

Index

Next

Fig.1.1 Initial window

Obtaining Help
Gramps has a Help menu that you can consult at any time. It includes the following
menu items:
• User Manual
Manual: Direct link to the online Gramps manual you are viewing right now.
Yes, you need an internet connection to consult the Gramps Manual.
• FAQ
FAQ: A link to the Frequently Asked Questions about Gramps.
• Key Bindings
Bindings: A link to the Keybindings reference for Gramps. Also known as
Keyboard shortcuts.

This page was last modified on 29 October 2011, at 08:37. This page has been accessed
2,071 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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Fig. 2.1 Gramps Main Window
• Navigator: The navigator is located at the left of the window and allows selection of
the different categories.
• Progress Bar and Status Bar: These are located at the very bottom of the Gramps
window.
• The Progress Bar is located in the lower left corner of the Gramps window. It
displays the progress of time consuming operations, such as opening and saving
large Family Tree databases, importing and exporting to other formats,
generating web sites, etc. When you are not doing these types of operations, the
Progress Bar is not shown.
• The Status Bar is located to the right of the Progress Bar. It displays information
about current Gramps activity and contextual information about the selected
items.

Introduction
When you open a Family Tree database (either existing or new), the main Gramps window is displayed (Fig. 2.1):
The main Gramps window contains the following elements:
• Menubar: The menubar is located at the very top of the window (right below the
window title) and provides access to all the features of Gramps.
• Toolbar: The toolbar is located right below the menubar. It gives you access to the
most frequently used functions of Gramps. You can set options that control how it
appears by going to the menu Edit ->Preferences . You can also hide the toolbar
entirely by going to the menu View ->Toolbar
->Toolbar.
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• Display area: The area in the center of the Gramps window is the display area. What
it displays depends on the currently selected View. We will discuss Views in detail
below.
• Bottombar: The bottombar is located below the display area.
• Sidebar: The sidebar is located to the right of the display area.

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

TODO
Need to update this content. eg fig 2.1 again?
Fig. 2.1 Gramps Main Window showing Search Bar
The Bottombar and the Sidebar allow gramplets to be displayed alongside a view. (Details to be provided, based e.g. on GEPS_019:_Improved_Sidebar_and_Split_Views and
Gramps 3.3 Wiki Manual - What's new?#GrampsBar and with references to #Filters,
Gramps 3.3 Wiki Manual - Filters and Gramps_3.3_Wiki_Manual_-_Gramplets#Sidebar_and_bottombar)
The Navigator, Toolbar, Sidebar and Bottombar can be individually turned on or off
by options in menu View
View. If the Sidebar is not displayed, then the Search bar is
displayed instead.

The different Categories
Genealogical information is very broad and can be extremely detailed. Displaying it poses a challenge that Gramps takes on by dividing and organizing the information into a
series of Categories, each with their own Views. Each View displays a portion of the total information, selected according to a particular category. This will become clearer as
we explore the different Categories.
The different Categories of the Navigator: The navigator is located at the left of the
window and allows selection of the different categories (See: Fig. 2.1)
•

•

People
People: Displays the people in the family tree without their connections. This
Category contains the PeopleListView and the PeopleTreeView.

•

Relationships
Relationships: Shows the relationships between the Active Person and other
people in a textual way. This includes parents, spouses, and children.

•

Family
Family: Shows the families in the family tree.

•
•

Ancestry
Ancestry: Displays graphical trees for the selected person.
Events
Events: Displays the events in the family tree.

•

Places
Places: Displays the places in the family tree.

•

Geography
Geography: Displays data of your family tree on a map.

•

Sources
Sources: Displays the sources in the family tree.

•

Repositories
Repositories: Displays the repositories in the family tree.

•

Media
Media: Displays the media objects in the family tree.

•
Notes
Notes: Displays the notes in the family tree.
The categories can contain several ways of presenting the data. Each specific way is
called a View. Before we launch into a description of each View, let's first explain how
to switch between Views.

Gramplets
Gramplets: Displays different Gramplets, small widgets that can help in your
genealogical research.
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Switching Views and Viewing Modes

Fig. 2.2 Sidebar view mode
Gramps comes with number of different Categories as standard. New Categories may be
made with plugins you download. There are two different Viewing Modes. You can tell
at a glance which Viewing Mode you are in: If you see icons listed vertically in a sidebar
at the left of the window, you are in the Sidebar Viewing Mode (see Fig 2.2).
When you are in the Sidebar Viewing Mode, you can select the Category you want
by clicking one of the sidebar icons.
Or you can also use the keyboard shorts CTRL + P and CTRL + N go to previous or
next category.
As mentioned, a category can contain different ways of presenting the data, called
a View. If there are several views, you can switch between the views on the toolbar as
each view will have an icon button. You can also switch via the menu View
View, or by pressing CTRL + <number> , where <number> is the view you want in this category.

Fig.2.4 Gramplets view
• Age Stats Gramplet - see age span graphs
• Attributes Gramplets - see active person's attributes
• Calendar Gramplet - see people's events on a particular date, or in a month in the
past
• Descendants Gramplet - see the active person's descendants
• Fan Chart Gramplet - see the active person's pedigree, in a circular fan chart
• Given Name Cloud Gramplet - most popular given names
• Pedigree Gramplet - see a complete pedigree in compressed text
• Quick View - run a Quick View on the current person
• Records Gramplet - see world's records of your data
• Relatives Gramplet - see the relatives of the active person
• Session Log Gramplet - keep track of what you have done, and what records you
have visited
• Statistics Gramplet - see stats on the database
• Surname Cloud Gramplet - most popular surnames as a "text cloud"
• TODO Gramplet - a notepad to keep tabs on your research
• Top Surnames Gramplet - top 10 most popular surnames

Gramplets Category
This contains the Gramplet View, which shows a number of widgets, called Gramplets,
that can help you in your research. Two Gramplets are shown on start-up (the Welcome
and Top Surname Gramplets). By right-clicking on the Gramplet View, a popup comes
up with the possibility of adding other Gramplets.
• Age on Date Gramplet - see the people alive and their ages on a particular date
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• Welcome Gramplet - a GRAMPS welcome message
• What's Next Gramplet - what needs to be done next
In addition, there are a number of additional Gramplets that you can easily install and
use. These include:
• Headline News Gramplet - current, breaking news from GRAMPS
• Data Entry Gramplet - edit active person's name, birth date and place, death date
and place, and add people
• Python Gramplet - a Python shell
• FAQ Gramplet - frequently asked questions
• Note Gramplet - see and edit active person's primary Person Note
and many others. See Third-party Plugins for more details.
For more detailed information on using the installed Gramplets, see Gramplets.

Fig. People ListView
the entire list of people sharing that name. Clicking the indicator again will "roll up"
the list and show only the family name.
By default, the People View List, displays several columns of information about each
person. You can add or remove columns to and from the display by calling up the
Column Editor dialog from the menu View -> Configure View... or click on
toolbar Configu re View... button and then checking or unchecking the
boxes listed. You can also change the position of a column in People View by clicking
and dragging it to a new position in the Editor (drag and drop). Once you have made the
changes you want, click OK to exit the Editor and see your changes in the People
View.

People Category
TreeView and ListView

Column Editor
The Column Editor is available in all Views and works
the same way in each.

Fig. People TreeView (default)

Filters
Genealogical databases can contain information on many people, families, places, and
objects. It is therefore possible for a View to contain a long list of data that is difficult
to work with. Gramps gives you two different means for controlling this condition by
allowing you to filter a list to a more manageable size.
These methods are Search and Filtering
Filtering.

Configuration
The People View lists the people stored in the database(See Fig. People ListView). People are grouped according to their family names. To the left of each family name is typically either an arrow or some other type of indicator (eg: +). Clicking it once will reveal
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Fig. 2.6 Filter Controls Displayed
Alternatively, you can enable the Filter sidebar , which will be displayed
on the right hand side of the display. When the filter sidebar is displayed, the
Search bar is not displayed. The Filter side bar allows you to interactively build
a set of filter rules that can be applied to the display. The filter is applied based on the
rules and the data, not on the screen display.

Searching vs. Filtering
Searching only searches for exact text matches. If the
date displayed is "Jan 1, 2000", a search of "1/1/2000"
will fail, but a filter of "1/1/2000" will match.

Fig. 2.5 Column Editor Dialog
A search will search the text displayed in list, whereas filters display people whose
data match the criteria of the filter. Search is a simple but fast method of searching the
columns displayed on the screen. Typing the characters into the Search box and clicking the Find button will display only lines that match the text.

When Gramps opens a database, no filtering is in effect. In People View, for example, all
people in the database are listed by default.
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Sorting columns

Relationships Category

The Relationships View displays all the relationships of the Active Person (the selected
person). Specifically, it shows his or her parents, siblings, spouses, and children.
The Relationships View is designed to allow for quick navigation. You can quickly
change the Active Person simply by clicking the name of any person listed on the page.
Each name is actually a hypertext link, similar to a web page.
The name of the Active Person is in bold style. Other names are shown either with
or without bold and italic emphasis depending on whether certain relationships exist for
the named person. For a person listed as a parent or spouse of the Active Person, the
name is emphasized if that person has a parent family. For a person listed as a sibling
or child of the Active Person, the name is emphasized if that person has children.
Dates are normally in regular style, and in italic style if the displayed event is a fallback event, i.e., a substitute event for another missing event. That may be christening
event for birth event, burial event for death event, etc.
The Relationships View displays the following sections:
• Active Person: At the top of the screen, name, ID, birth, and death information,
calculated age of the Active Person is displayed. If a photo of the person is available,
it is shown on the right hand side. Next to the person's name is a symbol indicating
gender, and an E dit button. Clicking the Edit button will allow you to edit
all of the person's individual information in an Edit Person dialog.

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

TODO
Need to update this content. To be written.
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• Parents: The next section, the Parents section, displays the families in which the
person is a child. Since it is possible for a person to have multiple sets of parents, it
is possible to have several Parents sections.
You can control how much information is displayed by using the View menu. The view
menu allows you to show or hide details (the birth and death information) and to show
or hide siblings. Next to each person listed is an Edit button, which will allow you
to edit all the details of that particular person.
You may add a set of parents by either selecting the Add Parents or the
Share Parents buttons. The Add Parents button will create a new
family with the Active Person listed as a child. The Share Parents button will
allow you to choose from a list of existing families, and then add the person as a child
to that family.
You may edit an existing parents by selecting the Edit button next to the parents. If you select the Delete button next to a set of parents, then the Active Person will be removed as a child from the parents. This button does not delete the parents' relationship.

relationships between two people. Spouse relationships
are not required to be only between a male and female.

Warning
If you are not careful, it is possible to create multiple
families with the same parents. This is rarely what the
user wants to do. If you attempt to add a new family
that has the same parents as an existing family, Gramps
will issue a warning dialog. If you get this dialog, you
should probably Cancel the edit, and then use the
Select button to select the existing family.
• Family: Similar to the Parents section is the Family section, which displays families
where the Active Person is a parent. Because it is possible to have multiple families,
it is possible to have multiple Family sections. Each family section displays the
spouse and any children.

Fig. 2.8 Relation reordering
You may add a family by selecting the Add Spouse button in the toolbar. This
will create a new family with the Active Person listed as a father or mother.
Selecting the Edit button next to the spouse will allow you to edit the displayed family. Clicking the Delete button will remove the person from the displayed family.

Spouse
We use the term spouse for sake of simplicity. However,
please note that spouse may in fact be a domestic partner, a partner in a civil union, or various other similar
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Families Category

Removing a person from a family
Removing a person from a family does not delete the
family. The person is removed as the father or mother,
and any other relationships in the family continue to
exist.

Note
We use the terms father and mother for the sake of simplicity. Even if there are no children in a family, the father and mother terminology is still used. In the case of
male/male or female/female relationships, the father
and mother labels should be considered to be convenience labels.
You can reorder the parents and spouses by selecting the Reorder button. This
option will only be enabled if more than one set of parents or more than one set of
spouses exists for the Active Person. Selecting this button will display a dialog that will
allow you to reorder the families.

Configuration

The Family List View displays a list of all families in the database(see Fig. 2.9). From
this view, you may add, edit, or delete families. The default display lists the ID, Father,
Mother, Relationship and Marriage Date. Children cannot be displayed on the screen in
this view.

Fig. Configure Relationships View

Remove button

You can configure the view from the display by calling up the Configure dialog
from the menu View -> Configure... or click on the toolbar Configure
View... button.

Unlike the Relationships View, clicking the Remove
button in this view will remove the family from the
database. All people will remain, but all relationships
between the people in the family will be removed.
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Ancestry Category
The Ancestry Category shows several graphical representations of the ancestry of the
active person. By default Gramps shows the Pedigree View; With the Fan Chart View being selectable from the toolbar. Installation of additional downloadable addons contain
extra views.

Pedigree View

Fig. 2.11 Pedigree view layout
The appearance of the children's names in the menu differentiates the dead ends of
the tree from the continuing branches.
Children who have children themselves appear in the menu in the boldface and italic type, while children without children (dead ends) appear in a regular font. If the
Active Person has only one child, no menu will be displayed (since there is only one
choice) and the child will become the Active Person when the arrow button is clicked.
The right-hand side of the window shows two right arrow buttons. When the top
button is clicked, the Father of the Active Person becomes the Active Person. When the
bottom button is clicked, the Mother of the Active Person becomes the Active Person.
Right-clicking on any person's box in the Pedigree View will bring up the "context
menu".

Fig. 2.10 Pedigree view 1
The Pedigree View shows up to five generations, depending on the size of the window.
Each person is indicated by a box labeled with his or her name, birth and death information, and optionally an image if available. Two lines branch from each box. The top one
shows the person's father and the bottom one the mother. Solid lines represent birth
relations, while dashed lines represent non-birth relations such as adoption, step-parenthood, guardianship, etc.
To the left of the Active Person is a left arrow button. If the Active Person has children, clicking this button expands a list of the Active Person's children. Selecting one
of the children makes that child the Active Person.
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Fig. 2.12 Pedigree view 2

Fig. 2.13 Pedigree view 3

Among other useful items, the context menu has sub-menus listing Spouses ,
Siblings , Children , and Parents of that person.
"Greyed-out" sub-menus indicate the absence of the data in the appropriate category. Similar to the children menu above, Childrens' and Parents' menus distinguish continuing lines from dead ends.

Events Category

Fan Chart View
This view shows the ancestry but as a pie chart. Clicking on a name in the chart will double the section of the pie allocated to that person. A second click brings the chart back
to the original form. Right click brings up a context menu like in the pedigree view, allowing to navigate to other people.
This view enables to see large ancestries in a more compact manner, and to see very
quickly which parts of an ancestry need further research.
You can rotate the view by click and drag outside the fan chart. You can move the
view by click and drag inside the inner (white) region.
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Fig. 2.14 Pedigree view 4
Events can be shared between multiple people and multiple families. The Events View
lists the all the events recorded in the database.
The columns available for display are: Description , ID , Type ,
Main Participants , Date , Place and Last Changed .
The default view displays the Description , ID , Type , Date and
Place of the event. The Column Editor dialog can be used to add, remove
and rearrange the displayed columns. This can be accessed from the Configure
View... button on the toolbar.

Fig. 2.15 Children menu
The list of Events can be sorted in the usual manner, by clicking on the column heading.
Clicking once sorts in ascending order, clicking again sorts in descending order.

Meaningful event description
Because events can be shared, you should take the extra
time to give each event a unique and meaningful description. This will help you find the correct event if
you decide to share events.
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Fig. 2.16 Personal context

Fig. 2.17 Fan Chart View
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Sources Category

Places Category

Fig. 2.20 Places view
Sources View lists the sources of certain information stored in the database.
These can include various documents (birth, death, and marriage certificates, etc.),
books, films, journals, private diaries, - nearly anything that can provide genealogical
evidence. Gramps gives you the option to provide a source for each event you record
(births, deaths, marriages, etc.). The Sources View lists the Title , ID , and
Author of the source, as well as any Publication information that may be
associated with it.
The list of Sources can be sorted by clicking on a column heading.
Clicking once sorts in ascending order, clicking again sorts in descending order. The
Column Editor dialog can be used to add, remove and rearrange the displayed
columns.

The Places Views lists the geographical places in which the events of the database took
place. These could be places of birth, death, and marriages of people, as well as their
home, employment, education addresses, or any other conceivable reference to the
geographical location. The Places View lists the places' Name , ID , Church
Parish , City , County , State , and Country . All of these
columns can be used for sorting by clicking on a column heading.
Clicking once sorts in ascending order, clicking again sorts in descending order. The
Column Editor dialog may be used to add, remove and rearrange the displayed
columns.
If a place has been highlighted, you may select the Google Maps, loading... button to attempt to display the place in a web browser. The map service
can be chosen from the drop down list under the black triangle to the right of the map
button.
Your default web browser should open, attempting to use either the longitude and
latitude coordinates or the place name to display the location using the Google Maps
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Geography Category

web site. Different map services might have different requirements for the location description.
This feature is limited, and may not always produce the results you desire.

Note
The Geography category is only present if OsmGpsMap
is present that Gramps can use.

PlaceTreeView and PlaceListView

Fig. 2.21 Places TreeView

Fig. 2.22 Places ListView
This category is for showing data on a map. It contains the Geographic View, which
allows you to see the people and their events placed on a map via an internet map
provider (OpenStreetMap or Google maps).
The Geographic View can:
• show all places in your family tree
• show a filtered selection of places

The two views in this category show the places grouped or ungrouped. The
PlaceTreeView tries to group the places in logical groups: country, county, ... .
This view is new in Gramps version 3.3.0. (In future versions the aim is to make the
grouping more intelligent. ???)
The PlaceListView on the other hand just shows all the places in one long list.
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• show all places connected to the active person
• show all places connected to the active family
• show all places connected to all events
• show all places connected to a filtered selection of events
These options are accessible via the buttons on the toolbar. To filter on places or events,
activate the filter sidebar via the menu View->Filter Sidebar
Furthermore, the Geographic view can help you add new places to your family tree,
or add latitude-longitude coordinates to existing places. To activate this, use the add
location button, or the link location button in the toolbar.
The top of the Geographic View shows two lines with information, allowing you to
change the information shown. The second line always shows in bold what is shown on
the map.
The first line has:
• Place list button and selection field.
The button shows how many places are present in the map. The selection fields
allows you to jump to one of these places. You can clear the selection field by
clicking the places list button.
•

• lock zoom level.
If you zoom the map to a resolution you want to keep, then you can press the
lock zoom level button, and every time the Geographic View redraws the map,
this zoomlevel will be used.
• provider selection change
Gramps uses OpenStreetMap or Google Maps to provide the map that is
displayed. With this button you can quickly change from one to the other. The
advantage of OpenStreetMap is that it is a free project, so you can update the
maps yourself with missing information via their website.
Via the toolbar Configure View... button (or via the menu View
View, the following functionality is available:
• Map options
• add crosshair in center of map, usefull to add or link places to the correct
latitude-longitude coordinates
• show coordinates in the statusbar
• Time period: this changes how the view divides events in groups
• Network: This view needs an internet connection. If your connection drops away
from time to time, or is not always on, you can set here to have the Geographic
view retry the internet connection. Like this, the Geographic view will become
active the moment your internet connection returns, without you needing to take
manual action.

Place page buttons
If there are many places, the map is no longer useful because too much
information is shown. Therefore, the places will be divided in pages. You can
navigate the pages and see the map change via the Place page buttons: <<
goes back a page, >> goes forward a page, and the middle button shows how
many pages there are and what is shown at the moment.

• Places with no latitude-longitude
The Geographic View can only show places with a valid latitude-longitude. A list
of all places that satisfy the selection, but cannot be put on the map, is available
via the button with a number and the ? sign. You can add latitude-longitude to
these places in one of the following ways:
• Use the place link button on the Geographic View
• Go to the Place View, and use the Go button to search the place and it's
location
• Download the Place completion tool via the menu Help->Plugin Manager
Manager. If
you download the data of your country, this tool can add latitude-longitude to
all your places.
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Media Category

Repositories Category

The Media View is a list of Media Objects used in the database.
Media Objects are any files that relate somehow to the stored genealogical data.
Technically, any file can be stored as a Media Object.
Most frequently, these are images, audio files, animation files, etc. The list box on
the bottom lists the Name , ID , Type , and Path of the Media Object.
The Column
Editor dialog may be used to rearrange the displayed
columns, which obey usual sorting rules. The top part of the Gramps window shows a
preview (if available) and information about the Media Object.

A repository can be thought of as a collection of sources.
Each source in the database can reference a repository (such as a library) in which
it belongs. The functionality of the Repositories View is similar to the other views.

Notes Category
A Note is pure text, as stored in the other objects.
The functionality of the notes View is similar to the other views. The view lists all
Notes stored in the Family Tree . Using the menu View ->Configure View...
you open the Column Editor and you can change the displayed columns. The
possibilities are Preview , ID , Type and Marker .
The Type can be (amongst others): Event Note, Address Note,Source text, Place Note
Double-clicking on a Note in the list will bring up a window where you can edit the
Note. You can change fonts, font color and background color. A spellchecker is available
for English and your local language.
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Fig. 2.26 Notes view
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This page was last modified on 1 November 2011, at 05:59. This page has been accessed
3,875 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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From Gramps
Jump to: navigation, search
Now we turn to a detailed exploration of the day-to-day use of Gramps. In this Chapter
we give a detailed overview of how you can manage your family trees, as well as share
your data with other genealogists.
Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

Fig. 3.3. Starting Family Trees
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Opening a Family Tree
To open a Family Tree, either choose the menu Family Trees ->Manage Family Trees...
or click the Toolbar Family Trees button. The Family Tree Manager will appear and you will see a list of all the Family Trees known to Gramps. In the
Status column an icon (looks like an open folder) will display beside any Family
Tree that is currently open. Select the tree you want to open, and open it by selecting
the Load Family Tree button. Alternatively you can double-click on the desired Family Tree.
To open a recently accessed Family Tree, choose either the menu Family Trees >Open Recent or the down arrow next to the Toolbar Family Trees button and
select the Family Tree from the list.

Starting a new Family Tree
To start a new Family Tree, choose the menu Family Trees ->Manage Family Trees... or
select the toolbar Family Trees button. This will open the Family Tree Manager (See Fig. 3.3).
Select the New button and Gramps will add a new Family Tree entry to the list of
Family Trees. To change its name from the default Family Tree 1, click on the name and
type in a new name.
Now select Load Family Tree to open the new, empty Family Tree.
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Deleting a Family Tree

Read Only Mode
If you do not have "write permissions" for the selected
Family Tree, it will be opened in a Read Only mode. In
this mode, the data may be viewed, but no changes will
be made to the Family Tree. To indicate this mode, the
title of the main window will be appended with (Read
Only) text.

Select the family tree you want removed, and click the Delete button.
This will completely remove the tree, with no possibility to retrieve the data. Consider taking a backup of your data by exporting to the GRAMPS XML format, and storing
that file.

Renaming a Family Tree
You can rename a Family Tree (or an archive of it) by selecting the tree you want to rename and clicking Rename . You can also click on the name in the list of trees.
In either case, you just type in the new name to have it take effect.

Opening a GEDCOM or XML database
Gramps allows you to open certain databases that have not been saved in Gramps own
file format from the command line, see Command line references. These include XML
and GEDCOM databases. But you should be aware that if the XML or GEDCOM database is
relatively large, you will encounter performance problems, and in the event of a crash
your data can be corrupted. Hence, it is normally better to create a new Gramps family
tree (database) and import your XML/GEDCOM data into it.

Backing up a Family Tree
• The safest way to backup your Gramps Family Tree is to export without privacy
options and filters to Gramps XML format (or Gramps XML Package to include
items from your Gallery) and copy the resultant file to a safe place, preferably in a
different building.

Opening databases
XML and GEDCOM databases require all data to be held
in memory and don't contain indexes. Gramps native
format is a database that only reads the data needed.
Thus, for a large family tree the data can be accessed
quicker and more efficiently by not using XML or
GEDCOM.

Backup dialog
Simply select the menu Family Trees->Make Backup..."
Backup...".

GEDCOM Editing
Please keep in mind that some information in a
GEDCOM file may be lost during import into Gramps as
well as export back to GEDCOM. Simply opening and
viewing the file will not change it. However, if any
changes were made and they were not abandoned upon
exit, exiting Gramps will save the data, with possible
data loss.

You can either choose to include the media or not.
Note that this is just a regular XML export, except that no data is filtered out. You
can import these as usual with any exported file.
You can also define the pattern for the backup filename by setting the paths.quickbackup-filename in the ~/.gramps/gramps33/gramps.ini key file like the following:
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Extracting a Family Tree Archive

[paths]
quick-backup-filename='%(filename)s_%(year)d-%(month)02d-%(day)02d.%(extension)s'
You can use any of the following keywords in the pattern: year, month, day, hour, minutes, seconds, filename, extension.
• You can use the Archive feature (see next section) to store snapshots of your Family
Tree. These snapshots can be used as simple backups, very useful if you want to try
something that you might later want to undo. However this method should not be
used for standard backups, as it will not survive a hard disk crash or most of the
other disasters that can befall a computer.
• For advanced users: each database is stored in its own subdirectory under ~/.gramps.
A manual backup can be made by backing up this directory.

Archiving a Family Tree

Fig. 3.3 Selecting a version to extract

You can easily archive and timestamp family trees with Gramps built-in use of GNU Revision Control System or RCS. For this to be possible this utility must be installed on
your computer.
To make an archive :
1. load your Family Tree.
2. click on the Toolbar Family Trees button (it has the Gramps logo
and displays Manage databases when you hover over it).
3. click on the family tree you've just loaded: the Archive button should
appear.
4. click on Archive and you will be asked for an archive name.
After archiving, the list of family trees will now show your original family tree with a
right-pointing triangle on its left.
• Click on the triangle to display the archive name.(Click again to collapse the
archive list).
Archives can be deleted, renamed and Extracted.

Simply highlight the archive you want to restore, and select the Extract button.

Fig. 3.3 Extracted version
Gramps will transfer the archive into a new Family Tree. The Family Tree name is
based on the original name and the archive name (see also Archiving a Family Tree).

If you click on an archive, the Extract button becomes visible. Click on this to
obtain the extracted archive. It will appear in the family tree list as <name of original
tree>:<name of archive> and is now an independent family tree. This can be a useful way
of preserving an archive, because archives disappear if the originating tree is deleted;
and they are not incorporated into a Portable Gramps XML export of the tree.
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Unlocking a Family Tree

Saving changes to your Family Tree

When Gramps opens a tree, it locks the tree, preventing you or anyone else opening it
at the same time. A second copy of Gramps will be able to open another family tree,
but the tree already open will appear with the lock icon, indicating you cannot open it.
Closing the tree in the first copy of Gramps will make it available to be opened in the
second copy.
If you could open the same Family Tree in two Gramps at once, it is likely your data
would be damaged.
In the unlikely event of a crash of Gramps, the family tree will be left in a locked
state. To unlock the tree, select the locked family tree, and click the Unlock button
that will be available. Only do this if you are sure no other copy of Gramps is using this
Family Tree.

Gramps saves your changes as soon as you apply them. This means, for example, that
any time you click OK when using Gramps, your changes are immediately recorded
and saved. There is no separate "save" command.
You can undo changes you have made by selecting the menu Edit ->Undo
->Undo. If you select this command repeatedly, your most recent changes will be undone one at a time.
To roll back multiple commands at a time, you can use the menu Edit dialog.
If you want to return your Family Tree to the way it was when you opened it, select
the menu Family Trees ->Abandon Changes and Quit
Quit. (This is just like quitting without
saving in other programs.)
If you would like to save a copy of your Family Tree under a different name, you will
need to export it and then import it into a new Family Tree. The Gramps XML database
format is recommended for this purpose.

Repairing a damaged Family Tree

Importing data
Importing allows you to bring data from other genealogy programs into a Gramps database. Currently, Gramps can import data from the following formats:
• Gramps XML (.gramps file extension)
• Gramps XML Package (.gpkg file extension)
• GRAMPS CSV Spreadsheet - comma separated values (.csv file extension)
• GRAMPS V2.x database (.grdb file extension)
• GEDCOM (.ged file extension)
• GeneWeb (.gw file extension)
• Pro-Gen (.def file extension)

Importing vs. opening
Should your Family Tree become damaged or corrupted in some way, Gramps Family
Tree Manager will display a red Error icon in the Status column.
To have Gramps attempt to repair the damage, select the Family Tree and then click
the Repair button.
This will attempt to rebuild your Family Tree from the backup files that are automatically created on exit.

Please recognize that importing a database is different
from opening a database. When you import, you are actually bringing data from one database into a Gramps
database. When you open a file, you are editing your
original file.
To import data, select the menu Family Trees ->Import . The Import database dialog will
open, asking you to specify the file you wish to import.
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Note that you can only import data into an existing database so if you are transferring all your data from another program or from an older version of Gramps, then first
create a new empty database and then import the data into it.

very quick and efficient, but not generally portable across computers with different
binary architecture (e.g. i386 vs. alpha).
If you import information from another Gramps database or Gramps XML database,
you will see the progress of the operation in the progress bar of Gramps main window.
When the import finishes, a feedback window shows the number of imported objects.
If the imported data originates from the very family tree in which you import the data,
the import feedback gives suggestions about what could be merged; the merge is not
done automatically for you. If you want to merge basic genealogy data automatically,
consider CSV Spreadsheet Export/Import.
The GRAMPS CSV Spreadsheet format allows importing and exporting of a subset of
your Gramps data in a simple spreadsheet format. See CSV Import and Export for more
information.

Data loss with some formats
It is important to note that the importing process is not
perfect for GEDCOM and GeneWeb databases. There is a
chance that some of the data in these databases will not
be imported into Gramps.

Order "up side down" Events generated under other programs

Exporting data

Gramps provides an help for ordering events according
to your preferences. See Sort Events tool.

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

The Gramps XML, Gramps XML Package and GRAMPS V2.x database are all native
Gramps formats. There is no risk of information loss when importing from or exporting
to these formats.
• Gramps XML (.gramps): The Gramps XML file is the standard Gramps dataexchange and backups format, and was also the default working-database format
for older (pre 2.x) versions of Gramps. Unlike the GRAMPS V2.x grdb format, it is
architecture independent and human-readable. The database may also have
references to non-local (external) media objects, therefore it is not guaranteed to
be completely portable (for full portability including media objects in the Gramps
XML package (.gpkg) should be used). The Gramps XML database is created by
exporting (Menu Family Trees ->Export...
->Export...) to that format.
• Gramps XML package (.gpkg): The Gramps XML package is a compressed archive
containing the Gramps XML file and all media objects (images, sound files, etc.) to
which the database refers. Because it contains all the media objects, this format is
completely portable. The Gramps XML package is created by exporting ( Menu
Family Trees ->Export... ) data in that format.
• GRAMPS V2.x database (.grdb): Prior to Gramps Version 3.3, this native Gramps
database format was a specific form of the Berkeley database (BSDDB) with a special
structure of data tables. This format was binary and architecture-dependent. It was

TODO
Need to update this content. Images out of date.
Exporting allows you to share any portion of your Gramps database with other researchers as well as to enable you to transfer your data to another computer. Currently,
Gramps can export data to the following formats: Gramps XML, GEDCOM, Gramps XML
Package, Web Family Tree, GeneWeb, and CSV Spreadsheet formats.

Export is saving a copy
When you export, you are saving a copy of the currently opened database. Exporting creates another file with
a copy of your data. Note that the database that remains
opened in your Gramps window is NOT the file saved by
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• Do not include records marked private: Check this box to prevent private records
from being included in the exported file.
• Restrict data on living people: Check this box to limit the information exported for
living people. This means that all information concerning their birth, death,
addresses, significant events, etc., will be omitted in the exported file. If you choose
this option, you will be given additional options to limit further the data on living
people. For example, you can choose to substitute the word Living for the first
name (see your settings); you can exclude notes; and you can exclude sources for
living people.
• Do not include not related records: Check this box to prevent not related records
from being included in the exported file.
Sometimes, it is not always obvious from the data if someone is actually alive. Gramps
uses an advanced algorithm to try to determine if a person could still be alive. Remember, Gramps is making its best guess, and it may not always be able to guess correctly all
the time. Please double check your data.

Export into Gramps formats
Privacy Filters

Fig. 3.5 Export assistant: format selection

It is important to verify your privacy options on Exporter. Do not enable filters or privacy options for
Gramps XML backups.

your export. Additional editing of the currently opened
database will not alter the copy produced by the export.

• Gramps XML database export (.gramps): This format is the standard format for
data-exchange and backups (see the related .gpkg format below for full portability
including media objects). Exporting into Gramps XML format will produce a
portable database. As XML is a text-based human-readable format, you may also use
it to take a look at your data. This format is compatible with the previous versions
of Gramps.
• Gramps package export (.gpkg): Exporting to the Gramps package format will
create a compressed file that contains the Gramps XML database and copies of all
associated media files. This is useful if you want to move your database to another
computer or to share it with someone.
• Export to CD: Exporting to CD will prepare your database and copies of all media
object files for recording onto a CD. To actually burn the CD, you will need to go to
the GNOME burn:/// location, which can be accessed by navigating through

To export data, choose Menu Family Trees ->Export... . This will bring up the Export
Assistant . Its pages will guide you through the format selection (see Fig 3.5), file
selection, and format specific export options. After a final confirmation page, the export will be performed according to the choices you have made. At any time, you can
click the Back button and revise any selection, and then go forward to redo the export.

Filters and privacy
Gramps allows you to export a database into common file formats.
It provides options that allow you to fine tune your export.
• Filters on People and Notes: Filters allow you to export a limited amount of data,
based on the criteria you select.
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Nautilus: After exporting to CD, select Go ->CD Creator in the Nautilus menu. Your
database directory will show up. To burn it to the CD, click the CD icon on the
Nautilus toolbar, or select File ->Write to CD in the Nautilus menu.
If a media file is not found during export, you will see the same Missing Media
dialog you encounter with GEDCOM export.

• Do not include records marked private: Check this box to prevent private records
from being included in the exported file.
• Restrict data on living people: Check this box to limit the information exported for
living people. This means that all information concerning their birth, death,
addresses, significant events, etc., will be omitted in the exported file. If you choose
this option, you will be given additional options to limit further the data on living
people. For example, you can choose to substitute the word Living for the first
name (see your settings); you can exclude notes; and you can exclude sources for
living people.
• Do not include not related records: Check this box to prevent not related records
from being included in the exported file.

Exporting into the GEDCOM format
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Export into other formats
• Web Family Tree: Exporting to Web Family Tree will create a text file that can be
used by the Web Family Tree program. Export options include filter selection and
the ability to limit data on living people to that of their family ties.
• GeneWeb: Exporting to GeneWeb will save a copy of your data into a popular web
genealogy format. To find out more about GeneWeb and its format, visit
http://cristal.inria.fr/~ddr/GeneWeb/en/.
• vCalendar and vCard: Exporting to vCalendar or vCard will save information in a
format used in many calendaring and addressbook applications, sometimes called
PIM for Personal Information Manager.
• GRAMPS CSV Spreadsheet format: Allows exporting (and importing) a subset of
your GRAMPS data in a simple spreadsheet format. See CSV Import and Export for
more information. Also, see Export Display .

Moving a Gramps 2.2 databases to Gramps 3.x
There are two ways of moving your Gramps data from version 2.2 to version 3.x; either
directly importing your version 2.2 grdb file or by exporting to Gramps XML format
first. Because of complexity in the way that version 2.2 stores data, exporting to Gramps
XML is usually the most convenient and problem free way of moving your data to
Gramps version 3.x.
• Import 2.2 grdb file: In a Gramps 2.2 database, your data is stored in a grdb file
along with one or more log files that are kept in directories found in the .gramps/

Gramps allows you to export a database into the common GEDCOM format. It provides
options that allow you to fine tune your export (see Fig.3.5).
• Filters on People and Notes: Filters allow you to export a limited amount of data,
based on the criteria you select.
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env directory. To import your 2.2 data directly into Gramps 3, create a new
database and select the option to import a Gramps 2.2 database. You need to make
sure that you are running Gramps 3 from the same user you used to run Gramps 2.2
so that it has access to the same .gramps/env directory containing the log files that
supplement your database. If you are running Gramps 3 from a different user or on
another machine you need to make provisions to make the same .gramps/env
directory and log files available. If you get an error saying "/tmp/tmpDkI5pO could
not be opened" or something similar when attempt to import your database then it
means that Gramps 3 cannot see all of the files that constitute your database.
• Gramps XML: With this approach firstly start up Gramps 2.2 and export your
database to the Gramps XML format. The XML file is actually compressed and
contained in a .gramps file. This file is portable, has no other dependent files and
can be moved to wherever you have Gramps 3 installed. Next, start Gramps 3 and

create an empty database using the Family Tree Manager and import the .gramps
file.

Previous

Index

Next

This page was last modified on 30 October 2011, at 01:45. This page has been accessed
2,434 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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This section is designed to give you the basic knowledge necessary to start putting your
genealogical information into Gramps. It will explain how to enter people into the database and how to specify their family relationships. (A more detailed explanation will
follow in the next chapter: Gramps 3.3 Wiki Manual - Entering and Editing Data: Detailed.)

• Information about an individual's parents and children
• Sources that document your research

Keybindings (Keyboard Shortcuts)
In addition to interacting with Gramps through menu
items and buttons, you can use its extensive set of "keybindings." For more information, see Appendix B: Keybindings reference.

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

Previous

Index

Now let us take a quick look at how you can enter and edit these various types of information.

To add or edit a person
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Next

Introduction
First, let us identify the types of information you can enter into your Gramps database.
These include:
• Personal information about an individual (names, addresses, birth and death dates,
etc.)
• Information about an individual's relationships (marriages, divorces, civil unions,
etc.)
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To edit information about a person already present in the database, select the person from the People View and click the Toolbar Edit button.

Alternate ways of adding or editing a person from
the People View
You can also use the Menu Edit->Add... and other items
available under Edit. Or you can right-click on the person and select Add... or Edit... from the
context menu that pops up.
People can also be added to the database in the Relationships View, Edit
Family dialog, and other places where it makes sense.

To specify a relationship

There are two primary ways to specify relationships between people - using the Relationships View and using the Edit Family dialog from the Family List View. The Family List is usually used to build all the relationships within a single family at a time. The Relationships View is usually used
to build multiple relationships to a single person.
To specify a new relationship to the Active Person, switch to the Relationships View (See family-fig) and you will see this individual indicated as the "Active
Person". Next to the Family label is a Add button (typically represented by a

There are multiple ways to add a person to the database. We will cover some of them
as we proceed. The simplest way to enter a person to add them from the People
View. While you are in the People View (see side-nofilt-fig ), click the Toolbar
Add button. Enter any data you know about this person into the Edit Person dialog (see edit-pers-fig for details).
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+ sign). Clicking the Add button will display the Edit Family dialog with
the Active Person set as either the father or the mother.

To search a person on dialog selector
Remember that you can get an entry on the list by
typing the first letter on your keyboard. (see Finding
records)

Now a question ?: Does the person who will form the relationship with the Active
Person already exist in the database? If yes, click the Select button to the other
person. You will then be able to browse through the list of people in the database to select the one you want. If not, click the Add button. This will allow you to add a new
person to the database and to specify the relationship this person has to the Active Person.

Fig. 4.2 Selecting a person

Filtering

To edit an existing relationship from the Relationships View, click on the
Edit button next to corresponding Family entry. If there is more than one relationship in the list, you can select the spouse or partner you want by clicking the corresponding Edit button next to the relationship.
To specify a new relationship in the Family List View, click on the Add
button on the toolbar, and an empty Edit Family dialog will open. At this
point, you can add people to the family.

By default, Gramps filters the displayed list to show only those people who could theoretically have a relationship with the Active Person. That is, Gramps only shows
those people whose birth dates and death dates fit within the lifetime of the Active Person. If you wish, you
can add a person to the list by clicking the + button.
To completely override the filter and display all people
from the database, check the Show all box.
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To specify parents

Warning
If you create a new family and select parents that are already in an existing family, Gramps will issue a warning
message. If you proceed by saving the new family, you
will have a duplicate family.

You can also specify the parents of a person in the Family List View. If the
family already exists, click on the Toolbar Edit button and add the person as a child
when the Edit Family dialog is displayed. If the family does not already exist,
click the Add button to create a new family, and add the appropriate parents and
children.

family-fig
You can specify Active Person's parents in the Relationship View (See
family-fig). A little care is required to prevent the creation of duplicate families. If
you wish to add the Active Person to an already existing family, you should click the
Select button. If the family including the parents does not already exist, you
should click the Add button.
If you click on the Select button, you are presented with the Select
Family dialog. This will allow you to select the existing family, and then the Active
Person will be added as a child to the family.
If you click on the Add button, a new Edit Family dialog is presented
with the Active Person listed a child of the new family. You can add the parents to the
family by either adding new people as the parents or selecting existing people as the
parents.
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To specify children

Adding photos and other media objects
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.
You can add photos and other media objects to individual people, events, sources, and
places. You can also add images that might not be limited to a single person or event
(for example, group family photos).
If you want to add an image to a single person, switch to the People View
(mainwin-fig), select a person, and then click the Edit icon on the toolbar. This will
bring up the Edit Person dialog (edit-pers-fig). Next, select the Gallery
tab, and click the + button to call up the Select a media object dialog.
Type a filename or browse to find the image file you want and then provide a title for
that image. Keep adding images until you are done.
To add images related to a relationship (for example, a marriage), switch to the
Family View (family-fig) and double-click on the Spouse box. This calls up the
Marriage/ Rel ationship editor dialog. Select the Gallery tab
and click the + button to add an image.
To add images related to a source or a place, first switch to the Source View
(sources-fig) or Place View (places-fig). Select the source or place you want and
then either double-click on it or click the Edit icon on the toolbar. Select the
Gallery tab and click the + button to add an image.
Finally, to add images that you want to include in the database, but hare are not
limited to any particular person, relationship, source or place, switch to the Media
View (media-fig). Then click the Add icon on the toolbar to add an image. If you have
already added any images to any individual galleries, you will also find them listed in
the Media View.

Adding children to a relationship is done through a similar procedure. From the Relationships View or the Family List View, select the existing family
or create a new family. Children can be added by selecting the Add button or
Select button to the right of the child list.
Clicking the Add button will display the Edit Person dialog, allowing
you to enter a new person. Clicking on the Select button, will allow you to select
an existing person from a list. By default, the child is added with a the relationship type
of birth to both parents.
If you wish to change the parent/child relationship from the default setting of birth,
select the child and click on the Edit button . This will display the Edit
Child Reference dialog.
If you wish to change the order of the children in the family, use the arrows or the
drag and drop function on Family Editor .

Alternate way of adding images to galleries
An image can always be added to any gallery by using
drag-and-drop. Items can be dragged from the Media
View, any gallery, the desktop, the file manager or a
web browser and dropped on the target gallery, adding
the image to the gallery.
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In any gallery, you can also use the Edit to edit image information and the - button and to remove the image reference from that gallery.

the Event Editor ( Source Editor , Place Editor , or Repository Editor ) dialog.
To edit information about events, sources, places, and repositories already present
in the database, switch to the appropriate view, select an entry you would like to view/
modify, and then click the Edit icon on the toolbar. Alternatively, you may doubleclick on the entry to edit it.

Removing an image from a gallery
Removing a media object from a gallery does not remove the image from the database. To completely remove the image from the database, delete it from
Media View by first selecting it and then clicking
the Remove icon on the toolbar.

Previous

Index

Next

To edit events, sources, places, and repositories
To add an event, a source, a place, or a repository to the database, switch to the appropriate Events View ( events-fig), Sources View (sources-fig), Places
View (places-fig), or Repositories View (repository-fig). Then click the
Add icon on the toolbar to add the corresponding object. Enter the information into

This page was last modified on 26 October 2011, at 05:30. This page has been accessed
1,214 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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The previous section offered you a quick overview of how to enter and edit data in
Gramps. This section continues that discussion in much greater detail.

A dialog often includes a series of "notebook tabs" that group the information into
subcategories. For example, the Edit Person dialog has notebook tabs for subcategories
such as Events, Attributes, Addresses, and Notes, among others.

Add, Remove, and Edit buttons
Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions
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In most cases, Gramps uses a + to correspond to
Add+ , a - correspond to Remove , and an
icon of a pen on a sheet of paper to denote Edit . We
will continue referring to the latter as the Edit+
button, while using + and - to denote the two former buttons.

Details
1. Gramps 3.3 Wiki Manual - Entering and Editing Data: Detailed - part 1: Learn
how to add persons, dates, families and relationships to Gramps
2. Gramps 3.3 Wiki Manual - Entering and Editing Data: Detailed - part 2: Learn
about the other core objects in Gramps: events, sources, places, repositories
and notes
3. Gramps 3.3 Wiki Manual - Entering and Editing Data: Detailed - part 3: Learn
how attributes and addresses work, as well as how you can merge data.

Next

Introduction
As we have seen above, Gramps offers you a series of Views. Each of these Views gives
you opportunities to enter and edit information. In fact, you can often get to the same
information from different Views.
In Gramps, information is entered and edited through what we call dialogs. Since
we use that term frequently, we should define what we mean by it:
A dialog is a pop-up window that provides one or more forms for entering and editing data that fits a certain category. Examples in Gramps include the Edit Person dialog and the Family Editor dialog, among many others.
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The previous section offered you a quick overview of how to enter and edit data in
Gramps. This section continues that discussion in much greater detail.

A dialog often includes a series of "notebook tabs" that group the information into
subcategories. For example, the Edit Person dialog has notebook tabs for subcategories
such as Events, Attributes, Addresses, and Notes, among others.

Add, Remove, and Edit buttons
In most cases, Gramps uses a + to correspond to
Add+ , a - correspond to Remove , and an
icon of a pen on a sheet of paper to denote Edit . We
will continue referring to the latter as the Edit+
button, while using + and - to denote the two former buttons.

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

Editing information about people
An overview of the elements
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Information about people is entered and edited through the Edit Person dialog. This dialog can be invoked from different Views in the following ways:
• From the People Category:
Double-click the name of the person whose data you would like to edit

Next

Introduction

Select the name by single click and then click the Edit buttton on the
toolbar.

As we have seen above, Gramps offers you a series of Views. Each of these Views gives
you opportunities to enter and edit information. In fact, you can often get to the same
information from different Views.
In Gramps, information is entered and edited through what we call dialogs. Since
we use that term frequently, we should define what we mean by it:
A dialog is a pop-up window that provides one or more forms for entering and editing data that fits a certain category. Examples in Gramps include the Edit Person dialog and the Family Editor dialog, among many others.

Select the name and then press Enter .
Select Edit... from the Edit menu of Gramps
Select Edit from the context menu that appears upon right-click on the
name.
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Note
Clicking OK will immediately save changes to the
database. There is no need for a Save operation, since
all changes are immediate.

Tip
If a tab label is in boldface type, this means it contains
data. If not, it has no data.

Preferred name section
The preferred or default name is the name that will be used in Gramps for the 'name' of
the person. You can set in the Gramps Preferences how a name is displayed, and in most
places you will see only the preferred name. Only detailed reports (textual and Narrative Web site generator) show also the alternate names. Note however that searching
on a name will search in all names attached to a person, not only the preferred name.
The preferred name section contains the typical name information you will edit on
creation of a person. Not all possible name information is shown here, only the most
used fields. To see the full range of data you can store about a name, click the edit button after the Preferred name label. This will show the Name Editor.
The name fields of the preferred name in the Person Editor are:
• Given name , the person's given name
• Family name , the part of a person's name indicating the family to which
the person belongs
• Family prefix , an optional prefix for the family name that is not used in
sorting, such as de or van and Suffix , an optional suffix to the name, such as
Jr. or III, selector
• Patronymic , which is the component of a personal name based on the name
of one's father, grandfather, and Title , which is a title used to refer to the
person such as Dr. or Rev., selector,
• Call name , officially this is the part of the given name that is the normally
used name. Eg, a person can have 3 given names as in Jean Baptiste Jules, where in
reality only Baptiste is used. In Germany and some other places, it was customary to

Fig. 5.1 Edit person
• From the Relationships: To edit the Active Person's data, click on the Edit button
next to the Active Person's name.
• From the Ancestry Category: Double-click in the box having the name of the person
whose data you want to edit.
In each of the above cases, the Edit Person dialog will appear:
The top of the window has two parts: The basic information about the Preferred
name of the person, and a section General with the privacy button (to set the
record as private), the gender selector, an ID you can give this record, and a marker you
can assign to the person indicating the state of the record (complete, TODO, uncertain,
....) which will give this record a specific color in the person view.
Below this top section, there are several "tabs" containing different categories of
available information. Click any tab to view and edit its contents.
Clicking the OK button at the bottom will apply all the changes made in all tabs
and close the dialog window. Clicking the Cancel button will close the window
without applying any changes. If any data in any tabs were modified, an alert window
will appear, prompting you to choose from the following options: close the dialog without saving changes, cancel the initial cancel request, or save the changes.
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Preferred image

underline the callname among the different given names, see also here. Some
people will use this field also for nickname, or changes to the Given name (like
Cristy for Cristina), but this is not the intended use. A call name is a proper legal
name. For nick names, or short name variants, you should create an alternative
name with a different type.
• Type of the name (birth name, married name, nick name, short name, etc.). It is
advised to use for the preferred name a name with legal tender as that is what most
often is found on documents, and store other name types in the Name tab of the
Person Editor .
The Family name and Type fields provide an "autocompletion" feature: as
you type in these fields, a menu appears below the field containing database entries
that match your partial input. This gives you a shortcut by letting you select an entry
that already exists in the database rather than having to type it all out. You can select
the entry using your mouse or using your arrow and Enter keys.
Nickname is a descriptive name given in place of or in addition to the official given
name. Family Nickname is non official name given to a family to distinguish them
of people with the same family name. Often referred to as eg. Farm name.

The person editor also shows in the top right an image region. This Image area
shows the first image available in the Gallery of this person (if any exist).

Person tab pages
The tabs reflect the following categories of personal data:
• Events: The Events tab lets you view and edit any events relevant to the
person. The bottom part of the window lists all such events stored in the database.
The top part shows the details of the currently selected event in the list (if any).
The buttons + , Edit , and - allow you to add, modify, and remove an
event record from the database. Note that the Edit and - buttons become
available only when an event is selected from the list.
• Names:

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Fig. 5.2 Names

General section

The Names tab lets you view and edit any alternate names the person may
have. The bottom part of the window lists all alternate names for the person
stored in the database. The top part shows the details of the currently selected
name in the list (if any). The buttons + , Edit , and - allow the addition,
modification, and removal of an alternate name from the database. Note that the
Edit and - buttons become available only when an alternate name is selected
from the list.

• The ' Gender menu offers the choice of person's gender : male ,
female , and unknown .
• The field ID displays the GRAMPS ID number which identifies the user in the
database. This value helps you distinguish between people who have the same
name. You may enter any unique value you want. If you do not provide a value,
Gramps will automatically select a value for you.
• The Privacy button lets you mark whether or not the person's record is
considered private.
• The Tags list lets you assign your custom tags and specify some basic
information on the status of your research.

When you add a new name or edit an existing name, the Name Editor
dialog is invoked. This Names dialog is described in the Name Editor section
• Attributes:
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remove an attribute record from the database. Note that the Edit and - buttons
become available only when an attribute is selected from the list.
If you edit an attribute the Attribute Editor opens.

Gedcom
Several predefined attributes refer to values present in
the GEDCOM standard.
• Addresses:

Fig. 5.3 Attributes
The Attributes tab lets you view and assign attributes to the person. You
have complete freedom to define and use attributes. For example, attributes
might be assigned to describe the person's physical characteristics or personality
traits.
Note that each attribute listed in the Attribute dialog consists of two
parts: the Attribute itself and a Value associated with that Attribute. This socalled "Parameter-Value" pairing can help you organize and systematize your
research. For example, if you define "Hair color" as an Attribute for a person,
"Hair Color" will become a selectable Attribute for all other people. The Value of
Hair Color for person A might be red, and brown for person B. In similar fashion,
you might define an Attribute like "Generosity" and use the Value of "Enormous"
to describe a particularly generous person.

Fig. 5.4 Addresses
The Addres ses tab lets you view and record the various mailing addresses
of the person. You are advised to use a residence event to store information of
residency of a person. The address tab is offered mainly for compatibility with
the GEDCOM standard where the rationale of addresses is mailing only.

The bottom part of the dialog window displays the list of all Attributes stored in
the database. The top part shows the details of the currently selected attribute in
the list (if any). The buttons + , Edit , and - let you add, modify, and

The bottom part of the window lists all addresses stored in the database. The top
part shows the details of the currently selected address in the list (if any). The
buttons + , Edit , and - allow you to correspondingly add, modify, and
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remove an address record from the database. Note that the Edit and buttons become available only when an address is selected from the list.
If you edit an address the Address Editor opens.
Some reports allow you to restrict data on living people. In particular, that
option will omit their addresses.
• Notes:

Fig. 5.6 Sources
The Source s tab allows you to view and document the sources for the
information you collect.
These might be general sources that do not describe a specific event, but which
nevertheless yield information about the person. For example, if Aunt Martha's
memoirs mention her great-grandson Paul, the researcher may assume that this
Paul actually existed and cite Aunt Martha's memoirs as the source that justifies
this assumption.

Fig. 5.5 Notes
The Notes tab provides a place to record various items about the person that
do not fit neatly into other categories, as well as text excerpts you want to add to
the family tree. You can share notes between different records in Gramps. The
iconbar in this tabpage offers the usual buttons: add a note, select an existing
note to add, edit a selected note, remove a note, and reorder buttons to change
the order of the notes

Tip
Sources which document specific events are best
recorded as sources of the event (under the
Events tab) instead of as a source of the person.
The person's Sources tab is best used for any
sources not specifically connected to any other data.

If you edit a note, you obtain the Note Editor.
• Sources
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The central part displays the list of all source references stored in the database in
relation to the person. The buttons + , Edit , and - allow you to
correspondingly add, modify, and remove a source reference to this person. Note
that the Edit , and - buttons become available only when a source
reference is selected from the list.

Tip
The first available image in the gallery will be also displayed in the Image area in the General tab.

On edit you can change the data in the source reference (unique to this person),
as well as the shared source object, see Editing Source References.

The buttons + , Edit , and - let you add a new image to the database,
link to an image already stored in the database, modify an image, and remove a
given media object from the person's gallery. Note that the Edit , and buttons become available only when a media object is selected from the list. You
arrive on the Media reference editor

• Gallery:

Note
Removing a media object from a person's gallery does
not remove it from the database. It only removes the
reference to that object from this person's record.
• Internet:

Fig. 5.7 Gallery
The Gallery tab lets you view and store photos, videos, and other media
objects that are associated with the person. The central part of the window lists
all such media objects. Any object in the form of a valid image file will result in
the display of a thumbnail view of the image. For other objects such as audio
files, movie files, etc., a corresponding file type icon is displayed instead.

Fig. 5.8 Internet
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The Internet tab displays Internet addresses relevant to the person. A
descriptive caption of the Internet location you are storing. Type of internet
address as needed to navigate to it, eg. http://gramps-project.org, E-mail, Web
Page, ...

occasions. Events can be shared between people, each indicating their role in the
event.
• LDS

The bottom part lists all such Internet addresses and accompanying descriptions.
The top part shows the details of the currently selected addresses in the list (if
any). The buttons + , Edit , and - let you add, modify, and remove an
Internet address. The "Go" button (represented by an icon having a green arrow
and yellow circle) opens your web browser and takes you directly to the
highlighted page. Note that the Edit , and - buttons become available only
when an address is selected from the list.
• Associations

Fig. 5.10 LDS
The LDS (Latter Days Saints) tab lets you view and edit information about LDS
ordinances of the person.
These are LDS Baptism, Endowment, and Sealed to Parents ordinances, as labeled
inside the tab. Each ordinance is described by its date, LDS temple, and Place
where it happened.
An additional pop-up menu, "Parents," is available for the Sealed to Parents
ordinance. Each ordinance can be further described through the selections
available in the Status pop-up menu. It can also be include notes and references
to sources through the corresponding Sources... and Note buttons.

Fig. 5.9 Associations
The Associations tab lets you view and edit information about the
associations between people in the database. The associations may include
Godparents, family friends, or any other types of associations you may wish to
record. Use Events instead for relations connected to specific time frames or
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Editing dates

for your version, chances are that other rules are in effect. If there is no manual in your language yet, you
may try following your instinct and go with the common ways of denoting dates in your language. If all else
fails, use the Date selection dialog described
below.

This section describes how to enter and modify dates. Since dates are so important in
genealogical research, Gramps takes special care to preserve and use any date information available.
Information can be entered into a date field by directly typing it or by invoking the
Date selection dialog. Both methods will be discussed below, but first, we
will cover some important features of dates as they are used in Gramps.
Date types
Dates in Gramps are classified according to the following types:
• Regular: A "regular" date is one which includes a specific day, date, or month. It can
be complete (e.g., June 6, 1990) or partial (e.g., July 1977).
• Before: A "before" date is one that can only be identified as occurring before a
certain day, month, or year.
• After: An "after" date is one that occurs after a certain day, month, or year.
• Range: A "range" describes a time period during which the event occurred.
For example, "between January 1932 and March 1932."
• Span: A "span" describes a time period during which a condition existed.
For example, "from May 12, 2000 to February 2, 2002."
Date formats and parsing rules
Gramps recognizes dates entered in a variety of formats. The default numeric format is that which is conventional for the environment is which Gramps is operating;
that is, DD.MM.YYYY for most European countries, MM/DD/YYYY for the U.S., and so
on.
Besides exact dates, Gramps recognizes many dates that are not regular: before, after, about, ranges and spans. It also understands the quality: estimated or calculated. Finally, it supports partial dates and many alternative calendars. Below is the list of date
entry rules to allow precise date parsing.

Regular single dates can be entered just as you would write them.
Examples: May 24, 1961 or January 1, 2004.
Dates that are not regular should start with the quality: estimated or
calculated , if applicable. Example: est. 1961, or calc 2005. (Note that a quality
does not need to be specified for regular dates.)
After the quality should appear the type. If the type is before , after , or
about , you scan specify the type by writing "before", "after" or "about". If the type
is a range, write "between DATE and DATE", and if the type is a span, write "from DATE
to DATE". patterns, where DATE is a single date.
Examples: est from 2001 to 2003, before June 1975, est about 2000, calc between May
1900 and January 1, 1990.
Partial dates are entered simply by omitting unknown information.
Examples: May 1961 and 2004.
Calendars
Alternate calendars are calendars other than the Gregorian calendar. Currently,
Gramps supports Hebrew, French Republican, Julian, Islamic, Persian, and Swedish alternate calendars. To specify the calendar other than the default Gregorian, append the
name of the calendar to the date string, e.g. "January 9, 1905 (julian)" or use the drop
down menu.
Swedish calender
The Swedish king, Karl XII, decided that Sweden should start using the Gregorian
calendar. However, it was planned to take place gradually by skipping 11 leap days
starting 1700-02-29 and end by 1744. So 1700-02-28 was followed by 1700-03-01. This
took place during the Great Nordic War and the leap days were kept 1704 and 1708. In
January 1711 the same king decided that Sweden should return to the Julian Calender
by 1712-03-01. In order to be in phase, an extra day was inserted on 1712-02-30. And that
was the end of the Swedish Calendar. Sweden converted to Gregorian in 1753-03-01,
by skipping dates between 1752-02-18 and 1753-02-28. In Gramps you can only enter

Date parsing rules
The list only applies to the English version of Gramps. If
you are using localized version of Gramps, your version
may or may not provide a localized date parser. At the
time of this writing, localized parsers exist for French,
German, Russian, Finnish, Dutch, Spanish, Slovak and
Swedish languages. If the localized parser is available
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valid dates for the Swedish Calender from 1700-03-01 to 1712-02-30. All other dates are
flagged as not valid and has to be corrected.
Dual-dated dates
Dual-dated dates (also called "double dating", "slash dates", and sometimes "Old
Style/New Style" dates) appear like "Jan 23, 1735/6". Often mistaken as a year uncertainty, this actually has a specific historic meaning. The dual dated date represents a
time when an area was in a transition between moving to January 1 as the beginning of
the new year. Thus Jan 23, 1735/6 is an indication to make it clear what date is being
referred to. In this example, "Jan 23, 1736" might have occurred after "Jun 23, 1736".
England and the American colonies didn't officially accept the "Jan 1" as the new
year date until 1752. Before 1752, the English government still officially observed March
25 as the first of the year, whereas most of the English population observed January 1 as
the first of the year. Many people therefore wrote dates falling between January 1 and
March 25 in the dual-dated format.
Sometimes, a dual date may appear as a fraction, as in this grave stone (170 and 3/4,
which means 1703 and 1704):

• Jan 20, 1865 (Mar25)
• Jan 20, 1750 (Julian,Mar1)
• Feb 23, 1710/1 (Mar25)
To indicate the beginning of a year that is different from that of January 1, you use the
following codes:
• Jan1
• Mar1
• Mar25
• Sep1
You can put that as the only item in parenthesis, or right after a calendar name (comma,
and no space).
Note that if new year's day is not Jan 1, then January will come after December that
year. Dates with new year day codes will be sorted appropriately.

Date validity indicators
Gramps uses a date validator.
While partial dates do not uniquely define the day, they allow at least for some type
of comparisons between the dates.
Red cross means that the date is not recognized as a valid date (e.g. "Christmas week
of 61", or "the summer when I had surgery"). In such a case the date will be stored as a
text string and therefore cannot be compared other dates. As you can see, it is best to
avoid such date entries. It would be better, for example, to enter a date of "December
1961" and then to add the note "Christmas week of '61."
On the Perso n View , not recognized dates will be displayed in bold by default. Style for not recognized dates can be modified into Preferences.

Fig 5.11 Gravestone

Marking a date as dual dated can be done by simply putting a slash between the
years. For example:
• 1721/2
• 1719/20
• 1799/800
These slash-years can appear anywhere in a date that a regular year can appear.
Dual-dated dates are currently represented in the Julian calendar so their month
and day will be the same as that in the textual representation.
Alternate new year day
With dual-dated dates (and other dates) you may know that the new year was celebrated on a day other than January 1. To indicate this in Gramps, put the month/day
code in parentheses, after the calendar (if one). For example:

Graphical User Interface for entering dates
While the above parsing rules provide a guide for you to type in most common dates,
you can also use Date selection dialog. The dialog is particularly useful for
building a complex date or for simply insuring that your information is entered in a
way Gramps will understand. The Date selection dialog can be invoked by
clicking the button next to the date entry field.
The Calendar menu lets you choose a calendar other than the default Gregorian. The Qualit y menu gives you the choices of Regular, Estimated, or Calculat-
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be copied and stored as the text comment string when
Gramps parses the entered text. Thus, any comment
that may have been there prior to the parsing will be
overwritten.

Editing information about relationships

Fig. 5.12 Date selection dialog
ed. The Type menu allows you establish the exact date type: Regular, Before, After,
About, Range, Span, and Text only. You can set the Date by setting the day, the
month, and the year. In the event that your date type is Range or Span, the Second
date will be activated. Finally, the Text comment text entry field allows storing an arbitrary text string along with the date.

Important comment about a date

Fig. 5.13 Family editor

If you have an important comment to make about a
date, you are better off doing so in a Note that corresponds to the event than in the Text comment field of
the Date selection dialog. We recommend
this for the following reason: If you enter a date by
typing it directly into the date field (that is, not via
the Date selector dialog), your entry will

Information about relationships is entered and edited through the Family Editor dialog. This dialog may be invoked in a number of ways:
From Relationships View: click on an Edit button in the family that you want
to edit.
From Family View: select the family in the list and then click the Edit button
on the Toolbar, or double-click on the family.
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From Ancestry Views: point your mouse over the black line connecting the spouses,
right-click and select Edit from the context menu, or double-click on the black
line.
Any of these methods will prompt you with the following Family Editor
dialog:

The Children tab lets you view and edit the list of children in this relationship.
The + button allows entering a new person to the database and adding that person as a
child in this relationship. The Select button lets you select an existing person to
be a child in the relationship. The Edit button allows for editing the relations between the selected child and the parents. Finally, the - lets you remove the selected
child from the relationship. Note that the Edit and - buttons become available
only when a child is selected from the list.

The top of the window shows the names of the people whose relationship is being edited, as well as their birth and death information. The main part of the window displays
three Relationship Information fields and the seven notebook tabs
representing different categories of information about the relationship. Click any tab
to view or edit the information it contains. The bottom part has OK and Cancel
buttons. Clicking the OK button at any time will apply all the changes made in all tabs
and close the dialog window. Clicking the Cancel button at any time will close the
window without applying any changes. If any of the data in any tab is modified, an alert
window will appear that will prompt you choose between closing the dialog without
saving changes, canceling the initial cancel request, or saving the changes.

Note
Removing a child from the list does not delete that child
from the database. It simply removes the child from
this relationship.

Tip
Use arrows (up/down) or drag and drop for setting children order into the family.

Note
Clicking OK will immediately save changes to the
database. This version of Gramps does not have a separate saving function, all changes are immediate.

• Events

Tip
If a tab label is in boldface type, this means it contains
data. If not, it has no data.
Fig. Events on Family editor

The Relatio nship Information section fields have the basic description
of the relationship. The ID field displays the ID number which labels this relationship in the database. Leave generated by Gramps. The available types (such as Married,
Unmarried, etc.) can be chosen from the drop-down Relationship type
menu. The Marker allows you to specify some basic information on the status of
your research.
The tabs provide the following information categories of relationship data:
• Children

The Events tab lets you view and edit the list of events relevant to the relationship. The buttons + , Edit , and - let you add, modify, or remove an event
record from the database. Note that the Edit and - buttons become available only when an event is selected from the list.
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Note
Removing an event from the list does not delete that
event from the database. It simply removes the event
reference from this relationship.
• Sources
The Sources tab lets you view and edit a list of references to the sources that
provide evidence for the relationship. These might be documents that refer to the relationship, but which do not necessarily document it officially. For example, if Aunt
Martha's memoirs mention that her great-grandson Paul was married, the researcher
may take this as evidence of the relationship between Paul and his wife existed and cite
the memoirs as the source for this assumption.

Tip
Sources that document specific events such as marriages or divorces are better filed in relation to those
events, under the Events tab.

The buttons + , Edit , and - allow let you add, modify, and remove a source
reference to this relationship. Note that the Edit and - buttons become available
only when a source reference is selected from the list.

Note
Removing an entry from the list does not delete that
source from the database. It simply removes the source
reference from this relationship.

• Attributes
The Attributes tab lets you view and edit particular information about the relationship that can be expressed as attributes. The buttons + , Edit , and - let
you add, modify, or remove an attribute. Note that the Edit and - buttons become available only when an attribute is selected from the list.
• Notes

Fig. 5.14 Sources editor
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The Notes tab lets you view and edit notes associated with the relationship. These
could be any comments which do not naturally fit into the "Parameter-Value" pairs
available to Attributes. To add a note or modify existing notes simply edit the text in
the text entry field.
The Format option lets you set the way the note will appear in reports and web
pages. If you select Flowed, the text generated will have single spaces put in place of all
multiple spaces, tabs, and single end-of-line characters. A blank line inserted between
two blocks of text will signal a new paragraph; additional inserted lines will be ignored.
If you select the Preformatted option, the text in reports and web pages will appear
exactly as you enter it in the Notes dialog.
• Gallery
The Gallery tab lets you store and display photos and other media objects associated with the relationship. The central part of the window lists all such objects and
gives you a thumbnail preview of image files. Other objects such as audio files, movie
files, etc., are represented by a generic Gramps icon. The buttons + , Select ,
Edit , and - let you add a new image, add a reference to an existing image, modify an existing image, and remove a media object's link to the relationship. Note that the
Edit and - buttons become available only when a media object is selected from
the list.
• LDS
The LDS (Latter Days Saints) tab displays information about the LDS Sealed to
Spouse ordinance. The data can include date, LDS temple, and Place. The status of the
ordinance can be described through the selections available in the Status pop-up menu
and can also be referenced in the corresponding Sources... and Note buttons.
To edit source data, switch to the Sources View and select the desired entry in the
list of sources. Double-click that entry or click the Edit icon on the toolbar to invoke the following Source Editor dialog: The main part of the window
displays four notebook tabs containing different categories of information. Click a tab
to view or edit its contents. The bottom part of the window has OK and Cancel

buttons. Clicking OK will apply all the changes made in all tabs and close the dialog
window. Clicking the Cancel button will close the window without applying any
changes.

Note
Clicking OK will immediately save changes to the
database (write on disk). All changes are immediate.

Tip
If a tab label is in boldface type, this means it contains
data. If not, it has no data.

Previous

Index

Next

This page was last modified on 26 October 2011, at 21:21. This page has been accessed
1,336 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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The previous section offered you a detailed overview of how to enter and edit data
persons and relationships. This section continues with other objects you encounter in
Gramps.
Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
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wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions
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Fig. 5.15 Event editor

Next

2. The Dat e of the event can be an exact date, a range (from ... to ..., between
...), or an inexact date (about ...).
3. The Des cription field gives you the opportunity to give a longer
description what this event is. Leave the Description empty if you
want to autogenerate it with the tool Extract Event Description, which uses
the form "{event type} of {Surname}, {Given name}" .
4. The ID is a unique identifier for the event. Leave this field blank to allow
Gramps to generate this value automatically for new events.
5. The Pla ce can be selected from a list of previously entered place or
entered anew using the selection and add buttons. Additionally, you can drag
and drop a place entry into this field.

Editing information about events
Events are edited through the Event Editor dialog (See Fig. 5.15). This dialog
can be accessed from either the Edit Person dialog or the Marriage/
Relationship dialog.
You can type this information directly into the adjacent fields.
The top part lets you view and edit basic information about the event:
1. The Type can be selected from the available types listed in the Event
type drop-down menu. E.g., Burial, Graduation, etc.
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Checking the Private record box marks the event record as private and allows it to be
omitted from reports.
The central part of the window displays five notebook tabs containing different categories of information. Click on a tab to view or edit its contents.
The tabs provide the following information categories of the event data:
• Sources
The Sources tab lets you view and edit sources relevant to an event. The central
part of the window lists all such source references stored in the database. The buttons
+ , Edit , and - let you add, modify, and remove a source reference associated with an event. Note that the Edit and - buttons become available only
when a source reference is selected from the list.
• Note
The Note tab provides a place to record notes or comments about the event. To add
a note or modify existing notes simply edit the text in the text entry field.
The bottom part of the window has OK and Cancel buttons. Clicking OK
will apply all the changes made in all tabs and close the dialog window. Clicking the
Cancel button will close the window without applying any changes.

Tip
If a tab label is in boldface type, this means it contains
data. If not, it has no data.

Fig. 5.16 Event information

Editing event references

For the role of the person in this event, use Primary for the main beneficiary, use a descriptive role otherwise (Eg., Witness, Celebrant, ...).

Event references connect a Event to a person and allow you to provide additional information about the event.
When adding event reference to person, the following dialog appears:
The dialog includes two main headings, Ev ent selection and Event
details .
• The Event selection displays : General , Sources ,
Attributes , Notes , Gallery , References .
• The Event details section indicates the details associated with the
particular reference to this Event: Role , Notes , Attributes .

Tip
Information in this dialog is specific to the particular
reference. A single event can be referenced many times,
and all such references will have in common the overall
event information. This dialog lets you provide
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2. The ID is an unique record to identify the media object, leave generated
by Gramps.
3. Date could be for a picture the date it is taken.
4. Path of the media object on your computer. Gramps does not store the
media internally, it only stores the path! Set the Relative Path in the
Preferences to avoid retyping the common base directory where all your
media is stored. The Media Manager tool can help managing paths of a
collection of media objects.
5. Mime value is the extension of the media object.
The central part of the window displays five notebook tabs containing different categories of information. Click a tab to view or edit its contents. The bottom part of the
window has OK and Cancel buttons. Clicking OK will apply all the changes
made in all tabs and close the dialog window. Clicking the Cancel button will close
the window without applying any changes.

reference-specific data, such as relevant role, attribute
to further specify and document the reference.

Editing information about media objects

Note
Clicking OK will immediately save changes to the
database (write on disk). All changes are immediate.

Tip
If a tab label is in boldface type, this means it contains
data. If not, it has no data.

The tabs represent the following categories of media data:
• General
The General tab lets you view and edit the object's Title and Date. You can type
this information directly into the corresponding fields. For the Date, you can also enter
information by clicking the LED button and invoking the Date selection dialog.

Fig. 5.17 Media properties editor
To edit media data, switch to the Media View and select the desired entry in the list of
sources. Double-click on that entry or click Edit on the toolbar to invoke the following Media Properties Editor dialog:
A thumbnail preview of the object is presented, along with a summary of its properties (ID, path, date and object type).
1. A descriptive Title for this media object.

Note
Every media object is referred to by its Path. The user is
responsible for keeping track of the object files. Gramps
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will only reference and display the contents, not manage the files themselves.

• Attributes
The Attribu tes tab lets you view and edit particular information about the media object that can be expressed as Attributes. The bottom part displays the list of all
such attributes stored in the database. The top part shows the details of the currently
selected attribute in the list (if any). The buttons + , Edit , and - let you add,
modify, or remove an attribute. Note that the Edit and - buttons become available only when an attribute is selected from the list.
• Notes
The Note tab provides a place to record various information about the source that
does not fit neatly into other categories. This area is particularly useful for recording
information that does not naturally fit into the "Parameter/Value" pairs available to
Attributes. To add a note or modify existing notes simply edit the text in the text entry
field.
• References
The References tab indicates any database records that refer to a given media
object. The list can be ordered according to any of its column headings: Type , ID
, or Name . Double-clicking an entry allows you to view and edit the corresponding
record.
Fig. 5.18 Media Object references

Note
Only primary objects can be shown in the References tab: Person, Family, Event, Source, or Place.
The secondary objects such as Names and Attributes, although able to refer the media object, will only show up
through their primary objects to which they belong.

• Region corners : x1, x2, y1, y2.
The region part allows to select a specific region on the Media Object. You can use
the mouse cursor on the picture to select a region, or use these spinbuttons to set the
top left, and bottom right corner of the referenced region. Point (0,0) is the top left corner of the picture, and (100,100) the bottom right corner.
• Privacy
The Privacy button lets you mark whether or not the record is considered private. Check the Private record box to mark this record as private .

Editing media object references
When Media Object references connect a Media Object to an other object, the following
dialog appears:
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Editing information about places
Supported longitude/latitude formats
When you create/modify a place, the possible formats used for longitude/latitude are :
'D.D4'

: degree notation, 4 decimals
eg +12.0154 , -124.3647
'D.D8'
: degree notation, 8 decimals (precision like ISO-DM
eg +12.01543265 , -124.36473268
'DEG'
: degree, minutes, seconds notation
eg 50°52'21.92"N , 124°52'21.92"E ° has UTF-8 code
or N50º52'21.92" , E124º52'21.92" º has UTF-8 code
The character for seconds can be either one double
or two single quote '
The letters N/S/W/E can be placed before or after
'DEG-:'
: degree, minutes, seconds notation with :
eg -50:52:21.92 , 124:52:21.92
'ISO-D'
: ISO 6709 degree notation i.e. ±DD.DDDD±DDD.DDDD
'ISO-DM' : ISO 6709 degree, minutes notation
i.e. ±DDMM.MMM±DDDMM.MMM
'ISO-DMS' : ISO 6709 degree, minutes, seconds notation
i.e. ±DDMMSS.SS±DDDMMSS.SS

Fig. 5.19. Place editor
To edit information about places, switch to the Places View and select the desired entry
from the list of places. Double-click that entry or click the Edit button on the toolbar to bring up the following Place Editor dialog:
There are four fields:
1. Place name : the full name of this place.
2. Latitude : the position above equation of the place in decimal or
degree notation. Eg, valid values are 12.0154, 50°52'21.92\"N, N50º52'21.92\"
or 50:52:21.92. You can set these values via the Geography View by searching
the place, or via a map service in the Place view.
3. Longitude : the position relative to the Prime, or Greenwich, Meridian
of the place in decimal or degree notation. Eg, valid values are -124.3647,
124°52'21.92\"E, E124º52'21.92\" or 124:52:21.92. You can set these values via
the Geography View by searching the place, or via a map service in the Place
view.
4. ID : an unique record to identify the place. Leave generated by Gramps.

The second part of the window displays seven notebook tabs containing different categories of information. Click a tab to view or edit its contents. The bottom part of the
window has OK and Cancel buttons. Clicking OK will apply all the changes
made in all tabs and close the dialog window. Clicking the Cancel button will close
the window without applying any changes.

Note
Clicking OK will immediately save changes to the
database. All changes are immediate.
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+ , Edit , and - let you add, modify, and remove a source reference associated
with a place. Note that the Edit and - buttons become available only when a
source reference is selected from the list.
• Gallery
The Gallery tab lets you store and display photos and other media objects associated with a given place. The central part of the window lists all such media objects and
gives you a thumbnail preview of image files. Other objects such as audio files, movie
files, etc., are represented by a generic Gramps icon. The buttons + , Select
, Edit , and - let you add a new image, add a reference to an existing image,
modify an existing image, and remove a media object's link to the place. Note that the
Edit and - buttons become available only when a media object is selected from
the list.
• Internet
The Internet tab contains Internet addresses relevant to the place. The bottom
part of the window lists all such Internet addresses stored in the database. The top part
shows the details of the currently selected address in the list (if any). The buttons + ,
Edit , and - let you add, modify, and remove an Internet address. The Go button (represented by an icon with a green arrow and yellow circle) opens your browser
and takes you to the web page corresponding to the highlighted Internet address. Note
that the Edit , - , and Go buttons become available only when an address is
selected from the list.
• References
The References tab indicates any database records (events or LDS ordinances)
that refer to a place. This information cannot be modified from the Place Editor dialog. Instead, the corresponding database record (e.g., a birth event) has to be
brought up and its place reference edited.

Tip
If a tab label is in boldface type and displays an icon,
this means it contains data. If not, it has no data.

The tabs represent following categories of place data:
• Location
The Location tab you view and edit the basic information about the place: the
Title which labels it in the database, Street , City , Church parish ,
County , State , Country , place code . You can type this information directly into the adjacent fields, they are used by Gramps for a better place management.
They are the place divisions:
1. The Country where the place is.
2. Second level of place division, eg., in the USA a State , in Germany a
Bundesland.
3. Third level of place division. Eg., in the USA a County .
4. The lowest clergical division of this place. Typically used for church sources
that only mention the Parish .
5. The village or City where the place is.
6. The lowest level of a place division is the Street name.
• Alternative locations
The Other names tab lets you view and edit other names by which the place
might be known. The bottom part of the window lists all other names of the place stored
in the database. The top part of the window shows the details of the currently selected
name in the list (if any). The buttons + , Edit , and - let you add, modify, and
remove a name record. Note that the Edit and - buttons become available only
when a name is selected from the list.
• Note
The Note tab displays any comments or notes concerning the place. To add a note
or modify existing notes simply edit the text in the text entry field.
• Sources
The Sources tab lets you view and edit sources relevant to a place. The central
part of the window lists all such source references stored in the database. The buttons

Editing information about sources
The general information at the top of the window lets you define basic information
about the source: its Title , Author , Abbreviation , and Publication information . You can type this information directly into the adjacent fields.
1. Title : Title of the source.
2. Authors : Authors of the source.
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Other objects such as audio files, movie files, etc., are represented by a generic Gramps
icon. The buttons + , Select , Edit , and - let you add a new image, add a
reference to an existing image, modify an existing image, and remove a media object's
link to the relationship. Note that the Edit and - buttons become available only
when a media object is selected from the list.
• Data
The Data tab displays "Key/Value" pairs that may be associated with the source.
These are similar to the "Attributes" used for other types of Gramps records. The difference between these Key/Value pairs and Attributes is that Attributes may have source
references and notes, while Key/Value data may not.
The central part of the window lists all existing Key/Value pairs. The buttons +
and - let you add and remove pairs. To modify the text of Key or Value, first select
the desired entry. Then click in either the Key or Value cell of that entry and type your
text. When you are done, click outside the cell to exit editing mode.
• Repositories
The Repositories tab displays the references to the repositories in which the
source is contained. The list can be ordered by any of its column headings: ID , Title , Call Number ,and Type . Double-clicking an entry allows you to view
and edit the record. You may also edit the reference. The buttons on the side of the tab
allow you add a new repository, link to (or share) an existing repository, edit the reference to the repository, or remove the reference.
• References
The References tab lists all the database records that refer to this source, if any.
The list can be ordered by any of its column headings: Type , ID , or Name .
Double-clicking an entry allows you to view and edit the record.

Fig. 5.20 Source editor
3.
4.

ID : an unique record to identify the source. Leave generated by Gramps.
Abbreviations : Provide a short title used for sorting, filing, and
retrieving source records.
5. Publication information : Publication Information, such as
city and year of publication, name of publisher, ...
The tabs provide the following information categories of source data:
• Note
The Note tab provides a place to record notes or comments about the source. To
add a note or modify existing notes simply edit the text in the text entry field. Only primary objects can be shown in the References tab: Person, Family, Event, Place,
or Media object. Secondary objects such as Names and Attributes can only be accessed
through the primary objects to which they belong.
• Gallery
The Gallery tab lets you store and display photos and other media objects associated with a given source (for example, a photo of a birth certificate). The central part
of the window lists all such objects and gives you a thumbnail preview of image files.

Editing source references
Source references connect a Source to another object and allow you to provide additional information about the source. When adding source references to events, places,
etc., the following dialog appears:
The dialog includes two main headings, Source
selection and
Source details . Source selection displays the Title of
the Source, its Author , and Publication information . The Title can be selected from the available sources listed in the drop-down menu. If the

7

From Gramps

Gramps 3.3 Wiki Manual - Entering and editing data: detailed - part 2

source you are referencing is not already in the database, you can enter it by clicking
New... and filling out the invoked Source Editor dialog.

1.

Date : Date associated with this source reference. Typically used to store
the log date (when text was added to the original source).
2. Volume/Film/Page : Specific location with in the information
referenced. For a published work, this could include the volume of a multivolume work and the page number(s). For a periodical, it could include
volume, issue, and page numbers. For a newspaper, it could include a column
number and page number. For an unpublished source, this could be a sheet
number, page number, frame number, etc. A census record might have a line
number or dwelling and family numbers in addition to the page number.
3. Confidence : Conveys the submitter's quantitative evaluation of the
credibility of a piece of information, based upon its supporting evidence. It is
not intended to eliminate the receiver's need to evaluate the evidence for
themselves.
1. Very Low = Unreliable evidence or estimated data.
2. Low = Questionable reliability of evidence (interviews, census, oral
genealogies, or potential for bias for example, an autobiography).
3. High = Secondary evidence, data officially recorded sometime after
event.
4. Very High = Direct and primary evidence used, or by dominance of
the evidence.

Tip
Information in this dialog is specific to the particular
reference. A single source can be referenced many
times, and all such references will have in common the
overall source information. This dialog lets you provide
reference-specific data, such as relevant quotes, comments, confidence, page numbers, etc., to further specify and document the reference.

Fig. 5.21 Source information
The Source details section indicates the details associated with the
particular reference to this Source: Confidence , Volume/ Film/ Page ,
Date , and Notes . You can choose the Confidence level from the Confidence drop-down menu. The remaining details can be typed in the corresponding
text entry fields.

Editing information about repositories
There 3 top fields:
1. The Nam e of the repository (where sources are stored).
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2.

ID : an unique record to identify the repository. Leave generated by
Gramps.
3. The Type of repository, eg., Library, Album, ...

browser and takes you directly to the highlighted page. Note that the Edit , and
- buttons become available only when an address is selected from the list.
• Note
The Note tab provides a place to record notes or comments about the repository.
To add a note or modify existing notes simply edit the text in the text entry field.
• References
The References tab indicates any database records that refer to a given repository. The list can be ordered according to any of its column headings: Type , ID
, or Name . Double-clicking an entry allows you to view and edit the corresponding
record.

Editing information about notes
Note tab
The Note tab is the place for adding notes to one of your people, sources, etc. The
tab allows you to order your notes in the order you want to see them. As on the other
tabs, you can add new notes, share existing notes with the object you are working on
and remove notes from this object (this does not remove the note from the family tree.
It is present in the note view afterward).

Fig. 5.22 Repository editor

Note editor

• Addresses:
The Addresses tab lets you view and record the various addresses of the repository.
The bottom part of the window lists all addresses stored in the database. The top
part shows the details of the currently selected address in the list (if any). The buttons
+ , Edit , and - allow you to correspondingly add, modify, and remove an address record from the database. Note that the Edit and - buttons become available only when an address is selected from the list.
• Internet:
The Internet tab displays Internet addresses relevant to the repository. The bottom part lists all such Internet addresses and accompanying descriptions. The top part
shows the details of the currently selected addresses in the list (if any). The buttons +
, Edit , and - let you add, modify, and remove an Internet address. The "Go" button (represented by an icon having a green arrow and yellow circle) opens your web

When creating a new note, or when editing an existing note, the note editor comes up.
There are two tabs, the 'Note' tab, and the 'References' tab.
• Note tab
The Note tab has the following elements
• A toolbar to apply styles to your notes. You can select and apply one of the
toolbuttons, or set the values as you want and start typing.
• italic, bold, underline : common functions known from text editors
• Font selection: a basic font selector showing all fonts on your system.
• Font size: the size of the font you type
• Font color: write the font in a certain color
• Background color: add a background color to the text you write
• Clear markup: This will remove all markup you have placed on the note
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•
•
•
•

•

Fig. 5.23 Note editor

ID : a unique id for the note. If left blank an automatic id will be
chosen according to the settings in the preferences
Marker : a marker setting for the note: Complete, Todo. You can add
your own marker by typing it
Type : a note type. You can add your own value by typing it
Preformatted checkbox: Notes in Gramps are considered
flowed for beautifull presentation in the reports. In this setting,
newlines and white spaces will be automatically ignored so as to form
complete paragraphs, which are defined by an empty line between two
textblocks. When Preformatted is checked, Gramps will assume
the whitespace and enters you used in the notes are important. Use this
for tables, literal transcripts, ... . Use monospace font to keep
preformatting. Try not to use preformatted if you do not need it, the
reports you create will be more beautifull.
Privacy : as on the other objects, you can indicate a note as private
so as to make sure you can remove this note from all output Gramps
creates with one easy click.

• References
The References tab indicates any objects that refer to a given note. The list
can be ordered according to any of its column headings: Type , ID , or Name .
Double-clicking an entry allows you to view and edit the corresponding record.

Important
There is no undo button or save button on the note editor. Just like other objects, it is stored to your family
tree on click of the Ok button. If you do long notes, consider saving from time to time to save your edits in between.

HTML links
If you add links to webpages with the full address in a
note, the link will turn blue and underlined when you
hover your mouse over the text. Clicking the link opens
the webpage in your default browser.

• A context menu on the textview.
The most important entry in this context menu is the spell selection. You
are offered a selection of installed languages on your system with spell
checking enabled.

Note markup and preformat in reports
Markup like bold
bold, color, underline, ... can be added to notes. A note can be preformatted
or not. It depends on the output type how this markup will appear. Here an overview is
given of what you can expect.

• The text view where you can write your note
• Some properties of your note
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1. Pdf and direct print (to printer or to file) fully support the markup and the
preformatted setting
2. ascii print removes all markup from the notes for obvious reasons
3. LaTeX output interprets the markup to its best of possibilities. LaTeX is not
well suited as a typesetting language to add custom style. That would break
the benefits LaTex offers. Hence, the following is done:
• bold
bold, underline and italic is supported
• fontsize is mapped to the size indicators of LaTeX in a fuzzy manner
• mono fonts are shown as a mono spaced font
• color and font is not supported
• preformatted is handled correctly

4. html output does not support markup at the moment
The conclusion of the above should be to use markup in notes only in those cases it adds
to the information stored. Gramps is not a text editor.

Previous

1. Narrative Web
Web. Many people use the Narrative Web report as an easy way to
work with their data. This report is trying to respect markup in the notes.
This is an interpreted translation, it is not one-to-one.
2. ODF output does not support markup at the moment. This will be added in
the future
3. RTF output does not support markup at the moment

Index

Next

This page was last modified on 26 October 2011, at 22:00. This page has been accessed
821 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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(Redirected from Gramps 3.3 Wiki Manual - Entering and Editing Data: Detailed - part 3)
Jump to: navigation, search
The previous section offered you a detailed overview of how to enter and edit the main
objects you see in Gramps. This section continues with some objects you will encounter
as part of sources, persons, ...
Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

Previous

Index

Next

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Fig. 5.24 Name Editor

The top of the window allows entry of the type of name (e.g., Birth Name, Married
Name, etc) from a dropdown list. Next are elements of the personal name most commonly grouped together as Given Name elements. Following the Given Name section

Name Editor
Names are edited through the newly improved Name Editor dialog:
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is the Family Names section. At the bottom are elements allowing for customization of
name sorting, dates for names, name sources and notes for names.

• A Prefix for the family name that is not used in sorting (such as "de" or
"van").
• Surname for the main portion of one's family name.
• Connector often used in matronymic or patronymic naming schemes, such
as dotter.
• Origin indicating the type of family name this is and its derivation.
• Family Nick Name for families commonly referred to using a more
vernacular nick name.

Tip
The tab labels reflect the presence of corresponding information: if the tab contains any data, its label appears
boldface
boldface; if the tab has no data then its label appears
regular (not bold).

See also: Names wiki entry
Check the Pri vate record icon in the top right corner to mark this name
record as private. This will give you a chance to omit this name from being included in
reports, if you choose so among the report generation options.

Type
The Name Type dropdown list allows you to select the type of name being entered.

General tab

Given Names Section

Options allow you to adjust specific grouping, sorting, and displaying properties
of this name, as well as to provide the date corresponding to the name.
• The Groupin g field provides an alternative grouping node for a name in the
person view, overriding the default grouping based on the family name. This may
be necessary with similar family names that need to be grouped together -- for
example Russian names Ivanov and Ivanova are considered the same, but
difference in gender is reflected in different spelling. To enable typing into this
field, check the Override check button.
People are displayed according to the name format given in the Preferences (the
default).

The Given Names Section contains all parts of a personal name you can store with
Gramps.
• Given , The person's given names should all be entered here.
• Call Name , The person's proper legal name that was used most commonly
by the person should be entered here. For example, someone named John Raymond
Smith who uses the name Raymond should have Raymond entered here. If this
person uses Ray commonly, this should be entered as a nickname since Ray is not
the proper legal name (see following). In Germany and some other places, it was
custom to underline the callname among the different given names (see also here).
• Title , The person's personal title, such as Doctor (or Dr.) can be entered here.
• Suffix , The person's personal name suffix, such as Junior (Jr.) or III, should be
entered here.
• Nick Name , The person's nickname should be entered here. Nicknames
include shortenings of proper legal names such as Greg for Gregory (cf. Call Name
above).

Here you can make sure this person is displayed according to a custom name
format (extra formats can be set in the Preferences).
• The Sort as and Display as determine the manner in which the
name appears in the People View and in the reports. The sort as allows you to
override the name pattern set in the Gramps preferences in sorting of the name.
For example, you suddenly have a branch of Swedish names with given and
patronymic, but the rest of your database sorts names on Family name, Given. You
can indicate here to sort this name always as Patronymic, Given.
Here you can make sure this person is sorted according to a custom name format
(extra formats can be set in the Preferences).

Family Names Section
The Family Names Section contains the person's family name elements. Gramps allows
for multiple family names as well as multiple kinds of family names.
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The display as allows you to say how the name is displayed. You might for
example want to sort a name in a specific manner, but still have the display of
the name as set in your preferences.
The Person Tree view groups people under the primary surname. You can
override this by setting here a group value. You will be asked if you want to
group this person only, or all people with this specific primary surname.
• The Date can provide information on the validity of this name -- use date spans
as necessary. The edit date icon opens the Date Editor. Eg. for a Married Name, date
the name is first used or marriage date.

Sources tab
The Sources tab displays information about sources relevant to this name and
controls allowing its modification. The central part displays the list of all such sources'
references stored in the database. The buttons + , Edit , and - allow you to
correspondingly add, modify, and remove a source reference to this name. Note that
the Edit and - buttons become available only when a source reference is selected from the list.
More info: Source reference editor

Fig. 5.25 Attribute editor
the changes made in all tabs and close the dialog window. Clicking the Cancel button at any time will close the window without applying any changes.

Tip

Note tab

The tab labels reflect the presence of corresponding information: if the tab contains any data, its label appears
boldface
boldface; if the tab has no data then its label appears
regular (not bold).

The Note tab displays any notes concerning the name. To add a note or modify existing notes simply edit the text in the text entry field.
More info: Note Editor

Attributes

The top tab allows editing of the most general information about the attribute:
1. The name of an Attribute you want to use. For example: Height (for a
person), Weather on this Day (for an event), ... Use this to store snippets of
information you collect and want to correctly link to sources. Attributes can
be used for people, families, events and media.
2. The Val ue of the attribute. Eg. 1.8m, Sunny, or Blue eyes.
The information can be typed in the appropriate text entry fields. The attribute name
can also be selected from available choices (if any) listed in the Attribute dropdown menu.

Attributes are edited through the following Attribute Editor dialog:
The top of the window shows the dialog title including the name of the person whose
attribute is being edited. The central part of the window displays three notebook tabs
containing different categories of available information. You can bring any tab to the
top for viewing or editing by clicking on the appropriate tab heading. The bottom part
has OK and Cancel buttons. Clicking the OK button at any time will apply all
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Note
Some predefined attributes are present because the are
defined in the GEDCOM standard.
Check the Private record box to mark this attribute record as private. This
will give you a chance to omit this attribute from being included in the reports, if you
choose so among the report generation options.
• Sources
The Sources tab displays information about sources relevant to this attribute and
controls allowing its modification. The central part displays the list of all such sources
references stored in the database. The buttons + , Edit , and - allow you to
correspondingly add, modify, and remove a source reference to this attribute. Note that
the Edit and - buttons become available only when a source reference is selected from the list.
• Note
The Note tab displays any notes concerning the attribute. To add a note or modify
existing notes simply edit the text in the text entry field.
The Format option allows you to set the appearance of the note in the output
(i.e. in reports and web pages). Selecting Flowed will replace all multiple spaces,
tabs, and single end-of-line characters with single space in the output. The two consecutive new lines (i.e. an empty line) denote a new paragraph. Selecting Preformatted will honor all multiple spaces tabs, and new lines, so that the output will
appear as it is entered into the text entry field.

Fig. 5.26 Address editor

Tip
The tab labels reflect the presence of corresponding information: if the tab contains any data, its label appears
boldface
boldface; if the tab has no data then its label appears
regular (not bold).

Addresses
Addresses are edited through the following Address Editor dialog:
The top part shows the dialog title including the name of the person whose address
is being edited. The central part of the window displays three notebook tabs containing
different categories of available information. You can bring any tab to the top for
viewing or editing by clicking on the appropriate tab heading. The bottom part has
OK and Cancel buttons. Clicking the OK button at any time will apply all the
changes made in all tabs and close the dialog window. Clicking the Cancel button
at any time will close the window without applying any changes.

It provides the following information categories of the address data:
The top of the window allows editing of the most general information about the address:
1. Date : Date at which the address is valid.
2. Street : The street of the address.
3. Locality : The locality name of the address.
4. City : The village or city of the address.
5. State/County : The state or county of the address in case a mail
address must contain this.
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Country : Country of the address.
ZIP/Postal code : Postal code.
Phone : Phone number linked to the address.

the same person. It can also happen after importing GEDCOM obtained from a relative,
whose database overlaps with your existing data.
Whenever you detect duplicate records, merging them a useful way of correcting
the situation.

Note

Tip

Use Residence Event for genealogical address data.

To make a merge, exactly two records have to be selected in the appropriate view (People View, Sources View,
or Places View). This is accomplished by selecting one
entry and then selecting another person while holding
down the Ctrl key.

The information can be typed in the appropriate text entry fields. Check the Private record box to mark this address record as private. This will give you a
chance to omit this address from being included in reports, if you choose so among the
report generation options.
• Sources
The Sources tab displays information about sources relevant to this address and
controls allowing its modification. The central part displays the list of all such sources
references stored in the database. The buttons + , Edit , and - allow you to
correspondingly add, modify, and remove a source reference to this address. Note that
the Edit and - buttons become available only when a source reference is selected from the list.
• Note
The Note tab displays any notes concerning the address. To add a note or modify
existing notes simply edit the text in the text entry field.
The Format option allows you to set the appearance of the note in the output
(i.e. in reports and web pages). Selecting Flowed will replace all multiple spaces,
tabs, and single end-of-line characters with single space in the output. The two consecutive new lines (i.e. an empty line) denote a new paragraph. Selecting Preformatted will honor all multiple spaces tabs, and new lines, so that the output will
appear as it is entered into the text entry field.

Merge People
Merging two people is done from the Edit menu.

Note
Merging people does not discard any information. The
decisions you make during the merge only affect which
data will become primary and which will become secondary for the resulting merged record.

• Merge
When exactly two people are selected, choose Edit ->Merge... to invoke the Merge
dialog.
The dialog allows you to make a decision on whether or not the selected records should
be merged. If you decide that the records should not be merged, despite similar names,
you may click Cancel button to close the dialog without making any changes. Expanding the "Detailed Selection" and the "Context Information" fields on the bottom left
(fig. 5.27) shows more information about the people to be merged.
If you decide to proceed with merging, select the appropriate Select radio
button to specify the record to be used as the source of primary data, then click OK .
The data from the other record will be kept as alternate data.

Merging records
Sometime several records in the database turn out to be describing the same object:
same person, same place, or same source. It could happen either when the data is entered twice by mistake, or when new information reveals that the two entries refer to

5

From Gramps

Gramps 3.3 Wiki Manual - Entering and editing data: detailed - part 3

Fig. 5.26 Merge people (regular view)
Specifically, all names from the other record will become alternate names of the
merged record. Similarly, parents, spouses, and children of the other record will become alternate parents, spouses, and children of the merged record, and so on.

Merge Families
When exactly two families are selected, choose Edit ->Merge... to invoke Merge
Families dialog.
The dialog allows you to make a decision on whether or not the selected records
should be merged.
If you decide that the records should not be merged, despite similar titles, you may
click Cancel to close the dialog without making any changes.
If you decide to proceed with merging, choose the appropriate radio button to specify:
•
•
to be used for the merged record, then click OK
Fig. 5.27 Merge people (expanded view)

Merge Events

If you decide that the records should not be merged, despite similar titles, you may
click Cancel to close the dialog without making any changes.
If you decide to proceed with merging, choose the appropriate radio button to specify:

When exactly two events are selected, choose Edit ->Merge... to invoke Merge
Events dialog.
The dialog allows you to make a decision on whether or not the selected records
should be merged.
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•
•
to be used for the merged record, then click OK

Merge Sources

Fig. 5.28 Merge sources (regular)

When exactly two sources are selected, choose Edit ->Merge... to invoke Merge
Sources dialog.

Fig. 5.29 Merge sources (expanded)

The dialog allows you to make a decision on whether or not the selected records should
be merged.
If you decide that the records should not be merged, despite similar titles, you may
click Cancel to close the dialog without making any changes.
If you decide to proceed with merging, choose the appropriate radio button to specify:
• Title
• Author
• Abbreviated title
• Publication information
• ID
to be used for the merged record, then click OK .

Merge Places
When exactly two places are selected, choose Edit ->Merge... to invoke Merge
Places dialog.
The dialog allows you to make a decision on whether or not the selected records
should be merged.
If you decide that the records should not be merged, despite similar titles, you may
click Cancel to close the dialog without making any changes.
If you decide to proceed with merging, choose the appropriate radio button to specify:
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Fig. 5.30 Merge places (regular)
• Title
• Latitude
• Longitude
• Location
• ID
to be used for the merged record, then click OK .

Merge Media Objects
When exactly two Media Objects are selected, choose Edit ->Merge... to invoke
Merge Media Objects dialog.
The dialog allows you to make a decision on whether or not the selected records
should be merged.
If you decide that the records should not be merged, despite similar titles, you may
click Cancel to close the dialog without making any changes.
If you decide to proceed with merging, choose the appropriate radio button to specify:
•
•
to be used for the merged record, then click OK

Fig. 5.31 Merge places (expanded)

Merge Repositories
When exactly two repositories are selected, choose Edit ->Merge... to invoke Merge
Repositories dialog.
The dialog allows you to make a decision on whether or not the selected records
should be merged.
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If you decide that the records should not be merged, despite similar titles, you may
click Cancel to close the dialog without making any changes.
If you decide to proceed with merging, choose the appropriate radio button to specify:
•
•
to be used for the merged record, then click OK

•
•
to be used for the merged record, then click OK
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Merge Notes
When exactly two notes are selected, choose Edit ->Merge... to invoke Merge
Notes dialog.
The dialog allows you to make a decision on whether or not the selected records
should be merged.
If you decide that the records should not be merged, despite similar titles, you may
click Cancel to close the dialog without making any changes.
If you decide to proceed with merging, choose the appropriate radio button to specify:

This page was last modified on 26 October 2011, at 22:04. This page has been accessed
1,180 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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As long as any database is open, Gramps is focused on a single person usually referred to
as an Active Person. This allows you to view or modify the data concerning this person,
his or her immediate family, etc. Navigating in the database (i.e. moving from person
to person) is in fact nothing else but changing the Active Person. This section describes
many alternative ways to navigate through the database using both the complex and
the convenient interfaces Gramps provides. All these ways eventually accomplish the
same thing, but some are more convenient than others, depending what you are doing
in Gramps at the moment.

that list entry. The person you have selected becomes active. The statusbar updates to
reflect the change of the active person.

Using the Family View
When in the Relationships, you can easily navigate between the members of the displayed family as follows:
To make the currently selected spouse the Active Person, click the double-arrow
button to the right of the Active Person box. Alternatively, right-click into the spouse
box and select Mak e the selected spouse an Active Person
item from the context menu.
To make the currently selected parents the active family (thereby making father
the Active Person and mother the selected spouse), click the right-arrow button to the
right of the active person's parents box. Alternatively, right-click into the active person's parents box and select Make the selected parents the active family item from the context menu.
To make the currently selected spouse's parents the active family (thereby making
father the Active Person and mother the selected spouse), click the right-arrow button
to the right of the spouse's parents box. Alternatively, right-click into the spouse's parents box and select Make the selected parents the active
family item from the context menu.
To make the currently selected child the Active Person, click the left-arrow button
to the right of the children box. Alternatively, right-click into the children box and select Make the selected child an Active Person item from
the context menu.
In addition to this, Gramps provides an extensive set of keyboard navigation options. The detailed reference to the key bindings is found in the Appendix B: Keybindings reference.

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions
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Using the People View
The most intuitive way to select an Active Person is to use the People Category. When
in the People View, just select the name of the desired person from the list by clicking
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Using the Ancestry Views

Setting the Home Person

The Ancestry Category also allow you to move along the family tree. The benefit of this
method is that you can see more than one generation of the family tree. Also, you can
jump directly from a great-grandson to a great-grandfather without going through the
intermediate generations.
Note that after changing the Active Person in the Ancestry Views, the display is readjusted to show up to five generations, starting from the newly selected Active Person.
When in the Ancestry Views, you can easily navigate between the members of the displayed family tree as follows:
To make any displayed person the Active Person, right-click the corresponding box
and choose the first entry in the context menu.
To make a child of the currently Active Person (if any) the Active Person, click the
left arrow button to the left of the corresponding box. If there is more than one child,
the button expands to the menu listing the children to choose from.
To move the whole family tree one generation back, click on the corresponding
right arrow button on the right-hand side of the display area. Clicking the upper button
will move the tree along the paternal line. Clicking the lower button will move the tree
along the maternal line.
Clicking either of these buttons is completely equivalent to double-clicking the lines
connecting to the left of the corresponding boxes for father and mother.
You can also quickly access any of the spouses, siblings, children, or parents of any
displayed person. To do this, move the mouse over the desired person's box and rightclick to invoke a context menu. The appropriate menu items will contain submenus listing all spouses, siblings, children, and parents of the corresponding person.

One and only one person in the database can be selected as the Home person. Once the
Home person is selected, moving to that person becomes a matter of a single click, regardless of which view you are using at the moment.
To set the Home person, first navigate to that person using any method you like.
Then choose the People category and select the menu Edit ->Set Home Person
Person. Once this
is done, you can move to the Home person from anywhere in the database by simply
clicking the Toolbar Home icon. You can also choose the menu Go ->Home or select
Home item from any context menu available on the right click or use the keyboard
shortcut Alt + Home .

Using history-based tools
Gramps also features a powerful set of history-based navigation tools. These tools are
similar to those commonly used in web browsers.
They include Ba ck and Forward items available from the Go menu, context menus (available in People, Family, and Pedigree views), and the toolbar buttons.
They also include the list of the recent selections available under the Go menu that
allows you to jump directly to any of the recent selections. Finally, right-clicking on the
Back and Forward toolbar buttons invokes the popup menu with corresponding portion of the history. Select any item from the menu to jump directly to it.

Bookmarks
Similar to setting the Home person, you can bookmark other people from the database
to simplify further navigation. To bookmark a person, first navigate to that person, then
choose the menu Bookmarks ->Add Bookmark
Bookmark. To move to that person from anywhere
in the database, choose the menu Bookmarks ->
->Person's
Person's name from the list of bookmarked names shown.
You can manage your bookmarks by choosing the menu Bookmarks ->Organize
bookmarks...
bookmarks.... This opens the Organize Bookmarks dialog with the list of
bookmarks and the controls to modify this list.
Use the Up and Down buttons to change the list sequence. Use the Remove button to remove a Bookmark. The Help will bring you to this page, and
you close the Orga nize Bookmarks window with the Close button.

Advantages of using right-click menus
Direct access to spouse and siblings. Complete lists of all
member of all categories, not only the preferred members.
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Finding records

Fig. 6.1 Organize Bookmarks
The Bookmarked People can be selected through the People View, as explained
above, but also through the Relationships View, Families View, and the Pedigree View.
On a similar basis you can also Bookmark: Events, Sources, Places, Media, Repositories , and Notes.

To find a record in a database, first switch to the appropriate View that provides the list
of the desired records: People, Sources, Places, or Media. Then start typing the name of
a person or the title of a Source, Place, or Media object that you are looking for, respectively. You may also press CTRL + F to turn on the search mode, but simply starting to
type is also enough.
As you type, the first record in the list that is compatible with your input will be selected.

Finding People
For more complex people searches you may want to use
filters. Enable filter controls by choosing menu View ->
Sidebar
Sidebar, select the desired filter, and click Find . For
details, see Filters.
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Using the Clipboard

dialog. To reuse the record, drag it from the Clipboard on to the corresponding place in
the editor, e.g. Address tab, Attribute tab, etc.

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Tip
Some objects are showing the link icon on the left. This
indicates that dragging such selection will produce a
reference to an existing object, not copy the object itself. For example, the media object file will not be duplicated. Instead, the reference will be made to an existing
media object, which will result in the local gallery entry.

Tip
Clipboard storage is persistent within a single Gramps
session. Closing the window will not lose the stored
records. However, exiting Gramps will.
This tool provides a temporary note pad to store database records for easy reuse. In
short, this is a sort of the copy-and-paste functionality extended from textual objects to
other types of records used in Gramps.

The Clipboard can be accessed with the Keyboard shortcut (accelerator key) CTRL + B .
For an application like Gramps the Clipboard is very important.
One example
You find a birth certificate of a person. In this certificate also the witnesses are
mentioned. And the birth certificate also determines a source where the
information was stored. The best way is to open the clipboard and drag the
source you want to work with there. Then use drag and drop to use it in new
items you use.

Clipboard makes extensive use of the drag and drop
technique
To invoke Clipboard, either choose the menu Edit>Clipboard or click the Toolbar Clipboard button.

Now you can finalize the information on the person editor screen. Drag that info also to
the Clipboard.
Now you add two new persons for the witnesses (assuming you do not have them
already in your database). Simply drag and drop the birth info to the witness event
screen. You are then presented with the screen where you can change the role of the
witness to witness for this birth event. You do the same with the other witness.
This saves you a lot of typing and possible errors.

Clipboard supports addresses, attributes (both personal and family), events (both
personal and family), names, media objects references, source references, URLs, and of
course textual information of notes and comments. To store any type of these records,
simply drag the existing record on to the Clipboard Pad from the corresponding editor
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Windows (Menu)

The Windows-> Menu provides quick access to opened windows you are working on.

Tagging
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.
Go to the Menu Edit ->Tag
->Tag.

Concept

Or click the Toolbar Tag button.
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• For people using gmail or thunderbird, tags will not be something new. Instead of
classifying emails into folders like in Outlook (Windows) or Evolution (Linux), emails
are classified by assigning tags to them. So instead of having a disjoint N:1
classification (a email can be in one and only one folder, and a folder can contain
many emails), in gmail or thunderbird there is a N:M classification (a email can have
several tags, and a tag can be applied to several emails)
Likewise, when you have a big tree, you might want to make subsets of the tree, and
these subsets might be overlapping. For example, the subsets of your fathers family and
your mothers family, some subset of your family that emigrated to the USA, or the famous people in the tree.
The idea is to assign a different tag to each subset: FATHER, MOTHER, USA and
FAMOUS for example.

Differences with markers

Specifying your fathers family using filters is an easy thing; there are already filters
based on some logics that do it. On the other hand, specifying the people that emigrated
to the USA is harder, while for the famous people in your family it is simply impossible
as there is no logical rule. Tags are much more practical here.
However filters have the advantage of being dynamical
dynamical. If you add an ancestor of
your father in the database, it will be automatically added to the filter.
On the other hand, tags are statical
statical. When adding a famous person in the tree, you
have to explicitely tag them as FAMOUS.
• The most immediate object that comes to mind are the individuals, and that is also
the most useful. However, other objects could be tagged:
• Places: For example "places to visit",
• Source: For example "sources in german",
• Notes: For example "notes in progess", or "notes in german",
• Media: For example "Picture belonging to Uncle Alfred".
Tags are available to use with People
People, Families
Families, Notes and Media
Media.

• Markers are like the folders for emails. A person can be given at most one marker.
Tags are thus like multiple-valued markers.

Tags and Filters
• Tags and filters both create subsets of the tree. However they have practical
differences in usage.
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Tags Column

Operations with tags
Here are a few ideas of operations that can be done with tags

Filtering
The most obvious use is that of filtering.

Tagging a selection of objects

It is convenient to have a Tags column in the views of objects that can be tagged.
The content is a comma-separated list of the tags of the objects.
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Due to the static nature of tags, it might be useful to add a tag to a selection of objects.
For example one should be able to select a number of person in the Person View, and
add them a new tag or an existing one.
This page was last modified on 26 October 2011, at 22:05. This page has been accessed
1,201 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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loaded by Gramps as they are needed, so that many users will not need to be aware of
the existence of plugins, or their delayed loading.
The Plugin Manager allows you to control how Gramps manages plugins.

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions
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Plugin types
There are two main categories of plugins in Gramps: "user plugins" and "system plugins". User plugins are those that you use and control to provide different functionality
for you. The system plugins are used by Gramps.
The following types of User Plugins are present in Gramps:
1. doc creators: Backends for which Gramps can write reports (pdf, odf, ascii
text, ...)
2. exporters: export formats you can export your data too via menu Family
Trees ->Export...
3. gramplets: small programs you can embed in the GrampletView, or detach
and use as a normal window
4. gramps views: the views visible in the main window of Gramps
5. importers: import formats from which Gramps can import data via menu
Family Trees ->Import...
6. map service: targets that can be used on the place view to go to an internet
map service (Go toolbar button)
7. quickreport: small reports that are available in the context menu on the
listviews, or via the Quickreport gramplet
8. reports: Textual or graphical reports Gramps can produce
9. tools: Tools you can start via the menu Tools
The following types of System Plugins are present in Gramps:
1. plugin libs: libraries that are present giving extra functionality.
2. relationships: relationship calculators for different languages
There are many plugins that come with Gramps. However, anyone can also write a plugin and share it. These third-party plugins are called "addons". We highly encourage
users and developers to share their creations with other Gramps users.

Next

The Plugin Manager is available from the menu Help ->Plugin Manager
Manager. Many of the features of the Plugin Manager are intended for developers, and the dialogues described
below are those seen by developers. The features for normal users are noted below
where they are different.
Gramps detects whether it is being run in User mode or Developer mode by the 'optimise' flag:
python -O gramps.py
See Debugging GRAMPS.
Gramps consists of a core plus many plugins. When Gramps starts, the core is
loaded and only a limited number of plugins are loaded. This decreases the startup time
and memory requirements of Gramps. Subsequently, many plugins are automatically

1

From Gramps

Gramps 3.3 Wiki Manual - Plugin Manager

Registered Plugins

Registration and loading
Plugins are either held locally on the computer and are known about by Gramps, when
they are said to be Registered
Registered, or they are held on a remote computer and Gramps only
knows their name, type and description, when they are said to be Addons
Addons.
When Gramps starts, information is automatically read about the local plugins, so
that they become registered. The Plugin Manager can be used to download remote Addons so that they too become registered.
Registered (i.e. local) plugins are loaded by Gramps in the following situations:
1. they are automatically loaded at startup. Some plugin types are loaded at
startup (e.g., non hidden views), some plugins can have a flag that forces
load on startup,
2. they are automatically loaded by virtue of the user clicking on a view or
requesting a report,
3. they are loaded by the user explicitly requesting load in the plugin manager,
4. remote plugins are loaded at the same time as they are registered by using
Install Addons described below.

Hide/Unhide

Here you see a list of all plugins that Gramps has found. These are the plugins which are
part of Gramps, as well as the plugins found in the gramps33/plugins directory within
the GRAMPS User Directory. The type of plugin is shown in the first column.
A plugin can be made hidden or unhidden. This is only useful for the User Plugins.

The plugin Manager can be used to hide or unhide plugins. Some menus will not display
hidden addons, so that the addon cannot be selected. For example, if a Gramplet is hidden, then it will not appear in the "Add a gramplet" context menu which appear when
right clicking the background of the Gramplets main tab. However, hiding some addons
(such as Relationships or Gramps Views) has no effect and may not even be allowed.

Actions
There are three tabs of the Plugin Manager: Registered Plugins, Loaded Plugins, and Install Addons.
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Loaded Plugins

Install Addons

Here you see a list of all plugins that have been attempted to be loaded. Normally, all
views (such as the Relationship View) will be loaded, and all gramplets/reports/tools
you have used will be loaded automatically.
If there was an error during the loading of a plugin, then the staus will be shown
in this tab. Double clicking a row showing a failure opens a dialog showing the error in
detail. You can use this to contact the plugin author or the Gramps bug list.

Here you will initially see an empty list. By clicking the "Refresh Addon List" button,
Gramps will fetch the listed third-party plugins (known as Addons) listed at 3.3 Addons.
You may wish to refresh this list every once in a while to see the latest Addons.
Also, you can enter an Addon's URL or path to a filename in the "Path to addon" to
load the Addon.
An addon is a packaged set of files made to run in this version of Gramps. The addon
package may end in "addon.tgz" or ".zip". You cannot install a .py file directly, but will
need to install the .gpr.py and .py files by having access them in a package. For details
on creating an Addon, see Addons Development.
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After refreshing the addon list you may also click on a specific Addon listed. This will
place the URL of the add in the "Path to addon". Then you can select "Install Addon" to
download and install the selected Addon.
You may also select "Install All Addons". This will go through the list and download
(or update) all of the listed Addons.
Later if you decide that you do not like an Addon, you can mark it "hidden" and it
will no longer show.
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This page was last modified on 26 October 2011, at 06:54. This page has been accessed
445 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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This page details the functionality of the Gramplets. If you would like to read more technical details about writing your own Gramplet, please see Gramplets. For more Gramplets that you can extend your Gramps functionality with, see Third-party Plugins.
A Gramps Gramplet is a view of data that either changes dynamically during the running of Gramps, or provides interactivity to your genealogical data. What is the difference between gramplets, reports, quick views, and tools?
• Reports provide a static output format of your data, typically for presentation
• Quick View provides a typically short, interactive listing derived from your data
• Tools provide a method of processing your data
• Gramplets provide a dynamic view and interface to your data
Gramplets are the widgets that are part of Gramps and can be seen in the Gramplet View
and Sidebars, Bottombars. The widgets provide all kind of functionality that can be useful for the researcher.
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When you first start the Gramplets View you will see two default Gramplets; the
Welcome Message Gramplet and the Top Surnames Gramplet
Gramplet.

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.
These are 18 default gramplets:
1. Age Stats Gramplet - see age span graphs
2. Age on Date Gramplet - see the people alive and their ages on a particular
date
3. Attributes Gramplets - see active person's attributes
4. Calendar Gramplet - see people's events on a particular date, or in a month
in the past
5. Descendants Gramplet - see the active person's descendants
6. Fan Chart Gramplet - see the active person's pedigree, in a circular fan chart
7. Given Name Cloud Gramplet - most popular given names
8. Pedigree Gramplet - see a complete pedigree in compressed text
9. Quick View - run a Quick View on the current person
10. Records Gramplet - see world's records of your data
11. Relatives Gramplet - see the relatives of the active person
12. Session Log Gramplet - keep track of what you have done, and what records
you have visted
13. Statistics Gramplet - see stats on the database
14. Surname Cloud Gramplet - most popular surnames as a "text cloud"
15. TODO Gramplet - a notepad to keep tabs on your research
16. Top Surnames Gramplet - top 10 most popular surnames
17. Welcome Gramplet - a Gramps welcome message
18. What's Next Gramplet - what needs to be done next

You can drag the Properties button (top left) of each Gramplet to move it around the
Gramplet View area. You can click the Properties button to detach the Gramplet from
Gramplet View and place it in its own window. The window will stay open regardless
of page (relationship, ancestry, etc). Closing the detached view will put it back onto the
Gramplets view. If you quit Gramps with a open gramplet, when you start gramps again,
it will open automatically.
When one or more Gramplets are undocked from the Gramplet View, you can
change to a different view (such as the People or Ancestry Views). In this way, you can
use these gramplets to supplement a particular view with additional details and functionality provided by the gramplet.

Additional Gramplets
Starting with Gramps version 3.3 a new system was implemented to have even more Gramplets available. This
system is controlled by the Plugin Manager
Manager. The Plugin
Manager can get additional Addons for you. Check the
list of the available reports here
here.

You can add new gramplets by right clicking on an open space on Gramplets. You can
also change the number of columns by right-clicking an open area on the Gramplets
page.

Here you can see the other gramplets available on this moment:
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• Data Entry Gramplet - edit active person's name, birth date and place, death date
and place, and add people
• Note Gramplet - see and edit active person's primary Person Note
• Headline News Gramplet - current, breaking news from Gramps
• FAQ Gramplet - frequently asked questions
• Python Gramplet - a Python shell
If a link in a Gramplet is to a specific person, then clicking the link will change the Active Person. Double-clicking such any link to a specific Gramps item (such as person or
family) will bring up the Editor for that item. To edit a linked person without changing the Active Person, right-click on the person link. Depending on the type of entry,
double-clicking any row in a Quick View table will either select more specific data (drill
down) or bring up the editor.
This section will describe each gramplet and its basic functionality.

Changing settings

Fig. 7.3 Age On Date Gramplet

You can change the settings of the Gramplets by editing
your ~/.gramps/
~/.gramps/gramplets.ini
gramplets.ini file. But you can only do
that when GRAMPS is not running. Just bring up the
gramplets.ini file in a text editor and make the desired
changes. You can change the title of the Gramplet by
changing the section name (surrounded by square
brackets). These options will be able to be changed via
the Gramplet View in the next version of GRAMPS. If
you have an idea for additional Gramplets, please let us
know!

Age on Date Gramplet
This Gramplet gives you the possibility of entering a date in an entry field. If you click
Run the Gramplet will compute the ages for everyone in your Family Tree on that
Date. The date must be entered in a format that Gramps accepts.
You can then sort by the age column, and double-click the row to view or edit.

Fig. 7.3a Age On Date Quick Report

Age Stats Gramplet
The Age Stats gramplet shows graphs of the breakdown of particular age spans. Clicking
on a row will bring up the associated people.
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You can change the gramplet's options by detaching, and selection the options
drop-down area, and pressing Save .

Calendar Gramplet

Fig. 7.4 Age Stats Gramplet

Fig. 7.8 Calendar
The Calendar gramplet shows a monthly calendar. Double-click a day to run the On
This Day Quick View.
With the < and > buttons top left corner (month) you can change to the previous and next month.
With the < and > buttons top right corner (year) you can change to the previous and next year.
The Quick View window shows you the Events of the selected day: Events on this exact date and Other events on this Month/day in history as well as Other events in that
year.
The information is presented in a table showing:
• Date
• Type
• Place
• Reference

Fig.7.5 Age Stats Gramplet showing options
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Quick View Gramplet

You can also drag a date to the date field of the Age on Date Gramplet to enter that date.

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Given Name Cloud Gramplet

Fig. 7.13 Quick View Gramplet
Fig. 7.11 Given Name Cloud Gramplet

The Quick View gramplet allows you to run a Quick View, it updates as you move
from person to person. (Currently, only People Quick Views can be run).
You can run any of the Quick Views for a person.
You can change the options by clicking the Option button (top, left hand button of
the Gramplet) which will detach the gramplet and bring it up an a window. Select Options on the top row, and a list of options will appear. Press Save to apply the
changes to the Quick View. You may then close the window to reattach the gramplet.
Currently, the Quick View Gramplet doesn't remember which Quick View between
Gramps sessions, so you'll have to reselect it when you restart Gramps. (This will be
fixed in an upcoming version of Gramps ???).

Like the Surname Cloud Gramplet, the Given Name Cloud gramplet shows the top most
popular given names in your family tree. The size of the name indicates how popular it
is. Mouse over the name to see the exact count, and the percent of people in the family
tree that have that name.
The gramplet splits up given names into words (broken up by spaces). For example
"Sarah Elizabeth" would appear under both "Sarah" and "Elizabeth".
Double-click on the given name to bring up a Quick View of all of the matching people.
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Records Gramplet

•
•
•
•
•
•

Oldest mother
Couple with most children
Living couple married most recently
Living couple married most long ago
Shortest past marriage
Longest past marriage

The list is not only interesting on its own, it is also a good sanity check of the data.
For some items you have to fill in some additional information.
This following example shows that there was a marriage event (thus calculation of
the offset) but none of the persons had a death event. Even if the date is not known, just
enter a death event for one of the partners and the list will be corrected.

Living couple married most long ago
# van Dosselaere, Egidius and Rechters, Petronella (382 years, 1 mont
# de Richter, Petrus and Asscericx, Catharina (379 years, 9 months)

Session Log Gramplet
Fig 7.14 Records Gramplet
The Records Gramplet shows a number of interesting facts about the records (mostly
age related) from your database. The list shows the top three for each element.
• Youngest living person
• Oldest living person
• Person died at youngest age
• Person died at oldest age
• Person married at youngest age
• Person married at oldest age
• Person divorced at youngest age
• Person divorced at oldest age
• Youngest father
• Youngest mother
• Oldest father

Fig. 7.16 Session Log Gramplet
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The session log keeps track of activity in this session. It lists selected and edited objects.
Click a name once to make this person the active person. Double-click on a name
or family brings up the edit page for that object. In addition, if you want to edit a
person, but don't want to change the active person, you can right-click on the person's
name.
This gramplet is handy because you can very quickly change the active person, or
edit the object, from the session list.

The Statistics gramplet runs a Statistics report. Double-click the phrases to bring up
the matching items.
Following information is provided to you in this Gramplet:
• Individuals
• Number of individuals
• Males
• Females
• Individuals with unknown gender
• Individuals with incomplete names
• Individuals with missing birth dates
• Disconnected individuals
• Family information
• Number of families
• Unique surnames
• Media objects
• Individuals with media objects
• Total numbers of media object references
• Number of unique media objects
• Total size of media objects
• Missing Media Objects
As with all Gramplets if you click on the left hand side Tool button you detach the
window and if you add persons to your family tree, you will see the amount of individuals change dynamically.

Statistics Gramplet
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Surname Cloud Gramplet
The surname cloud gramplet shows the top 100 (by default) used surnames. The name
font size is proportional to the amount of people with the same name.
Double-click a surname to run the Same Surnames Quick View . This
will open the Quick View window where you can find all people with a matching or alternate name. Person, birth date and name type are given.
If you mouse over the name you see the percentage of occurrence and total counts.
Change the number of names displayed by editing this section in ~/.gramps/gramplets.ini

Fig. 7.17 Statistics Gramplet
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Fig. 7.19 TODO Gramplet
(In future versions, you will be able to save links to Gramps items (like people,
events, and families. This will allow you to keep a group of links that you are working
on together. ???)
The text is persistent between sessions. The data is saved to disk when you exit
Gramps.
You can open more TODO lists to save different kinds of topics or organize your info.
Change the title of the gramplet by editing the section name in ~/.gramps/gramps33/gramplets.ini

Fig. 7.18 Surname Cloud

TODO Gramplet

Top Surnames Gramplet

The TODO gramplet is free form text area. You can use this area to put some notes,
remarks, things you should to get your research going. There are several other TODO
programs (e.g. Tomboy e.a.) but this Gramplet is useful as the information stays within
Gramps.

The top surnames gramplet shows the top 10 (by default) used surnames.
The top ten is presented as follows:
• Surname
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Fig. 7.20 Top 10 Surnames
• percentage
• occurrences
The list gives you also the Total unique surnames in the database as well as the total
number of people in your database.
Double-click a surname to run the Same Surnames Quick View . This
opens the Quick View window, which gives the people with the surname you
double-clicked.
A table is presented which shows all people with a matching name or alternate
name. Person's name, birth date and name type is given.
Change the number of names displayed by editing this section in ~/.gramps/gramplets.ini

Fig. 7.21 Welcome Gramplet
This information can also be found on the start page of Gramps

Welcome Gramplet
The welcome gramplet gives an introductory message to new users, and some basic instructions.
The welcome message describes what Gramps is, that the program is Open Source
Software and how you start a Family Tree.
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What's Next Gramplet

Sidebar and bottombar

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.
Since Gramps 3.3 we have common and specific gramplets according active view (navigation/category).
• Back references gramplets are like the references tab on object Editor.
• Filter gramplet is like the previous filter sidebar
• Common models for Notes, Gallery, Sources, Events
• Children gramplet on Person views (also ancestry category and relations), family
view

Fig 7.22 What's Next Gramplet

Person

The What's Next Gramplet displays a list of the "most urgent" information gaps in
your family tree. It is based on the following assumptions:
• You want to know first and last name, birth date and place, and death date and
place of each person
• You want to know father, mother, marriage date and place, and - if divorced divorce date and place of each family with married parents
• You want to know at least the mother of each family with unmarried parents
• The closer the relationship to the main person, the more "urgent" the information
gap is.
• The closer the common ancestor is from the main person, the more "urgent" the
information is (e.g. nephews are considered more "urgent" than uncles, even
though both have a distance of 3, because for nephews the common ancestor is
father/mother, while for uncles, the common ancestor is grandfather/
grandmother)
• Marriage data and personal data of the spouse is slightly less "urgent" than
personal data of the directly related person
• Half brothers are less "urgent" than brothers

Attributes Gramplet
The Attributes gramplet shows all of the attributes for the current, active person. Double click on the name of the attribute, and you will run a Quick View that shows all of
the people that have that attribute, and the values for it. You can sort the Quick View
by the attribute value by clicking on the column name.
In the Quick View, highlight the entry to change the active person (which will then
change the Attributes Gramplet), and double-click the Quick View entry to bring up the
Edit Person dialog window.

Descendant Gramplet
The Descendent gramplet shows the direct descendants of the active person.
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Fig. 7.6 Attributes Gramplet

Fig. 7.9 Descendant Gramplet
The order of the spouses and children is that given in the Gramps editor. To change
the order of spouses, click on Order on the Relationship view. To change the order of
children, drag and drop them in the correct order in the Family edit window.
This gramplet is based on the Descendant Report, available from the Textual Reports.
The Descendant gramplet will update when you change the active person, or change
family trees. It does not update automatically for edits or additions because this report
is time-consuming to run.
Minimizing a gramplet will prevent it from updating.
Fig. 7.7 Attributes Quick View
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Person details

The Fan Chart gramplet shows the direct ancestors of the active person in a circular
format. It is similar to the Pedigree View, but shown around the center/active person,
and further generations spiralling out.
Click on a parent in the chart and they will expand or contract above their child.
Right-click on a person and you can:
• select that person to be the active person
• edit the person
• select from among the person's relatives to be the active person
Clicking in an open area (non-person) and dragging the mouse will allow you to rotate
the chart about the center. In Gramps 3.3, you may also left-click and drag in the center to
reposition the fan chart.
A white edge on the outer radius of the chart indicates more parents for that person.
A black circle in the center indicates that the center person has children.
The Fan Chart gramplet will update when you change the active person, or change
family trees.
Minimizing a gramplet will prevent it from updating.

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Fan Chart Gramplet

Pedigree Gramplet

Fig. 7.10 Fan Chart Gramplet
Fig. 7.12 Pedigree Gramplet
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Place

The Pedigree gramplet shows a compressed view of the active person's direct ancestors.
It defaults to going back 100 generations. The names can be clicked to change the active
person, double-clicked (or right-click) to edit the person. This Gramplet also shows at
the bottom of the gramplet the number of people per generation. Double-click the Generation number to see the matching individuals.
In Gramps 3.3, you can now see birth and death dates next to a person's name.

Place details

Media Object

Relatives Gramplet

Preview
Since Gramps 3.3 the preview moved to a gramplet.

Image Metadata
The Image Metadata Gramplet offers an easy interface to add, edit, and remove Image
Exif Metadata from your images (*.jpg, *.png. *.tiff, *.exv, *.nef, *.psd, *.pgf).

Special Note
Before being able to use this gramplet/ addon, you will
need to download and install pyexiv2 or install pyexiv2
from your local Linux repository. Windows user, there
is an installer for you. Ubuntu, use the Universe repository to find pyexiv2.

Fig 7.15 Relatives Gramplet
This Gramplet shows all direct relatives of the active person. It's intended use is as
a navigation help, an alternative way to move through your Gramps database. If you
detach the gramplet, and place it next to Gramps, it will allow you to use it to easily
change the content of the current "person view".
If you are working in the ancestry views, the active person is the left-most person.
By clicking a name in the relatives gramplet, you can easily change the active person,
and all person view in the other window will update. As the relatives gramplet shows all
spouses, all children and all parents, this offers an alternative way of navigating your
data.
The names in this gramplet also allow you to call up the person editor directly, by
right-clicking on any of the names.

Once you have installed pyexiv2, see above for directions to download and install this
addon...
Pyexiv2 can be used from the command line interface (cli) as well, and from within
a python script:
1. import the pyexiv2 library
from pyexiv2 import ImageMetadata, ExifTag
2. specify your image
image = ImageMetadata("/home/user/image.jpg")
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Fig. Image Metadata Gramplet
3. read the image
image.read()
Exif, IPTC, XMP metadata reference tags can be found here.
Example:
image["Exif.Image.Artist"] # Artist
Smith and Johnson's Photography Studio
image["Exif.Image.DateTime"] # DateTime
1826 Apr 12 14:00:00
image["Exif.Image.DateTime"] = datetime.datetime.now() # Add DateTime
image.write() # write the Metadata

Usage scenario
My perferred way to use this addon is:
1. install pyexiv2
2. Install this addon
3. Restart Gramps
4. Click Views from the Menu bar, and select Media Views
5. Open the Side Bar
6. Slide the available empty right view to about half the screen.
7. Right click text to the Side Bar tab, and select Add a Gramplet
8. Select Image Metadata Gramplet
9. Select an image from the left hand MediaView

The interface
Data Fields
Photographer
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The name of the person or company taking the image

the Save button. For foreign countries that might use a ", "
instead of a ".", please use the "."

Select Date
Will bring up a calendar, and double-click on a date. The time will be filled in as
the current time

Description
Type in something about the image, the people in it or the location of the image.
Non-latin characters are NOT allowed. ASCII characters only...

Date

Buttons

The Date/ Time needs to be typed in as a very specific format:

1. Save

Year Mon Day Hour:Minutes:Seconds

Will write the metadata to the image, and convert latitude/ longitude if
it is in decimal format.

1826 Apr 12 14:06:00
Copyright
Can be anything that you please... Ex: (C) 2010 Smith and Wesson

2. Clear

Subject
Please enter keywords that describe the picture. Do NOT add a space after the
comma. Ex. : Census,Milwaukee,Oregon

3. Convert GPS Coordinates
will convert Latitude/ Longitude if it is in decimal format

Will clear all data fields

My favorite source for GPS Coordinates is: GPS Visualizer

Latitude/ Longitude
Latitude/ Longitude data can be entered in one of two ways:
1. Degrees Minutes Seconds Ex.: 10 59 14
In this format, you will need to select latitude reference, and
longitude reference

Previous

If the Latitude begins with a negative number, select 'S' as Lat.
Ref. or 'N' if a positive number. If the Longitude begins with a
negative number, select 'W' as the Long. Ref. or 'E' if a positive
number.

Index

Next

This page was last modified on 29 October 2011, at 12:37. This page has been accessed
1,236 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers

2. Decimal, Ex. : -34.15954
In this format, the Latitude and Longitude reference will be
selected for you after you click Convert GPS Coordinates or press
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From Gramps
Jump to: navigation, search
This section describes all the different reports available in Gramps.

Previous

Index

Manager can get additional Addons for you. Check the
list of the available reports here
here.
Generating Reports: This first subsection gives you some general remarks.
Substitution Values: you can use some handy values in your reports.

Next

Books

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

The book report creates a single document containing a collection of graphical and textual reports.

Graphical Reports
Graphical reports represent information in forms of charts and graphs.

Ancestor Tree

Introduction

The Ancestor Tree report generates the chart of people who are ancestors of the Active
Person.

The number of available reports in Gramps is huge and could be overwhelming at first
glance. The different subsections describe the various possibilities and options:

Calendar
The Calendar report produces a calendar with birthdays and anniversaries on a page by
month.

Additional Reports
Starting with Gramps version 3.3 a new system was implemented to have even more reports available. This
system is controlled by the Plugin Manager
Manager. The Plugin

Descendant Tree
The Descendant Tree report generates a graph of people who are descendants of the
Active Person.
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Family Descendant Tree

Relationship Graph

The Family Descendant Tree generates a graph of people who are descendants of the
Active Family.

The Relationship Graph creates a complex relationship graph in GraphViz format and
then converts into graphical output running it through the GraphViz dot tool behind
the scene.

Fan Chart

Text Reports

The Fan Chart report produces a chart resembling a fan, with Active Person in the center, parents the semicircle next to it, ans so on, for a total of five generations.

Text reports represent the desired information as formatted text.

Statistics Chart

Ahnentafel Report

The Statistics Chart report can collect and display a wealth of statistical data about your
database.

The Ahnentafel Report lists the Active Person and his or her ancestors along with their
vital data. The people are numbered in an establish standard called 'Ahnentafel'.

Timeline Chart

Birthday and Anniversary Report

The Timeline Chart report outputs the list of people with their lifetimes represented by
intervals on a common chronological scale.

The Birthday and Anniversary Report gives the same information as a calendar but in
text format.

Complete Individual Report

Graphs

The Complete Individual Report provides individual summaries similar to that of the
Individual Summary Report.

These reports are related to GraphViz.

Descendent Report

Family Lines Graph

The Descendant Report presents the descendants of the Active Person with a brief description in intended style.

The Family Lines Graph.py plugin was created to generate easy-to-follow graphs. Note
that FamilyLines does not display all of the people in the database -- instead, this plugin
generates smaller family trees, with many options to try and restrict the number of
people included. A typical use of this plugin is to generate simplified graphs printed on
large plotters.

Detailed Ancestral Report
The Detailed Ancestral Report covers in detail the ancestors of the Active Person, including a range of vital data as well as marriages.

Detailed Descendant Report

Hourglass Graph

The Detailed Descendant Report covers in detail the descendants of the Active Person
by generation, following the genealogical tradition of textual descendant reports by

The Hourglass Graph generate an hourglass graph using the GraphViz generator.
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Summary of the Database

generation. It aims to provide all important features expected to be found in these classic descendency formats and has received influence from various sources.

The Summary of the Database displays the overall statistics concerning number of individuals of each gender, various incomplete entries statistics, as well as family and media
statistics.

End of Line Report
The End of Line Report provides a list of of the person's last known ancestors with the
pedigree line, ordered by generations.

Family Group Report

Web Pages and Quick Reports

The Family Group Report creates a family group report, showing information on a set
of parents and their children.

Web Pages

Kinship Report

Narrated Web Site

Kinship Report provides the kinship of selected person according to level search( hight,
down generations) set by the user.

One of the reports in this category is the Narrated Web Site report. It generates a web
site (that is, a set of linked web pages), for a set of selected individuals.

Tag Report

Web Calendar

The Tag Report lists primary objects - persons, families, and notes - who match the selected tag. (It was formerly called the "marker report" in 3.2 gramps.)

Web Calendar

Number of Ancestors

Quick Reports

The Number of Ancestors displays the number of ancestors of the Active Person. The
form is - generation x has y individuals (z %).

Quick reports are reports that are available in the context menu's of person, family, ...
They are easy to make by users, even with limited coding knowledge.

Place Report

Previous

The Place Report produces a report according to places selected by the user. It will list
related person and event to the selected place.

Index

Next

Records Report
Records Report shows a number of interesting records(mostly age related) in your database, like oldest living person, youngest mother,etc.
This page was last modified on 26 October 2011, at 08:43. This page has been accessed
1,579 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers
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Jump to: navigation, search
This chapter describes the various tools available in Gramps.

Additional Tools
Starting with Gramps version 3.3 a new system was implemented to have even more tools available. This system is controlled by the Plugin Manager
Manager. The Plugin
Manager can get additional Addons for you. Check the
list of the available tools here
here.

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

Common Options
• id: = ID
Gramps ID of a central person.

Analysis and Exploration
Previous

Index

This section contains tools which analyze and explore the database, but do not alter it.
The following analysis and exploration tools are currently available in Gramps:

Next

Compare Individual Events...

Introduction

This tool compares events across the selected group of people. The people for this comparison are chosen with the use of custom filters. The custom filters can be created in
the Custom Filter Editor (see tools-util-cfe ) that can be invoked by clicking the Custom Filter Editor button. The resulting table produced by this tool can be
saved as a spreadsheet.

Gramps tools allow you to perform various types of analysis of your genealogical data.
Typically, the tools do not produce output in form of printouts or files. Instead, they
produce screen output immediately available for the researcher. However, when appropriate, you can save the results of running a tool into a file. Tools present one of the
major strengths of Gramps compared to the most genealogical software.
The tools can be accessed by choosing the menu Tools ->
->Tool
Tool Section ->
->Particular
Particular Tool .
Alternatively, you can browse the complete selection of available tools along with their
brief descriptions in a Tool Selection dialog invoked by clicking the Tools icon on
the toolbar.

Interactive Descendant Browser...
First you have to select a person or you start with the current Active Person.
Select from the menu Tools->Analysis and Exploration->Interactive Descendant
Browser...
Browser....
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The Help button will bring you to this page and with the Close you close the
Descendant Browser window.

Family Tree Processing
This section contains tools which may modify your database. The tools from this section
are used mostly for finding and correcting errors in the data. The following Family Tree
Processing tools are currently available in Gramps:

Note
The modifications will only be performed upon your
explicit consent, except for the automatic fixes performed by Check and repair Database
tool.

Edit Database Owner Information
Select the menu Tools->Family Tree Processing->Edit Database Owner information
information. This
brings up the Database Owner Editor window, where you can fill in the
needed info.
• Name:
• Street:
• Locality:
• City:
• State/County:
• Country:
• ZIP/Postal Code:
• Phone:
• Email:

Fig. 9.1 Descendant Browser
This tool builds a tree with the Active Person being the root. Children branch from
their parents in the usual manner.
You can click the down or > buttons to expand or collapse the nodes.
Use this tool for a quick glance of a person's descendants.

Tip
Double-clicking on tree node will bring up the Edit
Person dialog allowing to view or modify the personal data.

Extract Information from Names
This tool searches the entire database and attempts to extract titles and nicknames that
may be embedded in a person's Given name field. If any information could be
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Extract Place Data
• Canada
• Sweden
Stockholm (A)
• France
Paris, IDF 75000, FRA or Paris, ILE DE FRANCE 75000, FRA

Fig. 4.3 Database Owner Information

The dialog allows you to preview and confirm individual changes.
extracted, the candidates for fixing will be presented in the table. You may then decide
which to repair as suggested and which not to.

Extract Event Descriptions from Event Data
Extracts event descriptions from the event data by using a model :

Extract Place Data from a Place Title

{event type} of {Surname}, {Given name}

This tool attempts to extract city, state/province and zip code from a place title.
The tools operates on places where all fields in the main location are empty.
The description must match the following categories:

If event description is missing, then tool will use this event description field model.

Find Possible Duplicate People...

New York, NY 10000

This tool searches the entire database, looking for the entries that may represent the
same person.

Only available for :
• USA
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• Rating: this gives you an idea of the resemblance between the two people. The
higher the ranking, the higher the chance that the people are duplicates.
• First Person
• Second Person
If you select a row you can check the details with the Compare button or you can
double-click on the selected row.
Three buttons are present: Help brings you to this page, a Close to close
the window and a Compare button to which brings up a Compare People
window which was explain in detail in the Merge People Dialog. Here you can select
with the radio buttons one of the persons and eventually use the Merge and
close button to merge the data if you find the two persons are duplicates.
Selecting the Cancel button brings you back to the list.

Fix Capitalization of Family Names...

Fig. 4.4 Duplicate People
You can access this tool via the menu Tool->Family Tree Processing->Find Possible
Duplicate People...
People....
Two options are available:
• Match Threshold: choose between High, Medium and Low from the drop down
menu.
• Options: a check box to enable or disable the use of soundex codes for matching
possible duplicate people.
Only three buttons are present: Help brings you to this page, a Cancel to stop
processing and an OK button to start processing the data.
If you select the OK button, the data will be processes in two passes.
• Pass 1: Building preliminary lists
• Pass 2: Calculating potential matches.
A progress bar will be shown and depending the speed of your computer and the
amount of people in the database this can take some time.
Finally a Po tential Merges window is presented. This window shows a
list with three columns:

Fig. 4.5 Fix Capitalization
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This tool searches the entire database and attempts to fix the capitalization of family
names.
The aim is to have conventional capitalization: capital first letter and lower case for
the rest of the family name. If deviations from this rule are detected, the candidates for
fixing will be presented in the table.
You may then decide which to repair as suggested and which not to.
You can use this tool via menu Tools->Family Tree Processing->Fix Capitalization of
Family Names...
Names....

Undo history
Proceeding with this tool will erase the undo history for
this session. In particular, you will not be able to revert the changes made by this tool or any changes made
prior to it. It is recomended that you please stop here
and backup your database; so that you can revert the
process of running this tool.
You can choose Stop or Proceed with the tool .
If there where changes to Capitalization of Names you will be presented with the
Capitalization changes window. The window shows a list of the family
names that Gramps can convert to correct capitalization. In the list you will see a three
columns: Select check box(es), Original Name and Capitalization Change.
Select the names you want to be changed, then hit the Accept changes
and close button. Or use the Cancel button to abort changes.

Fig. 4.6 Change type
The Change Event Types window is presented. This tool will rename all
events of one type to a different type.
• Original event type: fill in the text field or use the drop down menu and select an
original event type
• New event type: fill in the text field (you can create a complete new type here) or
use the drop down menu and select a new type
The example shows a renaming of the Birth event to a Baptism event.
Finally use the Cancel or the OK button.

Rename Event Types
This tool allows all the events of a certain name to be renamed to a new name.

Undo history
Proceeding with this tool will erase the undo history for
this session. In particular, you will not be able to revert
the changes made by this tool or any changes made prior to it. If you think you may want to revert running
this tool, please stop here and backup your database.
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Sort Events

Renaming events
Once completed, this cannot be undone by the regular
Undo function.

Reorder GRAMPS ID
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.
This tool Reorder GRAMPS ID will change all the elements in the database to conform
to the scheme specified in the database's prefix id's.
You can change those settings in the menu Edit->Preferences... and then select the
ID Formats tab.
You can use this tool via menu Tools->Family Tree Processing->Reorder Gramps IDs
IDs.

Undo history

Fig. 4.7 Sort Events

Proceeding with this tool will erase the undo history for
this session. In particular, you will not be able to revert
the changes made by this tool or any changes made prior to it. If you think you may want to revert running
this tool, please stop here and backup your database.

Events appearing on the Event tab on a Person or Family Editor are not sorted in any
particular order other than the order that the events were added. The reason for not
enforcing any particular ordering, particularly ordering by date, is to allow for the situation where an event was known to have happened but the exact chronology is not. Importing or merging data from an external source can lead to extra events being added
to, but out of sequence with, the existing set of events of a person or family.
Events can be manually re-ordered by drag & drop or by use of the re-order buttons
on the Events tab. Either way, an event can be moved up or down in the list of
events and Gramps will remember the new order when the changes are saved. The new
ordering will be used wherever events are shown elsewhere in Gramps, such as on a report.
The order of all events on a tab can also be changed by clicking a column title. For
example, clicking the 'Date' column header will sort all the events in date order. However this way of sorting events is temporary and changes to the event order are not
preserved when the window is closed.

The window will show a progress bar.
In different steps following IDs' are reordered: Reordering People IDs', Reordering
Family IDs', Reordering Event IDs', Reordering Media Object IDs', Reordering Source
IDs', Reordering Place IDs', Reordering Repository IDs' and finally Reordering Note IDs'.
In a next step unused IDs' are searched for and assigned.

Custom IDs'
If you customized your IDs', all those setting are replaced by the default setting. So take care before you
use this tool!
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The drag and drop approach to sorting events is fine for moving a small number of
events but is not practical for large scale changes. The Sort Events tool has been designed specifically for this purpose, re-sorting all events in the database or just those
associated with a targeted selection of people chosen by using a filter.
The first option on the Sort Events dialog window is used to define the range of people who's events are to be sorted. The first choice in the list is to apply the sorting to
all people in the database. Alternative choices are to apply sorting to ancestors and descendants of a chosen person or to a range of people selected by a custom built person filter. After choosing who the sort should apply to, the next thing to consider is
how the events should be sorted. The first option is to sort by date. This is probably the
most likely choice, but other event attributes can be chosen too. The final choices are
whether to make the events sorted ascending or descending and whether to apply the
sort to family events that the selected people belong to as well.

• Missing media objects. The missing media object is the object whose file is
referenced in the database but does not exist. This can happen when the file is
accidentally deleted, renamed, or moved to another location.
• Empty families. These are the family entries which have no reference to any person
as their member.
• Parent relationship. This checks all families to ensure that father and mother are
not mixed up. The check is also made that parents have different gender. If they
have common gender then their relationship is renamed to "Partners".

Rebuild Reference Maps
This tool rebuilds reference map tables (References items on editors).

Rebuild Secondary Indices
This tool rebuilds secondary indices.

Undo history
Proceeding with this tool will erase the undo history for
this session. In particular, you will not be able to revert
the changes made by this tool or any changes made prior to it. If you think you may want to revert running
this tool, please stop here and backup your database.

Remove Unused Objects...

Sorting events

This section contains tools allowing you to perform a simple operation on a portion of
data. The results can be saved in your database, but they will not modify your existing
data. The following utilities are currently available in Gramps:

This tool will search your database for pieces of information which are not connected
to anything else, and then remove them.

Utilities

Once completed, this cannot be undone by the regular
Undo function.

Generate SoundEx codes

Database Repair

This utility generates Soundex codes for the names of people in the database. Please visit the NARA Soundex Indexing page to learn more about Soundex Indexing System.

Check and repair database

Soundex what is this?

This tool checks the database for integrity problems, fixing the problems it can. Specifically, the tool is checking for:
• Broken family links. These are the cases when a person's record refers to a family
while the family's record does not refer to that person, and vice versa.

Soundex is the most widely known of all phonetic algorithms which allow indexing of
words by their sound, as pronounced in English.
The Soundex is a coded surname (last name) index based on the way a surname
sounds rather than the way it is spelled. Surnames that sound the same, but are spelled
differently, like SMITH and SMYTH, have the same code and are filed together. The
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Soundex coding system was developed so that you can find a surname even though it
may have been recorded under various spellings.
First applied to the 1880 census, Soundex is a phonetic index, not a strictly alphabetical one. Its key feature is that it codes surnames (last names) based on the way a
name sounds rather than on how it is spelled. It was to help researchers find a surname
quickly even though it may have received different spellings.
Those doing census lookups must use the same method to encode surnames as the
census takers did when they generated the database.
To search for a particular surname, you must first work out its code.
• Basic Soundex Coding Rule:
Every Soundex code consists of a letter and three numbers, such as W-252. The letter
is always the first letter of the surname. The numbers are assigned to the remaining
letters of the surname according to the Soundex guide shown below. Zeroes are added
at the end if necessary to produce a four-character code. Additional letters are disregarded. Examples: Washington is coded W-252 (W, 2 for the S, 5 for the N, 2 for the G,
remaining letters disregarded). Lee is coded L-000 (L, 000 added).

• Pfister is coded as P-236 (P, F ignored, 2 for the S, 3 for the T, 6 for the R).
• Jackson is coded as J-250 (J, 2 for the C, K ignored, S ignored, 5 for the N, 0
added).
• Tymczak is coded as T-522 (T, 5 for the M, 2 for the C, Z ignored, 2 for the K).
Since the vowel "A" separates the Z and K, the K is coded.
• Names with Prefixes: If a surname has a prefix, such as Van, Con, De, Di, La, or
Le, code both with and without the prefix because the surname might be listed
under either code. Note, however, that Mc and Mac are not considered
prefixes.For example, VanDeusen might be coded two ways:V-532 (V, 5 for N, 3
for D, 2 for S) or D-250 (D, 2 for the S, 5 for the N, 0 added).
• Consonant Separators: If a vowel (A, E, I, O, U) separates two consonants that
have the same Soundex code, the consonant to the right of the vowel is coded.
Example:Tymczak is coded as T-522 (T, 5 for the M, 2 for the C, Z ignored (see
"Side-by-Side" rule above), 2 for the K). Since the vowel "A" separates the Z and
K, the K is coded. If "H" or "W" separate two consonants that have the same
Soundex code, the consonant to the right of the vowel is not coded. Example:
Ashcraft is coded A-261 (A, 2 for the S, C ignored, 6 for the R, 1 for the F). It is not
coded A-226.

Number Represents the Letters
1

B, F, P, V

2

C, G, J, K, Q, S, X, Z

3

D, T

4

L

5

M, N

6

R

Use of SoundEx module in GRAMPS

Disregard the letters A, E, I, O, U, H, W, and Y.
• Additional Soundex Coding Rules:
• Names With Double Letters: If the surname has any double letters, they should
be treated as one letter. For example:
• Gutierrez is coded G-362 (G, 3 for the T, 6 for the first R, second R ignored, 2
for the Z).
• Names with Letters Side-by-Side that have the Same Soundex Code Number: If
the surname has different letters side-by-side that have the same number in the
Soundex coding guide, they should be treated as one letter. Examples:

Fig. 4.8 SoundEx code generator
Select via the menu Tools->Utilities->Generate SoundEx Codes... the dialog for the
SoundEx cod e generator window opens. In the Name text field you
can type in a name or you could use the down arrow where you can choose a name
from the drop down list.
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The name you type in can be any name even a name not present in your Family
Tree.
The result is shown automatically eg:The soundex code for James is J520
A Help button is available which brings you to this page. With the Close
button (or using the keyboard shortcut Alt + C ) you close the SoundEx code
generator window.

This tool allows you to only modify the records within your Gramps database. If you
want to move or rename the files then you need to do it on your own, outside of Gramps.
Then you can adjust the paths using this tool so that the media objects store the correct
file locations.
If you click the Forward button (or using the keyboard shortcut Alt + F ) you
will get a window with three radio buttons:
• Replace substrings in the path: Selecting this radio button will bring up a
Replace substring settings window where you can type in any
string in the Replace text field and the With text field. At any time you
can click on the Cancel button or the Back button. Clicking the
Forward button will bring up the Final confirmation window.
• Convert paths from relative to absolute
• Convert paths from absolute to relative

Media Manager...

Not Related

Fig. 4.9 Final confirmation window
This tool allows batch operations on media objects stored in Gramps. An important distinction must be made between a Gramps media object and its file.
The Gramps media object is a collection of data about the media object file: its filename and/or path, its description, its ID, notes, source references, etc. These data do
not include the file itself
itself.
The files containing image, sound, video, etc. exist separately on your hard drive.
These files are not managed by Gramps and are not included in the Gramps database.
The Gramps database only stores the path and file names.

Fig. 4.10 Not related
This report will find people who are not related to the selected person.
You will get a Not related to '...' window which shows a list of all
the people that are NOT related to the selected person.
This list gives you:
• Name

9

From Gramps

Gramps 3.3 Wiki Manual - Tools

• ID
• Parents
• Marker
With the righ t arrow button and down arrow button you can collapse
or expand the list. Double clicking on a person will bring up the detailed person edit
window or family edit window.
If you select a person you can use the Marker text field: 3 choices are possible:
blank (you can fill in whatever suits you), TODO, and NotRelated. With the Apply
you can apply the selected marker to the person. This marker will then show up in the
right hand side column.

Relationship calculator
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.
This utility calculates and displays the relationship of any person to the Active Person.

Verify the Data...
This utility allows you to verify the database based on the set of criteria specified by
you.
For example, you may want to make sure that nobody in your database had children
at the age of 98. Based on common sense, such a record would indicate an error. However, it is not a consistency error in the database. Besides, someone might have a child
at the age of 98 (although this rarely happens). The Verify tool will display everything
that violates your criteria so that you can check whether the record is erroneous or not.
The ultimate decision is yours.
Select this via the menu Tools->Utilities->Verify the Data... you will get a
Database Verify Tool window. The window has four tabs; General ,
Women , Men , Families . Those tabs show a list with criteria and a input
field where you can alter the criteria value. In the lists below I show some workable values.
• General
General:

Fig. 4.11 Verify the Data...
• maximum age: 95
• minimum age to marry: 16
• maximum age to marry: 60
• maximum spouses for a person: 4
• maximum number of consecutive years of widowhood before next marriage: 30
• maximum age for an unmarried person: 99
There is a check box: estimate missing dates. This causes the tool to accept a baptism date
if a birth date is not known, and to accept a burial date if a death date is not known.
In addition, starting in Gramps version 3.3.0, it also causes the tool to accept "inexact"
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dates (i.e., any "legal" Gramps date which is not a fully-specified one (with an explicit
day and month and year)).
• Women
Women:
• minimum age to bear a child 16
• maximum age to bear a child 51
• maximum number of children 15
• Men
• minimum age to father a child 18
• maximum age to father a child 65
• maximum number of children 15
• Families
• maximum husband-wife age difference 41
• maximum number of years between children 11
• maximum span of years for all children 32
If you are OK with the criteria click the Run button (or hit <Alt+R> and you will be
presented with a Database Verification Results window.
Depending on your criteria and your data a list will be shown. Some possibilities of
findings are listed below. But there are others.
• Disconnected individuals (ones with no parent or spouse or child or sibling)
• old/dead father
• marriage after death/ before birth
• large year span for all children
• early/late marriage
• young/unborn mother
• husband and wife with the same surname
• same sex marriage/ female husband
• ...
To show how handy this Utility is, here two examples from real data:
The warning showed 'female husband': checking the data I found a family with
father : Anna Roelants. Luckily in the Description I read: The marriage of
Adam Roelants and Cornelia Crabbe. It was clearly a typo: Anna i.s.o. Adam. Without
this Tool it would be very hard to find.

On the bottom of the window four check boxes are available to make a selection easier. Those are Mark All , Unmark All , Invert Marks , and
Hide Marked .
Double-clicking on a row will give you a possibility to view and or edit the data.
With the Clos e button (or select the keyboard shortcut Alt + C ) you close the
Results window.
With the Help button (or select the keyboard shortcut Alt + H ) you will get to
this page.

Difference between Verify tool and previously described Check tool
The Check tool detects inconsistencies in the database
structure. The Verify tool,however, is detecting the
records that do not satisfy your particular criteria.

For example, you may want to make sure that nobody in your database had children at
the age of 98. Based on common sense, such a record would indicate an error. However,
it is not a consistency error in the database. Besides, someone might have a child at the
age of 98 (although this rarely happens). The Verify tool will display everything that violates your criteria so that you can check whether the record is erroneous or not. The
ultimate decision is yours.

Previous

Index

Next

This page was last modified on 26 October 2011, at 10:05. This page has been accessed
1,111 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers

The warning showed 'late marriage': checking the data: male person °1738
female person °1756 : marriage X 1804 [Gregorian Calender] : Everything seemed
to be OK: so they (re)married at the age of 66 and 48 years! The warning showed
up because the General criteria was set to 60
60.
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Special copyright notice: All edits to this page need to be under two different
copyright licenses:
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Fig. 10.1 General Preferences

General
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This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Preferences

This category contains preferences relevant to the general operation of the program.
Options are:
• Add default source on import: This option affects the importing of data. If this is
set, each item that is imported will contain a source reference to the imported file.

Most of the settings in Gramps, are configured in the Preferences dialog. To
invoke it, select the menu Edit ->Preferences...
->Preferences....
The tabs on the top display the available option categories.

Note
Adding a default source can significantly slow down the
importing your data.
• Enable spelling checker: This option controls the enabling and disabling of the
spelling checker for notes. The gtkspell package must be loaded for this to have an
effect.
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• Display Tip of the Day: This option controls the enabling and disabling of the Tip
of the Day dialog at startup.
• Use shading in Relationship View: This option controls the enabling and disabling
of shading in the Relationship View. If enabled, information will be grouped
together in regions with a shaded background.
• Display edit buttons on Realtionship View: This option controls the enabling and
disabling of the edit buttons in the Relationship view. If enabled you will see the
edit buttons on the right side of the displayed names.
• Remember last view displayed: This option controls the enabling and disabling of
the the display of the last view. Enabling will bring you to the view where you
stopped the program the last time.
• Number of generations for relationship determination: You can fill in the number
of generations used to determine relationships. The default value is 15
15.
• Base path for relative media path: Here you can fill in a base path for the media
objects. Clicking the Directory button gives you a Select media
directory editor where you can fill in the required path.

• Family Tree Database path: The default path where the Databases are stored is
home directory/.gramps/grampsdb
directory/.gramps/grampsdb. Unless you absolutely want to change this,
stay with the default path.
• Automatically load last database: This option controls the enabling and disabling of
the loading on start up of the last used database.

Display

Family Tree
Fig. 10.3 Display Preferences

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

This category contains preferences relevant to the display of data and names. Options
are:
• Name format: This option controls the display of names. In Gramps there are two
type of name display formats: the predefined formats, and the user defined custom
formats. Several different predefined name formats are available: Given - Prefix
Patronymic, Suffix Given - Prefix Surname, Given Patronymic Suffix etc. Clicking on
the righthand side Edit... will bring up a Display Name Editor
window where the available list of options is shown. The format is given as well as
an example. When predefined formats are not suitable one can define one's own
format. You can use the Add button to add a Name format to the list. Clicking
once will give you a SURNAME,Given Suffix(call) format and as example : SMITH,
Edwin Jose Sr (Ed)
(Ed). If you added new name formats to the list the Remove and
Edit buttons become available to change the name format list.

Fig. 10.2 Family Tree Preferences
This category contains preferences relevant to the Family Tree Database path.
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(e.g. by setting Gregorian calendar as default displayed calendar, users will have a
better coherency for displaying dates on period).
• Surname Guessing: This option affects the initial family name of a child when he/
she is added to the database. If None is selected, no guessing will be attempted.
Selecting Father's surname will use the family name of the father.
Selecting Combination of mother's and father's
surname will use the father's name followed by the mother's name. Finally,
Icelandic style will use the father's given name followed by the "sson"
suffix (e.g. the son of Edwin will be guessed as Edwinsson).

Note
Besides the system wide setting Gramps allows deciding
the name display format individually for every single
name via the Name Editor dialog

Tip
This option only affects the initial family name guessed
by Gramps when the Edit Person dialog is
launched. You can modify that name the way you see
fit. Set this option to the value that you will most frequently use, as it will save you a lot of typing.

• Status bar: This option controls the information displayed in the status bar. This
can be either the Active person's name and ID or Relationship to home person.
• Show text in sidebar buttons: This option controls whether or not a text
description is displayed next to the icon in the sidebar. This option takes effect
after the program has been restarted.

Text
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Note
Custom name display formats are stored in the databases, thus before loading any database the Custom
format details expander is disabled.

This category contains preferences relevant to how missing and private names and
records should be shown.
• Missing surname: in the input field you can determine how a missing surname
should be displayed. Default value is [Missing Surname]
Surname]. You can change this to [--]
or whatever is most convenient for you.

• Date format: This option controls the display of dates. Several different formats are
available, (e.g. YYYY-MM-DD (ISO)) which may be dependent on your locale.
• Calendar on reports: This option controls the display of calendar on reports, tools,
gramplets, views. Several different calendars are available (see Date Edition). Two
dates with two differents calendars will not properly display timeline or periode,

3

From Gramps

Gramps 3.3 Wiki Manual - Settings

Fig. 10.5 Dates Preferences

Fig. 10.4 Text Preferences

•
•
•
•

Family: Provides the template for generating IDs for a Family. Default value: F%04d.
Place: Provides the template for generating IDs for a Place. Default value: P%04d.
Source: Provides the template for generating IDs for a Source. Default value: S%04d.
Media Object: Provides the template for generating IDs for a Media Object. Default
value: O%04d.
• Event: Provides the template for generating IDs for an Event. Default value: E%04d.
• Repository: Provides the template for generating IDs for a Repository. Default
value: R%04d.
• Note: Provides the template for generating IDs for a Note. Default value: N%04d.

• Missing given name: in the input field you can determine how a missing given
name should be displayed. Default value is [Missing given name]
name]. You can change
this to whatever you want.
• Missing record
• Private surname
• Private given name
• Private record

Dates

ID Prefixes

ID Formats

The ID prefixes use formatting conventions common
for C, Python, and other programming languages. For
example, the %04d expands to an integer, prepended
with zeros to have the total width of four digits. If you

This category contains preferences relevant to the automatic generation of GRAMPS
IDs.
• Person: Provides the template for generating IDs for a Person. Default value: I%04d.
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Fig. 10.7 Warning Preferences
• Show plugin status dialog on plugin load error.

Researcher Information

Fig. 10.6 ID Format Preferences
would like IDs to be 1, 2, 3, etc., simply set the formatting parameter to %d.

Fig. 10.8 Researcher Preferences

Warnings

Enter your personal information in the corresponding text entry fields. Although
Gramps requests information about you, this information is used only so that Gramps
can create valid GEDCOM output files. A valid GEDCOM file requires information about
the file's creator. If you choose, you may leave the information empty, however none of
your exported GEDCOM files will be valid.

This category controls the display of warning dialogs, allowing the re-enabling of dialogs that have been disabled.
• Suppress warning when adding parents to a child.
• Suppress warning when cancelling with changed data.
• Suppress warning about missing researcher when exporting to GEDCOM.
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The available text entry fields are:
Name:
Address:
Locality:
City:
State/County:
Country:
ZIP/Postal Code:
Phone:
Email:

The columns of the list views may be added, removed, or reordered in a Column
Editor dialog. Only checked columns will be shown in the view. To change their order, drag any column to its desired place inside the editor. Clicking OK will reflect the
changes in the appropriate view. To invoke Column Editor dialog, choose via
the menu View ->Configure View... or click on toolbar Configure View...
button.

Column Editor
The Column Editor is available and works in
the same way for all list views. Specifically, it is available for People View, Family View (children list).
Sources View, Places View, Media View, Repositories
View and the Notes View.

Other settings
Besides Preferences dialog, there are other settings available in Gramps. For
various reasons they have been made more readily accessible, as listed below.

Column Editor
Setting Home person
The Home person is the person who becomes active when the Family tree database is
opened, and when the toolbar Home button is clicked or the Home menu item is
selected from either Go menu or the right-click context menu anywhere. The toolbar
Home button is available in the People View, Relationships View, and Pedigree View.
To set Home person, make the desired person active and then choose via the menu
Edit ->Set Home Person
Person.

Adjusting viewing controls
Whether the toolbar, the sidebar, or the filter (not available on Pedigree and Relationships Views) are displayed in the main window is adjusted through the View menu.
In the different views clicking the View menu will shows for boxes you can click:
• Navigator
• Toolbar
• Sidebar
• Bottombar
• Full Screen F11
Additionally, depending on the view you are in, other options will be available on
Configure .

Fig. 10.11 Column editor

6

From Gramps

Gramps 3.3 Wiki Manual - Settings

Modularity and plugins

• Gramplets:
• Set Columns to 1
• Set Columns to 2
• Set Columns to 3
• Relationships:
• Show Siblings
• Show Details
• Geography:
• Time period
• Layout
All other Views: the column editor.

Views are now real "plugins".
Gramps 3.3 is more modular and flexible.
See plugins manager and Addons.

Export View...

Fig. The plugins manager

Fig. 10.12 Export to ODS
On most Views, displayed data could be exported, choose via the menu Family Trees >Export View...
View....
Gramps will export data on screen according your choice: CSV or Open Document
spreadsheet format.
The example (see Fig. 10.12) shows an export to ODS.
This is a powerful function (no limitations), like a report.

Fig. Ability to hide plugins
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Advanced manipulation of settings

• preferences: keys related to preferences: all the common prefixes , todo -colors..
• researcher: all information regarding the researcher

Warning
The contents of this section is outside the scope of interest of a general user of Gramps. If you proceed with
tweaking the options on the low level you may damage
your Gramps installation. Be careful. YOU HAVE BEEN
WARNED!

Name Format Editor
This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.
New formats are created, and existing formats are modified using this editor.
• Format name: The name of the custom format. The format name can be any string,
it is used only to recognize the format later on the Display format list.
• Format definition: The actual format is defined here using special formatting
characters. Before and after these special characters any other character or string
is allowed. For example: "(%t) %L, %f" will give "(Dr.) SMITH, Edwin". The
formatting characters are:
Character

Fig. 10.13 The keys.ini file
Gramps 3 uses INI keys stored under .gramps (gramplets, keys) for managing user
preferences.
The list has following sub-items:
• behavior: typical Key names are: betawarn, enable-autobackup, use-tips...
• export: export and import dirs
• interface: a lot of keys regarding height and width of the different Views: e.g.
event-height: 450, event-ref-height: 585, event-ref-width: 728, event-width: 712...
• paths: keys related to recent imported files and dirs

Name

CHARACTER

NAME

%f

Given Name %F

GIVEN NAME

%l

Surname

%L

SURNAME

%t

Title

%T

TITLE

%p

Prefix

%P-

PREFIX

%s-

Suffix

%S

SUFFIX

%c

Call name

%C

CALL NAME

%y

Patronymic %Y

PATRONYMIC

• Example: Shows a dynamic example how the name will be displayed with the
current Forma t definition string.
• Format definition details: Shows a quick reminder of the special formatting
characters.
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Custom Filter Editor

From Gramps
Jump to: navigation, search
This appendix lists of all the filter rules currently defined in Gramps. Each of these rules
is available for use when creating custom filters, see tools-util-cfe . The rules are listed by
their categories.

Custom rules migration
To avoid unwanted effects after a major upgrades of
Gramps (eg, from version 3.2.x to 3.3.x), if required, you
can manually copy your custom_filter.xml from GRAMPS
User Directory to gramps_version_number.

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions
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You can carry out a considerable amount of selection of persons, events, places, etc.,
just using the Filter Sidebar in Person, Event, Place,etc. Views; but note, however, that
the 'Use regular expressions' option only works with particular fields in each View.
If the Filter Sidebar is inadequate for your purpose, you will need to build custom
filters.

Fig.11.1 Define filter
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The Custom Filter Editor builds custom filters that can be used to select people included in reports, exports, and other tools and utilities. This is in fact a very powerful
tool in genealogical analysis.
When you launch it, the User defined filters dialog appears that
lists all the filters (if any) previously defined by you. Click the Add... button to
define a new filter. Once you have designed your filters, you can edit, test, and delete
selected filters using the Edit... , Test... , and Delete buttons, respectively. All the filters displayed in the list will be automatically saved along with
your database and will be available with subsequent sessions of Gramps.

Changes on filters
The changes made to the filters only take effect when
you click the toolbar Apply and close button.

Fig.11.2 Add rule
click OK to add this rule to the rule list of the currently edited filter. Clicking Cancel will abort adding the rule to the filter.

Clicking the toolbar Add... button invokes the Define filter dialog
(See Fig.11.1)
Type the name for your new filter into the Name field.
Enter any comment that would help you identify this filter in the future into the
Comment field. Add as many rules to the Rule list as you would like to
your filter using Add... button. If the filter has more than one rule, select one of
the Rule operations . This allows you to choose whether all rules must apply, only one (either) rule must apply, or exactly one (either) rule must apply, in order
for the filter to generate a match. If your filter has only one rule, this selection has no
effect.
Check Return values that do not match the filter
rules to invert the filter rule. For example, inverting "has a common ancestor with
I1" rule will match everyone who does not have a common ancestor with that person).

Tip
A filter you have already designed may be used as a rule
for another filter. This gives you nearly infinite flexibility in custom-tailoring your selection criteria that can
be later used in most of the exports, reports, and some
of the tools (such as comparing individual events).

Which filters in which view?

Clicking the toolbar Add... button invokes the Add Rule dialog (See
Fig.11.2):
The pane on the left-hand side displays available filter rules arranged by their categories in an expandable tree. For detailed filter rule reference. Click on the arrows to
fold/unfold the appropriate category. Select the rule from the tree by clicking on its
name. The right-hand side displays the name, the description, and the values for the
currently selected rule. Once you are satisfied with your rule selection and its values,

Depending on the used View, you will get a different set of filters.
• Gramplets
no filters available
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• Persons View, Relationships View, and Pedigree View
Ancestral filters, Descendant filters, Family filters, General filters, Event
filters, and Relationship Filters.

• People having notes containing <regular expression>
Matches people whose notes contain text matching a regular expression.
Values: Regular expression

• Events View, Sources View, Media view, Repositories View, and Notes View
only General filters. Those General filters are specific for a View: in the Media
View the filters will only sort and search on Media Objects.

• People having notes containing <substring>
Matches people whose notes contain text matching a substring. Values:
Substring

• Places View
General filters, and Position filters.

• People marked private
Matches people that are indicated as private.

General filters

• People matching the <filter>
Matches people matched by the specied filter name. Values: Filter name. The
specified filter name should be selected from the menu.

Persons-, Relationship-, and Pedigree View
This category includes the following general rules:
• Bookmarked People
Matches the people on the bookmark list.

• People probably alive
Matches people without indications of death that are not too old. Values: On
Date

• Default person
Matches the default person.

• People with <id> matching regular expression
Matches people whose GRAMPS ID matches the regular expression. Values:
Regular expression

• Disconnected People
Matches people that have no family relationships to any other person in the
database.

• People with <count> LDS events
Matches people with a certain number of LDS events. Values: Number of
instances -- Number must be greater than/lesser/equal to

• Everyone
Matches everyone in the database.

• People with <count> addresses
Matches people with a certain number of personal addresses. Values: Number
of instances -- Number must be greater than/lesser/equal to

• Females
Matches all females.

• People with <count> associations
Matches people with a certain number of associations. Values: Number of
instances -- Number must be greater than/lesser/equal to

• Males
Matches all males.
• People having <count> notes
Matches people having a certain number of notes: Values: Number of
instances -- Number must be greater than/lesser/equal to

• People with <count> media
Matches people with a certain number of items in the gallery. Values: Number
of instances -- Number must be greater than/lesser/equal to
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• People with <count> source
Matches people with a certain number of items in the source. Values: Number
of instances -- Number must be greater than/lesser/equal to

• People with <id>
Matches people with GRAMPS ID. The rule returns a match only if the ID is
matched exactly. You can either enter the ID into a text entry field, or select
an object from the list by clicking Select... button. In the latter case,
the ID will appear in the text field after the selection was made.

• People with <marker>
Matches people with a marker of a particular value. Values: Marker type ' ',
Complete, or ToDo.

• People changed after <date time>
Matches person records changed after a specified date-time (yyy-mm-dd
hh:mm:ss) or in the range, if a second date-time is given: Values: Changed
after: -- but before:.

• People with complete records
Matches all the people whose records are complete.
• People with incomplete names
Matches people with firstname or lastname missing.

• People with events matching the <event filter>
Matches persons who have events that match a certain event filter. Values:
Event filter name.

• People with records containing <substring>
Matches people whose records contain text matching a substring. Values:
Substring -- Case Sensitive or not -- Regular-Expression matching or not

Person filters
• Has Address
This rule matches people with a personal address.

• People with the <name>
Matches people with a specied (partial) name. Values: Given Name -- Family
Name -- Suffix -- Title -- Prefix -- Patronymic -- Call Name

• Has Association
This rule matches people with a personal association.

• People with the source
Matches people who have a particular source. values: Source ID

• Has Complete Record
This rule matches all people whose records are marked as complete.
Currently, the completeness of personal information is marked manually, in
the Edit Person dialog.

• People with the family <attribute>
Matches people with the family attribute of a particular value. Values: Family
Attribute: Identification Number -- Age ...

• Has Name
This rule matches any person whose name matches the specified value in full
or in part. For example, Marta Ericsdotter will be matched by the rule using the
value "eric" for the family name. Separate values can be used for Given name,
Family name, Suffix, and the Title. The rule returns a match if, and only if, all
non-empty values are (partially) matched by a person's name. To use just one
value, leave the other values empty.

• People with the personal <attribute>
Matches people with the personal attribute of a particular value. Values:
Family Attribute: Identification Number -- Age ...
• People with unknown gender
Matches all people with unknown gender.
• People without a known birth date
Matches people without a known birthdate.

• Is default person
This rule matches the default (home) person.
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• Is a female
This rule matches any female person.

• Has the personal event
This rule matches people that have a personal event matching specified
values for the Event type, Date, Place, and Description. The rule returns a
match even if the person's event matches the value partially. The matching
rules are case-insensitive. For example, anyone who graduated in Sweden will
be matched by the rule using the Graduation event and the value "sw" for the
Place. The personal events should be selected from a pull-down menu. The
rule returns a match if, and only if, all non-empty values are (partially)
matched by the personal event. To use just one value, leave the other values
empty.

• Is a male
This rule matches any male person.
• People probably alive
This rule matches all people whose records do not indicate their death and
who are not unreasonably old, judging by their available birth data and
today's date.
• People with incomplete names
This rule matches all people with either given name or family name missing.

• Has the family event
This rule matches people that have a family event matching specified values
for the Event type, Date, Place, and Description. The rule returns a match even
if the person's event matches the value partially. The matching rules are caseinsensitive. For example, anyone who was married in Sweden will be matched
by the rule using the Marriage event and the value "sw" for the Place. The
family events should be selected from a pull-down menu. The rule returns a
match if, and only if, all non-empty values are (partially) matched by the
personal event. To use just one value, leave the other values empty.

• People without a birth date
This rule matches people missing birth date.

Event filters
This category includes the following rules that match people based on their recorded
events:
• Has the birth
This rule matches people whose birth event matches specified values for Date,
Place, and Description. The rule returns a match even if the person's birth
event matches the value partially. The matching rules are case-insensitive.
For example, anyone born in Sweden will be matched by the rule using the
value "sw" for the Place. The rule returns a match if, and only if, all nonempty values are (partially) matched by a person's birth. To use just one
value, leave the other values empty.

• Witness
This rule matches people who are present as a witness in the event. If the
personal or family event type is specified, only the events of this type will be
searched.
• People with incomplete events
This rule matches people missing date or place in any personal event.
• Families with incomplete events
This rule matches people missing date or place in any family event of any of
their families.

• Has the death
This rule matches people whose death event matches specified values for
Date, Place, and Description. The rule returns a match even if the person's
death event matches the value partially. The matching rules are caseinsensitive. For example, anyone who died in Sweden will be matched by the
rule using the value "sw" for the Place. The rule returns a match if, and only
if, all non-empty values are (partially) matched by a person's death. To use
just one value, leave the other values empty.

Family filters
This category includes the following rules that match people based on their family relationships:
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• People with children
This rule matches people with children.

• Is an ancestor of
This rule matches people who are ancestors of the specified person. The
Inclusive option determines whether the specified person should be
considered his/her own ancestor (useful for building reports). You can either
enter the ID into a text entry field, or select a person from the list by clicking
Select... button. In the latter case, the ID will appear in the text field
after the selection was made.

• People with multiple marriage records
This rule matches people with more than one spouse.
• People with no marriage records
This rule matches people with no spouses.

• Is an ancestor of person at least N generations away
This rule matches people who are ancestors of the specified person and are at
least N generations away from that person in their lineage. For example, using
this rule with the value of 2 for the number of generations will match
grandparents, great-grandparents, etc., but not the parents of the specified
person.

• People who were adopted
This rule matches adopted people.
• Has the relationships
This rule matches people with a particular relationship. The relationship must
match the type selected from the menu. Optionally, the number of
relationships and the number of children can be specified. The rule returns a
match if, and only if, all non-empty values are (partially) matched by a
person's relationship. To use just one value, leave the other values empty.
• Is spouse of filter match
This rule matches people married to someone who is matched by the specified
filter. The specified filter name should be selected from the menu.

• Is an ancestor of person not more than N generations away
This rule matches people who are ancestors of the specified person and are no
more than N generations away from that person in their lineage. For example,
using this rule with the value of 2 for the number of generations will match
parents and grandparents, but not great-grandparents, etc., of the specified
person.

• Is a child of filter match
This rule matches people for whom either parent is matched by the specified
filter. The specified filter name should be selected from the menu.

• Has a common ancestor with
This rule matches people who have common ancestors with the specified
person.

• Is a parent of filter match
This rule matches people whose child is matched by the specified filter. The
specified filter name should be selected from the menu.

• Has a common ancestor with filter match
This rule matches people who have common ancestors with someone who is
matched by the specified filter. The specified filter name should be selected
from the menu.

• Is a sibling of filter match
This rule matches people whose sibling is matched by the specified filter. The
specified filter name should be selected from the menu.

• Is an ancestor of filter match
This rule matches people who are ancestors of someone who is matched by
the specified filter. The specified filter name should be selected from the
menu.

Ancestral filters
This category includes the following rules that match people based on their ancestral
relations to other people:
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Descendant filters

Relationship filters

This category includes the following rules that match people based on their descendant
relations to other people:
• Is a descendant of
This rule matches people who are descendants of the specified person. The
Inclusive option determines whether the specified person should be
considered his/her own descendant (useful for building reports). You can
either enter the ID into a text entry field, or select a person from the list by
clicking Select... button. In the latter case, the ID will appear in the
text field after the selection was made.

This category includes the following rules that match people based on their mutual relationship:
• Relationship path between two people
This rule matches all ancestors of both people back to their common
ancestors (if exist). This produces the "relationship path" between these two
people, through their common ancestors. You can either enter the ID of each
person into the appropriate text entry fields, or select people from the list by
clicking their Select... buttons. In the latter case, the ID will appear
in the text field after the selection was made.

• Is a descendant of person at least N generations away
This rule matches people who are descendants of the specified person and are
at least N generations away from that person in their lineage. For example,
using this rule with the value of 2 for the number of generations will match
grandchildren, great-grandchildren, etc., but not the children of the specified
person.

Miscellaneous filters
This category includes the following rules which do not naturally fit into any of the
above categories:
• Has the personal attribute
This rule matches people who have the personal attribute of the specified
value. The specified personal attribute name should be selected from the
menu. The specified value should be typed into the text entry field.

• Is a descendant of person not more than N generations away
This rule matches people who are descendants of the specified person and are
no more than N generations away from that person in their lineage. For
example, using this rule with the value of 2 for the number of generations will
match children and grandchildren, but not great-grandchildren, etc., of the
specified person.

• Has the family attribute
This rule matches people who have the family attribute of the specified value.
The specified family attribute should be selected from the menu. The
specified value should be typed into the text entry field.

• Is a descendant of filter match
This rule matches people who are descendants of someone who is matched by
the specified filter. The specified filter name should be selected from the
menu.

• Has LDS
This rule matches people or families with a LDS event.

Previous

• Is a descendant family member of
This rule not only matches people who are descendants of the specified
person, but also those descendants' spouses.
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This appendix contains the list of questions that frequently come up in mailing list
discussions and forums. This list is by no means complete. If you would like to add
questions/answers to this list, please email your suggestions to the gramps-devel@lists.sourceforge.net list.

What is Gramps?
Gramps is the Genealogical Research and Analysis Management Program System. In
other words, it is a personal genealogy program letting you store, edit, and research genealogical data using the powers of your computer, see About.

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

Previous

Index

Where do I get it and how much does it cost?
Gramps can be installed at no charge. Gramps is an Open Source project covered by the
GNU General Public License. You have full access to the source code and are allowed to
distribute the program and source code freely.

Does Gramps exist in other languages?
Yes, at the release of Gramps 3.3 it has been translated into 28 languages, see GRAMPS
translations.

How do I keep backups?

Next

Use a recent version of Gramps! From version 2.2.5 onwards there is an automatic backup utility.
It is extremely important to keep backups of your data, and keep them in a safe
place. Gramps has a specific portable file format which is small, and human readable,
denoted by .gramps.
You can copy this backup file from time to time to a save location (eg a usb stick).
[Note: The .gramps files are compressed. Clicking them will open Gramps. To see the
XML select them and open them with a decompressing utility (like ark, gunzip), after
which you can extract the XML file which is human readable, see details.
Gramps does a quick hidden binary backup to allow restore if an error is noted. If
the correct package is installed you can use a revision system.

Also consider having a look at the following Categories on the Gramps wiki:
• How do I...
• Gramps Tutorials
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Does Gramps work on the Mac?

Another method is to backup the hidden directory /.gramps. This directory is situated in your home directory on Linux systems. Backing up this directory will backup your
databases and revisions.
Do not keep backups in GEDCOM
GEDCOM. Not all information Gramps stores can be written
in the GEDCOM. Hence, an export/import operation Gramps --> GEDCOM --> Gramps,
will mean you lose data. Use the .gramps file format for backups!
Do not keep backups in GRDB format
format. GRDB is a database, which might be computer
dependent (read, not working on a different PC). Small damage to a GRDB file can also
not be repaired. Use the .gramps file format for backups!

Yes, Mac is a community supported platform for Gramps.
See here.

What are the Minimum Specs to run Gramps?
We would recommend at least an 800x600 video display. For Gramps 3.3, the memory
requirements have been reduced, and Gramps can run quite efficiently on a 256MB system, holding considerably more people. A system with 512MB should be able to hold
around 200,000 people. Disk space requirements for databases are however considerably larger, with a typical database being several megabytes in size. For 120.000 people
you must consider already 530Mb for the database. Pictures are stored on disk separately, so a large harddisk is necessary.

Does Gramps support Unicode fonts?
In particular, does it support non-Roman Unicode fonts? Yes. Gramps works internally
with Unicode (UTF-8), so all alphabets can be used on all entry fields. All reports fully
support this, although for PDF/PS you need to work with gnome-print or LibreOffice.

How do I upgrade Gramps?
GNU/Linux operating systems will typically deal with upgrade issues for you. If they do
not then you need to ask users of your prefered GNU/Linux distribution.
The Windows port of Gramps needs to be updated manually.

Installation
What is needed to install Gramps under Linux, Solaris, or
FreeBSD?

This page's factual accuracy may be compromised
due to out-of-date information. Please help improve
the Gramps Wiki as a useful resource by updating it.

Gramps is a GTK application. Gramps needs to have the pygtk libraries installed on the
system. As long as these libraries are installed, Gramps should function. It will operate
under the GNOME desktop, KDE desktop, or any other desktop. If the GNOME bindings
for Python are installed on the system, Gramps will have additional functionality. The
Gramps project recommends version 2.8 or higher of GTK.

TODO
Need to update this content. To be written.

Does Gramps work on Windows?
Yes, many people use it on Windows. Probably the easiest thing is to Download the
GrampsAIO software "bundle" for Windows, as that is an all-in-one package of Gramps
with the other programs it needs, and so may be installed very trivially.
We will do our best to solve Windows-related problems. See here.
See GRAMPS and Windows for a summary of hints to use Gramps on a Windows PC.
Also, the Linux Genealogy CD can function as a live CD that you boot directly from
(If you have a CD/DVD-ROM Drive). You can then run Linux and Gramps off the CD, even
if your computer is entirely Windows.

(incomplete answer)
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How do I import data from another genealogy program into
Gramps?

Preferences
Can I change the dates in reports to 'day month year'?

The best way is to create a new family tree, and select the import option in the file
menu. Here you select the GEDCOM you generated with the other program, and import
it.

Yes, change in the preferences ("Edit->Preferences") the date for Gramps to the required format (eg YYYY-MM-DD or day month year), and make the report. Your global
date preferences will be used.

Can I install Gramps on a Linux Web Server and use it via a
web browser?

Collaboration-Portability

This would enable my relations worldwide to access and update it.
While Gramps can generate web sites, it does not provide a web interface that allows
for editing. If this is a requirement, then GeneWeb or PhpGedView are programs more
likely to meet your needs. Also have a look at experimental gramps-connect. However,
you may wish to ask yourself the following questions:
1. Do I really want relatives or other people to directly edit my genealogy
database?
2. Do I implicitly trust, without verification, any data that people may enter?
3. Do these people have the same understanding of good genealogy practice
that I have?
A better approach may be to provide a web form interface that allows others to enter
data that is then held for your examination. You can then decide if the information
should be entered into your database.
You may also want to consider the effects of possible downtime of your site if you
cannot afford yourself a premium webhosting service.

Is Gramps compatible with other genealogical software?
Gramps makes every effort to maintain compatibility with GEDCOM, the general standard of recording genealogical information. We have import and export filters that enable Gramps to read and write GEDCOM files.
It is important to understand that the GEDCOM standard is poorly implemented -virtually every genealogical software has its own "flavor" of GEDCOM. As we learn about
new flavor, the import/export filters can be created very quickly. However, finding out
about the unknown flavors requires user feedback. Please feel free to inform us about
any GEDCOM flavor not supported by Gramps, and we will do our best to support it!

Can Gramps read files created by other genealogy programs?
See above.

Can Gramps write files readable by other genealogy programs?

Reports

See above.

Can Gramps print a genealogical tree for my family?

What standards does Gramps support?

Yes. Different people have different ideas of what a genealogical tree is. Some think of it
as a chart going from the distant ancestor and listing all his/her descendants and their
families. Others think it should be a chart going from the person back in time, listing
the ancestors and their families. Yet other people think of a table, text report, etc.
Gramps can produce any of the above, and many more different charts and reports.
Moreover, the plugin architecture enables users (you) to create their own plugins
which could be new reports, charts, or research tools.

The nice thing about standards is that there never is a shortage of them. Gramps is tested to support the following flavors of GEDCOM: GEDCOM5.5, Brother's Keeper, Family
Origins, Family Tree Maker, Ftree, GeneWeb, Legacy, Personal Ancestral File, Pro-Gen,
Reunion, and Visual Genealogie.
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In what formats can Gramps output its reports?

If you only have Latin text, the PDF option will produce a smaller PDF compared to
that created by gnome-print, simply because no font information will be embedded.

Text reports are available in HTML, PDF, ODT, LaTeX, and RTF formats. Graphical reports (charts and diagrams) are available in PostScript, PDF, SVG, ODS, and GraphViz
formats.

I would like to contribute to Gramps by writing my favorite
report. How do I do that?

How can I change the default language in reports?

The easiest way to contribute to reports, filters, tools, etc. is to copy an existing Gramps
report, filter, or tool. If you can create what you want by modifying existing code -great! If your idea does not fit into the logic of any existing Gramps tool, you will need
to write your own plugin from scratch. Help is available on the Developers Portal, or on
the Developers mailing list: gramps-devel@lists.sourceforge.net.
To test your work in progress, you may save your plugin under $HOME/.gramps/
plugins directory and it should be found and imported on startup. The correctly written
plugin will register itself with Gramps, create menu item, and so on.
If you are happy with your plugin and would like to contribute your code back to
the Gramps project, you are very welcome to do so by contacting us at gramps-devel@lists.sourceforge.net

The reports are in the language of your linux installation. You can change it by installing extra language packs, see Howto: Change the language of reports

Is Gramps compatible with the Internet?
Gramps can store web addresses and direct your browser to them. It can import data
that you download from the Internet. It can export data that you could send over the
Internet. Gramps is familiar with the standard file formats widely used on the Internet
(e.g. JPEG, PNG, and GIF images, MP3, OGG, and WAV sound files, QuickTime, MPEG, and
AVI movie files, etc). Other than that, there is little that a genealogical program can do
with the Internet.

Database - Gramps file formats

Can I create custom reports/filters/whatever?
Yes. There are many levels of customization. One is creating or modifying the templates
used for the reports. This gives you some control over the fonts, colors, and some layout
of the reports. You can also use Gramps controls in the report dialogs to tell what contents should be used for a particular report. In addition to this, you have an ability to
create your own filters -- this is useful in selecting people based on criteria set by you.
You can combine these filters to create new, more complex filters. Finally, you have an
option to create your own plugins. These may be new reports, research tools, import/
export filters, etc. This assumes some knowledge of programming in Python.

What is the maximum database size (bytes) Gramps can handle?
Gramps has no hard limits on the size of a database that it can handle. Starting with
2.0.0 release, Gramps no longer loads all data into memory, which allows it to work with
a much larger database than before. In reality, however, there are practical limits. The
main limiting factors are the available memory on the system and the cache size used
for BSDDB database access. With common memory sizes these days, Gramps should
have no problem using databases with tens of thousands of people.

Why are non-Latin characters displayed as garbage in PDF/PS
reports?

How many people can Gramps database handle?

This is a limitation of the built-in fonts of PS and PDF formats. To print non-Latin text,
use the Print... in the format selection menu of the report dialog. This will use the
gnome-print backend, which supports PS and PDF creation, as well as direct printing. (Note: you might need to install gnome-print separately as it is not required for
Gramps).

See above. Again, this is dependent on how much memory you have, see GRAMPS Performance.
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My database is really big. Is there a way around loading all the
data into memory?

Bugs and requests
What do I do if I have found a bug?

Starting with 2.0.0 release, Gramps no longer loads all data into memory, which allows
it to work with a much larger database than before. The fileformat used is .grdb which
means Gramps database.

The best thing you can do is to fix the bug and send the patch to gramps-devel@lists.sourceforge.net :-)
If that is not possible, you should submit a bug report
A good bug report would include:
1. Version of Gramps you were using when you encountered the bug (available
through Help → About menu item).
2. Language under which Gramps was run (available by executing echo
$LANG in your terminal).
3. Symptoms indicating that this is indeed a bug.
4. Any Traceback messages, error messages, warnings, etc, that showed up in
your terminal or a in separate traceback window.
Most problems can be fixed quickly provided there is enough information. To ensure
this, please follow up on your bug reports. Then we will have a way of contacting you
should we need more information.

Can I run Gramps from a database on a NFS share?
Yes you can.

What does "portable" mean?
A Gramps 3 database (and any .grdb file) is very dependent on the software versions
that created it. For example, you can't just move your Gramps data in these formats to a
different operating system (or even a different version of an operating system) and expect that you will be able to read your data. The data is not "portable". Therefore, you
can't just rely on backups of these formats, but you should also occasionally export into
a format that is portable. There are two possible portable formats: GEDCOM and Gramps
XML (.gramps or .gpkg). But only Gramps XML is recommended, as it faithfully saves all
of your data.

Requests

Why is the database format (GRDB) not portable?

• Gramps should be a .... type of application
It is obvious that Gramps absolutely needs to become a (client-server/web-based/PHP/
weblog/Javascript/C++/distributed/KDE/Motif/Tcl/Win32/C#/You-name-it) application. When is this going to happen?
The surest way to see it happen is to get it done by yourself. Since Gramps is free/
open source, nobody prevents you from taking all of the code and continuing its development in whatever direction you see fit. In doing so, you may consider giving your
new project another name to avoid confusion with the continuing Gramps development. If you would like the Gramps project to provide advice, expertise, filters, etc., we
will gladly cooperate with your new project, to ensure compatibility or import/export
options to your new format of a project.
If, however, you would like the Gramps project to adopt your strategy, you would
need to convince Gramps developers that your strategy is good for Gramps and superior
to the present development strategy.

The biggest issue with Gramps portability lies with 'transactions'. With Gramps 2.2, we
added support for atomic transactions to protect data. With atomic transactions, multiple changes are committed as a single unit. Either all the changes make it, or none of
the changes make it. You are never left in a situation with a partial set of changes. A
side benefit of using transactions is that database access (reads and writes) are faster.
The problem with transactions (at least using BSDDB) is that it does not allow all the
data to be stored in a single file. Logging files are needed to keep track of things. These
logging files are kept in a DB Environment directory. We need a separate directory for
each file, otherwise the log files can interfere with each other.
In 2.2, we keep the log files under the ~/.gramps/<path> directory, creating a unique
directory for each database. The problem is that your GRDB file needs the log files,
which are in a different directory.
Copying the GRDB file is only copying a portion of the database.
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Adding to and editing my database

Previous

Index

Next

What is the difference between a residence and an address?
A residence is a place where someone lived for a period of time. An address is the name
of a residence formatted in the way expected by the postal system. Therefore each residence can also have an address if that is useful.

How do I change the order of children?

This page was last modified on 26 October 2011, at 12:55. This page has been accessed
1,841 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers

Children can be moved in the Family Editor by dragging and dropping or using the
up and down buttons.

How do I change the order of spouses?
Spouses can be reordered from the Relationship View by selecting the Reorder
button in the toolbar.

6

From Gramps

Gramps 3.3 Wiki Manual - Keybindings

Gramps 3.3 Wiki Manual - Keybindings
From Gramps
Jump to: navigation, search
This appendix lists keybindings (also known as Keyboard shortcuts) you can use on the
Gramps dialogs, so as to avoid the use of the mouse.
Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

CTRL + M

Close the navigator panel (left sidebar)

CTRL + 1 / 2 /..

Changes the view to view number 1/2/... in this view category

CTRL + B

Open the Clipboard

CTRL + D

Add the selected item as a bookmark

⇧ Shift + CTRL + D

Organize the bookmarks

CTRL + H

Open the Undo History dialog

CTRL + J

Jump to an ID

ALT + ← (Left arrow) Move to previous item in history
ALT + →

(Right ar-

row)

Previous

Index

Next

⇧ Shift + CTRL + C

Configure active view

⇧ Shift + CTRL + R

Toggle the right gramplet sidebar

⇧ Shift + CTRL + B

Toggle the bottom gramplet sidebar

All List Views bindings

List Views

The following bindings are available in all list views: People, Family List, Events,
Sources, Places, Media, Repositories and Notes View.

Common bindings
The following bindings are available in all views.
Key

Move to next item in history

Key
Function

CTRL + N

Changes the view to the next view category

CTRL + P

Changes the view to the previous view category

Function

↵ Enter

Edits the selected list item

CTRL + Insert

Adds a new item to the database

CTRL + Delete Deletes the selected list item
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People View bindings
Key

Function

↵ Enter Expands and hides entries of the selected surname

Editor Tab bindings
These bindings work on the tab pages of the editors (so not on the labels of the tabs!,
press tab on label to move to tabpage content).
Key
↵ Enter

Insert

Same action as the Add button when that button is present

Delete

Same action as the Remove button when that button is
present

Ctrl + O

Same action as the Share button when that button is
present

ALT + ←

(Left ar-

row)
ALT + → (Right ar-

row)
Mouse
Key

Call up context popup

Doubleclick

Same action as the Edit button when that button is present

Middleclick

Common action that is not the same as Edit button. Eg: on Family
Editor Child tab, edit child

Handy Shortcuts

Function
Same action as the Edit button when that button is present

Rightclick

Key

Function

F11 Maximises Gramps to use the Full screen

Previous

Index

Next

Change tabpage to the tabpage to the left
Change tabpage to the tabpage to the right

This page was last modified on 26 October 2011, at 12:56. This page has been accessed
747 times. Content is available under GNU Free Documentation License 1.2. Privacy
policy About Gramps Disclaimers

Function
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Version options

From Gramps
Jump to: navigation, search
This appendix provides the reference to the command line capabilities available when
launching Gramps from the terminal.

-v or --version prints version of Gramps and dependencies,
information about environment settings and python and system pat

Special copyright notice: All edits to this page need to be under two different
copyright licenses:
• GNU Free Documentation License 1.2 - see wiki copyright
• GPL - see manual copyright
These licenses allow the Gramps project to maximally use this wiki manual as
free content in future Gramps versions. If you do not agree with this dual license, then do not edit this page. You may only link to other pages within the
wiki which fall only under the GFDL license via external links (using the syntax: [http://www.gramps-project.org/...]), not via internal links.
Also, only use the known conventions

Format options
The format of any file destined for opening, importing, or exporting can be specified
with the
-f format
option. The acceptable format values are listed below.

Full family tree support

This section provides the reference list of all command line options available in Gramps.
If you want to know more than just a list of options, see next sections: Operation and
Examples. A list is also available on this page.

These formats contain all your data that is present in a family tree.
• gramps - Gramps XML format: This format is available for import, and export.
When not specified, it can be guessed if the filename ends with .gramps
• gpkg - Gramps package XML format: This format is available for import and export.
When not specified, it can be guessed if the filename ends with .gpkg. This creates a
zip package with your data as xml, and all your media files included
• grdb - pre Gramps 3.x database: This format is available for import to support the
old file format of Gramps. Everything in the grdb file is imported. When not
specified, it can be guessed if the filename ends with .grdb
• burn - GNOME iso burning: export, only available on GNOME where burn protocol
exists

List options

Reduced family tree support

-l, print a list of known family trees
-L, print a detailed list of known family trees

These formats contain most, but not all data that can be created in Gramps
• ged - GEDCOM format: This format is available for import, and export. When not
specified, it can be guessed if the filename ends with .ged

Previous

Index

Next

Available options
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• gw - GeneWeb file: This format is available for import and export. When not
specified, it can be guessed if the filename ends with .gw

python
python
python
python

Subset of your data

gramps.py
gramps.py
gramps.py
gramps.py

These formats contain a specific subset of your data
• csv - Comma Separated Value: This format is available for import and export. Be
careful however, import must be as values created by the export function. Only a
part of your data is contained in the output.
• vcf - VCard format: import and export
• vcs - VCalandar format: export
• def - old Pro-Gen format: import
• wft - Web Family Tree: This format is available for export only. When not specified,
it can be guessed if the filename ends with .wft

'Family Tree 1'
/home/cristina/.gramps/grampsdb/47320f3d
-O 'Family Tree 1'
-O /home/cristina/.gramps/grampsdb/47320f3d

Tip
If no option is given, just a name, Gramps will ignore
the rest of the command line arguments. Use the -O flag
to open, -i to import, and do something with the data.

Opening options

Tip

You can open a family tree, or you can open a file by importing it in an empty family
tree.
To let Gramps handle this automatically, just supply the familytree or filename you
want to open:

Only family trees can be opened directly. For other formats, you will need to use the import option which will
set up the empty database and then import data into it.

python gramps.py 'My Fam Tree'
python gramps.py JohnDoe.ged

Tip
Only a single family tree can be opened. If you need to
combine data from several sources, you will need to use
the import option.

The first opens a family tree, the second imports a gedcom into an empty family tree.
Additionally, you can pass Gramps the name of the family tree to be opened:
• use this option :
-O famtree

Import options

or

The files destined for import can be specified with the

--open=famtree

-i filename

-O, Open of a family tree. This can be done also by just typing the name (name or database dir)
Examples:

or
--import=filename

2

From Gramps

Gramps 3.3 Wiki Manual - Command Line

option. The format can be specified with the

-e filename

-f format

or

or

--export=filename

--format=format

option. The format can be specified with the

option, immediately following the filename . If not specified, the guess will be attempted
based on the filename.
Example:

-f
option immediately following the filename . If not specified, the guess will be attempted
based on the filename . For iso format, the filename is actually the name of directory the
Gramps database will be written into. For gramps-xml, gpkg, gedcom, wft, geneweb, and
gramps-pkg, the filename is the name of the resulting file.
-e, export a family tree in required format. It is not possible to export to a family tree.
Example:

python gramps.py -i 'Family Tree 1' -i 'Family Tree 2'
python gramps.py -i test.grdb -i data.gramps

Tip
More than one file can be imported in one command. If
this is the case, Gramps will incorporate the data from
the next file into the database available at the moment.

python gramps.py -i 'Family Tree 1' -i test.grdb -f grdb -e mergedDB
Note that above does not change 'Family Tree 1' as everything happens via a temporary
database, whereas:

When more than one input file is given, each has to be preceded by

python gramps.py -O 'Family Tree 1' -i test.grdb -f grdb -e mergedDB

-i

will import test.grdb into Family Tree 1, and then export to a file !

flag. The files are imported in the specified order, i.e.

Exporting more files
More than one file can be exported in one command.
If this is the case, Gramps will attempt to write several
files using the data from the database available at the
moment.

-i file1 -i file2
and
-i file2 -i file1
might produce different GRAMPS IDs in the resulting database.

When more than one output file is given, each has to be preceded by

Export options

-e

The files destined for export can be specified with the

flag. The files are written one by one, in the specified order.
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Action options

gramps -O "Family Tree 1" -a report -p "name=family_group,style=defau

The action to perform on the imported data can be specified with the

or without css in the html output:

-a action

gramps -O "Family Tree 1" -a report -p "name=family_group,style=defau

or

Report option string

--action=action

The report option string should satisfy the following
conditions: It must not contain any spaces (due to the
general nature of the command line interface). If some
arguments need to include spaces, the string should be
enclosed with quotation marks. Option string must list
pairs of option names and values. Within a pair, option
name and value must be separated by the equal sign.
Different pairs must be separated by commas.

option. This is done after all imports are successfully completed.
The following actions remain the same:
• report: This action allows producing reports from the command line.
• tool: This action allows to run a tool from the command line.
Reports and tools generally have many options of their own, so these actions should be
followed by the report/tool option string. The string is given using the
-p option_string

Most of the report options are specific for every report. However, there are some common options.
• name=report_name: This mandatory option determines which report will be
generated. If the supplied report_name does not correspond to any available
report, an error message will be printed followed by the list of available reports.
• of : output filename
• off: output format. These are the extension an output format makes available, eg,
pdf, html, doc, ...
• style: for text reports, the stylesheet to use. Defaults to 'default'.
• show=all: This will produce the list of names for all options available for a given
report.
• show=option_name: This will print the description of the functionality supplied by
the option_name, as well as what are the acceptable types and values for this
option.
So, to learn to use a report, do for example:

or
--options=option_string
option.
The actions available in older versions of Gramps which were relocated in Gramps 3.3
are:
• summary: This action was the same as Reports ->View ->Summary . In Gramps 3.3 it
was replaced by (or renamed to) -a report -p name=summary
name=summary.
• check: This action was the same as Tools ->Database Processing ->Check and Repair .
In Gramps 3.3 it was replaced by (or renamed to) -a tool -p name=check
name=check.

report action option
You can generate most reports from the command line using the report action.
An example:

gramps -O "Family Tree 1" -a report -p "name=family_group,show=all"
gramps -O "Family Tree 1" -a report -p "name=family_group,style=default,off=html,of=test.html"
In version 3.3, you can provide the css style to use here with the css option:
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The details vary with each shell but (in linux/UNIX) usually you can precede such a
square bracket with a backslash

Tip
If an option is not supplied, the last used value will be
used. If this report has never been generated before,
then the value from last generated report will be used
when applicable. Otherwise, the default value will be
used.

\
or put quotation marks around the square bracket, usually either "single" or "double"
ones.
The Hourglass Graph report allows you to put a "note" at the top of the report and
such a "note" is an example of a "list" option. Here is an example:

When more than one output action is given, each has to be preceded by

gramps -O "Family Tree 1" -a report -p name=hourglass_graph,note='[li

-a

which shows that inside such a list different lines are separated by commas, and that
spaces are acceptable since the quotation marks are already there for the square brackets.
But if you want to have a comma inside your report you have to somehow tell
Gramps that comma is not one which separates lines. You do that by enclosing the line
with the comma in quotation marks (either single or double).
But if you are already using a set of quotation marks (to enclose your square brackets) you have to use the other type to enclose the line with your comma. Here is an example:

flag. The actions are performed one by one, in the specified order.

lists
Some reports have options or arguments which are interpreted (by the report) to be on multiple lines. For instance some reports allow you to format how the information will be shown, perhaps with a name on one
line and the person's birth date on the next line. Such
multiple-line options or arguments are called "lists" by
Gramps.

gramps -O "Family Tree 1" -a report -p name=hourglass_graph,note="['l
It is possible to include any character in a list but the details are beyond the scope of
this command-line introduction to Gramps.
You will need to know the precise methods available in your particular command
shell interpreter to include a character which is "special" to your shell or "special" to
Gramps (like the comma in the example above) but in general you will have to "escape"
it twice, once to your shell and once again to Gramps, since you don't want your shell
to think it is some instruction it should pay attention to and you don't want Gramps to
think that either.

On the command line such lists must always start with a left square bracket
[
and must always end with a right square bracket
]

tool action option

but since such square brackets are usually "special" to the "shell" (they mean something to the command interpreter you are typing the command to), you must "escape"
them so that they are ignored by your shell.

You can run most tools from the command line using the 'tool' action. To see which
ones, say:
gramps -O "Family Tree 1" -a tool -p show=all
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To see a tool's available options, for instance the "verify" tool:

3.1) Set a value to its default:

gramps -O "Family Tree 1" -a tool -p name=verify,show=all
To run a tool, for instance the "verify" tool:

--config=behavior.database-path:DEFAULT
or
-c behavior.database-path:DEFAULT

gramps -O "Family Tree 1" -a tool -p name=verify

3.2) Set more than one value:

Force unlock option

--config=behavior.use-tips:False --config=behavior.autoload:True
or
-c behavior.use-tips:False -c behavior.autoload:True

-u, you can extend the -O flag with -u to force a locked family to be unlocked. This allows
you to recover from a crash that leaves the family tree (database) locked, from the command line.
An example (to unlock the "Family Tree 1" database):

When all configuration variable(s) are set Gramps will start with these new values.

Operation

gramps -O "Family Tree 1" -a report -u > /dev/null

If the first argument on the command line does not start with a dash (i.e. no flag),
Gramps will attempt to open the file with the name given by the first argument and
start an interactive session, ignoring the rest of the command line arguments.
If the

Note that it is not possible to open family trees that need repair from the command line

Configuration (config) option
The option takes three forms: (the following examples, except 3.2, use
behavior.database-path as the configuration variable to change.)
1) See all config values

-O
flag is given, then Gramps will try opening the supplied file name and then work with
that data, as instructed by the further command line parameters.

-s or --show
2) See a value:

Note

--config=behavior.database-path
or
-c behavior.database-path

Only one file can be opened in a single invocation of
Gramps. If you need to get data from multiple sources,
use the importing options by using

3) Set a value:

-i

--config=behavior.database-path:'/media/mydb'
or
-c behavior.database-path:'/media/mydb'

flag.
With or without the
-O
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flag, there could be multiple imports, exports, and actions specified further on the command line by using

option is given, Gramps will launch its main window and start the usual interactive session with the empty database, since there is no data to process, anyway. (Unless you
have already expressed a "preference" that it start with the last database it used.) If no

-i

-e

,

or

-e

-a

, and

options are given, Gramps will launch its main window and start the usual interactive
session with the database resulted from opening and all imports (if any). This database
resides in the import_db.grdb file under the ~/.gramps/import/ directory.
Any errors encountered during import, export, or action, will be either dumped to stdout (if these are exceptions handled by Gramps) or to stderr (if these are not handled).
Use usual shell redirections of stdout and stderr to save messages and errors in files.

-a
flags. The order of
-i
,

Examples

-e

• To import four databases (whose formats can be determined from their names) and
then check the resulting database for errors, one may type:

, or

gramps -i file1.ged -i file2.gpkg -i ~/db3.gramps -i file4.wft -a

-a

• To explicitly specify the formats in the above example, append filenames with
appropriate -f options:

options with respect to each does not matter. The actual execution order always is: all
imports (if any) -> all exports (if any) -> all actions (if any).

gramps -i file1.ged -f gedcom -i file2.gpkg -f gramps-pkg -i ~/db3

Note

• To record the database resulting from all imports, supply -e flag (use -f if the
filename does not allow Gramps to guess the format):

But opening must always be first!
If no

gramps -i file1.ged -i file2.gpkg -e ~/new-package -f gramps-pkg

-O

• To save any error messages of the above example into files outfile and errfile, run:

or

gramps -i file1.ged -i file2.dpkg -e ~/new-package -f gramps-pkg >

-i

7

From Gramps

Gramps 3.3 Wiki Manual - Command Line

• To import three databases and start interactive Gramps session with the result:

• Finally, to start normal interactive session type:

gramps -i file1.ged -i file2.gpkg -i ~/db3.gramps

gramps

• To open a database and, based on that data, generate timeline report in PDF format
putting the output into the my_timeline.pdf file:

Environment variables

Gramps can take advantage of these environment variables (but do not change them if
gramps -O 'Family Tree 1' -a report -p name=timeline,off=pdf,of=my_timeline.pdf
you do not know what are you doing):
• GRAMPSHOME - if set, override default path to profile allowing user to use ex.
network drive to store data and all settings. For technically advanced users who
Listing report options
run multiple versions of Gramps, setting a different $GRAMPSHOME is a way to
Use the name=timeline,show=all to find out
avoid interference between the different versions in the Gramps user directory.
about all available options for the timeline report. To
• LANG - is used by Gramps to determine which language file should be loaded.
find out details of a particular option, use show=option_name , e.g. name=timeline,show=off
Previous
Index
Next
string. To learn about available report names, use
name=show string.

• To convert a grdb on the fly to a .gramps xml file:
gramps -O 'Family Tree 1' -e output.gramps -f gramps-xml
This page was last modified on 26 October 2011, at 13:00. This page has been accessed
829 times. Content is available under GNU Free Documentation License 1.2. Privacy
LANGUAGE=de_DE; LANG=de_DE.UTF-8 gramps -O 'Family Tree 1' -a policy
report
-pGramps
name=navwebpage,target=/../de
About
Disclaimers
• To generate a web site into an other locale (in german):
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If you know of somebody else who should be listed here, please let us know.
To find more information about Gramps, please visit the Gramps Project Web page.
To report a bug or make a suggestion regarding this application or this manual, use
the help menu in Gramps, or follow the directions on this site.
This program is distributed under the terms of the GNU General Public license as
published by the Free Software Foundation; either version 2 of the License, or (at your
option) any later version. A copy of this license can be found at this link, or in the file
COPYING included with the source code of this program.
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